BASIC NAT AND SERIAL INTERFACE ON 1721.

Discussion in 'Cisco' started by Graeme, Dec 18, 2003.

  1. Graeme

    Graeme Guest

    could someone please let me know why nothing is working..

    My ISP supplied me with some basic config for the serial inteface, IP
    addresses. But i can't get anything to work.

    the interface is up protocol up but nothing is being routed, no pings
    nothing.

    Any help will be very much appreciated...

    Regards,

    G.

    WFRTR01(config)#do show run
    Building configuration...

    Current configuration : 1113 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname WFRTR01
    !
    enable secret 5<PASSWORD>
    enable password <PASSWORD>
    !
    ip subnet-zero
    ip dhcp excluded-address 10.0.1.1
    !
    !
    !
    !
    interface FastEthernet0
    ip address 192.168.16.1 255.255.255.0
    ip nat inside
    speed auto
    half-duplex
    !
    interface Serial0
    ip address <MY EXTERNAL ADDRESS> 255.255.255.252
    ip nat outside
    encapsulation frame-relay IETF
    logging event subif-link-status
    logging event dlci-status-change
    no fair-queue
    frame-relay map ip <THEIR ROUTER> 20 broadcast IETF
    frame-relay interface-dlci 20
    frame-relay lmi-type ansi
    !
    interface Serial1
    no ip address
    shutdown
    !
    ip nat inside source static tcp 192.168.16.2 25 80.168.21.66
    ip classless
    ip route 0.0.0.0 0.0.0.0 <THEIR ROUTER>
    no ip http server
    !
    !
    access-list 12 permit <REMOTE ADDRESS>
    access-list 12 permit 192.168.16.0 0.0.0.255
    snmp-server community public RO
    !
    line con 0
    line aux 0
    line vty 0 4
    access-class 12 in
    password <ANOTHER PASSWORD>
    login
    !
    end
     
    Graeme, Dec 18, 2003
    #1
    1. Advertising

  2. Graeme

    Tim Thorne Guest

    "Graeme" <> wrote:

    >could someone please let me know why nothing is working..
    >
    >My ISP supplied me with some basic config for the serial inteface, IP
    >addresses. But i can't get anything to work.
    >
    >the interface is up protocol up but nothing is being routed, no pings
    >nothing.


    Try adding "ip routing" to the global config.

    I think you might need to sort out your frame config too. Try creating
    a p2p sub interface for it.

    interface Serial0
    no ip address
    encapsulation frame-relay IETF
    frame-relay lmi-type ansi
    frame-relay interface-dlci 20
    frame-relay intf-type dce or dte
    !
    interface Serial0.20 point-to-point
    ip address <MY EXTERNAL ADDRESS> 255.255.255.252
    ip nat outside
    frame-relay interface-dlci 20
    frame-relay map ip <THEIR ROUTER> 20 broadcast IETF

    Tim
     
    Tim Thorne, Dec 18, 2003
    #2
    1. Advertising

  3. Graeme

    Graeme Guest

    Tim the interface config is right ( so they reckon) as I'm able to ping
    theISP'S router the other end but it's just not pings to anything elses
    fail. Internal pings also work

    (all pinging and Traces done from inside(telnet)/on the router)



    I'm sure ists' very simple routing thing but my experience fo all this is
    very limited.









    Many thanks for your help,

    Regsards,



    Graeme
     
    Graeme, Dec 18, 2003
    #3
  4. Graeme

    Tim Thorne Guest

    "Graeme" <> wrote:

    >Tim the interface config is right ( so they reckon) as I'm able to ping
    >theISP'S router the other end but it's just not pings to anything elses
    >fail. Internal pings also work
    >
    >(all pinging and Traces done from inside(telnet)/on the router)
    >
    >I'm sure ists' very simple routing thing but my experience fo all this is
    >very limited.


    It sounds like Clara have forgotten to stick a route pointing your
    network back to your router on their gateway router. Can you attach a
    PC to the router and browse the web?

    Tim
     
    Tim Thorne, Dec 18, 2003
    #4
  5. Graeme

    Graeme Guest

    Tim,

    Plugged in a Laptop. can ping the router, can ping the externa interface
    address, can't ping their router. can't ping DNS server on their network.

    Is this a problem my end or theirs?

    Cheers for your help so far


    Regards,

    graeme.
     
    Graeme, Dec 18, 2003
    #5
  6. Graeme

    Page Guest

    (Tim Thorne) wrote in message news:<>...
    > "Graeme" <> wrote:
    >
    > >could someone please let me know why nothing is working..
    > >
    > >My ISP supplied me with some basic config for the serial inteface, IP
    > >addresses. But i can't get anything to work.
    > >
    > >the interface is up protocol up but nothing is being routed, no pings
    > >nothing.

    >
    > Try adding "ip routing" to the global config.
    >
    > I think you might need to sort out your frame config too. Try creating
    > a p2p sub interface for it.
    >
    > interface Serial0
    > no ip address
    > encapsulation frame-relay IETF
    > frame-relay lmi-type ansi
    > frame-relay interface-dlci 20
    > frame-relay intf-type dce or dte
    > !
    > interface Serial0.20 point-to-point
    > ip address <MY EXTERNAL ADDRESS> 255.255.255.252
    > ip nat outside
    > frame-relay interface-dlci 20
    > frame-relay map ip <THEIR ROUTER> 20 broadcast IETF
    >
    > Tim


    What does the Show Int s0 command give you? Are you seeing line and prot up?
     
    Page, Dec 18, 2003
    #6
  7. Graeme

    Graeme Guest

    Line is up and protocol is up the isp cna "see" my router and they say it's
    fine but i cna't ping it from the outside and i can onl ping the router at
    the other end of the leased line everything else is "destination
    unreachable"

    I'd paste the show run & show in but i'm on site and conecting to my PC in
    the office from a dodgy satelite linkk..

    That's why i'm getting so many typos.

    ;o)


    many thanks in advance,

    Graeme.
     
    Graeme, Dec 18, 2003
    #7
  8. Graeme

    Graeme Guest

    Here's the Showint serial and show frame-relay map

    I think (my opionion isn't worth much in this field) that the link is OK.?

    And it's something really simple to get the routing wroking. If i could
    confidently say to my ISP support people "fix it, it's your end!" i'd be
    happy and could go to bed/or at least home!

    Many thanks
    Graeme.


    WFRTR01#show int serial0
    Serial0 is up, line protocol is up
    Hardware is PowerQUICC Serial
    Internet address is xx.yy.zz.aa/30
    MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation FRAME-RELAY IETF, loopback not set
    Keepalive set (10 sec)
    LMI enq sent 2595, LMI stat recvd 2595, LMI upd recvd 0, DTE LMI up
    LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
    LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE
    Broadcast queue 0/64, broadcasts sent/dropped 167/11, interface broadcasts
    40
    Last input 00:00:00, output 00:00:00, output hang never
    Last clearing of "show interface" counters 07:16:07
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    10974 packets input, 608595 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    2 input errors, 0 CRC, 2 frame, 0 overrun, 0 ignored, 0 abort
    3700 packets output, 155320 bytes, 0 underruns
    0 output errors, 0 collisions, 4 interface resets
    0 output buffer failures, 0 output buffers swapped out

    WFRTR01#show frame-relay map
    Serial0 (up): ip xx.yy.zz.aa dlci 20(0x14,0x440), static,
    broadcast,
    IETF, status defined, active
     
    Graeme, Dec 18, 2003
    #8
  9. Graeme

    Tim Thorne Guest

    "Graeme" <> wrote:

    >Tim,
    >
    >Plugged in a Laptop. can ping the router, can ping the externa interface
    >address, can't ping their router. can't ping DNS server on their network.
    >
    >Is this a problem my end or theirs?


    Could be either. Post the results of a "show frame-relay pvc" and
    "show ip interface serial 0". Should be able to diagnose more from
    than.

    >Cheers for your help so far


    You're welcome.

    Tim
     
    Tim Thorne, Dec 18, 2003
    #9
  10. Graeme

    Graeme Guest

    As requested:

    Thanks again.

    Graeme.


    do show ip int serial0:

    Serial0 is up, line protocol is up
    Internet address is ww.xx.yy.zz/30
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is disabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is enabled
    IP Feature Fast switching turbo vector
    IP multicast fast switching is disabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are Fast
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Probe proxy name replies are disabled
    Policy routing is disabled
    Network address translation is disabled
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled
    BGP Policy Mapping is disabled


    do show int serial0:

    Serial0 is up, line protocol is up
    Hardware is PowerQUICC Serial
    Internet address is ww.xx.yy.zz/30
    MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation FRAME-RELAY IETF, loopback not set
    Keepalive set (10 sec)
    LMI enq sent 2731, LMI stat recvd 2730, LMI upd recvd 0, DTE LMI up
    LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
    LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE
    Broadcast queue 0/64, broadcasts sent/dropped 179/11, interface broadcasts
    52
    Last input 00:00:01, output 00:00:01, output hang never
    Last clearing of "show interface" counters 07:38:51
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    11624 packets input, 645540 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    3 input errors, 0 CRC, 3 frame, 0 overrun, 0 ignored, 0 abort
    3855 packets output, 158726 bytes, 0 underruns
    0 output errors, 0 collisions, 5 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
    DCD=up DSR=up DTR=up RTS=up CTS=up


    do show frame-relay pvc:

    WFRTR01(config)#do show frame-relay pvc

    PVC Statistics for interface Serial0 (Frame Relay DTE)

    Active Inactive Deleted Static
    Local 1 0 0 0
    Switched 0 0 0 0
    Unused 0 0 0 0

    DLCI = 20, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0

    input pkts 3060 output pkts 84 in bytes 203818
    out bytes 6908 dropped pkts 0 in FECN pkts 0
    in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
    in DE pkts 0 out DE pkts 0
    out bcast pkts 48 out bcast bytes 3700
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    pvc create time 02:32:37, last time pvc status changed 00:15:23
     
    Graeme, Dec 18, 2003
    #10
  11. Graeme

    Tim Thorne Guest

    "Graeme" <> wrote:

    >Here's the Showint serial and show frame-relay map
    >
    >I think (my opionion isn't worth much in this field) that the link is OK.?
    >
    >And it's something really simple to get the routing wroking. If i could
    >confidently say to my ISP support people "fix it, it's your end!" i'd be
    >happy and could go to bed/or at least home!
    >
    >Many thanks
    >Graeme.
    >
    >WFRTR01#show int serial0
    >Serial0 is up, line protocol is up
    > Hardware is PowerQUICC Serial
    > Internet address is xx.yy.zz.aa/30
    > MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation FRAME-RELAY IETF, loopback not set
    > Keepalive set (10 sec)
    > LMI enq sent 2595, LMI stat recvd 2595, LMI upd recvd 0, DTE LMI up
    > LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
    > LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE


    The frame-relay config is at fault. I've always configured FR by
    creating a sub interface and running IP across that, leaving the
    serial interface for layer 2 stuff. I wasn't aware you could both over
    the same interface. Trying configuring it with a sub interface and
    give it another try.

    Tim
     
    Tim Thorne, Dec 18, 2003
    #11
  12. Graeme

    Graeme Guest

    Any pointers wouild be great I'll try in the mean time.. But your original
    P2P config wasn't succesful it come up with some erros when i tried to use
    the commands from the origianl config

    What about this:

    only IT doesnt' let me put frame-relay map ip xxxxxxxx broadcast IETF
    command in...!

    it says... FRAME-RELAY INTERFACE-DLCI command should be used on
    point-to-point interfaces

    any ideas please?



    interface Serial0
    no ip address
    encapsulation frame-relay IETF
    logging event subif-link-status
    logging event dlci-status-change
    no fair-queue
    frame-relay lmi-type ansi
    !
    interface Serial0.1 point-to-point
    ip address WW.XX.YY.ZZ 255.255.255.252
    frame-relay interface-dlci 20
    !.
     
    Graeme, Dec 19, 2003
    #12
  13. Graeme

    John Agosta Guest

    "Tim Thorne" <> wrote in message
    news:...
    > "Graeme" <> wrote:
    >
    > >Here's the Showint serial and show frame-relay map
    > >
    > >I think (my opionion isn't worth much in this field) that the link is

    OK.?
    > >
    > >And it's something really simple to get the routing wroking. If i could
    > >confidently say to my ISP support people "fix it, it's your end!" i'd be
    > >happy and could go to bed/or at least home!
    > >
    > >Many thanks
    > >Graeme.
    > >
    > >WFRTR01#show int serial0
    > >Serial0 is up, line protocol is up
    > > Hardware is PowerQUICC Serial
    > > Internet address is xx.yy.zz.aa/30
    > > MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    > > reliability 255/255, txload 1/255, rxload 1/255
    > > Encapsulation FRAME-RELAY IETF, loopback not set
    > > Keepalive set (10 sec)
    > > LMI enq sent 2595, LMI stat recvd 2595, LMI upd recvd 0, DTE LMI up
    > > LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
    > > LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE

    >
    > The frame-relay config is at fault. I've always configured FR by
    > creating a sub interface and running IP across that, leaving the
    > serial interface for layer 2 stuff. I wasn't aware you could both over
    > the same interface. Trying configuring it with a sub interface and
    > give it another try.
    >
    > Tim



    It would always help to post your 'entire' configuration....

    You have never shown any NAT statement, nor have you
    posted your routing statements. Do you have a default route pointing to your
    ISP ? Indications are "no"
    being you can ping the remote end of your directly
    connected interface, but nothing beyond that point....
    Also, your ISP will need a route to get back to your
    'internal' hosts. NAT statements are going to be needed
    for that, too, unless your internals are using address space
    provided by your ISP.

    Have fun....
     
    John Agosta, Dec 19, 2003
    #13
  14. Graeme

    Graeme Guest

    My current config was included in the original post.

    I've tried it with both NAT AND NO nat to no avail...(our range is assigned
    by our isp )

    The previous show statemetns were with the no nat config..

    Cheers in andvance for your further help

    many thanks
    GReme.
    "John Agosta" <> wrote in message
    news:...
    >
    > "Tim Thorne" <> wrote in message
    > news:...
    > > "Graeme" <> wrote:
    > >
    > > >Here's the Showint serial and show frame-relay map
    > > >
    > > >I think (my opionion isn't worth much in this field) that the link is

    > OK.?
    > > >
    > > >And it's something really simple to get the routing wroking. If i

    could
    > > >confidently say to my ISP support people "fix it, it's your end!" i'd

    be
    > > >happy and could go to bed/or at least home!
    > > >
    > > >Many thanks
    > > >Graeme.
    > > >
    > > >WFRTR01#show int serial0
    > > >Serial0 is up, line protocol is up
    > > > Hardware is PowerQUICC Serial
    > > > Internet address is xx.yy.zz.aa/30
    > > > MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    > > > reliability 255/255, txload 1/255, rxload 1/255
    > > > Encapsulation FRAME-RELAY IETF, loopback not set
    > > > Keepalive set (10 sec)
    > > > LMI enq sent 2595, LMI stat recvd 2595, LMI upd recvd 0, DTE LMI up
    > > > LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
    > > > LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE

    > >
    > > The frame-relay config is at fault. I've always configured FR by
    > > creating a sub interface and running IP across that, leaving the
    > > serial interface for layer 2 stuff. I wasn't aware you could both over
    > > the same interface. Trying configuring it with a sub interface and
    > > give it another try.
    > >
    > > Tim

    >
    >
    > It would always help to post your 'entire' configuration....
    >
    > You have never shown any NAT statement, nor have you
    > posted your routing statements. Do you have a default route pointing to

    your
    > ISP ? Indications are "no"
    > being you can ping the remote end of your directly
    > connected interface, but nothing beyond that point....
    > Also, your ISP will need a route to get back to your
    > 'internal' hosts. NAT statements are going to be needed
    > for that, too, unless your internals are using address space
    > provided by your ISP.
    >
    > Have fun....
    >
    >
    >
     
    Graeme, Dec 19, 2003
    #14
  15. Graeme

    Peter Rowe Guest

    I can't see a global NAT command that actually activates NAT, try

    IP NAT INSIDE SOURCE LIST 7 INTERFACE SERIAL0 OVERLOAD
    ACCESS-LIST 7 PERMIT IP 192.168.16.1 0.0.0.255 any

    peter.



    >>> Graeme<> 19/12/2003 00:42:15 >>>

    My current config was included in the original post.

    I've tried it with both NAT AND NO nat to no avail...(our range is assigned
    by our isp )

    The previous show statemetns were with the no nat config..

    Cheers in andvance for your further help

    many thanks
    GReme.
    "John Agosta" <> wrote in message
    news:...
    >
    > "Tim Thorne" <> wrote in message
    > news:...
    > > "Graeme" <> wrote:
    > >
    > > >Here's the Showint serial and show frame-relay map
    > > >
    > > >I think (my opionion isn't worth much in this field) that the link is

    > OK.?
    > > >
    > > >And it's something really simple to get the routing wroking. If i

    could
    > > >confidently say to my ISP support people "fix it, it's your end!" i'd

    be
    > > >happy and could go to bed/or at least home!
    > > >
    > > >Many thanks
    > > >Graeme.
    > > >
    > > >WFRTR01#show int serial0
    > > >Serial0 is up, line protocol is up
    > > > Hardware is PowerQUICC Serial
    > > > Internet address is xx.yy.zz.aa/30
    > > > MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    > > > reliability 255/255, txload 1/255, rxload 1/255
    > > > Encapsulation FRAME-RELAY IETF, loopback not set
    > > > Keepalive set (10 sec)
    > > > LMI enq sent 2595, LMI stat recvd 2595, LMI upd recvd 0, DTE LMI up
    > > > LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
    > > > LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE

    > >
    > > The frame-relay config is at fault. I've always configured FR by
    > > creating a sub interface and running IP across that, leaving the
    > > serial interface for layer 2 stuff. I wasn't aware you could both over
    > > the same interface. Trying configuring it with a sub interface and
    > > give it another try.
    > >
    > > Tim

    >
    >
    > It would always help to post your 'entire' configuration....
    >
    > You have never shown any NAT statement, nor have you
    > posted your routing statements. Do you have a default route pointing to

    your
    > ISP ? Indications are "no"
    > being you can ping the remote end of your directly
    > connected interface, but nothing beyond that point....
    > Also, your ISP will need a route to get back to your
    > 'internal' hosts. NAT statements are going to be needed
    > for that, too, unless your internals are using address space
    > provided by your ISP.
    >
    > Have fun....
    >
    >
    >
     
    Peter Rowe, Dec 19, 2003
    #15
  16. Graeme

    Graeme Guest

    Re: BASIC(no NAT now)SERIAL INTERFACE ON 1721.

    Thanks to everyone for all the input so far this has been quite a learning
    experience!

    I'vve tried many things to get this working but so far this is what has
    worked:

    The ISP's thirdline guys have suggested a 'show ip route' comamand which
    despite the "ip route 0.0.0.0 ..etc" was not showing as a static route ! so
    I've done a 'write erase' and they got me to type in a supplied config from
    scratch and it's working (better) now i can ping from inside the router to
    both sides of the router but can't ping through the router from either
    side..! This one must be simple for you guys,

    Many thanks again for all your help,

    Graeme.
    My config-
    urrent configuration : 836 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname WFRTR01
    !
    enable secret 5 <PASSWORD>
    !
    ip subnet-zero
    ip name-server <DNS IP ONE>
    ip name-server <DNS IP TWO>
    !
    !
    !
    !
    interface FastEthernet0
    ip address <First Host in Allocated Range> 255.255.255.248
    speed auto
    full-duplex
    !
    interface Serial0
    ip address <B-End Router IP> 255.255.255.252
    encapsulation frame-relay IETF
    logging event subif-link-status
    logging event dlci-status-change
    no fair-queue
    frame-relay map ip <A-End Router IP> 20 broadcast IETF
    frame-relay interface-dlci 20
    frame-relay lmi-type ansi
    !
    interface Serial1
    no ip address
    shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 <A-End Router IP>
    ip http server
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password <PASSWORD2>
    login
    !
    no scheduler allocate
    end
     
    Graeme, Dec 19, 2003
    #16
  17. Graeme

    Chris Guest

    Re: BASIC(no NAT now)SERIAL INTERFACE ON 1721.

    "Graeme" <> wrote in message
    news:3fe2e240$0$37275$...
    > Thanks to everyone for all the input so far this has been quite a learning
    > experience!
    >
    > I'vve tried many things to get this working but so far this is what has
    > worked:
    >
    > The ISP's thirdline guys have suggested a 'show ip route' comamand which
    > despite the "ip route 0.0.0.0 ..etc" was not showing as a static route !

    so
    > I've done a 'write erase' and they got me to type in a supplied config

    from
    > scratch and it's working (better) now i can ping from inside the router to
    > both sides of the router but can't ping through the router from either
    > side..! This one must be simple for you guys,



    From the router, can you ping beyond the ISP's router (ie, to an address on
    the internet) or just A-end router? Also, if you are using a live /29 range
    on the ethernet side and you patch the fastethernet port into a laptop or PC
    and set up the next usable address, can you ping the external address of
    your router and the other end of the link (ie. the ISP's router).

    Chris.




    > Many thanks again for all your help,
    >
    > Graeme.
    > My config-
    > urrent configuration : 836 bytes
    > !
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname WFRTR01
    > !
    > enable secret 5 <PASSWORD>
    > !
    > ip subnet-zero
    > ip name-server <DNS IP ONE>
    > ip name-server <DNS IP TWO>
    > !
    > !
    > !
    > !
    > interface FastEthernet0
    > ip address <First Host in Allocated Range> 255.255.255.248
    > speed auto
    > full-duplex
    > !
    > interface Serial0
    > ip address <B-End Router IP> 255.255.255.252
    > encapsulation frame-relay IETF
    > logging event subif-link-status
    > logging event dlci-status-change
    > no fair-queue
    > frame-relay map ip <A-End Router IP> 20 broadcast IETF
    > frame-relay interface-dlci 20
    > frame-relay lmi-type ansi
    > !
    > interface Serial1
    > no ip address
    > shutdown
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 <A-End Router IP>
    > ip http server
    > !
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > password <PASSWORD2>
    > login
    > !
    > no scheduler allocate
    > end
    >
    >
     
    Chris, Dec 19, 2003
    #17
  18. Graeme

    charter Guest

    Re: BASIC(no NAT now)SERIAL INTERFACE ON 1721.

    first post in a while. i've been through this just today. i could ping trace
    etc to whereever but could not surf. turned out bad ip route back to my
    place. check your provider. alot of people can mess with tables on tier 1.
    my .02 Kent
    "Chris" <> wrote in message
    news:bs00in$jjs$...
    >
    > "Graeme" <> wrote in message
    > news:3fe2e240$0$37275$...
    > > Thanks to everyone for all the input so far this has been quite a

    learning
    > > experience!
    > >
    > > I'vve tried many things to get this working but so far this is what has
    > > worked:
    > >
    > > The ISP's thirdline guys have suggested a 'show ip route' comamand which
    > > despite the "ip route 0.0.0.0 ..etc" was not showing as a static route

    !
    > so
    > > I've done a 'write erase' and they got me to type in a supplied config

    > from
    > > scratch and it's working (better) now i can ping from inside the router

    to
    > > both sides of the router but can't ping through the router from either
    > > side..! This one must be simple for you guys,

    >
    >
    > From the router, can you ping beyond the ISP's router (ie, to an address

    on
    > the internet) or just A-end router? Also, if you are using a live /29

    range
    > on the ethernet side and you patch the fastethernet port into a laptop or

    PC
    > and set up the next usable address, can you ping the external address of
    > your router and the other end of the link (ie. the ISP's router).
    >
    > Chris.
    >
    >
    >
    >
    > > Many thanks again for all your help,
    > >
    > > Graeme.
    > > My config-
    > > urrent configuration : 836 bytes
    > > !
    > > version 12.2
    > > service timestamps debug uptime
    > > service timestamps log uptime
    > > no service password-encryption
    > > !
    > > hostname WFRTR01
    > > !
    > > enable secret 5 <PASSWORD>
    > > !
    > > ip subnet-zero
    > > ip name-server <DNS IP ONE>
    > > ip name-server <DNS IP TWO>
    > > !
    > > !
    > > !
    > > !
    > > interface FastEthernet0
    > > ip address <First Host in Allocated Range> 255.255.255.248
    > > speed auto
    > > full-duplex
    > > !
    > > interface Serial0
    > > ip address <B-End Router IP> 255.255.255.252
    > > encapsulation frame-relay IETF
    > > logging event subif-link-status
    > > logging event dlci-status-change
    > > no fair-queue
    > > frame-relay map ip <A-End Router IP> 20 broadcast IETF
    > > frame-relay interface-dlci 20
    > > frame-relay lmi-type ansi
    > > !
    > > interface Serial1
    > > no ip address
    > > shutdown
    > > !
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 <A-End Router IP>
    > > ip http server
    > > !
    > > !
    > > !
    > > line con 0
    > > line aux 0
    > > line vty 0 4
    > > password <PASSWORD2>
    > > login
    > > !
    > > no scheduler allocate
    > > end
    > >
    > >

    >
    >
     
    charter, Dec 20, 2003
    #18
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrea
    Replies:
    0
    Views:
    885
    Andrea
    Apr 19, 2004
  2. Faustino Dina
    Replies:
    2
    Views:
    2,368
    Hansang Bae
    Aug 18, 2004
  3. Anubis
    Replies:
    5
    Views:
    779
    Ivan Ostreš
    Nov 28, 2004
  4. Scooter
    Replies:
    1
    Views:
    900
    BradReeseCom
    Feb 25, 2005
  5. Moloy
    Replies:
    1
    Views:
    1,054
Loading...

Share This Page