Basic lab config - where is my default route wrong

Discussion in 'Cisco' started by evergladesfl@gmail.com, Sep 4, 2006.

  1. Guest

    I have two 2501s that I am playing with for CCNA lab exercises.
    BHM is the router connected to the Internet gateway (the gateway's
    internal address is 192.168.0.3).
    The problem I am experiencing is that I cannot get to the Internet from
    GAD (see configs below), though I can from BHM:

    =========================
    sho run
    BHM#sho running-config
    !
    version 12.2
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Ethernet0
    ip address 192.168.0.80 255.255.255.0
    !
    interface Serial0
    ip address 172.17.0.2 255.255.0.0
    clockrate 56000
    !
    router rip
    version 2
    network 172.17.0.0
    network 192.168.0.0
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.0.3
    ==============================
    sho run
    GAD#sho running-config

    version 12.2
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Ethernet0
    ip address 172.16.0.1 255.255.0.0
    !
    interface Serial0
    ip address 172.17.0.1 255.255.0.0
    !
    router rip
    version 2
    network 172.16.0.0
    network 172.17.0.0
    !
    ip classless
    ip default-network 192.168.0.0

    ===========================
    >From GAD I can ping 192.168.0.80, which is BHM's e0 on the same network

    as the Internet gateway. But I can get no further than that interface
    (cannot ping 192.168.0.3). From BHM I can ping anywhere on the
    Internet.

    Please help me make sense of this.

    Thanks

    -tom
    , Sep 4, 2006
    #1
    1. Advertising

  2. Guest

    wrote:
    > I have two 2501s that I am playing with for CCNA lab exercises.
    > BHM is the router connected to the Internet gateway (the gateway's
    > internal address is 192.168.0.3).
    > The problem I am experiencing is that I cannot get to the Internet from
    > GAD (see configs below), though I can from BHM:
    >
    > =========================
    > sho run
    > BHM#sho running-config
    > !
    > version 12.2
    > !
    > ip subnet-zero
    > no ip domain-lookup
    > !
    > interface Ethernet0
    > ip address 192.168.0.80 255.255.255.0
    > !
    > interface Serial0
    > ip address 172.17.0.2 255.255.0.0
    > clockrate 56000
    > !
    > router rip
    > version 2
    > network 172.17.0.0
    > network 192.168.0.0
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 192.168.0.3
    > ==============================
    > sho run
    > GAD#sho running-config
    >
    > version 12.2
    > !
    > ip subnet-zero
    > no ip domain-lookup
    > !
    > interface Ethernet0
    > ip address 172.16.0.1 255.255.0.0
    > !
    > interface Serial0
    > ip address 172.17.0.1 255.255.0.0
    > !
    > router rip
    > version 2
    > network 172.16.0.0
    > network 172.17.0.0
    > !
    > ip classless
    > ip default-network 192.168.0.0
    >
    > ===========================
    > >From GAD I can ping 192.168.0.80, which is BHM's e0 on the same network

    > as the Internet gateway. But I can get no further than that interface
    > (cannot ping 192.168.0.3). From BHM I can ping anywhere on the
    > Internet.
    >
    > Please help me make sense of this.
    >
    > Thanks
    >
    > -tom


    >From the IOS Command Reference section on "ip default-network"


    "If the router has a directly connected interface onto the specified
    network, the dynamic routing protocols running on that router will
    generate (or source) a default route. For Router Information Protocol
    (RIP), this is flagged as the pseudonetwork 0.0.0.0; for Interior
    Gateway Routing Protocol (IGRP), it is the network itself, flagged as
    an exterior route."

    If this is the entire configuration, then your router GAD has no need
    to source a default route (which would be sent to other routers). Even
    if it does need to generate a default route via rip, it has no directly
    connected interface to the 192.168.0.0 network as required.

    For your purposes I think a simple "ip route 0.0.0.0 0.0.0.0
    172.17.0.2" would work best.

    I would also change the mask on your serial interfaces to
    255.255.255.252, but that's just me. They should work OK as specified.
    , Sep 4, 2006
    #2
    1. Advertising

  3. Guest

    Thanks for the reply. I have not yet used the the ip route 0.0.0.0
    0.0.0.0 172.17.0.2 command you suggest, but will give it a go.

    One thing that I still do not understand is why GAD cannot get to the
    address 192.168.0.3, since it does have a route to 192.168.0.0 and can
    get to 192.168.0.80 (e0 on BHM).

    Could you help me understand this?

    Thanks
    wrote:

    > For your purposes I think a simple "ip route 0.0.0.0 0.0.0.0
    > 172.17.0.2" would work best.
    , Sep 4, 2006
    #3
  4. chris Guest

    <> wrote in message
    news:...
    > Thanks for the reply. I have not yet used the the ip route 0.0.0.0
    > 0.0.0.0 172.17.0.2 command you suggest, but will give it a go.
    >
    > One thing that I still do not understand is why GAD cannot get to the
    > address 192.168.0.3, since it does have a route to 192.168.0.0 and can
    > get to 192.168.0.80 (e0 on BHM).
    >
    > Could you help me understand this?
    >
    > Thanks
    > wrote:
    >
    >> For your purposes I think a simple "ip route 0.0.0.0 0.0.0.0
    >> 172.17.0.2" would work best.

    >


    So does the internet gateway on 192.168.0.3 have a route back to GAD via the
    BHM router?

    Chris.
    chris, Sep 4, 2006
    #4
  5. Guest

    Crap - that's it!

    Thanks!


    chris wrote:

    >
    > So does the internet gateway on 192.168.0.3 have a route back to GAD via the
    > BHM router?
    >
    > Chris.
    , Sep 4, 2006
    #5
  6. Guest

    wrote:
    > I have two 2501s that I am playing with for CCNA lab exercises.
    > BHM is the router connected to the Internet gateway (the gateway's
    > internal address is 192.168.0.3).
    > The problem I am experiencing is that I cannot get to the Internet from
    > GAD (see configs below), though I can from BHM:
    >
    > =========================
    > sho run
    > BHM#sho running-config
    > !
    > version 12.2
    > !
    > ip subnet-zero
    > no ip domain-lookup
    > !
    > interface Ethernet0
    > ip address 192.168.0.80 255.255.255.0
    > !
    > interface Serial0
    > ip address 172.17.0.2 255.255.0.0
    > clockrate 56000
    > !
    > router rip
    > version 2
    > network 172.17.0.0
    > network 192.168.0.0
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 192.168.0.3
    > ==============================
    > sho run
    > GAD#sho running-config
    >
    > version 12.2
    > !
    > ip subnet-zero
    > no ip domain-lookup
    > !
    > interface Ethernet0
    > ip address 172.16.0.1 255.255.0.0
    > !
    > interface Serial0
    > ip address 172.17.0.1 255.255.0.0
    > !
    > router rip
    > version 2
    > network 172.16.0.0
    > network 172.17.0.0
    > !
    > ip classless
    > ip default-network 192.168.0.0
    >
    > ===========================
    > >From GAD I can ping 192.168.0.80, which is BHM's e0 on the same network

    > as the Internet gateway. But I can get no further than that interface
    > (cannot ping 192.168.0.3). From BHM I can ping anywhere on the
    > Internet.
    >
    > Please help me make sense of this.
    >
    > Thanks
    >
    > -tom
    , Sep 8, 2006
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Steve Marshall

    Default Config Files or Basic Config

    Steve Marshall, Nov 5, 2003, in forum: Cisco
    Replies:
    2
    Views:
    497
    Chris
    Nov 5, 2003
  2. perimere
    Replies:
    0
    Views:
    1,081
    perimere
    Mar 27, 2007
  3. Replies:
    9
    Views:
    4,843
    Scott Perry
    Aug 7, 2008
  4. Replies:
    1
    Views:
    767
    Trendkill
    Apr 1, 2009
  5. Replies:
    0
    Views:
    514
Loading...

Share This Page