Basic IPv6 Connectivity

Discussion in 'Cisco' started by whitemice, Mar 21, 2008.

  1. whitemice

    whitemice Guest

    I have two routers, a 7206 and an 2600 connected via a point-to-point
    T1. IPv4 connectivity works. Now I'm tring to bring up IPv6
    connectivity. Only neither router seems to 'see' the other. While a
    route to the subnet which is the T1 connection appears I can't even
    ping either side. Of course I [and everyone :)] am new to IPv6 so
    I'm potentially overlooking something.

    Also, is the "ipv6 enable" required for an interface with an IPv6
    address assgined? It seems like "ipv6 enable" would be implicit if an
    IPv6 address is assigned. I've found documentation that specifies
    "ipv6 enable" and documentation that doesn't. And would "ipv6 enable"
    be required on an unnumbered interface that is tied to an interface
    where IPv6 is enabled?

    Cisco 7206
    ----------------------------------
    Abbreviated config:
    ipv6 unicast-routing
    !
    interface Loopback0
    ip address 10.6.42.1 255.255.255.255
    ipv6 address FDB5:60DA:9B8A:2::/64 eui-64
    ipv6 enable
    ipv6 rip mi enable
    !
    interface FastEthernet0/0
    ip address 192.168.1.6 255.255.255.0
    duplex full
    speed auto
    ipv6 address FDB5:60DA:9B8A:1::6/64
    ipv6 rip mi enable
    !
    interface Serial2/0/1:0
    description GRD-RDG PtP
    bandwidth 1544
    ip unnumbered Loopback0
    ipv6 unnumbered Loopback0
    service-policy output voip
    ipv6 enable
    !
    ipv6 router rip mi
    !

    seaweed>show ipv6 route
    IPv6 Routing Table - 6 entries
    Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
    U - Per-user Static route
    I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS
    summary
    O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF
    ext 2
    ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
    C FDB5:60DA:9B8A:1::/64 [0/0]
    via ::, FastEthernet0/0
    L FDB5:60DA:9B8A:1::6/128 [0/0]
    via ::, FastEthernet0/0
    C FDB5:60DA:9B8A:2::/64 [0/0]
    via ::, Loopback0
    L FDB5:60DA:9B8A:2:21A:2FFF:FE89:9608/128 [0/0]
    via ::, Loopback0
    L FE80::/10 [0/0]
    via ::, Null0
    L FF00::/8 [0/0]
    via ::, Null0
    seaweed>show ipv6 ne
    seaweed>


    Cisco 2600
    ------------------------------------
    Abbreviated config:
    ipv6 unicast-routing
    !
    interface Loopback0
    ip address 10.6.42.33 255.255.255.255
    ipv6 address FDB5:60DA:9B8A:2::/64 eui-64
    ipv6 enable
    ipv6 rip mi enable
    !
    interface Ethernet0/0
    ip address 192.168.33.19 255.255.255.0
    ip helper-address 192.168.1.9
    no ip route-cache
    no ip mroute-cache
    half-duplex
    ipv6 address FDB5:60DA:9B8A:21::13/64
    ipv6 rip mi enable
    no keepalive
    !
    interface Serial0/0
    description RDG-GRD PtP
    bandwidth 1544
    ip unnumbered Loopback0
    service-policy output voip
    no ip mroute-cache
    ipv6 unnumbered Loopback0
    ipv6 enable
    !
    ipv6 router rip mi
    !

    rdggate#show ipv6 ne
    rdggate#show ipv6 route
    IPv6 Routing Table - 6 entries
    Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
    U - Per-user Static route
    I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS
    summary
    O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF
    ext 2
    ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
    C FDB5:60DA:9B8A:2::/64 [0/0]
    via ::, Loopback0
    L FDB5:60DA:9B8A:2:205:9BFF:FEAF:2080/128 [0/0]
    via ::, Loopback0
    C FDB5:60DA:9B8A:21::/64 [0/0]
    via ::, Ethernet0/0
    L FDB5:60DA:9B8A:21::13/128 [0/0]
    via ::, Ethernet0/0
    L FE80::/10 [0/0]
    via ::, Null0
    L FF00::/8 [0/0]
    via ::, Null0
    rdggate#ping FDB5:60DA:9B8A:2:21A:2FFF:FE89:9608

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to FDB5:60DA:9B8A:2:21A:2FFF:FE89:9608,
    timeout is 2 seconds:
    ......
    Success rate is 0 percent (0/5)
     
    whitemice, Mar 21, 2008
    #1
    1. Advertising

  2. whitemice

    Merv Guest

    I would try configing IPv6 global address directly on the Serial
    interface instead of using unnumbered

    7206
    ===

    int s 2/0/1:0
    ipv6 address 1::1/64


    2600
    ===

    int s 0/0
    ipv6 address 1::2/64


    sh ipv6 int

    sh ipv6 nei
     
    Merv, Mar 21, 2008
    #2
    1. Advertising

  3. whitemice <> writes:
    >I have two routers, a 7206 and an 2600 connected via a point-to-point
    >T1. IPv4 connectivity works. Now I'm tring to bring up IPv6
    >connectivity. Only neither router seems to 'see' the other. While a
    >route to the subnet which is the T1 connection appears I can't even
    >ping either side. Of course I [and everyone :)] am new to IPv6 so
    >I'm potentially overlooking something.


    Why is it new to everyone? I've run beta IPv6 code on cisco a 3102 and
    2500's and 3600's in the late 90's? (I'm guessing I'm close to the
    only one to have run up those beta image on a 3102 though :)

    >Also, is the "ipv6 enable" required for an interface with an IPv6
    >address assgined? It seems like "ipv6 enable" would be implicit if an
    >IPv6 address is assigned. I've found documentation that specifies
    >"ipv6 enable" and documentation that doesn't. And would "ipv6 enable"
    >be required on an unnumbered interface that is tied to an interface
    >where IPv6 is enabled?



    The ipv6 enabled is required on each interface talking. Its a
    relatively recent invention, since IPv6 is autoconfiguring, you don't
    necessarily have to put an IPv6 address on an interface. The intention
    of having "ipv6 enabled" being requires is so that you don't turn on
    the global IPv6 knob and suddenly have 100's of ports auto-configure
    and talk IPv6 to the global Net on IPv6 potentially ignoring a
    firewall there.. You only enable the interface when you're ready to talk.

    Also, since IPv6 has link-local IP addressing, why are you trying to
    do unnumbered with it? It already has link-local IPv6 addressing as it
    is. If you don't want to use global IPs, use the local link-local IPs?

    I'd lose the un-numbered interfaces out of your config, let the
    interfaces have their link-local IPs. Ping across the link with the
    link-local ones.

    Also note that your IPv6 rip isn't working, and you have no static
    routing in place. Thats probably why your pings don't return.
    I'd rip it out to be simpler. No un-numbered interfacing. No RIP,
    just an IP per interface, and static routing.
     
    Doug McIntyre, Mar 21, 2008
    #3
  4. whitemice

    Merv Guest

    The "ipv6 enable" command is used to bring up an interface with a link-
    local address only. If an interface has a global IPv6 address
    configured then "ipv6 enable" is not required. Also removing ipv6
    enable from an interface that has an IPv6 global address configured
    will not disable IPv6 processing on that interface.

    For router-to-router links we should not require IPv6 ND router
    advertisements so disable as should be using an IGP. Also do not
    require IPv6 DUD on router-to-router links so put max time as IGP will
    be used to discover if neighbour has vanished. Use IGP fast
    convergence timers or BFD if required

    ipv6 nd ra suppress
    ipv6 nd ns-interval 15000
    ipv6 nd reachable-time 3600000


    Also can use ra suppression on LAN interfaces when a first-hop
    reachability protocol such as HSRP or VRRP is used.
     
    Merv, Mar 22, 2008
    #4
  5. whitemice

    whitemice Guest

    Thanks everybody for the feedback & details; it was indeed the
    unnumbered interfaces that was messing it up. Needed to be my head
    out of IPv4 mode! Routing protocol and all seems to be working now.

    Router#1:
    ipv6 unicast-routing
    !
    interface FastEthernet0/0
    ip address 192.168.1.6 255.255.255.0
    ipv6 address FDB5:60DA:9B8A:1::6/64
    ipv6 rip mi enable
    !
    interface Serial2/0/1:0
    ipv6 enable
    ipv6 rip mi enable
    !
    ipv6 route 2001::/16 FDB5:60DA:9B8A:1::37 100
    ipv6 route 2002::/16 FDB5:60DA:9B8A:1::37 100
    ipv6 router rip mi
    redistribute static
    !

    Router#2:
    ipv6 unicast-routing
    !
    interface FastEthernet0/0
    ipv6 address FDB5:60DA:9B8A:21::13/64
    ipv6 rip mi enable
    !
    interface Serial2/0/1:0
    ipv6 enable
    ipv6 rip mi enable
    !
    ipv6 router rip mi
    !
     
    whitemice, Mar 24, 2008
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    2
    Views:
    1,619
  2. Jaime
    Replies:
    2
    Views:
    559
    Jaime
    Sep 20, 2003
  3. Jimmy Dean
    Replies:
    3
    Views:
    1,106
    Duane Arnold
    Jul 25, 2005
  4. Sharp Dressed Man

    TurboTax Basic vs. Taxcut Basic?

    Sharp Dressed Man, Jan 10, 2009, in forum: Computer Support
    Replies:
    1
    Views:
    677
    Sharp Dressed Man
    Jan 12, 2009
  5. hbizta
    Replies:
    1
    Views:
    1,979
    sunzy
    Aug 20, 2010
Loading...

Share This Page