Basic Config help needed 1841 Router 2 ethernet

Discussion in 'Cisco' started by corb, Feb 15, 2007.

  1. corb

    corb Guest

    Hi, I am attempting to configure an 1841 with 2 Ethernet connections and am
    unable to get things working with a simple config.



    My setup is :



    External IP Ethernet 0 - Internal IP Ethernet 1 NAT 10.0.0.X/24



    Below is the config can someone notice any mistakes?.



    I'm trying to replace an Belkin router with the 1841



    Any help would be appreciated



    thanks.







    !

    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname 1841-Energy_centre

    !

    boot-start-marker

    boot-end-marker

    !

    enable secret 5 $1$mDzN$iWCpz4fKcx5PIOf6pwgBs0

    enable password 123tcp45

    !

    no aaa new-model

    ip cef

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    interface FastEthernet0/0

    ip address 62.49.X.X 255.255.255.240

    ip nat outside

    ip virtual-reassembly

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    ip address 10.0.0.254 255.255.255.0

    ip nat inside

    ip virtual-reassembly

    speed auto

    full-duplex

    no mop enabled

    !

    ip route 0.0.0.0 0.0.0.0 62.49.X.X

    !

    no ip http server

    no ip http secure-server

    ip nat inside source list 15 interface FastEthernet0/0 overload

    !

    access-list 15 permit 10.0.0.0 0.0.0.255

    !

    !

    control-plane

    !

    !

    line con 0

    line aux 0

    line vty 0 4

    password XXXXX

    login

    !

    scheduler allocate 20000 1000

    end
     
    corb, Feb 15, 2007
    #1
    1. Advertising

  2. corb

    Brian V Guest

    "corb" <> wrote in message
    news:peWAh.9505$...
    > Hi, I am attempting to configure an 1841 with 2 Ethernet connections and
    > am unable to get things working with a simple config.
    >
    >
    >
    > My setup is :
    >
    >
    >
    > External IP Ethernet 0 - Internal IP Ethernet 1 NAT 10.0.0.X/24
    >
    >
    >
    > Below is the config can someone notice any mistakes?.
    >
    >
    >
    > I'm trying to replace an Belkin router with the 1841
    >
    >
    >
    > Any help would be appreciated
    >
    >
    >
    > thanks.
    >
    >
    >
    >
    >
    >
    >
    > !
    >
    > version 12.4
    >
    > service timestamps debug datetime msec
    >
    > service timestamps log datetime msec
    >
    > no service password-encryption
    >
    > !
    >
    > hostname 1841-Energy_centre
    >
    > !
    >
    > boot-start-marker
    >
    > boot-end-marker
    >
    > !
    >
    > enable secret 5 $1$mDzN$iWCpz4fKcx5PIOf6pwgBs0
    >
    > enable password 123tcp45
    >
    > !
    >
    > no aaa new-model
    >
    > ip cef
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > interface FastEthernet0/0
    >
    > ip address 62.49.X.X 255.255.255.240
    >
    > ip nat outside
    >
    > ip virtual-reassembly
    >
    > duplex auto
    >
    > speed auto
    >
    > !
    >
    > interface FastEthernet0/1
    >
    > ip address 10.0.0.254 255.255.255.0
    >
    > ip nat inside
    >
    > ip virtual-reassembly
    >
    > speed auto
    >
    > full-duplex
    >
    > no mop enabled
    >
    > !
    >
    > ip route 0.0.0.0 0.0.0.0 62.49.X.X
    >
    > !
    >
    > no ip http server
    >
    > no ip http secure-server
    >
    > ip nat inside source list 15 interface FastEthernet0/0 overload
    >
    > !
    >
    > access-list 15 permit 10.0.0.0 0.0.0.255
    >
    > !
    >
    > !
    >
    > control-plane
    >
    > !
    >
    > !
    >
    > line con 0
    >
    > line aux 0
    >
    > line vty 0 4
    >
    > password XXXXX
    >
    > login
    >
    > !
    >
    > scheduler allocate 20000 1000
    >
    > end
    >
    >


    Config is fine, no problems with it.

    What type of device is the outside interface patching in to? If a cable
    modem you would need to power it off for about 2 minutes to clear it's MAC
    table, most only allow a single MAC and the Belkins may be cached in there.

    What does a show interface say? Are they both up and up?

    From the router itself can you ping your default gateway?
     
    Brian V, Feb 15, 2007
    #2
    1. Advertising

  3. corb

    corb Guest

    "Brian V" <> wrote in message
    news:...
    >
    > "corb" <> wrote in message
    > news:peWAh.9505$...
    >> Hi, I am attempting to configure an 1841 with 2 Ethernet connections and
    >> am unable to get things working with a simple config.
    >>
    >>
    >>
    >> My setup is :
    >>
    >>
    >>
    >> External IP Ethernet 0 - Internal IP Ethernet 1 NAT 10.0.0.X/24
    >>
    >>
    >>
    >> Below is the config can someone notice any mistakes?.
    >>
    >>
    >>
    >> I'm trying to replace an Belkin router with the 1841
    >>
    >>
    >>
    >> Any help would be appreciated
    >>
    >>
    >>
    >> thanks.
    >>
    >>
    >>
    >>
    >>
    >>
    >>
    >> !
    >>
    >> version 12.4
    >>
    >> service timestamps debug datetime msec
    >>
    >> service timestamps log datetime msec
    >>
    >> no service password-encryption
    >>
    >> !
    >>
    >> hostname 1841-Energy_centre
    >>
    >> !
    >>
    >> boot-start-marker
    >>
    >> boot-end-marker
    >>
    >> !
    >>
    >> enable secret 5 $1$mDzN$iWCpz4fKcx5PIOf6pwgBs0
    >>
    >> enable password 123tcp45
    >>
    >> !
    >>
    >> no aaa new-model
    >>
    >> ip cef
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> !
    >>
    >> interface FastEthernet0/0
    >>
    >> ip address 62.49.X.X 255.255.255.240
    >>
    >> ip nat outside
    >>
    >> ip virtual-reassembly
    >>
    >> duplex auto
    >>
    >> speed auto
    >>
    >> !
    >>
    >> interface FastEthernet0/1
    >>
    >> ip address 10.0.0.254 255.255.255.0
    >>
    >> ip nat inside
    >>
    >> ip virtual-reassembly
    >>
    >> speed auto
    >>
    >> full-duplex
    >>
    >> no mop enabled
    >>
    >> !
    >>
    >> ip route 0.0.0.0 0.0.0.0 62.49.X.X
    >>
    >> !
    >>
    >> no ip http server
    >>
    >> no ip http secure-server
    >>
    >> ip nat inside source list 15 interface FastEthernet0/0 overload
    >>
    >> !
    >>
    >> access-list 15 permit 10.0.0.0 0.0.0.255
    >>
    >> !
    >>
    >> !
    >>
    >> control-plane
    >>
    >> !
    >>
    >> !
    >>
    >> line con 0
    >>
    >> line aux 0
    >>
    >> line vty 0 4
    >>
    >> password XXXXX
    >>
    >> login
    >>
    >> !
    >>
    >> scheduler allocate 20000 1000
    >>
    >> end
    >>
    >>

    >
    > Config is fine, no problems with it.
    >
    > What type of device is the outside interface patching in to? If a cable
    > modem you would need to power it off for about 2 minutes to clear it's MAC
    > table, most only allow a single MAC and the Belkins may be cached in
    > there.
    >
    > What does a show interface say? Are they both up and up?
    >
    > From the router itself can you ping your default gateway?
    >


    Hi thanks for the reply.

    Its and ADSL modem so at the mo there is an ADSL modem device with external
    IP address- Ethernet - Belikin ethernet router with external IP (this works
    fine)

    yes both interfaces were up and up, couldnt ping default gateway.
     
    corb, Feb 15, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Steve Marshall

    Default Config Files or Basic Config

    Steve Marshall, Nov 5, 2003, in forum: Cisco
    Replies:
    2
    Views:
    553
    Chris
    Nov 5, 2003
  2. Peter
    Replies:
    2
    Views:
    1,087
  3. Replies:
    2
    Views:
    1,636
  4. sparticle
    Replies:
    3
    Views:
    1,230
  5. SteveBosell

    Basic PIX and Router config help

    SteveBosell, Sep 16, 2007, in forum: Cisco
    Replies:
    0
    Views:
    730
    SteveBosell
    Sep 16, 2007
Loading...

Share This Page