Bad Multicast sound quality

Discussion in 'Cisco' started by Faustino Dina, Aug 31, 2004.

  1. Hi,

    I'm doing some lab testing for multicasting across cisco routers. I have
    two 3810 Cisco routers connected back-to-back by using the Aux port at
    38400bps speed. Each Ethernet interface is connected to a different LAN
    segment. PCs attached to both segments run Windows 2000/XP Phone Dialer. I
    have tested three different configurations recommended by Cisco at Multicast
    Quick-Start Configuration Guide
    (http://www.cisco.com/warp/public/105/48.html): dense mode, sparse mode with
    one RP, and auto-RP with one RP. On the three configuration I've got the
    same result: The direct IP dialing PC to PC works with good voice quality,
    but the quality of the voice tele-conference is too bad. It works, you can
    recognize that somebody is talking on the other end of the line, but it is
    impossible to recognize what is spoken. It is similar when you hear Internet
    music by a very slow connections. I guess I'm losing packets. First I
    suspect the 38400bps lik between routers. But it works great when calling
    directly, without multicasting.
    What can be wrong? Both routers run IOS 12.0. Any idea is welcomed.

    Thanks in advance

    --
    Faustino Dina

    The configuration of the routers is like the following:

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname BOTTOM
    !
    logging buffered 4096 debugging
    no logging console
    no logging monitor
    enable secret ***
    enable password ***
    !
    !
    !
    !
    !
    network-clock base-rate 56k
    ip subnet-zero
    !
    ip multicast-routing
    ip dvmrp route-limit 20000
    !
    !
    !
    process-max-time 200
    !
    interface Ethernet0
    ip address 10.10.10.253 255.255.255.0
    no ip directed-broadcast
    ip pim sparse-dense-mode
    no ip mroute-cache
    !
    interface Async1
    ip address 192.168.10.2 255.255.255.0
    ip directed-broadcast
    ip pim sparse-dense-mode
    encapsulation ppp
    async dynamic routing
    async mode dedicated
    !
    interface Switch0
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    no ip mroute-cache
    no fair-queue
    !
    no ip http server
    no ip classless
    ip route 0.0.0.0 0.0.0.0 Ethernet0
    ip route 10.10.19.0 255.255.255.0 192.168.10.1
    ip pim send-rp-announce Ethernet0 scope 16
    ip pim send-rp-discovery scope 16
    !
    logging trap debugging
    logging 10.10.10.67
    snmp-server engineID local 000000090200003094FB7AF5
    snmp-server community BOTTOM RO
    !
    line con 0
    exec-timeout 0 0
    transport input none
    line aux 0
    modem InOut
    transport input all
    speed 38400
    speed 38400
    line 2 3
    line vty 0 4
    password ****
    login
    !
    !
    voice-port 1/1
    timeouts call-disconnect 0
    !
    voice-port 1/2
    timeouts call-disconnect 0
    !
    voice-port 1/5
    timeouts call-disconnect 0
    timing hookflash-out 0
    !
    voice-port 1/6
    timeouts call-disconnect 0
    timing hookflash-out 0
    !
    !
    end
     
    Faustino Dina, Aug 31, 2004
    #1
    1. Advertising

  2. Faustino Dina

    MC Guest

    Do not use the AUX port for this type of testing, The AUX port will cause
    too many CPU interupts and not sure how will work trying to handle
    multicast. Best to use a dedicated controller IO which will not interupt for
    each packet of data as the AUX port will do. The AUX port which is an ASYNC
    serial interface will gernerate an interupt for each byte of data.

    Also you can enable fast switching of multicast packets using the ip
    mroute-cache interface configuration command, fast switching of multicast
    packets is off by default. This may help with performance.

    Interrupts are generated any time a character is output from the console or
    auxiliary ports of a router.

    UARTs are slow compared to the processing speed of the router, so it is
    unlikely, though possible, that console or auxiliary interrupts can cause a
    high CPU utilization on the router, unless the router has a large number of
    tty lines in use. However when using AUX ports as a dialbackup connection
    can be OK I have seen a few circumstances where using the AUX ports
    back-to-back like that can casue a lot of CPU overhead and if combined with
    not processing the multicast traffic properly may cause problems.

    The TTY Background process is a generic process used by all terminal lines
    (console, aux, async, and so on). This itself should not cause and
    performance problems of the router but since this process has a lower
    priority compared to the other processes that need to be scheduled by the
    Cisco IOS software may not be processing the packets through the AUX port as
    it should.

    Best to use an dedicated controller IO interface for this, weather SYNC or
    ASYNC, Dedicated controllers do not have the same limitations as the AUX
    port.

    "Faustino Dina" <> wrote in message
    news:...
    > Hi,
    >
    > I'm doing some lab testing for multicasting across cisco routers. I have
    > two 3810 Cisco routers connected back-to-back by using the Aux port at
    > 38400bps speed. Each Ethernet interface is connected to a different LAN
    > segment. PCs attached to both segments run Windows 2000/XP Phone Dialer. I
    > have tested three different configurations recommended by Cisco at

    Multicast
    > Quick-Start Configuration Guide
    > (http://www.cisco.com/warp/public/105/48.html): dense mode, sparse mode

    with
    > one RP, and auto-RP with one RP. On the three configuration I've got the
    > same result: The direct IP dialing PC to PC works with good voice quality,
    > but the quality of the voice tele-conference is too bad. It works, you can
    > recognize that somebody is talking on the other end of the line, but it is
    > impossible to recognize what is spoken. It is similar when you hear

    Internet
    > music by a very slow connections. I guess I'm losing packets. First I
    > suspect the 38400bps lik between routers. But it works great when calling
    > directly, without multicasting.
    > What can be wrong? Both routers run IOS 12.0. Any idea is welcomed.
    >
    > Thanks in advance
    >
    > --
    > Faustino Dina
    >
    > The configuration of the routers is like the following:
    >
    > Current configuration:
    > !
    > version 12.0
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > service udp-small-servers
    > service tcp-small-servers
    > !
    > hostname BOTTOM
    > !
    > logging buffered 4096 debugging
    > no logging console
    > no logging monitor
    > enable secret ***
    > enable password ***
    > !
    > !
    > !
    > !
    > !
    > network-clock base-rate 56k
    > ip subnet-zero
    > !
    > ip multicast-routing
    > ip dvmrp route-limit 20000
    > !
    > !
    > !
    > process-max-time 200
    > !
    > interface Ethernet0
    > ip address 10.10.10.253 255.255.255.0
    > no ip directed-broadcast
    > ip pim sparse-dense-mode
    > no ip mroute-cache
    > !
    > interface Async1
    > ip address 192.168.10.2 255.255.255.0
    > ip directed-broadcast
    > ip pim sparse-dense-mode
    > encapsulation ppp
    > async dynamic routing
    > async mode dedicated
    > !
    > interface Switch0
    > no ip address
    > no ip directed-broadcast
    > encapsulation frame-relay
    > no ip mroute-cache
    > no fair-queue
    > !
    > no ip http server
    > no ip classless
    > ip route 0.0.0.0 0.0.0.0 Ethernet0
    > ip route 10.10.19.0 255.255.255.0 192.168.10.1
    > ip pim send-rp-announce Ethernet0 scope 16
    > ip pim send-rp-discovery scope 16
    > !
    > logging trap debugging
    > logging 10.10.10.67
    > snmp-server engineID local 000000090200003094FB7AF5
    > snmp-server community BOTTOM RO
    > !
    > line con 0
    > exec-timeout 0 0
    > transport input none
    > line aux 0
    > modem InOut
    > transport input all
    > speed 38400
    > speed 38400
    > line 2 3
    > line vty 0 4
    > password ****
    > login
    > !
    > !
    > voice-port 1/1
    > timeouts call-disconnect 0
    > !
    > voice-port 1/2
    > timeouts call-disconnect 0
    > !
    > voice-port 1/5
    > timeouts call-disconnect 0
    > timing hookflash-out 0
    > !
    > voice-port 1/6
    > timeouts call-disconnect 0
    > timing hookflash-out 0
    > !
    > !
    > end
    >
    >
     
    MC, Aug 31, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    12
    Views:
    3,122
    Michael Alan Chary
    Feb 23, 2005
  2. Replies:
    0
    Views:
    554
  3. Proteus
    Replies:
    20
    Views:
    1,858
    Paul J Gans
    Sep 13, 2004
  4. Paul Sassieni

    Skype - bad sound quality

    Paul Sassieni, Apr 16, 2006, in forum: Computer Support
    Replies:
    7
    Views:
    3,698
    Meat Plow
    Apr 18, 2006
  5. John

    Bad media, bad files or bad Nero?

    John, Dec 31, 2007, in forum: Computer Information
    Replies:
    23
    Views:
    1,309
    Keith
    Jan 8, 2008
Loading...

Share This Page