Back to back "routers on a stick"

Discussion in 'Cisco' started by damon@soho-systems.com, Jun 24, 2005.

  1. Guest

    Have a little trouble with connectivity loss in this scenario;

    router1 <> switch1 <> switch2 <> router2

    router1 is running dot1q vlan encapsultion.

    router2 is also running dot1q vlan enacpasulation.

    the ports on switch1 and switch2 that are connected to the routers are
    dot1q trunk ports.

    the ports that are connected via crossover between switch1 and switch2
    are vlan access ports.

    everything works fine for several days, then locks up. all interfaces
    show linked and up, but no ip trafic will pass. ressetting switch 2
    corrects the problem.

    any ideas? bad hardware or bad config?

    relevant configs;

    router1

    'subinterface connected to vlan trunk port on switch1
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address x.x.x.x 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    no ip mroute-cache
    no keepalive
    no cdp enable

    switch1

    'connected to router1
    interface FastEthernet0/1
    duplex full
    speed 100
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    'conected to switch2
    interface FastEthernet0/2
    duplex full
    speed 10
    switchport access vlan 10

    switch2

    'port coneted to switch1
    interface FastEthernet0/9
    switchport access vlan 209
    switchport mode access
    switchport protected
    load-interval 30
    duplex full
    speed 10

    router2

    interface GigabitEthernet13/2.9
    encapsulation dot1Q 209
    ip address x.x.x.x 255.255.255.252
    no ip directed-broadcast
    , Jun 24, 2005
    #1
    1. Advertising

  2. Mark Lar Guest

    wrote:

    > everything works fine for several days, then locks up. all interfaces
    > show linked and up, but no ip trafic will pass. ressetting switch 2
    > corrects the problem.

    Checked for port errors on each device? Could try hard-setting
    everything to 10/half, or twiddle the nerd-knobs on fa0/9 some.

    M.
    Mark Lar, Jun 25, 2005
    #2
    1. Advertising

  3. Guest

    , Jun 25, 2005
    #3
  4. Guest

    , Jun 25, 2005
    #4
  5. Mark Lar Guest

    wrote:

    > please see: http://www.dieinter.net/forum
    >

    Why?

    The question was asked on Usenet, doesn't it seem sensible to answer it
    here as well?
    Mark Lar, Jun 26, 2005
    #5
  6. Mark Lar Guest

    Mark Lar wrote:

    > wrote:
    >
    >> please see: http://www.dieinter.net/forum
    >>

    > Why?
    >
    > The question was asked on Usenet, doesn't it seem sensible to answer it
    > here as well?

    Besides, the answer given is wrong!
    Mark Lar, Jun 26, 2005
    #6
  7. Guest

    > router1 <> switch1 <> switch2 <> router2
    >
    > router1 is running dot1q vlan encapsultion.
    > router2 is also running dot1q vlan enacpasulation.
    >
    > the ports on switch1 and switch2 that are connected > to the routers are
    > dot1q trunk ports.
    >
    > the ports that are connected via crossover between > switch1 and switch2
    > are vlan access ports.
    >
    > everything works fine for several days, then locks up. > all interfaces
    > show linked and up, but no ip trafic will pass.
    > ressetting switch 2
    > corrects the problem.
    >
    > any ideas? bad hardware or bad config?


    This looks like a school question to me:)

    Could be bad hardware but there are other
    things to check first.

    Are there port errors.
    Are port traffic counters incrementing?

    Try running say ospf and see if you can
    maintain a neighbour relationship between the
    routers. Log neighbour changes.
    Check the arp tables, you could have
    a duplicate address
    Check the CAM tables on the switches.
    i.e. sh mac-address

    if ospf is too frightening or you don't have it
    hsrp would probably do. Use debug.
    Make sure logging is enabled.
    , Jun 27, 2005
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. pandula
    Replies:
    1
    Views:
    4,299
    Luc D.B.
    Jul 10, 2003
  2. Fiber Optic

    back-to-back with ISDN

    Fiber Optic, Jul 22, 2003, in forum: Cisco
    Replies:
    8
    Views:
    7,403
    Tilman Schmidt
    Jul 25, 2003
  3. Dejan Gambin
    Replies:
    0
    Views:
    734
    Dejan Gambin
    Oct 16, 2003
  4. sbab

    back to back cable

    sbab, Oct 17, 2003, in forum: Cisco
    Replies:
    2
    Views:
    871
    Tom Lawrence
    Oct 21, 2003
  5. Cyber-Soldier
    Replies:
    1
    Views:
    684
    Andrej Brkic
    Nov 20, 2003
Loading...

Share This Page