Aux to console reverse telnet - help needed!

Discussion in 'Cisco' started by Eustahije, Jul 27, 2004.

  1. Eustahije

    Eustahije Guest

    Hello,

    I am trying to connect Cisco 1721 AUX port to a Cisco 2600 series router's
    console Port. I do not have hardware support for asynchronous ports on my
    Cisco 1721 and only line 5 (aux 0) can be used and configured for that
    purpose. (int async 5, line aux 0). When I connect two Cisco 1721 routers
    with rollover cable (aux to console), everything works fine, but when I try
    to connect C1721's aux port to C2600's console, I can't work on my C2600. I
    can connect (reverse telnet) and I get boot messages from it, but I don't
    get any echo and I can't configure my C2600.
    Does anyone have any idea how can I configure my (only) Cisco 1721's
    asynchronous port to work properly?

    Tnx in advance,

    Salvador
    Eustahije, Jul 27, 2004
    #1
    1. Advertising

  2. Eustahije

    Hansang Bae Guest

    In article <ce4vb4$eau$>, says...
    > Hello,
    >
    > I am trying to connect Cisco 1721 AUX port to a Cisco 2600 series router's
    > console Port. I do not have hardware support for asynchronous ports on my
    > Cisco 1721 and only line 5 (aux 0) can be used and configured for that
    > purpose. (int async 5, line aux 0). When I connect two Cisco 1721 routers
    > with rollover cable (aux to console), everything works fine, but when I try
    > to connect C1721's aux port to C2600's console, I can't work on my C2600. I
    > can connect (reverse telnet) and I get boot messages from it, but I don't
    > get any echo and I can't configure my C2600.
    > Does anyone have any idea how can I configure my (only) Cisco 1721's
    > asynchronous port to work properly?



    On the 1700 router:

    line aux 0
    no exec
    transport input all

    Now you'll be able to reverse telnet out of the aux port to the console
    of the 2600.


    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
    Hansang Bae, Jul 28, 2004
    #2
    1. Advertising

  3. Eustahije

    Salvador Guest

    I tried that, but it doesn't work. Nevertheless, I'll try once again.
    Thanks.


    "Hansang Bae" <> wrote in message
    news:...
    > In article <ce4vb4$eau$>, says...
    > > Hello,
    > >
    > > I am trying to connect Cisco 1721 AUX port to a Cisco 2600 series

    router's
    > > console Port. I do not have hardware support for asynchronous ports on

    my
    > > Cisco 1721 and only line 5 (aux 0) can be used and configured for that
    > > purpose. (int async 5, line aux 0). When I connect two Cisco 1721

    routers
    > > with rollover cable (aux to console), everything works fine, but when I

    try
    > > to connect C1721's aux port to C2600's console, I can't work on my

    C2600. I
    > > can connect (reverse telnet) and I get boot messages from it, but I

    don't
    > > get any echo and I can't configure my C2600.
    > > Does anyone have any idea how can I configure my (only) Cisco 1721's
    > > asynchronous port to work properly?

    >
    >
    > On the 1700 router:
    >
    > line aux 0
    > no exec
    > transport input all
    >
    > Now you'll be able to reverse telnet out of the aux port to the console
    > of the 2600.
    >
    >
    > --
    >
    > hsb
    >
    > "Somehow I imagined this experience would be more rewarding" Calvin
    > *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    > ********************************************************************
    > Due to the volume of email that I receive, I may not not be able to
    > reply to emails sent to my account. Please post a followup instead.
    > ********************************************************************
    Salvador, Jul 28, 2004
    #3
  4. Hola Salvador

    Before we even begin, lets set up the cabling first.

    You need a straight through cable going from the console port of the
    console-only device to the AUX port on your router.

    Now lets get going with the router config:


    In order to set up reverse telnet, these are the steps:

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    1. Configure the AUX port.

    router#config t
    router(config)#line aux 0
    router(config-line)#modem InOut
    router(config-line)#transport input all
    router(config-line)#speed 19200
    router(config-line)#exit

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    2. Then you must create a loopback addresss

    router#config t
    router(config)#int loopback 0
    router(config-if)#ip address 10.0.0.1 255.0.0.0
    router(config-if)#no shut
    router(config-if)#exit

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    3. Now you must find out what "line" the router uses for the AUX
    port.

    OUTSIDE OF CONFIG MODE (hit CTRL-Z to get out) enter the command "sh
    line"
    you will get an output resembling the following:

    router#sh line
    Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise
    Overruns Int
    0 CTY - - - - - 0 0 0/0
    -
    225 AUX 19200/19200 - inout - - - 0 0 0/0
    -
    * 226 VTY - - - - - 10 0 0/0
    -
    227 VTY - - - - - 0 0 0/0
    -
    228 VTY - - - - - 0 0 0/0
    -
    229 VTY - - - - - 0 0 0/0
    -
    230 VTY - - - - - 0 0 0/0
    -

    This particular router (a 3660) uses line 225 for the AUX port.

    --------

    This is the output from a 2611.

    router#sh line
    Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise
    Overruns Int
    0 CTY - - - - - 0 0 0/0
    -
    65 AUX 19200/19200 - inout - - - 8 0 2177/0
    -
    * 66 VTY - - - - - 24 0 0/0
    -
    67 VTY - - - - - 3 0 0/0
    -
    68 VTY - - - - - 1 0 0/0
    -
    69 VTY - - - - - 0 0 0/0
    -
    70 VTY - - - - - 0 0 0/0
    -

    It uses line 65 for the AUX port. (The port with the * by it is
    the line you are currently connected to.)

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    4. Telnet:

    To do this, you will telnet to the IP address you set on the loopback
    interface.
    The port number you will telnet to is 2000+line#.

    So for the 3660, assuming my loopback interface has IP address of
    10.0.0.1,
    I would telnet to 10.0.0.1:2225

    For the 2611, assuming my loopback interface has IP address of
    10.0.0.1,
    I would telnet to 10.0.0.1:2065.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    5. Finishing:

    When you are done, while holding the keys CTRL+SHIFT+6, press the
    letter X.
    This will kick you out of the AUX port.

    The router will still keep the line connected and no one will be able
    to
    retelnet back in until you clear the line.

    To do this, OUTSIDE OF CONFIG MODE (hit CTRL-Z to get out of config
    mode)
    you enter the command "clear line xxx" where "x" is the line#.

    So for the 3660, I would enter "clear line 225"

    On the 2611, I would enter "clear line 65"

    It will ask you to confirm, just hit the enter key.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    And that is everything there is to know about reverse telnetting.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Here is a sample configuration, this is everything you need to reverse
    telnet:


    sample-config#sh run
    Building configuration...

    Current configuration : 3481 bytes
    !
    !
    interface Loopback0
    ip address 10.0.0.1 255.0.0.0
    !
    line con 0
    transport input none
    line aux 0
    modem InOut
    transport input all
    speed 19200
    line vty 0 4
    password xxxxxxx
    login
    !
    end

    Taken from From: http://www.tek-tips.com/gfaqs.cfm/lev2/8/lev3/58/pid/557/fid/1312

    Saludos,
    Victor Cappuccio
    www.vcappuccio.freeservers.com

    "Eustahije" <> wrote in message news:<ce4vb4$eau$>...
    > Hello,
    >
    > I am trying to connect Cisco 1721 AUX port to a Cisco 2600 series router's
    > console Port. I do not have hardware support for asynchronous ports on my
    > Cisco 1721 and only line 5 (aux 0) can be used and configured for that
    > purpose. (int async 5, line aux 0). When I connect two Cisco 1721 routers
    > with rollover cable (aux to console), everything works fine, but when I try
    > to connect C1721's aux port to C2600's console, I can't work on my C2600. I
    > can connect (reverse telnet) and I get boot messages from it, but I don't
    > get any echo and I can't configure my C2600.
    > Does anyone have any idea how can I configure my (only) Cisco 1721's
    > asynchronous port to work properly?
    >
    > Tnx in advance,
    >
    > Salvador
    Victor Cappuccio, Jul 29, 2004
    #4
  5. Eustahije

    Salvador Guest

    "Victor Cappuccio" <> wrote in message
    news:...
    > Hola Salvador
    >

    ....

    Thanks a lot.

    Sal.
    Salvador, Jul 29, 2004
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Aaron Leonard

    Re: AS5350 reverse telnet

    Aaron Leonard, Jul 10, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,611
    Aaron Leonard
    Jul 10, 2003
  2. A. Andrews

    cisco/DNP/SCADA and reverse telnet

    A. Andrews, Jan 8, 2004, in forum: Cisco
    Replies:
    0
    Views:
    616
    A. Andrews
    Jan 8, 2004
  3. A. Andrews

    Cisco reverse Telnet problem

    A. Andrews, Jan 15, 2004, in forum: Cisco
    Replies:
    4
    Views:
    4,480
    Hansang Bae
    Jan 21, 2004
  4. AM

    AUX to CONSOLE.

    AM, Feb 3, 2005, in forum: Cisco
    Replies:
    0
    Views:
    615
  5. Replies:
    2
    Views:
    742
    Philip D'Ath
    Feb 26, 2005
Loading...

Share This Page