Asterisk@Home - Incoming Calls

Discussion in 'UK VOIP' started by Sean, Oct 2, 2005.

  1. Sean

    Sean Guest

    Hi, i have asterisk running, outgoing calls are fine, internal calls are
    fine. But incoming external calls have me very confused and annoyed!

    When i call myself from another SIP device, or a friend does they get
    service unavilable in x-lite/pro. The call is then logged in my recent
    calls as unanswered, and it claims its route is 's'.

    Anyone have any idea what i am going on about, and how i can fix this?

    Cheers
    Sean, Oct 2, 2005
    #1
    1. Advertising

  2. Sean

    Jono Guest

    Sean wrote:
    || Hi, i have asterisk running, outgoing calls are fine, internal calls
    || are fine. But incoming external calls have me very confused and
    || annoyed!
    ||
    || When i call myself from another SIP device, or a friend does they get
    || service unavilable in x-lite/pro. The call is then logged in my
    || recent calls as unanswered, and it claims its route is 's'.
    ||
    || Anyone have any idea what i am going on about, and how i can fix
    || this?
    ||
    || Cheers

    Which company are you using?

    I've made use of the tutorial here
    http://esupport.gradwell.net/index.php?_a=knowledgebase&_j=subcat&_i=29 to
    good effect for Sipgate.

    IIRC, there are a bunch of changes you need to make to stop incoming SIP
    calls going to a busy extension (which A@H does by default)......., however,
    following the tutorial & setting up the DDIs (DIDs) it all works fine.
    Jono, Oct 2, 2005
    #2
    1. Advertising

  3. Sean

    Sean Guest

    Jono wrote:
    > Sean wrote:
    > || Hi, i have asterisk running, outgoing calls are fine, internal calls
    > || are fine. But incoming external calls have me very confused and
    > || annoyed!
    > ||
    > || When i call myself from another SIP device, or a friend does they get
    > || service unavilable in x-lite/pro. The call is then logged in my
    > || recent calls as unanswered, and it claims its route is 's'.
    > ||
    > || Anyone have any idea what i am going on about, and how i can fix
    > || this?
    > ||
    > || Cheers
    >
    > Which company are you using?
    >
    > I've made use of the tutorial here
    > http://esupport.gradwell.net/index.php?_a=knowledgebase&_j=subcat&_i=29 to
    > good effect for Sipgate.
    >
    > IIRC, there are a bunch of changes you need to make to stop incoming SIP
    > calls going to a busy extension (which A@H does by default)......., however,
    > following the tutorial & setting up the DDIs (DIDs) it all works fine.
    >
    >

    Thanks, i've got the DID's set up, and it works inernally on the call
    queue system, i will however have a good look through that link.

    I'm trying to get it working on FWD at the moment:)
    Sean, Oct 2, 2005
    #3
  4. Sean

    Sean Guest

    I think i will just throw the thing out of the window... Different
    places say different things, that gradwell thing says leave incoming
    thing blank, others don't.

    I've spent out 8 hours, and give up
    Sean, Oct 2, 2005
    #4
  5. Sean

    Jono Guest

    Sean wrote:
    || I think i will just throw the thing out of the window... Different
    || places say different things, that gradwell thing says leave incoming
    || thing blank, others don't.
    ||
    || I've spent out 8 hours, and give up

    Why not apply for a free Sipgate number & see if it works then?

    You'd be able to rule out FWD that way.

    I'm assuming you've got all the necessary ports forwarded.
    Jono, Oct 2, 2005
    #5
  6. Sean

    Sean Guest

    Jono wrote:
    > Sean wrote:
    > || I think i will just throw the thing out of the window... Different
    > || places say different things, that gradwell thing says leave incoming
    > || thing blank, others don't.
    > ||
    > || I've spent out 8 hours, and give up
    >
    > Why not apply for a free Sipgate number & see if it works then?
    >
    > You'd be able to rule out FWD that way.
    >
    > I'm assuming you've got all the necessary ports forwarded.
    >
    >


    Its as as a DMZ.........will try sipgate soon,,...thanks
    Sean, Oct 2, 2005
    #6
  7. Sean

    Sean Guest

    Outgoing not working on sipgate, and incoming not either :)
    Sean, Oct 2, 2005
    #7
  8. Sean

    Jono Guest

    Sean wrote:
    || Outgoing not working on sipgate, and incoming not either :)

    What have you set up in your Outbound Routes?
    Jono, Oct 2, 2005
    #8
  9. Sean

    Sean Guest

    I set sipgate as only one, with x. as the dial thing
    Sean, Oct 2, 2005
    #9
  10. Sean

    Sean Guest

    Ahh, well it's now working!

    I don't know how, but it does. I asked a friend who has recently set up
    asterisk to login and help. I edited the sip conf page, and it now works!

    :):):)
    Sean, Oct 3, 2005
    #10
  11. Sean

    Jono Guest

    Sean wrote:
    || Ahh, well it's now working!
    ||
    || I don't know how, but it does. I asked a friend who has recently set
    || up asterisk to login and help. I edited the sip conf page, and it
    || now works!
    ||
    || :):):)

    Great stuff.

    What did you change in sip.conf?
    Jono, Oct 3, 2005
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter Watson

    Asterisk AMP & Incoming calls

    Peter Watson, May 25, 2005, in forum: UK VOIP
    Replies:
    11
    Views:
    5,516
    Peter Watson
    May 29, 2005
  2. paul123
    Replies:
    4
    Views:
    2,456
    maxcappa
    Mar 8, 2010
  3. Giganews
    Replies:
    27
    Views:
    2,374
    Brian
    Oct 10, 2006
  4. Michael Bower
    Replies:
    3
    Views:
    4,573
    beenthere
    Oct 1, 2006
  5. Graham J
    Replies:
    6
    Views:
    541
    Dave Higton
    Apr 17, 2013
Loading...

Share This Page