ASTERISK@HOME 2.7 AND VOIPBUSTER SETUP

Discussion in 'UK VOIP' started by phpguy, Dec 30, 2007.

  1. phpguy

    phpguy Guest

    i got an asterisk@home 2.7 box setup with zap and voipbuster

    the zap works and i set it up to dial using my landline and fxo card
    when i dial 99= something it ommits the 99 and dials the rest

    i want to set up the voipbuster trunk to do the same with 88 but for
    some reason it wotn connect

    i used the default settings im behiond a router and i put nat to yes
    but nothing


    what do i need to do ? all my phones are sip phones linksys spa 921

    i can see from the flash panel its going through to trunk but nothing
    happens then times out, i cant hear anytihng

    i setted up asterisk as sip trunk not iax2


    thanks in advance



    OUTGOING SETTINGS

    host=194.120.0.198
    nat=1
    secret=XXXXXX
    type=peer
    username=XXXXXXXX

    //////////////////////////////////

    INCOMING SETTINGS

    context=from-pstn
    secret=XXXXXXXXXXXXXXX
    type=user


    /////////////////////////////

    REGISTRATION

    XXXXX:XXXXXXXXXX@194.120.0.198

    ////////////////////////////////

    SIP.CONF

    ; Note: If your SIP devices are behind a NAT and your Asterisk
    ; server isn't, try adding "nat=1" to each peer definition to
    ; solve translation problems.


    [general]
    port = 5060 ; Port to bind to (SIP is 5060)
    bindaddr = 192.168.100.69 ; Address to bind to (all addresses on
    machine)
    disallow=all
    allow=ulaw
    allow=alaw
    context = from-sip-external ; Send unknown SIP callers to this context
    callerid = Unknown


    #include sip_nat.conf
    #include sip_custom.conf
    #include sip_additional.conf


    //////////////////////////////////////
    phpguy, Dec 30, 2007
    #1
    1. Advertising

  2. phpguy

    Guest

    On 30 Dec, 21:02, phpguy <> wrote:
    > i got an asterisk@home 2.7 box setup with zap and voipbuster
    >
    > the zap works and i set it up to dial using my landline and fxo card
    > when i dial 99= something it ommits the 99 and dials the rest
    >
    > i want to set up the voipbuster trunk to do the same with 88 but for
    > some reason it wotn connect


    I'm assuming you've set the dial rules in *both* the trunk *and* the
    corresponding outbound route.


    my settings in AAH2.7 were as follows:

    SIP TRUNK: Voipbuster
    /////////////////////////////////
    Outgoing dial rules: (for UK + International - Note my UK outbound
    route was 0|[1278]XXXXXXXXX and 0044|.)

    0044+1XXXXXXXXX
    0044+2XXXXXXXXX
    0044+7XXXXXXXXX
    0044+8XXXXXXXXX
    00.
    /////////////////////////////////
    Outgoing Settings
    /////////////////////////////////
    Trunk name: voipbuster
    ----------------------
    Peer Details:
    allow=ulaw&alaw
    canreinvite=yes
    disallow=all
    fromdomain=voipbuster.com
    fromuser=USERNAME
    host=sip.voipbuster.com
    insecure=very
    nat=yes
    qualify=1000
    secret=PASSWORD
    srvlookup=yes
    type=friend
    username=USERNAME

    ///////////////////////////////////
    Incoming details:
    USER details: empty

    ///////////////////////////////////
    Register string:

    USERNAME:p

    //////////////////////////////////////
    If you have a voip-in number, this would look a little different - but
    that's another issue.
    Also, if you have more than 2 voipbuster accounts on your AAH box,
    you'll need to delete the line: qualify=1000
    , Dec 31, 2007
    #2
    1. Advertising

  3. phpguy

    Hongtian Guest

    On 31 Dec, 04:02, phpguy <> wrote:
    > i got an asterisk@home 2.7 box setup with zap and voipbuster
    >
    > the zap works and i set it up to dial using my landline and fxo card
    > when i dial 99= something it ommits the 99 and dials the rest
    >
    > i want to set up the voipbuster trunk to do the same with 88 but for
    > some reason it wotn connect
    >
    > i used the default settings im behiond a router and i put nat to yes
    > but nothing
    >
    > what do i need to do ? all my phones are sip phones linksys spa 921
    >
    > i can see from the flash panel its going through to trunk but nothing
    > happens then times out, i cant hear anytihng
    >
    > i setted up asterisk as sip trunk not iax2
    >
    > thanks in advance
    >
    > OUTGOING SETTINGS
    >
    > host=194.120.0.198
    > nat=1
    > secret=XXXXXX
    > type=peer
    > username=XXXXXXXX
    >
    > //////////////////////////////////
    >
    > INCOMING SETTINGS
    >
    > context=from-pstn
    > secret=XXXXXXXXXXXXXXX
    > type=user
    >
    > /////////////////////////////
    >
    > REGISTRATION
    >
    > XXXXX:XXXXXXX...@194.120.0.198
    >
    > ////////////////////////////////
    >
    > SIP.CONF
    >
    > ; Note: If your SIP devices are behind a NAT and your Asterisk
    > ; server isn't, try adding "nat=1" to each peer definition to
    > ; solve translation problems.
    >
    > [general]
    > port = 5060 ; Port to bind to (SIP is 5060)
    > bindaddr = 192.168.100.69 ; Address to bind to (all addresses on
    > machine)
    > disallow=all
    > allow=ulaw
    > allow=alaw
    > context = from-sip-external ; Send unknown SIP callers to this context
    > callerid = Unknown
    >
    > #include sip_nat.conf
    > #include sip_custom.conf
    > #include sip_additional.conf
    >
    > //////////////////////////////////////


    It is terrible. I would like to suggest you try miniSipServer. It is
    very easy to use.
    Hongtian, Dec 31, 2007
    #3
  4. phpguy

    Jono Guest

    Hongtian pretended :
    > It is terrible. I would like to suggest you try miniSipServer. It is
    > very easy to use.


    Not that I can comment on miniSipServer, however, AAH 2.7 is far from
    terrible.

    I have been using that version since it came out....until yesterday.

    The OP could & should consider using PBX-in-a-Flash (which I set up
    yesterday)

    <http://nerdvittles.com/index.php?p=196>

    <http://www.pbxinaflash.org/index.htm>
    Jono, Dec 31, 2007
    #4
  5. phpguy

    Guest

    On Dec 31, 12:28 pm, Jono <> wrote:
    > Hongtian pretended :
    >
    > > It is terrible. I would like to suggest you try miniSipServer. It is
    > > very easy to use.

    >
    > Not that I can comment on miniSipServer, however, AAH 2.7 is far from
    > terrible.


    Agreed.

    > I have been using that version since it came out....until yesterday.
    >
    > The OP could & should consider using PBX-in-a-Flash (which I set up
    > yesterday)
    >
    > <http://nerdvittles.com/index.php?p=196>
    >
    > <http://www.pbxinaflash.org/index.htm>


    And those settings above also work in PBX-in-a-Flash B-)
    , Dec 31, 2007
    #5
  6. phpguy

    phpguy Guest

    hello there i tried that but it says all circuits are busy now and
    voipbuster truck is greyed out in the flash operator panel, any idea
    why this happens ? cheers



    On 31 Dec 2007, 11:18, wrote:
    > On 30 Dec, 21:02, phpguy <> wrote:
    >
    > > i got an asterisk@home 2.7 box setup with zap and voipbuster

    >
    > > the zap works and i set it up to dial using my landline and fxo card
    > > when i dial 99= something it ommits the 99 and dials the rest

    >
    > > i want to set up the voipbuster trunk to do the same with 88 but for
    > > some reason it wotn connect

    >
    > I'm assuming you've set the dial rules in *both* the trunk *and* the
    > corresponding outbound route.
    >
    > my settings in AAH2.7 were as follows:
    >
    > SIP TRUNK: Voipbuster
    > /////////////////////////////////
    > Outgoing dial rules: (for UK + International - Note my UK outbound
    > route was 0|[1278]XXXXXXXXX and 0044|.)
    >
    > 0044+1XXXXXXXXX
    > 0044+2XXXXXXXXX
    > 0044+7XXXXXXXXX
    > 0044+8XXXXXXXXX
    > 00.
    > /////////////////////////////////
    > Outgoing Settings
    > /////////////////////////////////
    > Trunk name: voipbuster
    > ----------------------
    > Peer Details:
    > allow=ulaw&alaw
    > canreinvite=yes
    > disallow=all
    > fromdomain=voipbuster.com
    > fromuser=USERNAME
    > host=sip.voipbuster.com
    > insecure=very
    > nat=yes
    > qualify=1000
    > secret=PASSWORD
    > srvlookup=yes
    > type=friend
    > username=USERNAME
    >
    > ///////////////////////////////////
    > Incoming details:
    > USER details: empty
    >
    > ///////////////////////////////////
    > Register string:
    >
    > USERNAME:p
    >
    > //////////////////////////////////////
    > If you have a voip-in number, this would look a little different - but
    > that's another issue.
    > Also, if you have more than 2 voipbuster accounts on your AAH box,
    > you'll need to delete the line: qualify=1000
    phpguy, Jan 3, 2008
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Orc General
    Replies:
    1
    Views:
    529
    BlueRinse
    May 24, 2005
  2. estropelic
    Replies:
    1
    Views:
    2,905
    Enzo Michelangeli
    Jul 14, 2005
  3. Peter Watson

    Asterisk setup for Sipgate and Call1899

    Peter Watson, May 16, 2005, in forum: UK VOIP
    Replies:
    0
    Views:
    1,184
    Peter Watson
    May 16, 2005
  4. The Cable Guy

    Asterisk & Call18866 & Voipbuster

    The Cable Guy, May 28, 2005, in forum: UK VOIP
    Replies:
    4
    Views:
    2,462
    The Cable Guy
    Jun 1, 2005
  5. paul123
    Replies:
    4
    Views:
    2,436
    maxcappa
    Mar 8, 2010
Loading...

Share This Page