Associate with 871W, no IP address

Discussion in 'Cisco' started by tom, Apr 6, 2006.

  1. tom

    tom Guest

    I am working with a Cisco 871W. No fewer than three computers
    associate to it, gain an IP address from it, and connect to the outside
    world through it. A new addition to the network is having the
    following issue: It associates, but never gains an IP.
    The only difference between any of these systems is that the computer
    that does not gain an IP address is 802.11b, where the others are all
    g.
    There is no indication of any dhcp activity to the 871W, according to
    show log, though I can see it associate.
    I am at a loss, and any help would be appreciated.

    -tom
    tom, Apr 6, 2006
    #1
    1. Advertising

  2. tom

    corb Guest

    give it a static and see what happens.

    "tom" <> wrote in message
    news:...
    >I am working with a Cisco 871W. No fewer than three computers
    > associate to it, gain an IP address from it, and connect to the outside
    > world through it. A new addition to the network is having the
    > following issue: It associates, but never gains an IP.
    > The only difference between any of these systems is that the computer
    > that does not gain an IP address is 802.11b, where the others are all
    > g.
    > There is no indication of any dhcp activity to the 871W, according to
    > show log, though I can see it associate.
    > I am at a loss, and any help would be appreciated.
    >
    > -tom
    >
    corb, Apr 6, 2006
    #2
    1. Advertising

  3. tom

    tom Guest

    corb wrote:
    > give it a static and see what happens.


    XP shows wireless connectivity ("Signal Strength Excellent, Connected
    at 11Mpbs"), but can't ping the 871W, or of course, anything beyond.

    -tom
    tom, Apr 6, 2006
    #3
  4. tom

    Dana Guest

    "tom" <> wrote in message
    news:...
    > corb wrote:
    > > give it a static and see what happens.

    >
    > XP shows wireless connectivity ("Signal Strength Excellent, Connected
    > at 11Mpbs"), but can't ping the 871W, or of course, anything beyond.
    >
    > -tom


    How about SSID and or encryption if any used. You said you seen it
    associate, does it give the mac address of the host, and from the 871 can
    you do a link test.

    >
    Dana, Apr 6, 2006
    #4
  5. tom

    Dana Guest

    "tom" <> wrote in message
    news:...
    > I am working with a Cisco 871W. No fewer than three computers
    > associate to it, gain an IP address from it, and connect to the outside
    > world through it. A new addition to the network is having the
    > following issue: It associates, but never gains an IP.
    > The only difference between any of these systems is that the computer
    > that does not gain an IP address is 802.11b, where the others are all
    > g.
    > There is no indication of any dhcp activity to the 871W, according to
    > show log, though I can see it associate.
    > I am at a loss, and any help would be appreciated.
    >
    > -tom


    Couple of things to check.
    Ensure bridge/router is broadcasting ssid, or your laptop has the correct
    ssid.
    Ensure 802.11b is enabled via SDM.
    If you are associated you should be able to perform a link test, see if that
    works.
    >
    Dana, Apr 6, 2006
    #5
  6. tom

    Dana Guest

    --
    The fundamental principle of our Constitution . . . enjoins [requires] that
    the will of the majority shall prevail.
    George Washington
    --------------------------------------------------------------
    The will of the majority [is] the natural law of every society [and] is the
    only sure guardian of the rights of man. Perhaps even this may sometimes
    err. But its errors are honest, solitary and short-lived
    Though the will of the majority is in all cases to prevail, that will to be
    rightful must be reasonable - the minority possess their equal rights which
    equal law must protect
    Thomas Jefferson
    "tom" <> wrote in message
    news:...
    > I am working with a Cisco 871W. No fewer than three computers
    > associate to it, gain an IP address from it, and connect to the outside
    > world through it. A new addition to the network is having the
    > following issue: It associates, but never gains an IP.
    > The only difference between any of these systems is that the computer
    > that does not gain an IP address is 802.11b, where the others are all
    > g.
    > There is no indication of any dhcp activity to the 871W, according to
    > show log, though I can see it associate.
    > I am at a loss, and any help would be appreciated.


    Try these links

    http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a0080608364.shtml

    http://www.cisco.com/en/US/products...iguration_guides_chapter09186a0080506565.html
    >
    > -tom
    >
    Dana, Apr 6, 2006
    #6
  7. tom

    Dana Guest

    "tom" <> wrote in message
    news:...
    > I am working with a Cisco 871W. No fewer than three computers
    > associate to it, gain an IP address from it, and connect to the outside
    > world through it. A new addition to the network is having the
    > following issue: It associates, but never gains an IP.
    > The only difference between any of these systems is that the computer
    > that does not gain an IP address is 802.11b, where the others are all
    > g.
    > There is no indication of any dhcp activity to the 871W, according to
    > show log, though I can see it associate.
    > I am at a loss, and any help would be appreciated.
    >
    > -tom


    Is the 871 configured for radius.
    You may have to add the new host to the radius server if it is being used.

    >
    Dana, Apr 6, 2006
    #7
  8. tom

    Merv Guest

    > The only difference between any of these systems is that the computer
    > that does not gain an IP address is 802.11b, where the others are all g.



    1. What version of IOS is load on 871W


    2. enable dhcp debugging and see if AP receives DHCP discover message
    from PC

    conf t
    logging buffer 10000 debug
    wri mem

    debug dhcp detail

    show log


    Use the following command before and after to see if AP receives a DHCP
    request from PC

    show ip dhcp server statistics



    3.Make sure the 802.11b speeds are set to basic:

    basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0
    48.0 54.0



    4. What is the make and model of the 802.11b wireless adapter and its
    client software version ?


    5. As others have suggested, try configuring an static IP address to
    see if you can then ping AP.


    6. Does the PC have SP2 service pack installed ?
    Merv, Apr 6, 2006
    #8
  9. tom

    tom Guest

    > > -tom
    >
    > Is the 871 configured for radius.
    > You may have to add the new host to the radius server if it is being used.
    >
    > >


    No, no radius - local authentication only.
    tom, Apr 6, 2006
    #9
  10. tom

    tom Guest

    > Ensure bridge/router is broadcasting ssid, or your laptop has the correct
    >ssid.
    >Ensure 802.11b is enabled via SDM.
    >If you are associated you should be able to perform a link test, see if that
    >works.


    I am not broadcasting SSID, quite intentially. I am sure that the
    computer has the correct SSID, because of the establishment of a link
    (defined as the XP machine indicating the link).

    I will have to learn how to do a link test from the 871W, and post the
    results.
    tom, Apr 6, 2006
    #10
  11. tom

    tom Guest

    > Ensure 802.11b is enabled via SDM.
    >If you are associated you should be able to perform a link test, see if that
    >works


    How/why would 802.11b be enabled/disabled? Is there a way to disable
    802.11b on an 802.11g device?
    Thanks
    tom, Apr 6, 2006
    #11
  12. tom

    tom Guest

    The wireless adapter is a mini-pci device in a Dell 8200 laptop, not
    sure of brand. Please see above post for results of assigning a static
    IP (didn't work). Yes on SP2. Please see config file posted below.



    !
    version 12.3
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !

    !
    logging buffered 51200 debugging
    logging console critical
    !
    clock timezone PCTime -8
    clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
    no aaa new-model
    ip subnet-zero
    ip cef
    ip dhcp excluded-address 192.168.0.1 192.168.0.49
    !
    !
    ip dhcp pool sdm-pool1
    import all
    network 192.168.0.0 255.255.255.0
    dns-server 4.2.2.2
    default-router 192.168.0.3
    !
    !
    ip inspect name DEFAULT100 cuseeme
    ip inspect name DEFAULT100 ftp
    ip inspect name DEFAULT100 h323
    ip inspect name DEFAULT100 icmp
    ip inspect name DEFAULT100 netshow
    ip inspect name DEFAULT100 rcmd
    ip inspect name DEFAULT100 realaudio
    ip inspect name DEFAULT100 rtsp
    ip inspect name DEFAULT100 esmtp
    ip inspect name DEFAULT100 sqlnet
    ip inspect name DEFAULT100 streamworks
    ip inspect name DEFAULT100 tftp
    ip inspect name DEFAULT100 tcp
    ip inspect name DEFAULT100 udp
    ip inspect name DEFAULT100 vdolive
    ip tcp synwait-time 10
    no ip domain lookup
    ip domain name yourdomain.com
    ip name-server 4.2.2.2
    ip ssh time-out 60
    ip ssh authentication-retries 2

    !
    no ftp-server write-enable
    !

    !
    bridge irb
    !
    !
    interface FastEthernet0
    no ip address
    no cdp enable
    !
    interface FastEthernet1
    no ip address
    no cdp enable
    !
    interface FastEthernet2
    no ip address
    no cdp enable
    !
    interface FastEthernet3
    no ip address
    no cdp enable
    !
    interface FastEthernet4
    description $ES_WAN$$FW_OUTSIDE$$ETH-WAN$
    ip address dhcp
    ip inspect DEFAULT100 out
    ip nat outside
    ip virtual-reassembly
    ip route-cache flow
    duplex auto
    speed auto
    no cdp enable
    !
    interface Dot11Radio0
    no ip address
    !
    encryption key 1 size 40bit 7 1234567889 transmit-key
    encryption mode wep mandatory
    !
    ssid myssidrighthere
    authentication open
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0
    36.0 48.0
    54.0
    station-role root
    no dot11 extension aironet
    l2-filter bridge-group-acl
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
    no ip address
    ip tcp adjust-mss 1452
    bridge-group 1
    !
    interface BVI1
    description $ES_LAN$$FW_INSIDE$
    ip address 192.168.0.3 255.255.255.0
    ip access-group 100 in
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 dhcp
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 5 life 86400 requests 10000
    ip nat inside source list 1 interface FastEthernet4 overload

    ip access-list extended sdm_fastethernet4_in
    remark SDM_ACL Category=1
    ip access-list extended sdm_fastethernet4_in_100
    remark SDM_ACL Category=1

    !
    logging trap debugging
    access-list 1 remark INSIDE_IF=BVI1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 100 remark auto-generated by Cisco SDM Express firewall
    configuratio
    n
    access-list 100 remark SDM_ACL Category=1
    access-list 100 deny ip host 255.255.255.255 any
    access-list 100 deny ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 101 remark auto-generated by Cisco SDM Express firewall
    configuratio
    n
    access-list 101 remark SDM_ACL Category=1
    access-list 101 permit udp host 4.2.2.2 eq domain any
    access-list 101 deny ip 192.168.0.0 0.0.0.255 any
    access-list 101 permit icmp any any echo-reply
    access-list 101 permit icmp any any time-exceeded
    access-list 101 permit icmp any any unreachable
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip 127.0.0.0 0.255.255.255 any
    access-list 101 deny ip host 255.255.255.255 any
    access-list 101 deny ip any any
    access-list 101 remark auto-generated by Cisco SDM Express firewall
    configuratio
    n
    access-list 101 remark SDM_ACL Category=1
    access-list 101 remark auto-generated by Cisco SDM Express firewall
    configuratio
    n
    access-list 101 remark SDM_ACL Category=1
    access-list 701 permit 000e.3b04.a26c 0000.0000.0000
    access-list 701 permit 000b.7d0b.0c60 0000.0000.0000
    access-list 701 permit 0014.bf11.f9f7 0000.0000.0000
    access-list 701 permit 0090.4bb0.1234 0000.0000.0000
    access-list 701 permit 0040.f4d6.2e4a 0000.0000.0000
    access-list 701 deny 0000.0000.0000 ffff.ffff.ffff
    no cdp run
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    tom, Apr 6, 2006
    #12
  13. tom

    Dana Guest

    "tom" <> wrote in message
    news:...
    > > Ensure bridge/router is broadcasting ssid, or your laptop has the

    correct
    > >ssid.
    > >Ensure 802.11b is enabled via SDM.
    > >If you are associated you should be able to perform a link test, see if

    that
    > >works.

    >
    > I am not broadcasting SSID, quite intentially. I am sure that the
    > computer has the correct SSID, because of the establishment of a link
    > (defined as the XP machine indicating the link).


    An established rf link does not mean you have a network link, which is what
    it looks like you have here. IE the wireless card in the laptop sees the
    access point, but does not establish a network link.
    This is where authentication comes in.
    Use some of the debug commands on the bridge to see what the connection is
    doing. You can do this on the 1400, do not know if it is available on your
    wireless router

    >
    > I will have to learn how to do a link test from the 871W, and post the
    > results.
    >
    Dana, Apr 6, 2006
    #13
  14. tom

    Dana Guest

    "tom" <> wrote in message
    news:...
    > > Ensure 802.11b is enabled via SDM.
    > >If you are associated you should be able to perform a link test, see if

    that
    > >works

    >
    > How/why would 802.11b be enabled/disabled? Is there a way to disable
    > 802.11b on an 802.11g device?
    > Thanks


    The SDM manual shows that it can be disabled/enabled.
    According to the docs you should be able to use both.
    Is your 871 only capable of 11.g? if that is the case there is your answer.
    >
    Dana, Apr 6, 2006
    #14
  15. tom

    tom Guest


    >
    > The SDM manual shows that it can be disabled/enabled.
    > According to the docs you should be able to use both.
    > Is your 871 only capable of 11.g? if that is the case there is your answer.
    > >


    No, according to the documentation, it is an 802.11b/g device.

    Do you know the commands to disable/enable 802.11b?

    Thanks
    tom, Apr 6, 2006
    #15
  16. tom

    tom Guest

    Thanks to everyone for the posts - the resolution follows:
    I did a link status check from the 871W, and found there was a link. I
    checked the DHCP log, and found that no DHCP requests were hitting the
    DHCP server.
    Checking the properties on the wireless card (Dell TrueMobile 1180)
    revealed that the WEP Key Index was set to a different number than the
    Key Index on the router. Changing this value solved the problem.
    I need to learn more about wireless . . .

    Thanks to everyone.
    -tom
    tom, Apr 7, 2006
    #16
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?c2lnbGFwaWFu?=

    Wi-Fi connectivity cannot associate with Access Point; NO SP2

    =?Utf-8?B?c2lnbGFwaWFu?=, Nov 29, 2005, in forum: Wireless Networking
    Replies:
    3
    Views:
    9,208
    camilinksys
    Jul 1, 2006
  2. MichaelHilton

    how to not associate with root 350

    MichaelHilton, May 20, 2004, in forum: Cisco
    Replies:
    1
    Views:
    446
    Dan Lanciani
    May 20, 2004
  3. AM
    Replies:
    2
    Views:
    389
  4. tom
    Replies:
    21
    Views:
    12,969
  5. tom
    Replies:
    2
    Views:
    660
Loading...

Share This Page