Assistance requested w/ Inter vlan routing on 1711?

Discussion in 'Cisco' started by Joe Filla, Dec 24, 2004.

  1. Joe Filla

    Joe Filla Guest

    Need a bit of assistance please on getting inter vlan routing working on my
    1711. I can ping hosts on the internet, and FE0 iteself, but I cannot ping
    any ov 192.169.x.1. I thought by adding the eigrp routing commands, that
    would do the trick but not dice I'm afraid. I think I'm close, but I may be
    miles away. Here's the relevant config.

    Thanks for help.

    JF
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption

    ip subnet-zero
    no ip source-route
    no ip gratuitous-arps
    !
    !
    no ip domain lookup
    !
    !
    no ip bootp server
    ip cef
    ip audit po max-events 100
    no ftp-server write-enable
    !

    no crypto isakmp enable
    !
    interface FastEthernet0
    ip address 66.93.x.x 255.255.x.x no ip redirects
    no ip proxy-arp
    speed auto
    full-duplex
    no cdp enable
    !
    interface FastEthernet1
    switchport access vlan 10
    no ip address
    no cdp enable
    !
    interface FastEthernet2
    switchport access vlan 2
    no ip address
    no cdp enable
    !
    interface FastEthernet3
    switchport access vlan 3
    no ip address
    no cdp enable
    !
    interface FastEthernet4
    switchport access vlan 4
    no ip address
    no cdp enable
    !
    interface Vlan10
    ip address 192.168.1.1 255.255.255.0
    !
    interface Vlan4
    ip address 192.168.4.1 255.255.255.0
    !
    interface Vlan3
    ip address 192.168.3.1 255.255.255.0
    !
    interface Vlan2
    ip address 192.168.2.1 255.255.255.0
    !
    interface Vlan1
    no ip address
    shutdown

    !
    router eigrp 1
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.4.0
    auto-summary
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 x.x.x.x
    no ip http server
    no ip http secure-server
     
    Joe Filla, Dec 24, 2004
    #1
    1. Advertising

  2. On Fri, 24 Dec 2004 01:30:06 -0800, Joe Filla wrote:

    > Need a bit of assistance please on getting inter vlan routing working on
    > my 1711. I can ping hosts on the internet, and FE0 iteself, but I cannot
    > ping any ov 192.169.x.1. I thought by adding the eigrp routing commands,


    > !
    > interface FastEthernet1
    > switchport access vlan 10
    > no ip address
    > no cdp enable
    > !
    > interface FastEthernet2
    > switchport access vlan 2
    > no ip address
    > no cdp enable
    > !
    > interface FastEthernet3
    > switchport access vlan 3
    > no ip address
    > no cdp enable
    > !
    > interface FastEthernet4
    > switchport access vlan 4
    > no ip address
    > no cdp enable
    > !
    > interface Vlan10
    > ip address 192.168.1.1 255.255.255.0
    > !
    > interface Vlan4
    > ip address 192.168.4.1 255.255.255.0
    > !
    > interface Vlan3
    > ip address 192.168.3.1 255.255.255.0
    > !
    > interface Vlan2
    > ip address 192.168.2.1 255.255.255.0
    > !


    What is the state of the interfaces? Is their line protocol up? If not
    you won't ping them.

    The FastEthernets will come up if you connect them to the another device
    (switch/pc) with the appropriate cable. The Vlans will be up when at
    least one of their access ports are up.

    --
    Rgds,
    Martin
     
    Martin Gallagher, Dec 24, 2004
    #2
    1. Advertising

  3. Joe Filla

    JF Guest

    "Martin Gallagher" <> wrote in message
    news:p...
    > On Fri, 24 Dec 2004 01:30:06 -0800, Joe Filla wrote:
    >
    > What is the state of the interfaces? Is their line protocol up? If not
    > you won't ping them.
    >
    > The FastEthernets will come up if you connect them to the another device
    > (switch/pc) with the appropriate cable. The Vlans will be up when at
    > least one of their access ports are up.
    >
    > --
    > Rgds,
    > Martin


    Martin,

    Thanks for the clarification/help. I've attached some Powerbooks to
    different vlans and I can ping them from the 1711. I can ping each laptop on
    different interfaces. However while I can ping hosts on the Net from my 1711
    itself, I cannot ping/reach anything on the Internet, even by adding a
    default route to my ISPs router, from any of the hosts on my Vlans. I have
    tested w & w/o EIGRP but still no dice. Is this a routing issue, or
    something else? I appreciate your holiday help!

    JF
     
    JF, Dec 24, 2004
    #3
  4. Joe Filla

    PES Guest

    JF wrote:
    > "Martin Gallagher" <> wrote in message
    > news:p...
    >
    >>On Fri, 24 Dec 2004 01:30:06 -0800, Joe Filla wrote:
    >>
    >> What is the state of the interfaces? Is their line protocol up? If not
    >>you won't ping them.
    >>
    >> The FastEthernets will come up if you connect them to the another device
    >>(switch/pc) with the appropriate cable. The Vlans will be up when at
    >>least one of their access ports are up.
    >>
    >>--
    >>Rgds,
    >>Martin

    >
    >
    > Martin,
    >
    > Thanks for the clarification/help. I've attached some Powerbooks to
    > different vlans and I can ping them from the 1711. I can ping each laptop on
    > different interfaces. However while I can ping hosts on the Net from my 1711
    > itself, I cannot ping/reach anything on the Internet, even by adding a
    > default route to my ISPs router, from any of the hosts on my Vlans. I have
    > tested w & w/o EIGRP but still no dice. Is this a routing issue, or
    > something else? I appreciate your holiday help!
    >
    > JF
    >
    >


    I see no nat in your configuration. Is your isp going to do translation
    for you. If so, do they know of all of your private ranges. Something
    like this may work.

    interface FastEthernet0
    ip nat outside
    !
    interface Vlan10
    ip nat inside
    !
    interface Vlan4
    ip nat inside
    !
    interface Vlan3
    ip nat inside
    !
    interface Vlan2
    ip nat inside
    !

    access-list 199 permit ip 192.168.0.0 0.0.4.255 any
    ip nat insidide source list 199 interface fastethernet 0 overload


    Also, eigrp has nothing to do if this is the only router. EIGRP is to
    propagate the routes that are learned by one router throughout the rest
    of the network.

    Also, this looks like it may be a security bundle (inc fw/ipsec etc) I
    would strongly recommend learn to use the cbac feature.
    --
    -------------------------
    Paul Stewart
    Lexnet Inc.
    Email address is in ROT13
     
    PES, Dec 24, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mamun Shaheed

    Inter VLAN Routing.

    Mamun Shaheed, Oct 22, 2003, in forum: Cisco
    Replies:
    5
    Views:
    22,807
    shakeel
    Dec 15, 2007
  2. John Gill

    Re: Inter VLAN Routing

    John Gill, Oct 27, 2003, in forum: Cisco
    Replies:
    4
    Views:
    4,413
    Andre Beck
    Nov 1, 2003
  3. Damo
    Replies:
    8
    Views:
    6,693
  4. jakah
    Replies:
    0
    Views:
    986
    jakah
    May 11, 2006
  5. JohnD
    Replies:
    3
    Views:
    4,332
    stephen
    Dec 18, 2007
Loading...

Share This Page