Appletalk routing

Discussion in 'Cisco' started by Bryan Irvine, Mar 16, 2005.

  1. Bryan  Irvine

    Bryan Irvine Guest

    I have a remote router that for some reason isn't broadcasting it's
    appletalk zone. The remote Mac's do show that they are in that
    particular routers zone, but that info never makes it over the network.
    Other zones show up.

    Any troubleshooting tips you can provide would be great. The only
    appletalk routing I know is to make sure the numbers aren't the same on
    any 2 routers.

    It might be worth pointing out that this router *used* to work before
    we moved that office (yup the whole office). Also worth pointing out
    is that I do get RIP updates from that location, they are able to
    browse the internet and get email etc etc, it's only appletalk.

    Help!


    --Bryan
    Bryan Irvine, Mar 16, 2005
    #1
    1. Advertising

  2. Bryan Irvine <> wrote:
    > I have a remote router that for some reason isn't broadcasting it's
    > appletalk zone. The remote Mac's do show that they are in that
    > particular routers zone, but that info never makes it over the network.


    On the router in that remote office AT-related config may look like this:

    hostname router-a
    !
    appletalk routing
    appletalk route-redistribution
    !
    interface ethernet0
    appletalk cable-range 1000-1100 1001.123
    appletalk zone ATZoneName
    !
    interface serial0
    appletalk cable-range 100-110 101.12
    appletalk zone ATZoneName
    !

    On a local router zone/cable-range for serial connection should be
    rather similar, and cable-range for local LAN should be different:

    hostname router-b
    !
    appletalk routing
    !
    interface serial0
    appletalk cable-range 100-110 101.234
    appletalk zone ATZoneName
    !
    interface ethernet0
    appletalk cable-range 2000-2100 2002.111
    appletalk zone ATZoneName
    !

    Then use "sh apple route" commands to find out about AT network routes
    on each side of serial link.

    --
    andrei
    Andrei Ivanov, Mar 16, 2005
    #2
    1. Advertising

  3. Bryan  Irvine

    Guest

    the only noticable difference was the lack of of appletalk
    route-redistribution, and that my config uses multilink to wrap 2 T1's
    into a single link.

    here's my configs

    MAIN ROUTER:

    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname kent
    !
    no logging console
    enable secret 5 45lk34lkml3455m44
    enable password 7 fsdf4m44mm4434
    !
    ip subnet-zero
    !
    !
    ip name-server 64.1.201.134
    ip name-server 64.1.201.135
    !
    multilink virtual-template 1
    appletalk routing
    appletalk route-redistribution
    ipx routing 0008.21ed.af60
    !
    !
    !
    interface Loopback0
    ip address 192.168.210.1 255.255.255.252
    ipx network FEED1111
    !
    interface FastEthernet0/0
    description Kent LAN
    ip address 10.0.0.97 255.255.0.0
    duplex auto
    speed auto
    appletalk cable-range 1010-1019 1016.79
    appletalk zone Kent
    ipx network 100 encapsulation SAP
    no mop enabled
    !
    interface Serial0/0
    description T1-1 MLP trunk to Bellevue
    no ip address
    encapsulation ppp
    no fair-queue
    ppp multilink
    !
    interface Serial0/1
    description T1 to Mercer Island
    ip address 192.168.210.5 255.255.255.252
    appletalk cable-range 800-800 800.234
    appletalk zone Wan MIR
    no fair-queue
    !
    interface Serial0/2
    description T1-2 MLP trunk to Bellevue
    no ip address
    encapsulation ppp
    no fair-queue
    ppp multilink
    !
    interface Serial0/3
    description T1 to Port Angeles
    ip address 192.168.210.9 255.255.255.252
    appletalk cable-range 500-500 500.119
    appletalk zone Wan PA
    !
    interface Virtual-Template1
    ip unnumbered Loopback0
    appletalk cable-range 600-600 600.5
    appletalk zone Wan Kent
    no appletalk route-cache
    ipx ppp-client Loopback0
    ppp multilink
    !
    router rip
    version 2
    redistribute connected
    redistribute static
    network 10.0.0.0
    network 192.168.210.0
    !
    ip default-gateway 10.0.0.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.0.0.1
    ip route 192.168.98.0 255.255.255.0 Serial0/1
    ip route 192.233.98.0 255.255.255.0 192.168.210.6
    ip route 192.233.99.0 255.255.255.0 Serial0/3
    no ip http server
    no ip pim bidir-enable
    !
    dialer-list 1 protocol ip permit
    dialer-list 1 protocol ipx permit
    !
    !
    !
    snmp-server community kent RO
    banner motd ^C
    ************************************************
    ** Authorized access only **
    ************************************************
    ^C
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    line vty 0 4
    password 7 034555G55G45
    login
    !
    no scheduler allocate



    And the router that doesn't seem to be working

    REMOTE ROUTER:
    Building configuration...

    Current configuration : 1566 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Bellevue
    !
    enable secret 5 $45G5GG5G5GERG5G54RG545GD
    enable password 7 453G545G45G4ERG
    !
    ip subnet-zero
    !
    !
    ip name-server 64.1.201.134
    ip name-server 64.1.201.135
    !
    multilink virtual-template 1
    appletalk routing
    ipx routing 0008.21ed.bb60
    !
    !
    !
    interface Loopback0
    ip address 192.168.210.2 255.255.255.252
    ipx network FEED1111
    !
    interface FastEthernet0/0
    description Bellevue Lan
    ip address 10.1.0.97 255.255.255.0
    duplex auto
    speed auto
    appletalk cable-range 1020-1029 1025.201
    appletalk zone Bellevue
    ipx network FAB encapsulation SAP
    !
    interface Serial0/0
    description T1-1 MLP trunk to Kent
    no ip address
    encapsulation ppp
    no ip mroute-cache
    no fair-queue
    ppp multilink
    !
    interface Serial0/1
    description T1-2 MLP trunk to Kent
    no ip address
    encapsulation ppp
    no fair-queue
    ppp multilink
    !
    interface Virtual-Template1
    ip unnumbered Loopback0
    appletalk cable-range 600-600 600.242
    appletalk zone Wan Bellevue
    no appletalk route-cache
    ipx ppp-client Loopback0
    ppp multilink
    !
    router rip
    version 2
    redistribute connected
    network 10.0.0.0
    network 192.168.210.0
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.0.0.97
    no ip http server
    no ip pim bidir-enable
    !
    !
    !
    !
    snmp-server community bellevue RO
    banner motd ^C
    **********************************************
    AUTHORIZED ACCESS ONLY !
    **********************************************
    ^C
    !
    line con 0
    line aux 0
    line vty 0 4
    password 7 G45G45G45G4G5
    login
    !
    end
    , Mar 17, 2005
    #3
  4. Bryan  Irvine

    Hansang Bae Guest

    Bryan Irvine wrote:

    > I have a remote router that for some reason isn't broadcasting it's
    > appletalk zone. The remote Mac's do show that they are in that
    > particular routers zone, but that info never makes it over the
    > network. Other zones show up.
    >
    > Any troubleshooting tips you can provide would be great. The only
    > appletalk routing I know is to make sure the numbers aren't the same
    > on any 2 routers.
    >
    > It might be worth pointing out that this router used to work before
    > we moved that office (yup the whole office). Also worth pointing out
    > is that I do get RIP updates from that location, they are able to
    > browse the internet and get email etc etc, it's only appletalk.



    If an appletalk problem occurs after a move, the first thing you should
    do is power down EVERY SINGLE appletalk devices INCLUDING print
    servers.


    --

    hsb


    "Somehow I imagined this experience would be more rewarding" Calvin
    **************************ROT13 MY ADDRESS*************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
    Hansang Bae, Mar 17, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jeff Mao

    ISO AppleTalk Routing basics help

    Jeff Mao, Oct 21, 2003, in forum: Cisco
    Replies:
    1
    Views:
    442
    Sam Wilson
    Oct 22, 2003
  2. Rick
    Replies:
    2
    Views:
    542
  3. Jim O'Hagan

    1760 Router and Appletalk

    Jim O'Hagan, Oct 4, 2004, in forum: Cisco
    Replies:
    1
    Views:
    413
    Walter Roberson
    Oct 4, 2004
  4. nini

    appletalk network

    nini, Oct 12, 2005, in forum: Cisco
    Replies:
    4
    Views:
    513
    Sam Wilson
    Oct 13, 2005
  5. yvanog

    AppleTalk Browsing

    yvanog, Sep 20, 2006, in forum: Cisco
    Replies:
    0
    Views:
    344
    yvanog
    Sep 20, 2006
Loading...

Share This Page