Anyone successfully passing caller ID info thru voip.co.uk

Discussion in 'UK VOIP' started by Linker3000, Mar 29, 2007.

  1. Linker3000

    Linker3000 Guest

    As per the title - has anyone managed to pass an allowed caller ID
    string from a Trixbox extension out via voip.co.uk?

    I am playing with a test Trixbox system hosting two phones and we want
    each phone to present a different caller ID to the called party, but the
    current voip.co.uk software seems to ignore this. Even withholding
    caller ID would be OK but this does not happen even if you set it so
    within your SIP accounts at voip.co.uk.

    Anyone had more success than me?

    Thanks.
    Linker3000, Mar 29, 2007
    #1
    1. Advertising

  2. Linker3000

    Jono Guest

    Linker3000 expressed precisely :
    > As per the title - has anyone managed to pass an allowed caller ID string
    > from a Trixbox extension out via voip.co.uk?
    >
    > I am playing with a test Trixbox system hosting two phones and we want each
    > phone to present a different caller ID to the called party, but the current
    > voip.co.uk software seems to ignore this. Even withholding caller ID would be
    > OK but this does not happen even if you set it so within your SIP accounts at
    > voip.co.uk.
    >
    > Anyone had more success than me?
    >
    > Thanks.


    Not tried with voip.co.uk, however, thanks to Philippe (for bringing to
    my attention), I can now present ANY* of my numbers with Asterisk &
    voipcheap.com

    *0044870, 0049, 00441, 004479 are four I've set up so far.
    Jono, Mar 30, 2007
    #2
    1. Advertising

  3. Linker3000

    Herman Guest

    "Jono" <> wrote in message
    news:...
    > Linker3000 expressed precisely :
    >> As per the title - has anyone managed to pass an allowed caller ID string
    >> from a Trixbox extension out via voip.co.uk?
    >>
    >> I am playing with a test Trixbox system hosting two phones and we want
    >> each phone to present a different caller ID to the called party, but the
    >> current voip.co.uk software seems to ignore this. Even withholding caller
    >> ID would be OK but this does not happen even if you set it so within your
    >> SIP accounts at voip.co.uk.
    >>
    >> Anyone had more success than me?
    >>
    >> Thanks.

    >
    > Not tried with voip.co.uk, however, thanks to Philippe (for bringing to my
    > attention), I can now present ANY* of my numbers with Asterisk &
    > voipcheap.com
    >
    > *0044870, 0049, 00441, 004479 are four I've set up so far.


    You have 00441 working over voipcheap? Please tell us more - I must have
    missed that post.
    Herman, Mar 30, 2007
    #3
  4. Linker3000

    Jono Guest

    Herman wrote on 30/03/2007 :
    > "Jono" <> wrote in message
    > news:...
    >> Linker3000 expressed precisely :
    >>> As per the title - has anyone managed to pass an allowed caller ID string
    >>> from a Trixbox extension out via voip.co.uk?
    >>>
    >>> I am playing with a test Trixbox system hosting two phones and we want
    >>> each phone to present a different caller ID to the called party, but the
    >>> current voip.co.uk software seems to ignore this. Even withholding caller
    >>> ID would be OK but this does not happen even if you set it so within your
    >>> SIP accounts at voip.co.uk.
    >>>
    >>> Anyone had more success than me?
    >>>
    >>> Thanks.

    >>
    >> Not tried with voip.co.uk, however, thanks to Philippe (for bringing to my
    >> attention), I can now present ANY* of my numbers with Asterisk &
    >> voipcheap.com
    >>
    >> *0044870, 0049, 00441, 004479 are four I've set up so far.

    >
    > You have 00441 working over voipcheap? Please tell us more - I must have
    > missed that post.


    Download the newest release of the voipcheap.com softfone.

    Add your landline numbers, then run the verification process - your
    landline will get a call which asks you to enter a 4 digit number that
    is displayed on screen.

    It doesn't seem to discriminate between numbers. I've set a couple of
    UK numbers up, a German one & a UK 0870 number. I haven't tested what
    the German one looks like as a presentaion number - I suspect it won't
    be formatted correctly, at least for recipients of calls in the UK.
    Jono, Mar 31, 2007
    #4
  5. Linker3000

    Matt Guest

    On Mar 31, 12:08 am, Jono <> wrote:
    > Herman wrote on 30/03/2007 :
    >
    >
    >
    >
    >
    > > "Jono" <> wrote in message
    > >news:...
    > >> Linker3000 expressed precisely :
    > >>> As per the title - has anyone managed to pass an allowed caller ID string
    > >>> from a Trixbox extension out via voip.co.uk?

    >
    > >>> I am playing with a test Trixbox system hosting two phones and we want
    > >>> each phone to present a different caller ID to the called party, but the
    > >>> current voip.co.uk software seems to ignore this. Even withholding caller
    > >>> ID would be OK but this does not happen even if you set it so within your
    > >>> SIP accounts at voip.co.uk.

    >
    > >>> Anyone had more success than me?

    >
    > >>> Thanks.

    >
    > >> Not tried with voip.co.uk, however, thanks to Philippe (for bringing to my
    > >> attention), I can now present ANY* of my numbers with Asterisk &
    > >> voipcheap.com

    >
    > >> *0044870, 0049, 00441, 004479 are four I've set up so far.

    >
    > > You have 00441 working over voipcheap? Please tell us more - I must have
    > > missed that post.

    >
    > Download the newest release of the voipcheap.com softfone.
    >
    > Add your landline numbers, then run the verification process - your
    > landline will get a call which asks you to enter a 4 digit number that
    > is displayed on screen.
    >
    > It doesn't seem to discriminate between numbers. I've set a couple of
    > UK numbers up, a German one & a UK 0870 number. I haven't tested what
    > the German one looks like as a presentaion number - I suspect it won't
    > be formatted correctly, at least for recipients of calls in the UK.- Hide quoted text -
    >
    > - Show quoted text -


    Cheers for the tip-off!

    If I try to register an 08704xxxxx number I get an error from the
    voipcheap software?

    Has anyone else had this?

    Thanks

    Matthew
    Matt, Mar 31, 2007
    #5
  6. Linker3000

    Jono Guest

    >> It doesn't seem to discriminate between numbers. I've set a couple of
    >> UK numbers up, a German one & a UK 0870 number. I haven't tested what
    >> the German one looks like as a presentaion number - I suspect it won't
    >> be formatted correctly, at least for recipients of calls in the UK.- Hide
    >> quoted text -
    >>
    >> - Show quoted text -

    >
    > Cheers for the tip-off!
    >
    > If I try to register an 08704xxxxx number I get an error from the
    > voipcheap software?
    >
    > Has anyone else had this?


    Have you downloaded the latest version of the softfone?

    Make sure you're using the softfone & not the web interface.

    Save your number(s) in the Personal Details section & then go to CLI section
    to verify.

    FWIW, my 0870 number is 08700
    Jono, Mar 31, 2007
    #6
  7. Linker3000

    Matt Guest

    On Mar 31, 12:14 pm, "Jono" <> wrote:
    > >> It doesn't seem to discriminate between numbers. I've set a couple of
    > >> UK numbers up, a German one & a UK 0870 number. I haven't tested what
    > >> the German one looks like as a presentaion number - I suspect it won't
    > >> be formatted correctly, at least for recipients of calls in the UK.- Hide
    > >> quoted text -

    >
    > >> - Show quoted text -

    >
    > > Cheers for the tip-off!

    >
    > > If I try to register an 08704xxxxx number I get an error from the
    > > voipcheap software?

    >
    > > Has anyone else had this?

    >
    > Have you downloaded the latest version of the softfone?
    >
    > Make sure you're using the softfone & not the web interface.
    >
    > Save your number(s) in the Personal Details section & then go to CLI section
    > to verify.
    >
    > FWIW, my 0870 number is 08700



    It lets me verify my other numbers, but not the 08704 number. Very
    strange...

    Now getting Trixbox to use that details seems to be another challenge!

    Do you set the outgoing id in the extension or the trunk? Or both?
    Which format are you using? 00441827, 441827 or 01827?

    Sorry for all the questions,

    Many thanks

    Matthew
    Matt, Mar 31, 2007
    #7
  8. "Jono" <> wrote in message
    news:...
    > >> Not tried with voip.co.uk, however, thanks to Philippe (for bringing to

    my
    > >> attention), I can now present ANY* of my numbers with Asterisk &
    > >> voipcheap.com
    > >>
    > >> *0044870, 0049, 00441, 004479 are four I've set up so far.

    > >
    > > You have 00441 working over voipcheap? Please tell us more - I must

    have
    > > missed that post.

    >
    > Download the newest release of the voipcheap.com softfone.
    >
    > Add your landline numbers, then run the verification process - your
    > landline will get a call which asks you to enter a 4 digit number that
    > is displayed on screen.
    >
    > It doesn't seem to discriminate between numbers. I've set a couple of
    > UK numbers up, a German one & a UK 0870 number. I haven't tested what
    > the German one looks like as a presentaion number - I suspect it won't
    > be formatted correctly, at least for recipients of calls in the UK.
    >

    A few more tips to get this correctly done:
    * register your landlines as descrobed above, but make sure you use the
    format 0044 xxxx, not in the format +44 xxx
    The latter will work for verification, but not for CLI..
    * set your SIP device or IP phone to use your phone number, and also use the
    same format (0044 xxxx) here.
    If you have dones this correctly, it will work perfectly, even for non-UK
    numbers.

    Philippe.
    Philippe Deleye, Mar 31, 2007
    #8
  9. Linker3000

    Jono Guest

    It happens that Philippe Deleye formulated :

    >>

    > A few more tips to get this correctly done:
    > * register your landlines as descrobed above, but make sure you use the
    > format 0044 xxxx, not in the format +44 xxx
    > The latter will work for verification, but not for CLI..
    > * set your SIP device or IP phone to use your phone number, and also use the
    > same format (0044 xxxx) here.
    > If you have dones this correctly, it will work perfectly, even for non-UK
    > numbers.
    >
    > Philippe.


    I will try my German number in a bit, however, even though I have set
    everything up as 004401 or 0044870 (for the UK ones), the number that
    is presented is not in the format 00441, nor +441 but 01. Therefore, I
    suspect that the German one would be correct for dialling a German
    number......
    Jono, Mar 31, 2007
    #9
  10. Linker3000

    Jono Guest

    on 31/03/2007, Matt supposed :

    > It lets me verify my other numbers, but not the 08704 number. Very
    > strange...
    >
    > Now getting Trixbox to use that details seems to be another challenge!
    >
    > Do you set the outgoing id in the extension or the trunk? Or both?
    > Which format are you using? 00441827, 441827 or 01827?


    Here's my voipcheap.com trunk. As you can see that the CLID is set in
    my trunk, not in the extensions.

    PEER Details:
    allow=ulaw&alaw
    authuser=username
    disallow=all
    dtmfmode=rfc2833
    fromdomain=voipcheap.com
    fromuser=00448700xxxxxx
    host=sip.voipcheap.com
    insecure=very
    nat=yes
    qualify=yes
    secret=password
    type=friend
    username=username
    Jono, Mar 31, 2007
    #10
  11. Linker3000

    Matt Guest

    On Mar 31, 2:47 pm, Jono <> wrote:
    > on 31/03/2007, Matt supposed :
    >
    > > It lets me verify my other numbers, but not the 08704 number. Very
    > > strange...

    >
    > > Now getting Trixbox to use that details seems to be another challenge!

    >
    > > Do you set the outgoing id in the extension or the trunk? Or both?
    > > Which format are you using? 00441827, 441827 or 01827?

    >
    > Here's my voipcheap.com trunk. As you can see that the CLID is set in
    > my trunk, not in the extensions.
    >
    > PEER Details:
    > allow=ulaw&alaw
    > authuser=username
    > disallow=all
    > dtmfmode=rfc2833
    > fromdomain=voipcheap.com
    > fromuser=00448700xxxxxx
    > host=sip.voipcheap.com
    > insecure=very
    > nat=yes
    > qualify=yes
    > secret=password
    > type=friend
    > username=username


    Cheers Jono,

    Will try those settings later.

    Ta!

    Matt
    Matt, Mar 31, 2007
    #11
  12. "Jono" <> wrote in message
    news:...
    > I will try my German number in a bit, however, even though I have set
    > everything up as 004401 or 0044870 (for the UK ones), the number that
    > is presented is not in the format 00441, nor +441 but 01. Therefore, I
    > suspect that the German one would be correct for dialling a German
    > number......


    Yes, of course the CLI is presented as 01. This is because your provider in
    the UK (e.g. BT) is correcting the 00441 into 01.
    If you use a german number for outgong CLI, the number will be presented as
    0049xxx except in Germany, where it will be presented as 0xxx
    Philippe Deleye, Mar 31, 2007
    #12
  13. Linker3000

    Matt Guest

    On Mar 31, 4:08 pm, "Matt" <> wrote:
    > On Mar 31, 2:47 pm, Jono <> wrote:
    >
    >
    >
    >
    >
    > > on 31/03/2007, Matt supposed :

    >
    > > > It lets me verify my other numbers, but not the 08704 number. Very
    > > > strange...

    >
    > > > Now getting Trixbox to use that details seems to be another challenge!

    >
    > > > Do you set the outgoing id in the extension or the trunk? Or both?
    > > > Which format are you using? 00441827, 441827 or 01827?

    >
    > > Here's my voipcheap.com trunk. As you can see that the CLID is set in
    > > my trunk, not in the extensions.

    >
    > > PEER Details:
    > > allow=ulaw&alaw
    > > authuser=username
    > > disallow=all
    > > dtmfmode=rfc2833
    > > fromdomain=voipcheap.com
    > > fromuser=00448700xxxxxx
    > > host=sip.voipcheap.com
    > > insecure=very
    > > nat=yes
    > > qualify=yes
    > > secret=password
    > > type=friend
    > > username=username

    >
    > Cheers Jono,
    >
    > Will try those settings later.
    >
    > Ta!
    >
    > Matt- Hide quoted text -
    >
    > - Show quoted text -


    That sorted it.

    Just need to find a way of setting the clid on an extension be
    extension basis....

    Cheers Jono!
    Matt, Mar 31, 2007
    #13
  14. Linker3000

    Jono Guest

    Philippe Deleye wrote :
    > "Jono" <> wrote in message
    > news:...
    >> I will try my German number in a bit, however, even though I have set
    >> everything up as 004401 or 0044870 (for the UK ones), the number that
    >> is presented is not in the format 00441, nor +441 but 01. Therefore, I
    >> suspect that the German one would be correct for dialling a German
    >> number......

    >
    > Yes, of course the CLI is presented as 01. This is because your provider in
    > the UK (e.g. BT) is correcting the 00441 into 01.
    > If you use a german number for outgong CLI, the number will be presented as
    > 0049xxx except in Germany, where it will be presented as 0xxx


    I am gonna have to try it now...
    Jono, Mar 31, 2007
    #14
  15. Linker3000

    Jono Guest

    Philippe Deleye expressed precisely :
    > "Jono" <> wrote in message
    > news:...
    >> I will try my German number in a bit, however, even though I have set
    >> everything up as 004401 or 0044870 (for the UK ones), the number that
    >> is presented is not in the format 00441, nor +441 but 01. Therefore, I
    >> suspect that the German one would be correct for dialling a German
    >> number......

    >
    > Yes, of course the CLI is presented as 01. This is because your provider in
    > the UK (e.g. BT) is correcting the 00441 into 01.
    > If you use a german number for outgong CLI, the number will be presented as
    > 0049xxx except in Germany, where it will be presented as 0xxx


    Not sure I've seen you get anything wrong yet & it hasn't happened this
    time either.
    Jono, Mar 31, 2007
    #15
  16. Linker3000

    Mike Sun Guest

    "Philippe Deleye" <> wrote in message
    news:460e45f2$0$13864$...
    > A few more tips to get this correctly done:
    > * register your landlines as descrobed above, but make sure you use the
    > format 0044 xxxx, not in the format +44 xxx
    > The latter will work for verification, but not for CLI..
    > * set your SIP device or IP phone to use your phone number, and also use
    > the
    > same format (0044 xxxx) here.
    > If you have dones this correctly, it will work perfectly, even for non-UK
    > numbers.


    Hey - that is a fantastically helpful tip which I confirm works well with
    my ATA (Gate 102) and voipcheap.com - many thanks - Cheers from Mike
    Mike Sun, Mar 31, 2007
    #16
  17. "Jono" <> wrote in message
    news:...
    > Not sure I've seen you get anything wrong yet & it hasn't happened this
    > time either.
    >

    Is this a compliment ?? Thanks a lot ;)
    Happy to know that I could help
    I must admit that my english is not that good (I'm flemish speaking belgian)
    but I guess I could make myself understanable ...
    I'm also following german voip groups, hence I'm just transmitting
    (translating) thungs I learned over there ;)

    rgds
    Philippe
    Philippe Deleye, Mar 31, 2007
    #17
  18. Linker3000

    Jono Guest

    on 31/03/2007, Philippe Deleye supposed :
    > "Jono" <> wrote in message
    > news:...
    >> Not sure I've seen you get anything wrong yet & it hasn't happened this
    >> time either.
    >>

    > Is this a compliment ?? Thanks a lot ;)
    > Happy to know that I could help
    > I must admit that my english is not that good (I'm flemish speaking belgian)
    > but I guess I could make myself understanable ...
    > I'm also following german voip groups, hence I'm just transmitting
    > (translating) thungs I learned over there ;)
    >
    > rgds
    > Philippe


    Obviously rushing when typing the above..?

    For a moment, I wondered what a Flemish was that spoke Belgian :).
    English - what an odd language.

    It was most definitely a compliment, yes.

    Thanks for your input & make sure you come back here!
    Jono, Mar 31, 2007
    #18
  19. Linker3000

    Matt Guest

    On Mar 31, 7:41 pm, "Matt" <> wrote:
    > On Mar 31, 4:08 pm, "Matt" <> wrote:
    >
    >
    >
    > > On Mar 31, 2:47 pm, Jono <> wrote:

    >
    > > > on 31/03/2007, Matt supposed :

    >
    > > > > It lets me verify my other numbers, but not the 08704 number. Very
    > > > > strange...

    >
    > > > > Now getting Trixbox to use that details seems to be another challenge!

    >
    > > > > Do you set the outgoing id in the extension or the trunk? Or both?
    > > > > Which format are you using? 00441827, 441827 or 01827?

    >
    > > > Here's my voipcheap.com trunk. As you can see that the CLID is set in
    > > > my trunk, not in the extensions.

    >
    > > > PEER Details:
    > > > allow=ulaw&alaw
    > > > authuser=username
    > > > disallow=all
    > > > dtmfmode=rfc2833
    > > > fromdomain=voipcheap.com
    > > > fromuser=00448700xxxxxx
    > > > host=sip.voipcheap.com
    > > > insecure=very
    > > > nat=yes
    > > > qualify=yes
    > > > secret=password
    > > > type=friend
    > > > username=username

    >
    > > Cheers Jono,

    >
    > > Will try those settings later.

    >
    > > Ta!

    >
    > > Matt- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > That sorted it.
    >
    > Just need to find a way of setting the clid on an extension be
    > extension basis....
    >
    > Cheers Jono!


    In answer to my own question....

    If you remove the fromuser definition in the trunk, and set the CLID
    in the extension, is all seems to work and pass out the extenstion
    CLID!

    Hope this helps someone else.

    Thanks

    Matthew
    Matt, Apr 5, 2007
    #19
  20. Linker3000

    Jono Guest

    Matt was thinking very hard :

    >
    > In answer to my own question....
    >
    > If you remove the fromuser definition in the trunk, and set the CLID
    > in the extension, is all seems to work and pass out the extenstion
    > CLID!
    >
    > Hope this helps someone else.
    >
    > Thanks
    >
    > Matthew


    Interesting.

    Pity only 5 numbers can be added.....
    Jono, Apr 5, 2007
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Clement Kim
    Replies:
    4
    Views:
    5,752
    Unnar Gardarsson
    Feb 8, 2004
  2. Arawak
    Replies:
    0
    Views:
    563
    Arawak
    Jul 4, 2003
  3. Alan F Cross
    Replies:
    0
    Views:
    479
    Alan F Cross
    Aug 10, 2003
  4. RCSea
    Replies:
    12
    Views:
    1,212
    Charlie Russel - MVP
    Aug 2, 2005
  5. Replies:
    21
    Views:
    1,433
    Shauna
    Aug 26, 2008
Loading...

Share This Page