Another little help on PPTP vpn, i'm really close... Probably a route issue...

Discussion in 'Cisco' started by Masterx81, Jun 19, 2007.

  1. Masterx81

    Masterx81 Guest

    Hi to all... I've some troubles getting a vpn working...
    A pptp client connect to the router, get the right ip, but not the the
    right route for the packets.
    On the wxp client i've removed the flag 'use default gateway on the
    remote network' (or something similar) because with this set the
    client pc can't navigate, it try to use the vpn gateway also for
    internet, and the template has not the nat inside.
    But removing this flag the client can ping the internal interface of
    the vpn router, but not any other pc on the same network of the
    router.
    The router has an ip in the range 192.168.200.x (with a dhcp server
    configured), the client is in the range 192.168.1.x.
    These are routes that are added on the client when connected to the
    vpn:

    Indirizzo rete Mask
    Gateway Interfaccia Metrica
    xx.xx.xx.xx 255.255.255.255 192.168.1.1
    192.168.1.254 1
    192.168.200.0 255.255.255.0 192.168.200.17
    192.168.200.17 1
    192.168.200.17 255.255.255.255 127.0.0.1
    127.0.0.1 50
    192.168.200.255 255.255.255.255 192.168.200.17
    192.168.200.17 50
    224.0.0.0 240.0.0.0 192.168.200.17
    192.168.200.17 50
    255.255.255.255 255.255.255.255 192.168.200.17
    192.168.200.17 1

    I not see a route to the network of the vpn...
    So, with this routes i can ping the 'directly' connected vpn server
    (the router), but can't ping any other ip on the network of the
    router.

    With the flag activated on the client, this line is added:
    Indirizzo rete Mask Gateway
    Interfaccia Metrica
    0.0.0.0 0.0.0.0 192.168.200.254
    192.168.200.17 1

    But in any case i can't ping anything on the vpn network...
    x.x.x.x is the public ip of the vpn server
    192.168.200.17 is the ip of the client learned from the dhcp on the
    vpn server
    192.168.1.254 is the ip of the network interface of the client pc
    192.168.200.254 is the ip of the interface of the router
    192.168.1.1 is the default gateway of the client pc (the router
    that it uses for navigate in itnernet)


    How i can modify the config of the router to let know the client where
    push the packets?

    Really thanks!!!
     
    Masterx81, Jun 19, 2007
    #1
    1. Advertising

  2. Masterx81

    Cliff Guest

    On Jun 19, 10:28 am, Masterx81 <> wrote:
    > Hi to all... I've some troubles getting a vpn working...
    > A pptp client connect to the router, get the right ip, but not the the
    > right route for the packets.
    > On the wxp client i've removed the flag 'use default gateway on the
    > remote network' (or something similar) because with this set the
    > client pc can't navigate, it try to use the vpn gateway also for
    > internet, and the template has not the nat inside.
    > But removing this flag the client can ping the internal interface of
    > the vpn router, but not any other pc on the same network of the
    > router.
    > The router has an ip in the range 192.168.200.x (with a dhcp server
    > configured), the client is in the range 192.168.1.x.
    > These are routes that are added on the client when connected to the
    > vpn:
    >
    > Indirizzo rete Mask
    > Gateway Interfaccia Metrica
    > xx.xx.xx.xx 255.255.255.255 192.168.1.1
    > 192.168.1.254 1
    > 192.168.200.0 255.255.255.0 192.168.200.17
    > 192.168.200.17 1
    > 192.168.200.17 255.255.255.255 127.0.0.1
    > 127.0.0.1 50
    > 192.168.200.255 255.255.255.255 192.168.200.17
    > 192.168.200.17 50
    > 224.0.0.0 240.0.0.0 192.168.200.17
    > 192.168.200.17 50
    > 255.255.255.255 255.255.255.255 192.168.200.17
    > 192.168.200.17 1
    >
    > I not see a route to the network of the vpn...
    > So, with this routes i can ping the 'directly' connected vpn server
    > (the router), but can't ping any other ip on the network of the
    > router.
    >
    > With the flag activated on the client, this line is added:
    > Indirizzo rete Mask Gateway
    > Interfaccia Metrica
    > 0.0.0.0 0.0.0.0 192.168.200.254
    > 192.168.200.17 1
    >
    > But in any case i can't ping anything on the vpn network...
    > x.x.x.x is the public ip of the vpn server
    > 192.168.200.17 is the ip of the client learned from the dhcp on the
    > vpn server
    > 192.168.1.254 is the ip of the network interface of the client pc
    > 192.168.200.254 is the ip of the interface of the router
    > 192.168.1.1 is the default gateway of the client pc (the router
    > that it uses for navigate in itnernet)
    >
    > How i can modify the config of the router to let know the client where
    > push the packets?
    >
    > Really thanks!!!


    im all confused. Clients shouldnt be "pushing packets" any where. They
    shoud be sending/receiving. Your router should do all the routing and
    your router should have all the route statements. Sounds like you just
    havnt added any static routes on the router yet.
     
    Cliff, Jun 19, 2007
    #2
    1. Advertising

  3. Masterx81

    Masterx81 Guest

    On 19 Giu, 18:04, Cliff <> wrote:
    > On Jun 19, 10:28 am, Masterx81 <> wrote:
    >
    >
    >
    >
    >
    > > Hi to all... I've some troubles getting a vpn working...
    > > A pptp client connect to the router, get the right ip, but not the the
    > > right route for the packets.
    > > On the wxp client i've removed the flag 'use default gateway on the
    > > remote network' (or something similar) because with this set the
    > > client pc can't navigate, it try to use the vpn gateway also for
    > > internet, and the template has not the nat inside.
    > > But removing this flag the client can ping the internal interface of
    > > the vpn router, but not any other pc on the same network of the
    > > router.
    > > The router has an ip in the range 192.168.200.x (with a dhcp server
    > > configured), the client is in the range 192.168.1.x.
    > > These are routes that are added on the client when connected to the
    > > vpn:

    >
    > > Indirizzo rete Mask
    > > Gateway Interfaccia Metrica
    > > xx.xx.xx.xx 255.255.255.255 192.168.1.1
    > > 192.168.1.254 1
    > > 192.168.200.0 255.255.255.0 192.168.200.17
    > > 192.168.200.17 1
    > > 192.168.200.17 255.255.255.255 127.0.0.1
    > > 127.0.0.1 50
    > > 192.168.200.255 255.255.255.255 192.168.200.17
    > > 192.168.200.17 50
    > > 224.0.0.0 240.0.0.0 192.168.200.17
    > > 192.168.200.17 50
    > > 255.255.255.255 255.255.255.255 192.168.200.17
    > > 192.168.200.17 1

    >
    > > I not see a route to the network of the vpn...
    > > So, with this routes i can ping the 'directly' connected vpn server
    > > (the router), but can't ping any other ip on the network of the
    > > router.

    >
    > > With the flag activated on the client, this line is added:
    > > Indirizzo rete Mask Gateway
    > > Interfaccia Metrica
    > > 0.0.0.0 0.0.0.0 192.168.200.254
    > > 192.168.200.17 1

    >
    > > But in any case i can't ping anything on the vpn network...
    > > x.x.x.x is the public ip of the vpn server
    > > 192.168.200.17 is the ip of the client learned from the dhcp on the
    > > vpn server
    > > 192.168.1.254 is the ip of the network interface of the client pc
    > > 192.168.200.254 is the ip of the interface of the router
    > > 192.168.1.1 is the default gateway of the client pc (the router
    > > that it uses for navigate in itnernet)

    >
    > > How i can modify the config of the router to let know the client where
    > > push the packets?

    >
    > > Really thanks!!!

    >
    > im all confused. Clients shouldnt be "pushing packets" any where. They
    > shoud be sending/receiving. Your router should do all the routing and
    > your router should have all the route statements. Sounds like you just
    > havnt added any static routes on the router yet.- Nascondi testo tra virgolette -
    >
    > - Mostra testo tra virgolette -


    Yes, no static routes...
    Only the default 0.0.0.0 0.0.0.0 atm0.1 for forwarding the packets to
    internet...
    I need to substitute this default route?
     
    Masterx81, Jun 20, 2007
    #3
  4. Masterx81

    Cliff Guest

    On Jun 20, 1:53 am, Masterx81 <> wrote:
    > On 19 Giu, 18:04, Cliff <> wrote:
    >
    >
    >
    >
    >
    > > On Jun 19, 10:28 am, Masterx81 <> wrote:

    >
    > > > Hi to all... I've some troubles getting a vpn working...
    > > > A pptp client connect to the router, get the right ip, but not the the
    > > > right route for the packets.
    > > > On the wxp client i've removed the flag 'use default gateway on the
    > > > remote network' (or something similar) because with this set the
    > > > client pc can't navigate, it try to use the vpn gateway also for
    > > > internet, and the template has not the nat inside.
    > > > But removing this flag the client can ping the internal interface of
    > > > the vpn router, but not any other pc on the same network of the
    > > > router.
    > > > The router has an ip in the range 192.168.200.x (with a dhcp server
    > > > configured), the client is in the range 192.168.1.x.
    > > > These are routes that are added on the client when connected to the
    > > > vpn:

    >
    > > > Indirizzo rete Mask
    > > > Gateway Interfaccia Metrica
    > > > xx.xx.xx.xx 255.255.255.255 192.168.1.1
    > > > 192.168.1.254 1
    > > > 192.168.200.0 255.255.255.0 192.168.200.17
    > > > 192.168.200.17 1
    > > > 192.168.200.17 255.255.255.255 127.0.0.1
    > > > 127.0.0.1 50
    > > > 192.168.200.255 255.255.255.255 192.168.200.17
    > > > 192.168.200.17 50
    > > > 224.0.0.0 240.0.0.0 192.168.200.17
    > > > 192.168.200.17 50
    > > > 255.255.255.255 255.255.255.255 192.168.200.17
    > > > 192.168.200.17 1

    >
    > > > I not see a route to the network of the vpn...
    > > > So, with this routes i can ping the 'directly' connected vpn server
    > > > (the router), but can't ping any other ip on the network of the
    > > > router.

    >
    > > > With the flag activated on the client, this line is added:
    > > > Indirizzo rete Mask Gateway
    > > > Interfaccia Metrica
    > > > 0.0.0.0 0.0.0.0 192.168.200.254
    > > > 192.168.200.17 1

    >
    > > > But in any case i can't ping anything on the vpn network...
    > > > x.x.x.x is the public ip of the vpn server
    > > > 192.168.200.17 is the ip of the client learned from the dhcp on the
    > > > vpn server
    > > > 192.168.1.254 is the ip of the network interface of the client pc
    > > > 192.168.200.254 is the ip of the interface of the router
    > > > 192.168.1.1 is the default gateway of the client pc (the router
    > > > that it uses for navigate in itnernet)

    >
    > > > How i can modify the config of the router to let know the client where
    > > > push the packets?

    >
    > > > Really thanks!!!

    >
    > > im all confused. Clients shouldnt be "pushing packets" any where. They
    > > shoud be sending/receiving. Your router should do all the routing and
    > > your router should have all the route statements. Sounds like you just
    > > havnt added any static routes on the router yet.- Nascondi testo tra virgolette -

    >
    > > - Mostra testo tra virgolette -

    >
    > Yes, no static routes...
    > Only the default 0.0.0.0 0.0.0.0 atm0.1 for forwarding the packets to
    > internet...
    > I need to substitute this default route?- Hide quoted text -
    >
    > - Show quoted text -


    Keep the static route, thats your default gateway.

    Sounds like you just need to add static routes to all your VPN's.
     
    Cliff, Jun 20, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Douglas
    Replies:
    1
    Views:
    475
    Aaron Leonard
    May 6, 2004
  2. joanne

    Probably a really simple solution

    joanne, Feb 9, 2004, in forum: Computer Support
    Replies:
    6
    Views:
    457
    Mr.SlippyFist
    Feb 12, 2004
  3. William Zinck
    Replies:
    1
    Views:
    9,485
    =?ISO-8859-1?Q?R=F4g=EAr?=
    Mar 8, 2005
  4. iiiiiieeeeee
    Replies:
    1
    Views:
    448
    What's in a Name?
    Mar 12, 2007
  5. Replies:
    9
    Views:
    5,205
    Scott Perry
    Aug 7, 2008
Loading...

Share This Page