An odd Windows behaviour

Discussion in 'NZ Computing' started by Gib Bogle, Mar 7, 2013.

  1. In article <khbfpr$3q4$>, wrote:
    >On 8/03/2013 11:37 a.m., ~misfit~ wrote:
    >> Somewhere on teh intarwebs Gib Bogle wrote:
    >>> On 8/03/2013 9:04 a.m., Gib Bogle wrote:
    >>>> Normally when you right-click on a file and select 'Open with' you
    >>>> can choose the program to open the file, either from the supplied
    >>>> list of candidates or by browsing for the .exe. I have found that
    >>>> on one machine I use (Windows XP, work computer) I am not able to
    >>>> open a particular file type like this. The file is .pro, and is
    >>>> opened by qtcreator.exe. When I browse for and select
    >>>> qtcreator.exe, the OS ignores my choice and insists on opening it
    >>>> with my text editor. The only way to open the file is to start
    >>>> qtcreator then open it. Other machines I use do not have this
    >>>> problem. It would be nice to understand what's happening, but more
    >>>> important
    >>>> to know how to correct the problem. Presumably there is a way to
    >>>> tell Windows that qtcreator.exe is the way to open a .pro file. Can
    >>>> someone tell me what this is?
    >>>
    >>> BTW the standard approach to set the file association does not work.
    >>> There seems to be something special about the .pro extension, on XP
    >>> anyway.

    >>
    >> Maybe it's been told to always open with notepad (checkbox ticked)? I could
    >> be wrong.......
    >>
    >> If so I think there's a registry setting that can be changed to go back to
    >> giving you a choice.
    >>

    >
    >Oddly, qtcreator.exe is in the registry setting for .pro. It does not
    >appear in the list offered in Explorer though. It's as if it doesn't
    >meet some Windows criterion. I thought perhaps its location needed to
    >be in the PATH, but that didn't make any difference.


    Choose 'browse' when you get to 'choose program' and find the .exe file that
    way ?
    Bruce Sinclair, Mar 11, 2013
    #21
    1. Advertising

  2. Gib Bogle

    Gib Bogle Guest

    On 11/03/2013 1:12 p.m., Bruce Sinclair wrote:
    > In article <khbfpr$3q4$>, wrote:
    >> On 8/03/2013 11:37 a.m., ~misfit~ wrote:
    >>> Somewhere on teh intarwebs Gib Bogle wrote:
    >>>> On 8/03/2013 9:04 a.m., Gib Bogle wrote:
    >>>>> Normally when you right-click on a file and select 'Open with' you
    >>>>> can choose the program to open the file, either from the supplied
    >>>>> list of candidates or by browsing for the .exe. I have found that
    >>>>> on one machine I use (Windows XP, work computer) I am not able to
    >>>>> open a particular file type like this. The file is .pro, and is
    >>>>> opened by qtcreator.exe. When I browse for and select
    >>>>> qtcreator.exe, the OS ignores my choice and insists on opening it
    >>>>> with my text editor. The only way to open the file is to start
    >>>>> qtcreator then open it. Other machines I use do not have this
    >>>>> problem. It would be nice to understand what's happening, but more
    >>>>> important
    >>>>> to know how to correct the problem. Presumably there is a way to
    >>>>> tell Windows that qtcreator.exe is the way to open a .pro file. Can
    >>>>> someone tell me what this is?
    >>>>
    >>>> BTW the standard approach to set the file association does not work.
    >>>> There seems to be something special about the .pro extension, on XP
    >>>> anyway.
    >>>
    >>> Maybe it's been told to always open with notepad (checkbox ticked)? I could
    >>> be wrong.......
    >>>
    >>> If so I think there's a registry setting that can be changed to go back to
    >>> giving you a choice.
    >>>

    >>
    >> Oddly, qtcreator.exe is in the registry setting for .pro. It does not
    >> appear in the list offered in Explorer though. It's as if it doesn't
    >> meet some Windows criterion. I thought perhaps its location needed to
    >> be in the PATH, but that didn't make any difference.

    >
    > Choose 'browse' when you get to 'choose program' and find the .exe file that
    > way ?


    Yes, that's the first thing I tried. "When I browse for and select
    qtcreator.exe, the OS ignores my choice and insists on opening it
    with my text editor."
    Gib Bogle, Mar 11, 2013
    #22
    1. Advertising

  3. In article <khk7k1$8k6$>, wrote:
    (snip)
    >>> Oddly, qtcreator.exe is in the registry setting for .pro. It does not
    >>> appear in the list offered in Explorer though. It's as if it doesn't
    >>> meet some Windows criterion. I thought perhaps its location needed to
    >>> be in the PATH, but that didn't make any difference.

    >>
    >> Choose 'browse' when you get to 'choose program' and find the .exe file that
    >> way ?

    >
    >Yes, that's the first thing I tried. "When I browse for and select
    >qtcreator.exe, the OS ignores my choice and insists on opening it
    >with my text editor."


    Very odd.
    Perhaps ... windows is broken ? ... but you knew that. :) :)
    Bruce Sinclair, Mar 11, 2013
    #23
  4. Gib Bogle

    Gib Bogle Guest

    On 12/03/2013 5:33 p.m., Kiwi wrote:
    > On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    > wrote:
    >
    >> Yes, that's the first thing I tried. "When I browse for and select
    >> qtcreator.exe, the OS ignores my choice and insists on opening it
    >> with my text editor."

    >
    > Go to Folder Options>File Types and select the entry for the file type
    > .pro. Click on the Advanced button and note the default action in
    > bold. Edit this to point to the desired program.
    >
    > Cheers, Kiwi
    >


    When I select the extension PRO from the list the Advanced button does
    not show. It changes to Restore. Entries for all other extensions have
    the Advanced button. When I click the Change button it takes me down
    the Open With > Browse path, where, as usual, I can select qtcreator.exe
    but it does not get selected, the text editor remains selected. It
    seems that according to XP there is something special about .pro files.
    Gib Bogle, Mar 12, 2013
    #24
  5. Gib Bogle

    Dave Doe Guest

    In article <khmgg6$j31$>, , Gib
    Bogle says...
    >
    > On 12/03/2013 5:33 p.m., Kiwi wrote:
    > > On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    > > wrote:
    > >
    > >> Yes, that's the first thing I tried. "When I browse for and select
    > >> qtcreator.exe, the OS ignores my choice and insists on opening it
    > >> with my text editor."

    > >
    > > Go to Folder Options>File Types and select the entry for the file type
    > > .pro. Click on the Advanced button and note the default action in
    > > bold. Edit this to point to the desired program.
    > >
    > > Cheers, Kiwi
    > >

    >
    > When I select the extension PRO from the list the Advanced button does
    > not show. It changes to Restore. Entries for all other extensions have
    > the Advanced button. When I click the Change button it takes me down
    > the Open With > Browse path, where, as usual, I can select qtcreator.exe
    > but it does not get selected, the text editor remains selected. It
    > seems that according to XP there is something special about .pro files.


    I doubt it, as .pro files are not normally in the File Types list. I'd
    presume that an installed app has done this (put the file association
    in). Do you have any special (third party) text editor installed?


    --
    Duncan.
    Dave Doe, Mar 12, 2013
    #25
  6. Gib Bogle

    Dave Doe Guest

    In article <-september.org>,
    , Dave Doe says...
    >
    > In article <khmgg6$j31$>, , Gib
    > Bogle says...
    > >
    > > On 12/03/2013 5:33 p.m., Kiwi wrote:
    > > > On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    > > > wrote:
    > > >
    > > >> Yes, that's the first thing I tried. "When I browse for and select
    > > >> qtcreator.exe, the OS ignores my choice and insists on opening it
    > > >> with my text editor."
    > > >
    > > > Go to Folder Options>File Types and select the entry for the file type
    > > > .pro. Click on the Advanced button and note the default action in
    > > > bold. Edit this to point to the desired program.
    > > >
    > > > Cheers, Kiwi
    > > >

    > >
    > > When I select the extension PRO from the list the Advanced button does
    > > not show. It changes to Restore. Entries for all other extensions have
    > > the Advanced button. When I click the Change button it takes me down
    > > the Open With > Browse path, where, as usual, I can select qtcreator.exe
    > > but it does not get selected, the text editor remains selected. It
    > > seems that according to XP there is something special about .pro files.

    >
    > I doubt it, as .pro files are not normally in the File Types list. I'd
    > presume that an installed app has done this (put the file association
    > in). Do you have any special (third party) text editor installed?


    And a couple other things... can you Delete the File Association
    (Control Panel, Folder OPtions, File Types) for the PRO? - and even if
    not, why not try and create a New one.

    --
    Duncan.
    Dave Doe, Mar 12, 2013
    #26
  7. Gib Bogle

    Gib Bogle Guest

    On 12/03/2013 10:54 p.m., Dave Doe wrote:
    > In article <-september.org>,
    > , Dave Doe says...
    >>
    >> In article <khmgg6$j31$>, , Gib
    >> Bogle says...
    >>>
    >>> On 12/03/2013 5:33 p.m., Kiwi wrote:
    >>>> On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    >>>> wrote:
    >>>>
    >>>>> Yes, that's the first thing I tried. "When I browse for and select
    >>>>> qtcreator.exe, the OS ignores my choice and insists on opening it
    >>>>> with my text editor."
    >>>>
    >>>> Go to Folder Options>File Types and select the entry for the file type
    >>>> .pro. Click on the Advanced button and note the default action in
    >>>> bold. Edit this to point to the desired program.
    >>>>
    >>>> Cheers, Kiwi
    >>>>
    >>>
    >>> When I select the extension PRO from the list the Advanced button does
    >>> not show. It changes to Restore. Entries for all other extensions have
    >>> the Advanced button. When I click the Change button it takes me down
    >>> the Open With > Browse path, where, as usual, I can select qtcreator.exe
    >>> but it does not get selected, the text editor remains selected. It
    >>> seems that according to XP there is something special about .pro files.

    >>
    >> I doubt it, as .pro files are not normally in the File Types list. I'd
    >> presume that an installed app has done this (put the file association
    >> in). Do you have any special (third party) text editor installed?

    >
    > And a couple other things... can you Delete the File Association
    > (Control Panel, Folder OPtions, File Types) for the PRO? - and even if
    > not, why not try and create a New one.
    >


    I've been down all these avenues. There was not an entry for .pro files
    in the File Types list, I added it. It is not possible to create an
    association with qtcreator.exe, I've tried every way including the
    registry (qtcreator is in the registry list, but does not appear in Open
    With). All the methods of creating an association lead to the Open With
    (Choose program) > Browse popup, which does not allow qtcreator.exe to
    be added to the list. These problems are unique to XP, i.e. they do not
    occur with W7. Yes, I'm using another text editor PFE (Programmers File
    Editor) on both XP and W7.
    Gib Bogle, Mar 12, 2013
    #27
  8. Gib Bogle

    Enkidu Guest

    On 12/03/13 19:03, Gib Bogle wrote:
    > On 12/03/2013 5:33 p.m., Kiwi wrote:
    >> On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    >> wrote:
    >>
    >>> Yes, that's the first thing I tried. "When I browse for and select
    >>> qtcreator.exe, the OS ignores my choice and insists on opening it
    >>> with my text editor."

    >>
    >> Go to Folder Options>File Types and select the entry for the file type
    >> .pro. Click on the Advanced button and note the default action in
    >> bold. Edit this to point to the desired program.
    >>
    >> Cheers, Kiwi
    >>

    >
    > When I select the extension PRO from the list the Advanced button does
    > not show. It changes to Restore. Entries for all other extensions have
    > the Advanced button. When I click the Change button it takes me down
    > the Open With > Browse path, where, as usual, I can select qtcreator.exe
    > but it does not get selected, the text editor remains selected. It
    > seems that according to XP there is something special about .pro files.
    >

    Is qtcreator.exe executable? Are the permissions correct on the file?
    Have you looked in the Event log?

    Cheers,

    Cliff
    Enkidu, Mar 12, 2013
    #28
  9. Gib Bogle

    Gib Bogle Guest

    On 13/03/2013 9:44 a.m., Enkidu wrote:
    > On 12/03/13 19:03, Gib Bogle wrote:
    >> On 12/03/2013 5:33 p.m., Kiwi wrote:
    >>> On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    >>> wrote:
    >>>
    >>>> Yes, that's the first thing I tried. "When I browse for and select
    >>>> qtcreator.exe, the OS ignores my choice and insists on opening it
    >>>> with my text editor."
    >>>
    >>> Go to Folder Options>File Types and select the entry for the file type
    >>> .pro. Click on the Advanced button and note the default action in
    >>> bold. Edit this to point to the desired program.
    >>>
    >>> Cheers, Kiwi
    >>>

    >>
    >> When I select the extension PRO from the list the Advanced button does
    >> not show. It changes to Restore. Entries for all other extensions have
    >> the Advanced button. When I click the Change button it takes me down
    >> the Open With > Browse path, where, as usual, I can select qtcreator.exe
    >> but it does not get selected, the text editor remains selected. It
    >> seems that according to XP there is something special about .pro files.
    > >

    > Is qtcreator.exe executable? Are the permissions correct on the file?
    > Have you looked in the Event log?
    >
    > Cheers,
    >
    > Cliff


    I haven't looked in the Event log. The program is certainly executable
    - I use it all the time. I can invoke it with the .pro file from the
    command line, for example, or run it then open the .pro file.
    Gib Bogle, Mar 12, 2013
    #29
  10. Gib Bogle

    Dave Doe Guest

    In article <khnssd$g69$>, , Gib
    Bogle says...
    >
    > On 12/03/2013 10:54 p.m., Dave Doe wrote:
    > > In article <-september.org>,
    > > , Dave Doe says...
    > >>
    > >> In article <khmgg6$j31$>, , Gib
    > >> Bogle says...
    > >>>
    > >>> On 12/03/2013 5:33 p.m., Kiwi wrote:
    > >>>> On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    > >>>> wrote:
    > >>>>
    > >>>>> Yes, that's the first thing I tried. "When I browse for and select
    > >>>>> qtcreator.exe, the OS ignores my choice and insists on opening it
    > >>>>> with my text editor."
    > >>>>
    > >>>> Go to Folder Options>File Types and select the entry for the file type
    > >>>> .pro. Click on the Advanced button and note the default action in
    > >>>> bold. Edit this to point to the desired program.
    > >>>>
    > >>>> Cheers, Kiwi
    > >>>>
    > >>>
    > >>> When I select the extension PRO from the list the Advanced button does
    > >>> not show. It changes to Restore. Entries for all other extensions have
    > >>> the Advanced button. When I click the Change button it takes me down
    > >>> the Open With > Browse path, where, as usual, I can select qtcreator.exe
    > >>> but it does not get selected, the text editor remains selected. It
    > >>> seems that according to XP there is something special about .pro files.
    > >>
    > >> I doubt it, as .pro files are not normally in the File Types list. I'd
    > >> presume that an installed app has done this (put the file association
    > >> in). Do you have any special (third party) text editor installed?

    > >
    > > And a couple other things... can you Delete the File Association
    > > (Control Panel, Folder OPtions, File Types) for the PRO? - and even if
    > > not, why not try and create a New one.
    > >

    >
    > I've been down all these avenues. There was not an entry for .pro files
    > in the File Types list, I added it. It is not possible to create an
    > association with qtcreator.exe,


    OK, well that's new info AFAIK (ie yes, I've read the thread :) ).

    So uh, what *is* qtcreator.exe ??? :)
    And where is the .exe and what attributes does it have?

    From the thread, you've got this working via the command line? - ie
    qtcreator correctly accepts arguments (such as a file parsed to it)? -
    just to confirm that :)

    --
    Duncan.
    Dave Doe, Mar 12, 2013
    #30
  11. Gib Bogle

    Gib Bogle Guest

    On 13/03/2013 11:36 a.m., Dave Doe wrote:
    > In article <khnssd$g69$>, , Gib
    > Bogle says...
    >>
    >> On 12/03/2013 10:54 p.m., Dave Doe wrote:
    >>> In article <-september.org>,
    >>> , Dave Doe says...
    >>>>
    >>>> In article <khmgg6$j31$>, , Gib
    >>>> Bogle says...
    >>>>>
    >>>>> On 12/03/2013 5:33 p.m., Kiwi wrote:
    >>>>>> On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    >>>>>> wrote:
    >>>>>>
    >>>>>>> Yes, that's the first thing I tried. "When I browse for and select
    >>>>>>> qtcreator.exe, the OS ignores my choice and insists on opening it
    >>>>>>> with my text editor."
    >>>>>>
    >>>>>> Go to Folder Options>File Types and select the entry for the file type
    >>>>>> .pro. Click on the Advanced button and note the default action in
    >>>>>> bold. Edit this to point to the desired program.
    >>>>>>
    >>>>>> Cheers, Kiwi
    >>>>>>
    >>>>>
    >>>>> When I select the extension PRO from the list the Advanced button does
    >>>>> not show. It changes to Restore. Entries for all other extensions have
    >>>>> the Advanced button. When I click the Change button it takes me down
    >>>>> the Open With > Browse path, where, as usual, I can select qtcreator.exe
    >>>>> but it does not get selected, the text editor remains selected. It
    >>>>> seems that according to XP there is something special about .pro files.
    >>>>
    >>>> I doubt it, as .pro files are not normally in the File Types list. I'd
    >>>> presume that an installed app has done this (put the file association
    >>>> in). Do you have any special (third party) text editor installed?
    >>>
    >>> And a couple other things... can you Delete the File Association
    >>> (Control Panel, Folder OPtions, File Types) for the PRO? - and even if
    >>> not, why not try and create a New one.
    >>>

    >>
    >> I've been down all these avenues. There was not an entry for .pro files
    >> in the File Types list, I added it. It is not possible to create an
    >> association with qtcreator.exe,

    >
    > OK, well that's new info AFAIK (ie yes, I've read the thread :) ).


    Actually Dave it was in my initial post:
    "Normally when you right-click on a file and select 'Open with' you can
    choose the program to open the file, either from the supplied list of
    candidates or by browsing for the .exe. I have found that on one
    machine I use (Windows XP, work computer) I am not able to open a
    particular file type like this. The file is .pro, and is opened by
    qtcreator.exe. When I browse for and select qtcreator.exe, the OS
    ignores my choice and insists on opening it with my text editor."
    In case it isn't crystal clear, I'm referring to browsing from the 'Open
    With' window.

    > So uh, what *is* qtcreator.exe ??? :)
    > And where is the .exe and what attributes does it have?


    qtcreator.exe is the Qt program for creating Qt GUIs. It is a perfectly
    normal executable; I can run it from the command line, by
    double-clicking on it in Explorer, or by selecting it from the Programs
    menu. If it matters (it doesn't) is resides in C:\QtSDK\QtCreator\bin.
    I have been using versions of this program for years, on XP and Win7.

    > From the thread, you've got this working via the command line? - ie
    > qtcreator correctly accepts arguments (such as a file parsed to it)? -
    > just to confirm that :)
    >


    I can run qtcreator.exe in all the usual ways, and it correctly accepts
    the argument fubar.pro from the command line.
    Gib Bogle, Mar 13, 2013
    #31
  12. Gib Bogle

    Dave Doe Guest

    In article <khol1b$hq4$>, , Gib
    Bogle says...
    >
    > On 13/03/2013 11:36 a.m., Dave Doe wrote:
    > > In article <khnssd$g69$>, , Gib
    > > Bogle says...
    > >>
    > >> On 12/03/2013 10:54 p.m., Dave Doe wrote:
    > >>> In article <-september.org>,
    > >>> , Dave Doe says...
    > >>>>
    > >>>> In article <khmgg6$j31$>, , Gib
    > >>>> Bogle says...
    > >>>>>
    > >>>>> On 12/03/2013 5:33 p.m., Kiwi wrote:
    > >>>>>> On Mon, 11 Mar 2013 22:20:02 +1300, Gib Bogle <>
    > >>>>>> wrote:
    > >>>>>>
    > >>>>>>> Yes, that's the first thing I tried. "When I browse for and select
    > >>>>>>> qtcreator.exe, the OS ignores my choice and insists on opening it
    > >>>>>>> with my text editor."
    > >>>>>>
    > >>>>>> Go to Folder Options>File Types and select the entry for the file type
    > >>>>>> .pro. Click on the Advanced button and note the default action in
    > >>>>>> bold. Edit this to point to the desired program.
    > >>>>>>
    > >>>>>> Cheers, Kiwi
    > >>>>>>
    > >>>>>
    > >>>>> When I select the extension PRO from the list the Advanced button does
    > >>>>> not show. It changes to Restore. Entries for all other extensions have
    > >>>>> the Advanced button. When I click the Change button it takes me down
    > >>>>> the Open With > Browse path, where, as usual, I can select qtcreator.exe
    > >>>>> but it does not get selected, the text editor remains selected. It
    > >>>>> seems that according to XP there is something special about .pro files.
    > >>>>
    > >>>> I doubt it, as .pro files are not normally in the File Types list. I'd
    > >>>> presume that an installed app has done this (put the file association
    > >>>> in). Do you have any special (third party) text editor installed?
    > >>>
    > >>> And a couple other things... can you Delete the File Association
    > >>> (Control Panel, Folder OPtions, File Types) for the PRO? - and even if
    > >>> not, why not try and create a New one.
    > >>>
    > >>
    > >> I've been down all these avenues. There was not an entry for .pro files
    > >> in the File Types list, I added it. It is not possible to create an
    > >> association with qtcreator.exe,

    > >
    > > OK, well that's new info AFAIK (ie yes, I've read the thread :) ).

    >
    > Actually Dave it was in my initial post:
    > "Normally when you right-click on a file and select 'Open with' you can
    > choose the program to open the file, either from the supplied list of
    > candidates or by browsing for the .exe. I have found that on one
    > machine I use (Windows XP, work computer) I am not able to open a
    > particular file type like this. The file is .pro, and is opened by
    > qtcreator.exe. When I browse for and select qtcreator.exe, the OS
    > ignores my choice and insists on opening it with my text editor."
    > In case it isn't crystal clear, I'm referring to browsing from the 'Open
    > With' window.


    And I was referring to your answer re File Associations - which is new
    info - certainly, a different way of achieving the same, but still new
    info - the file association PRO didn't exist before, you created it, and
    it would not let you browse via that method (no Advanced button).

    >
    > > So uh, what *is* qtcreator.exe ??? :)
    > > And where is the .exe and what attributes does it have?

    >
    > qtcreator.exe is the Qt program for creating Qt GUIs. It is a perfectly
    > normal executable; I can run it from the command line, by
    > double-clicking on it in Explorer, or by selecting it from the Programs
    > menu. If it matters (it doesn't) is resides in C:\QtSDK\QtCreator\bin.
    > I have been using versions of this program for years, on XP and Win7.
    >
    > > From the thread, you've got this working via the command line? - ie
    > > qtcreator correctly accepts arguments (such as a file parsed to it)? -
    > > just to confirm that :)
    > >

    >
    > I can run qtcreator.exe in all the usual ways, and it correctly accepts
    > the argument fubar.pro from the command line.


    I think you should test this on your Win7 or 8 PC (if you have Pro or
    better) and run up a Virtual PC of XP, or run the free Windows XP Mode -
    and test in there. But if you're happy that you know this will work OK,
    why bother - you're happy to deduce it is on your work PC only. Is the
    work PC on a domain environment? And if so, what happens if you logon
    the local PC account (not the domain account) and try setting the file
    association? Can you talk the boss into a new PC? :)

    --
    Duncan.
    Dave Doe, Mar 13, 2013
    #32
  13. Gib Bogle

    Gib Bogle Guest

    On 13/03/2013 4:48 p.m., Dave Doe wrote:

    >> I can run qtcreator.exe in all the usual ways, and it correctly accepts
    >> the argument fubar.pro from the command line.

    >
    > I think you should test this on your Win7 or 8 PC (if you have Pro or
    > better) and run up a Virtual PC of XP, or run the free Windows XP Mode -
    > and test in there. But if you're happy that you know this will work OK,
    > why bother - you're happy to deduce it is on your work PC only. Is the
    > work PC on a domain environment? And if so, what happens if you logon
    > the local PC account (not the domain account) and try setting the file
    > association? Can you talk the boss into a new PC? :)
    >


    It all works as expected on Win7. The work PC is on a domain
    environment. Next time I'm at the office I'll try a local logon. I
    seldom go there, since I work at home, using VPN and Remote Desktop. A
    new PC is not on the cards.

    I'm pursuing this purely out of interest - it is an intriguing puzzle, I
    hate to leave puzzles like this unsolved. I can always start qtcreator
    then open the .pro file, and I can use the Sendto facility.
    Gib Bogle, Mar 13, 2013
    #33
  14. Gib Bogle

    Dave Doe Guest

    In article <khouci$4tj$>, , Gib
    Bogle says...
    >
    > On 13/03/2013 4:48 p.m., Dave Doe wrote:
    >
    > >> I can run qtcreator.exe in all the usual ways, and it correctly accepts
    > >> the argument fubar.pro from the command line.

    > >
    > > I think you should test this on your Win7 or 8 PC (if you have Pro or
    > > better) and run up a Virtual PC of XP, or run the free Windows XP Mode -
    > > and test in there. But if you're happy that you know this will work OK,
    > > why bother - you're happy to deduce it is on your work PC only. Is the
    > > work PC on a domain environment? And if so, what happens if you logon
    > > the local PC account (not the domain account) and try setting the file
    > > association? Can you talk the boss into a new PC? :)
    > >

    >
    > It all works as expected on Win7. The work PC is on a domain
    > environment. Next time I'm at the office I'll try a local logon. I
    > seldom go there, since I work at home, using VPN and Remote Desktop. A
    > new PC is not on the cards.
    >
    > I'm pursuing this purely out of interest - it is an intriguing puzzle, I
    > hate to leave puzzles like this unsolved. I can always start qtcreator
    > then open the .pro file, and I can use the Sendto facility.


    Sure, it's good to sort these things out - find out why :)

    I know it works in Win7, just suggesting you run up an XP Mode version
    of it, and test in that...

    http://www.microsoft.com/windows/virtual-pc/default.aspx

    http://www.microsoft.com/windows/virtual-pc/download.aspx

    --
    Duncan.
    Dave Doe, Mar 13, 2013
    #34
  15. Gib Bogle

    Gib Bogle Guest

    On 13/03/2013 7:18 p.m., Dave Doe wrote:

    >> It all works as expected on Win7. The work PC is on a domain
    >> environment. Next time I'm at the office I'll try a local logon. I
    >> seldom go there, since I work at home, using VPN and Remote Desktop. A
    >> new PC is not on the cards.
    >>
    >> I'm pursuing this purely out of interest - it is an intriguing puzzle, I
    >> hate to leave puzzles like this unsolved. I can always start qtcreator
    >> then open the .pro file, and I can use the Sendto facility.

    >
    > Sure, it's good to sort these things out - find out why :)
    >
    > I know it works in Win7, just suggesting you run up an XP Mode version
    > of it, and test in that...
    >
    > http://www.microsoft.com/windows/virtual-pc/default.aspx
    >
    > http://www.microsoft.com/windows/virtual-pc/download.aspx
    >


    Ah, right. I'll see if my enthusiasm reaches that far ;)
    Gib Bogle, Mar 13, 2013
    #35
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. BASeCamper

    Odd behaviour with FF, but not IE...

    BASeCamper, Sep 20, 2006, in forum: Firefox
    Replies:
    0
    Views:
    396
    BASeCamper
    Sep 20, 2006
  2. jils

    odd behaviour in win xp

    jils, Oct 25, 2006, in forum: Computer Support
    Replies:
    9
    Views:
    548
  3. Chris Gilbert

    30D - odd shutter/metering behaviour

    Chris Gilbert, May 25, 2007, in forum: Digital Photography
    Replies:
    21
    Views:
    635
    John McWilliams
    May 29, 2007
  4. Gib Bogle

    Odd ADSL behaviour

    Gib Bogle, Aug 3, 2003, in forum: NZ Computing
    Replies:
    6
    Views:
    377
  5. Roger Mills

    Skypephone S2 odd behaviour

    Roger Mills, Apr 5, 2012, in forum: UK VOIP
    Replies:
    3
    Views:
    894
    Graham.
    Apr 6, 2012
Loading...

Share This Page