alt-tab with multiple games open doesn't always work...

Discussion in 'Windows 64bit' started by Skybuck Flying, Apr 13, 2007.

  1. P

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 13, 2007
    #1
    1. Advertising

  2. Can't say for sure, but doing that between heavy games running in 'full
    screen' mode, could mean confusion. Alt-Tab'ing between app's running in
    'window' mode shouldn't give you any trouble as long as they aren't
    screaming for memory and you have implemented a reasonable 'swapping'
    scheme.

    Is this XP, or Vista? It may be a driver issue, something that is resolved
    'down-the-line'?


    Tony. . .


    "Skybuck Flying" <> wrote in message
    news:evmt4f$agt$1.ov.home.nl...
    > P
    >
    > Bye,
    > Skybuck.
    >
    >
     
    Tony Sperling, Apr 13, 2007
    #2
    1. Advertising

  3. Also, on XP you have an option to optimize for System Cache or Background
    Processes - the system default should serve you well, if you tried tweaking
    this, perhaps you should reset it? In addition, some games and sim's might
    have an internal option to keep running when they loose focus - FS does,
    there's another possible point of conflict?


    Tony. . .


    "Tony Sperling" <> wrote in message
    news:...
    > Can't say for sure, but doing that between heavy games running in 'full
    > screen' mode, could mean confusion. Alt-Tab'ing between app's running in
    > 'window' mode shouldn't give you any trouble as long as they aren't
    > screaming for memory and you have implemented a reasonable 'swapping'
    > scheme.
    >
    > Is this XP, or Vista? It may be a driver issue, something that is resolved
    > 'down-the-line'?
    >
    >
    > Tony. . .
    >
    >
    > "Skybuck Flying" <> wrote in message
    > news:evmt4f$agt$1.ov.home.nl...
    > > P
    > >
    > > Bye,
    > > Skybuck.
    > >
    > >

    >
    >
     
    Tony Sperling, Apr 13, 2007
    #3
  4. "Tony Sperling" <> wrote in message
    news:...
    > Can't say for sure, but doing that between heavy games running in 'full
    > screen' mode, could mean confusion. Alt-Tab'ing between app's running in
    > 'window' mode shouldn't give you any trouble as long as they aren't
    > screaming for memory and you have implemented a reasonable 'swapping'
    > scheme.
    >
    > Is this XP, or Vista? It may be a driver issue, something that is resolved
    > 'down-the-line'?


    The only two things which have changed:

    1. Installed XP SP2.

    2. Installed latest X-Fi soundblaster driver.


    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 13, 2007
    #4
  5. Probably a driver then. The latest may not always be the greatest - I would
    either go back to the former sound driver or un-install, then re-install the
    video driver to make sure it is familiar with the new environment.


    Tony. . .


    "Skybuck Flying" <> wrote in message
    news:evobrm$q5n$1.ov.home.nl...
    > "Tony Sperling" <> wrote in message
    > news:...
    > > Can't say for sure, but doing that between heavy games running in 'full
    > > screen' mode, could mean confusion. Alt-Tab'ing between app's running in
    > > 'window' mode shouldn't give you any trouble as long as they aren't
    > > screaming for memory and you have implemented a reasonable 'swapping'
    > > scheme.
    > >
    > > Is this XP, or Vista? It may be a driver issue, something that is

    resolved
    > > 'down-the-line'?

    >
    > The only two things which have changed:
    >
    > 1. Installed XP SP2.
    >
    > 2. Installed latest X-Fi soundblaster driver.
    >
    >
    > Bye,
    > Skybuck.
    >
    >
     
    Tony Sperling, Apr 13, 2007
    #5
  6. "Tony Sperling" <> wrote in message
    news:...
    > Probably a driver then. The latest may not always be the greatest - I
    > would
    > either go back to the former sound driver or un-install, then re-install
    > the
    > video driver to make sure it is familiar with the new environment.


    Well there was one more thing I changed but thought it wasn't worth
    mentioning.

    Now play Battlefield 2 with 1920x1200 resolution.

    Switching from BF2 to the desktop also freezes.

    I keep f*cking around with alt-tab until it works.

    Right now something weird happened... it seemed like windows xp 64 bit..
    missed an alt key up message... and mouse button up message.

    since the shooting in the game was weird and editing notepad was weird as
    well.

    Tomorrow I am gonna investigate:

    1. Switch back resolution to see if that's the problem.

    2. Go back to older x-fi driver.

    If these problems don't solve it then it's an SP2 problem.

    The I'll try:

    3. Latest nvidia driver to see if that helps.

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #6
  7. Well, I just deinstalled all creative live software, and openal, and some
    other little thingies.

    Reinstalled what appears to be audio drivers only:

    SBXF_PCDRV_LB_2_09_0001.exe

    This is a webupdate.

    The problem is probably with:

    SBXF_PCDRV_LB_2_09_0007.exe

    However the instructions said to first fully deinstalled de audio drivers...
    I did not do that back then...

    But then again version 0001 is working just fine... so gonna keep those.

    However I now lost all other creative live software (which I don't really
    use).

    The only thing I wish that was present is the audio console with the volume
    display...

    That's not included in the webupdate... which is kinda stupid.

    But since I am testing anyway... I might as well give the newer driver one
    more chance... by following instructions properly and seeing if it indeed
    creates a problem.

    So far geometry wars was working just fine with 0001.

    So I will now repeat it for 0007 ;)

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #7
  8. Amazing,

    I tried to deinstall 0001, and rebooted, however it seems impossible without
    the original software.

    Windows can still play sound !

    Creative has made a mess of things as always.

    I can't believe these people are not able to deinstall software properply.

    Well that means I can't risk testing 0007 anymore because that might create
    the problem again.

    So now I will simply reinstall the original software and apply update 0001
    one more time ;)

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #8
  9. Well I just did a full reinstall of the cd's fortunately they still working
    =D

    Also installed 0001 and now geometry wars alt-tabs smooth as butter...

    Which probably means the rest is smooth as butter as well =D

    Yes... because with 0007 my system looked like crap when alt-tabbing...

    And now it's the dream pc again which it's supposed to be ;)

    I can run quake4, quake3, doom3, and battlefield 2 all four at the same time
    =D

    Yeahahahahahahaha.

    Later today I will play some more BF2... and if I have a problem I will
    report back... otherwise consider the problem solved for now...

    Ofcourse BF2 does have some sound issue's... after playing for a long
    time... the sound sometimes gets corrupted...

    However I did not have that problem with doom3 and quake4... so it's seems
    BF2 related ;)

    So you were correct after all... the latest drivers isn't always the best
    drivers ;) :)

    However I might also try some new gfx drivers in a few days... too see how
    to works out...

    However for now... I still have to see if the problem is really solved.. so
    gonna give it a few days =D

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #9
  10. Nope,

    I never believed the older driver is better than newer driver story anyway.

    Spoke to soon, the alt-tabbing problem remains.

    This could mean:

    1. Battlefield 2 Demo, 1920x1200 resolution problem.

    2. Windows XP x64 Pro SP2 problem.

    3. Nvidia driver problem.

    Hmmm I really wanna play on 1920x1200 resolution, so now gonna try Nvidia
    driver update.

    If that don't work gonna see if it's a high resolution problem, since BF2
    Demo doesn't support it really, it's a command line trick.

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #10
  11. Well updating nvidia drivers not possible for gtx 7900, already have latest
    drivers 93.71.

    Well then the possibilities that remain:

    1. High resolution problem.

    2. SP2 problem.

    Now gonna start bf2demo via the executable instead of the link with special
    command things.

    So no commands and lower resolution 1600x1200 ;)

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #11
  12. Well,

    I think I have now cracked down the problem.

    It's definetly related to resolution 1920x1200 with the following command
    line trick:

    D:\Games\Battlefield2Demo\BF2.exe +menu 1 +fullscreen 1 +szx 1920 +szy 1200

    Apperently BF2Demo is just buggy and cannot support 1920x1200 properly...
    but it also might be an nvidia driver issue.

    Default resolution with 1600x1200 works ok.

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #12
  13. To be honest, I too did have some serious headache from those drivers some
    time ago, that was before I read the README (or whatever it was). There are
    descriptions that explane how the different parts of Creative's
    conglomeration of a sound system fits together, I just cannot remember
    anymore where or what, but it's there and it will tell you in what sequence
    to install the different parts - this is actually of vital imprtance to it
    all working, which it finally did for me.

    There is one part that they call the Console, that includes the Control
    Panel applet and mixer and must install before the Web thing, or I'm wrong
    and it was the other way around or something else entirely, I strongly
    suggest investigating this properly, there once was a specific sequence in
    which to go through the installation!


    Tony. . .



    "Skybuck Flying" <> wrote in message
    news:f0n0d8$nul$1.ov.home.nl...
    > Well updating nvidia drivers not possible for gtx 7900, already have

    latest
    > drivers 93.71.
    >
    > Well then the possibilities that remain:
    >
    > 1. High resolution problem.
    >
    > 2. SP2 problem.
    >
    > Now gonna start bf2demo via the executable instead of the link with

    special
    > command things.
    >
    > So no commands and lower resolution 1600x1200 ;)
    >
    > Bye,
    > Skybuck.
    >
    >
     
    Tony Sperling, Apr 25, 2007
    #13
  14. Well,

    I finally also reinstalled webupdate 4/0007 since that wasn't the problem.

    And from now on I will simply have to play in 1600x1200 if I want to alt-tab
    properly ;)

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #14
  15. Yeah,

    There are 3 cd's too start with.

    1. Installation CD is mort important.
    2. Extra program's CD.
    3. Demonstration CD.

    2 and 3 not so important.

    But it's wise to install 1 first.

    Then any webupdate can be applied.

    It's called the audio console... but I think they just mean the audio
    drivers.

    CD's are very important... because the webupdate is just drivers only... no
    fancy stuff :)

    Also after audio drivers installed/reinstalled check equalizer for
    settings.. because it resets everything.

    I like to turn down the base a bit... first few bars in equalizer...

    And ofcourse I always enable the 24 bit crystalizer... since that makes
    everything sound 10 times better than ever before.

    And ofcourse I also set speakers to 7.1 and ofcourse test the speakers with
    the very cool creative volume panel/game/entertainment/music console panel
    =D

    Whatever they call it, it s cool, must have =D

    Bye,
    Skybuck.
     
    Skybuck Flying, Apr 25, 2007
    #15
  16. Skybuck Flying

    Maincat Guest

    "Skybuck Flying" <> wrote in message
    news:f0naet$g06$1.ov.home.nl...
    > Well,
    >
    > I finally also reinstalled webupdate 4/0007 since that wasn't the problem.
    >
    > And from now on I will simply have to play in 1600x1200 if I want to
    > alt-tab properly ;)
    >
    > Bye,
    > Skybuck.
    >

    And who cares?
     
    Maincat, Apr 25, 2007
    #16
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Alexander Fischer
    Replies:
    1
    Views:
    794
    Alexander Fischer
    Oct 1, 2004
  2. Lisa Hetherington
    Replies:
    6
    Views:
    10,421
    Big Will
    May 3, 2005
  3. Barend Blankenstein

    Alt+tab keys don't work anymore

    Barend Blankenstein, Jul 14, 2004, in forum: Computer Support
    Replies:
    2
    Views:
    625
    Toolman Tim
    Jul 15, 2004
  4. iceman
    Replies:
    7
    Views:
    3,338
    Patrick Keenan
    Nov 7, 2005
  5. .
    Replies:
    1
    Views:
    552
    Robert Baer
    Jun 18, 2004
Loading...

Share This Page