Advice on router QoS for voip.co.uk

Discussion in 'UK VOIP' started by Kabads, Dec 28, 2006.

  1. Kabads

    Kabads Guest

    I've never managed to get voip.co.uk working properly and my contract
    is up for renewal in February (IIRC) and I would like to get it working
    reliably before February to renew.

    I'm currently experiencing dropped and poor call quality, which I think
    is due to improper config of QoS on my DSL router. My set-up is
    represented thus:

    ADSL --> router --> voip MTA (supplied by voip.co.uk) --> DECT phone
    |--> wireless router --> wireless laptops
    |--> PC

    I understand that voip.co.uk recommend that all machines should connect
    from the MTA, but as there is only one network port, I'd rather use the
    4 on my router. Also, I'm sure this can be done as my router allows for
    QoS.

    As stated, my router allows for QoS configuration, but I've yet to
    manage to configure it happily with my MTA. The MTA is set to receive a
    fixed IP from the router (192.168.1.5) with the router on 192.168.1.1.

    I've set up a router LAN QoS rules for the traffic between 192.168.1.1
    and 192.168.1.5, for high priority, medium priority (with 80%, 20%) but
    nothing seems to connect nicely. The MTA also has QoS enabled, but with
    no settings. You can see the MTA QoS config screen at:
    http://www.monkeez.org/publicpics/voip/voip3.png

    You can see the current config that I have on my router at:
    http://www.monkeez.org/publicpics/voip/voip1.png

    and then the config screen where I am entering information at:
    http://www.monkeez.org/publicpics/voip/voip2.png

    Basically, any advice you can offer on this last screen to get an
    optimal setting for my MTA would be gratefully received. Am I correct
    in focusing on port 5060? Are there any other ports that I should allow
    for?

    TIA
    Adam
     
    Kabads, Dec 28, 2006
    #1
    1. Advertising

  2. Kabads

    Meggahurtz Guest

    "Kabads" <> wrote in message
    news:...

    Hi Adam,

    I`m also finding QOS on my router to be just soggy fish, may I ask which
    router you have?

    My moneys on a Linksys? If it is i`ve tried the DD wrt firmware which is
    suppose to work well for QOS but i`ve had no luck with that either.

    I`ve been reading the Drateks are good for QOS but they are abit pricey (to
    say the least).
     
    Meggahurtz, Dec 28, 2006
    #2
    1. Advertising

  3. Kabads wrote:
    > I've never managed to get voip.co.uk working properly and my contract
    > is up for renewal in February (IIRC) and I would like to get it working
    > reliably before February to renew.
    >

    I've got a Zoom x5v in this configuration (running in Franceusing
    voip.co.uk), it is a combined ADSL modem and 1 port Voip router which
    handles the QoS for you.

    Worth a shot if you know that that is what is wrong.

    Have you done any tests on your internet connection and the bandwidth
    you get to voip.co.uk's servers? (latency etc.)
     
    Thomas Kenyon, Dec 28, 2006
    #3
  4. In article <>,
    Kabads <> wrote:
    >I've never managed to get voip.co.uk working properly and my contract
    >is up for renewal in February (IIRC) and I would like to get it working
    >reliably before February to renew.
    >
    >I'm currently experiencing dropped and poor call quality, which I think
    >is due to improper config of QoS on my DSL router. My set-up is
    >represented thus:
    >
    >ADSL --> router --> voip MTA (supplied by voip.co.uk) --> DECT phone
    > |--> wireless router --> wireless laptops
    > |--> PC


    Have you gone back to basics to work out if you really do need
    QoS? ie. unplug everything from your router except the MTA and make some
    calls... Of-course if you're constantly down/up loading from the other
    PCs then you might well need it, but I've found that in-general QoS isn't
    needed in a typical home environment, but if you have it, then enable it.

    Another thing to remember is that QoS is only really effective in one
    direction - ie. data leaving your network to go out to the big-bad
    internet. You have very little control over data coming in (because the
    data has already come in and by then it's too late to do anything with it,
    so it might as well just pass it throught to the much higher speed LAN)

    >I understand that voip.co.uk recommend that all machines should connect
    >from the MTA, but as there is only one network port, I'd rather use the
    >4 on my router. Also, I'm sure this can be done as my router allows for
    >QoS.
    >
    >As stated, my router allows for QoS configuration, but I've yet to
    >manage to configure it happily with my MTA. The MTA is set to receive a
    >fixed IP from the router (192.168.1.5) with the router on 192.168.1.1.
    >
    >I've set up a router LAN QoS rules for the traffic between 192.168.1.1
    >and 192.168.1.5, for high priority, medium priority (with 80%, 20%) but
    >nothing seems to connect nicely. The MTA also has QoS enabled, but with
    >no settings. You can see the MTA QoS config screen at:
    >http://www.monkeez.org/publicpics/voip/voip3.png
    >
    >You can see the current config that I have on my router at:
    >http://www.monkeez.org/publicpics/voip/voip1.png


    Ah. You're QoSing SIP. What you need to QoS is RTP, and that will depend
    on the ports your MTA uses (and voip.co.uk). The default is 10000 through
    20000. If you can, just QoS on the IP address and match all ports. (or
    1 through 65535)

    >and then the config screen where I am entering information at:
    >http://www.monkeez.org/publicpics/voip/voip2.png


    See if you can not enter any port numbers. Also, you want to QoS on UDP
    (which is how SIP and RTP is carried), not TCP, so set that to UDP or
    both if it has a both setting.

    Remember: SIP just controls the call, RTP carries the data for the call.

    >Basically, any advice you can offer on this last screen to get an
    >optimal setting for my MTA would be gratefully received. Am I correct
    >in focusing on port 5060? Are there any other ports that I should allow
    >for?


    Find out what ports voip.co.uk uses for RTP, or QoS on IP address only.

    Gordon
     
    Gordon Henderson, Dec 28, 2006
    #4
  5. In article <3uOkh.24444$>,
    Meggahurtz <> wrote:

    >I`ve been reading the Drateks are good for QOS but they are abit pricey (to
    >say the least).


    You can get bargians on eBay - eg: 230069053456 which can be re-flashed
    with the latest firmware without any problems. (I use Drayteks a lot -
    they do have their limitations, but are OK for most people)

    Gordon
     
    Gordon Henderson, Dec 28, 2006
    #5
  6. Kabads

    Bill49 Guest

    Hi Adam,
    As I understand it (but I could be very wrong!) sip is only used for
    the initiation of a session. The data itself is transfered using the
    Real-Time Protocol (RTP), so this should also be entered in your qos
    table. The ports my sipura uses for RTP are 16384-16684, and I guess
    these are pretty standard, although you should look at the sip page of
    your atm to check it uses the same ports. The protocol used for RTP
    is UDP ( not TCP). It's also worth putting any p2p stuff on low
    priority.
    Having said this, QOS has a rather bad reputation. I think you would be
    better putting the ATM first (dumping your modem/router) and plugging
    it into a router, then your would not have to worry about qos.
    Bill
     
    Bill49, Dec 28, 2006
    #6
  7. Kabads

    ale.cx Guest

    Bill49 wrote:

    > Hi Adam,
    > As I understand it (but I could be very wrong!) sip is only used for
    > the initiation of a session. The data itself is transfered using the
    > Real-Time Protocol (RTP), so this should also be entered in your qos
    > table. The ports my sipura uses for RTP are 16384-16684, and I guess
    > these are pretty standard, although you should look at the sip page of
    > your atm to check it uses the same ports.


    The only standard for RTP is >0 and <65536 ;-)

    alexd
     
    ale.cx, Dec 29, 2006
    #7
  8. Kabads

    Kabads Guest

    Bill49 wrote:
    > Hi Adam,

    <snip>
    > Having said this, QOS has a rather bad reputation. I think you would be
    > better putting the ATM first (dumping your modem/router) and plugging
    > it into a router, then your would not have to worry about qos.
    > Bill


    Just an update on what I'm trying here (without any reliability test
    here yet). I plugged in just the voip MTA all by itself and it seems to
    work (ADSL -> router -> MTA). I put a laptop in to the MTA and got a
    terribly slow internet connection on the laptop (probably due to a high
    QoS setting on the MTA).

    When I plugged in my wireless router, everything went pear-shaped with
    voip, so this is obviously using more bandwidth, or whatever the MTA
    needs. So, instead of just promoting the MTA, I'm limiting the wireless
    router through QoS. I'll report back if this resolves (wishful
    thinking).

    Thanks for all the help offered. Just shows how clueless I am in this
    area :->

    Adam
     
    Kabads, Dec 29, 2006
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,517
  2. ck cheng
    Replies:
    0
    Views:
    607
    ck cheng
    Jan 6, 2005
  3. db
    Replies:
    3
    Views:
    720
  4. dominix
    Replies:
    2
    Views:
    485
    dominix
    Feb 6, 2007
  5. Giuen
    Replies:
    0
    Views:
    1,016
    Giuen
    Sep 12, 2008
Loading...

Share This Page