ADSL with ISDN backup

Discussion in 'Cisco' started by Guyster, Dec 10, 2005.

  1. Guyster

    Guyster Guest

    Morning all,

    I am trying to configure an 1841 router to give ADSL access to an ISP
    with an ISDN backup in case the ADSL fails. I have just about got it
    working using the backup interface command on the ATM interface. The
    problem is that when simulating an ADSL failure by pulling the cable,
    the BRI interface comes up and the dialer connects but the ADSL dialer
    stays up which leaves the route out via the ADSL dialer in the routing
    table so no traffic can get out. Any one got any ideas?
     
    Guyster, Dec 10, 2005
    #1
    1. Advertising

  2. Guyster

    Igor Mamuzic Guest

    When you pull out ADSL cable is your dialer goes down in a couple of
    minutes? I tried this on 851W router and dialer goes down in a few
    minutes... If this period matches the period that you see under 'idle timer'
    variable in the 'show dialer' output, then try to reduce this value to
    something more comfortable to you...

    B.R.
    Igor




    "Guyster" <> wrote in message
    news:...
    > Morning all,
    >
    > I am trying to configure an 1841 router to give ADSL access to an ISP
    > with an ISDN backup in case the ADSL fails. I have just about got it
    > working using the backup interface command on the ATM interface. The
    > problem is that when simulating an ADSL failure by pulling the cable,
    > the BRI interface comes up and the dialer connects but the ADSL dialer
    > stays up which leaves the route out via the ADSL dialer in the routing
    > table so no traffic can get out. Any one got any ideas?
    >
     
    Igor Mamuzic, Dec 10, 2005
    #2
    1. Advertising

  3. Guyster

    Guyster Guest

    I tried that - I had it set at 10 seconds for testing but the dialer
    was staying up, could this be because the default route was still in
    the routing table and inbound traffic was still being sent that way so
    the router doensnt think the dialer is idle? From the info I found on
    setting this up I got the impression that when the backup ISDN
    interface comes up the ATM should go down and take the dialer with it,
    is it possible to force this?.
     
    Guyster, Dec 10, 2005
    #3
  4. Guyster

    Igor Mamuzic Guest

    hm...strange thing... I never used before ATM interface for connecting to
    ADSL. I usually use PPPoE client on my Cisco routers and after provider
    disconnects those every 24h, dialer also comes down and up (it bounds to
    the virtual-profile actually).

    Can I see how you defined your default route?

    Also, I have another option for you: PBR with tracking option (it may not
    apply to your topology)
    (http://www.cisco.com/en/US/products...iguration_guide_chapter09186a0080457bcc.html).
    This will send IP SLA probes (icmp echo requests) to some Internet host that
    you define in it. When IP SLA probe fails (you don't get ICMP echo reply),
    your router will use next route-map 'set ip next-hop' statement (you will
    define it to use) to send packets to the Internet. Unfortunately, this only
    works if you are able to specifie next-hop ip address. I'm afraid that in
    your case you have to specifie one of your dialer interfaces:( ...

    But send me your default route first...

    B.R.
    Igor


    "Guyster" <> wrote in message
    news:...
    >I tried that - I had it set at 10 seconds for testing but the dialer
    > was staying up, could this be because the default route was still in
    > the routing table and inbound traffic was still being sent that way so
    > the router doensnt think the dialer is idle? From the info I found on
    > setting this up I got the impression that when the backup ISDN
    > interface comes up the ATM should go down and take the dialer with it,
    > is it possible to force this?.
    >
     
    Igor Mamuzic, Dec 10, 2005
    #4
  5. Guyster

    Guyster Guest

    Hi, thanks for your help, here are the highlights of the config,
    including the default route - I dont have a next hop address or routing
    protocol so it looks like the only option I have is the backup
    interface command
    Cheers
    Guy

    clock timezone . 0
    clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 2:00
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    !
    ip name-server 62.241.162.200
    isdn switch-type basic-net3
    !
    interface FastEthernet0/1
    ip address *.*.*.* 255.255.255.248
    duplex auto
    speed auto
    !
    interface ATM0/0/0
    no ip address
    backup interface BRI0/1/0
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 2
    !
    !
    interface BRI0/1/0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    no keepalive
    !
    interface Dialer0
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer string 08450795056
    dialer-group 1
    ppp chap hostname *
    ppp chap password *
    !
    interface Dialer2
    ip address negotiated
    encapsulation ppp
    dialer pool 2
    dialer idle-timeout 10
    dialer-group 2
    no cdp enable
    ppp chap hostname *
    ppp chap password *
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer2
    ip route 0.0.0.0 0.0.0.0 Dialer0 80
     
    Guyster, Dec 11, 2005
    #5
  6. Guyster

    Igor Mamuzic Guest

    Try with this:

    interface Dialer2
    no dialer-group 2

    This should eliminate interesting traffic issue, that is, maybe there is
    always some interesting traffic that keeps this dialer up...

    B.R.
    Igor


    "Guyster" <> wrote in message
    news:...
    > Hi, thanks for your help, here are the highlights of the config,
    > including the default route - I dont have a next hop address or routing
    > protocol so it looks like the only option I have is the backup
    > interface command
    > Cheers
    > Guy
    >
    > clock timezone . 0
    > clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 2:00
    > mmi polling-interval 60
    > no mmi auto-configure
    > no mmi pvc
    > mmi snmp-timeout 180
    > ip subnet-zero
    > !
    > ip name-server 62.241.162.200
    > isdn switch-type basic-net3
    > !
    > interface FastEthernet0/1
    > ip address *.*.*.* 255.255.255.248
    > duplex auto
    > speed auto
    > !
    > interface ATM0/0/0
    > no ip address
    > backup interface BRI0/1/0
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 2
    > !
    > !
    > interface BRI0/1/0
    > no ip address
    > encapsulation ppp
    > dialer pool-member 1
    > isdn switch-type basic-net3
    > no keepalive
    > !
    > interface Dialer0
    > ip address negotiated
    > encapsulation ppp
    > dialer pool 1
    > dialer string 08450795056
    > dialer-group 1
    > ppp chap hostname *
    > ppp chap password *
    > !
    > interface Dialer2
    > ip address negotiated
    > encapsulation ppp
    > dialer pool 2
    > dialer idle-timeout 10
    > dialer-group 2
    > no cdp enable
    > ppp chap hostname *
    > ppp chap password *
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer2
    > ip route 0.0.0.0 0.0.0.0 Dialer0 80
    >
     
    Igor Mamuzic, Dec 11, 2005
    #6
  7. Guyster

    Guyster Guest

    Thanks again, I will give that a go - I cant try it until wednesday
    evening though, I will let you know how it goes

    Cheers
    Guy
     
    Guyster, Dec 12, 2005
    #7
  8. In article <>,
    Guyster <> wrote:
    >Morning all,
    >
    >I am trying to configure an 1841 router to give ADSL access to an ISP
    >with an ISDN backup in case the ADSL fails. I have just about got it
    >working using the backup interface command on the ATM interface. The
    >problem is that when simulating an ADSL failure by pulling the cable,
    >the BRI interface comes up and the dialer connects but the ADSL dialer
    >stays up which leaves the route out via the ADSL dialer in the routing
    >table so no traffic can get out. Any one got any ideas?


    You need to take a different approach to failover. Backup interface
    requires the interface being backed up to fail but dialer interfaces
    never go down, they are either UP (for real) or UP (spoofing).

    You need to design your backup scheme using a mechanism which does
    not depend on the dialer going down. Normally, this is done through a
    routing protocol, but that is rarely an option with ADSL ISPs. Most
    people in your situation use "ping based routing" to detect loss of
    the ADSL link (a fringe benefit of Cisco's Response Time Recorder
    feature) and use that to activate/deactivate the default route
    through the ADSL link. A floating static route can then be used
    to activate the ISDN backup. But be aware that this approach has
    some nasty side effects if you are performing NAT on both ADSL and
    ISDN paths inside the router. It also may require you to manually
    reactivate the ADSL link before its return to action can be detected.

    Good luck and have fun!
    --
    Vincent C Jones, Consultant Expert advice and a helping hand
    Networking Unlimited, Inc. for those who want to manage and
    Tenafly, NJ Phone: 201 568-7810 control their networking destiny
    http://www.networkingunlimited.com
     
    Vincent C Jones, Dec 12, 2005
    #8
  9. Guyster

    Igor Mamuzic Guest

    Vince,

    If you don't think on PBR with tracking option, can you provide some links
    for "ping based routing"?... I didn't know until now that this feature
    exists... I used before only PBR with tracking option and Cisco IP SLA
    monitoring.

    Thanks in advance...
    B.R.
    Igor

    "Vincent C Jones" <> wrote in message
    news:dnkdhh$h6s$...
    > In article <>,
    > Guyster <> wrote:
    >>Morning all,
    >>
    >>I am trying to configure an 1841 router to give ADSL access to an ISP
    >>with an ISDN backup in case the ADSL fails. I have just about got it
    >>working using the backup interface command on the ATM interface. The
    >>problem is that when simulating an ADSL failure by pulling the cable,
    >>the BRI interface comes up and the dialer connects but the ADSL dialer
    >>stays up which leaves the route out via the ADSL dialer in the routing
    >>table so no traffic can get out. Any one got any ideas?

    >
    > You need to take a different approach to failover. Backup interface
    > requires the interface being backed up to fail but dialer interfaces
    > never go down, they are either UP (for real) or UP (spoofing).
    >
    > You need to design your backup scheme using a mechanism which does
    > not depend on the dialer going down. Normally, this is done through a
    > routing protocol, but that is rarely an option with ADSL ISPs. Most
    > people in your situation use "ping based routing" to detect loss of
    > the ADSL link (a fringe benefit of Cisco's Response Time Recorder
    > feature) and use that to activate/deactivate the default route
    > through the ADSL link. A floating static route can then be used
    > to activate the ISDN backup. But be aware that this approach has
    > some nasty side effects if you are performing NAT on both ADSL and
    > ISDN paths inside the router. It also may require you to manually
    > reactivate the ADSL link before its return to action can be detected.
    >
    > Good luck and have fun!
    > --
    > Vincent C Jones, Consultant Expert advice and a helping hand
    > Networking Unlimited, Inc. for those who want to manage and
    > Tenafly, NJ Phone: 201 568-7810 control their networking destiny
    > http://www.networkingunlimited.com
     
    Igor Mamuzic, Dec 12, 2005
    #9
  10. Igor Mamuzic <> wrote:
    >Vince,
    >
    >If you don't think on PBR with tracking option, can you provide some links


    Could you rephrase the clause leading up to the first comma? I
    can't parse it, which makes it hard to reply.

    >for "ping based routing"?... I didn't know until now that this feature


    http://www.cisco.com/en/US/tech/tk364/technologies_configuration_example09186a0080211f5c.shtml

    >exists... I used before only PBR with tracking option and Cisco IP SLA
    >monitoring.


    In Cisco IOS, "ping based routing" can be done using PBR with
    tracking option, so I think we're using different terms for the same
    features. When first introduced, Cisco called it their "Response
    Time Recorder" (RTR) feature.

    >
    >Thanks in advance...
    >B.R.
    >Igor
    >
    >"Vincent C Jones" <> wrote in message
    >news:dnkdhh$h6s$...
    >> In article <>,
    >> Guyster <> wrote:
    >>>Morning all,
    >>>
    >>>I am trying to configure an 1841 router to give ADSL access to an ISP
    >>>with an ISDN backup in case the ADSL fails. I have just about got it
    >>>working using the backup interface command on the ATM interface. The
    >>>problem is that when simulating an ADSL failure by pulling the cable,
    >>>the BRI interface comes up and the dialer connects but the ADSL dialer
    >>>stays up which leaves the route out via the ADSL dialer in the routing
    >>>table so no traffic can get out. Any one got any ideas?

    >>
    >> You need to take a different approach to failover. Backup interface
    >> requires the interface being backed up to fail but dialer interfaces
    >> never go down, they are either UP (for real) or UP (spoofing).
    >>
    >> You need to design your backup scheme using a mechanism which does
    >> not depend on the dialer going down. Normally, this is done through a
    >> routing protocol, but that is rarely an option with ADSL ISPs. Most
    >> people in your situation use "ping based routing" to detect loss of
    >> the ADSL link (a fringe benefit of Cisco's Response Time Recorder
    >> feature) and use that to activate/deactivate the default route
    >> through the ADSL link. A floating static route can then be used
    >> to activate the ISDN backup. But be aware that this approach has
    >> some nasty side effects if you are performing NAT on both ADSL and
    >> ISDN paths inside the router. It also may require you to manually
    >> reactivate the ADSL link before its return to action can be detected.
    >>
    >> Good luck and have fun!
    >> --
    >> Vincent C Jones, Consultant


    --
    Vincent C Jones, Consultant Expert advice and a helping hand
    Networking Unlimited, Inc. for those who want to manage and
    Tenafly, NJ Phone: 201 568-7810 control their networking destiny
    http://www.networkingunlimited.com
     
    Vincent C Jones, Dec 12, 2005
    #10
  11. Guyster

    Igor Mamuzic Guest

    Yes, It seems that we are using different terms for the same feature...

    But I think that this won't help to Guyster's issue, because when you use
    'verify-availability' route-map 'set' statement then only option, I get is
    to specifie next hop ip address. I'm afraid that Guyster due to the nature
    of his Internet connections doesn't know what the next-hop ip will be next
    time he connects.... On the contrary if he can predict next-hop ip then this
    is perfect solution for him... I don't understand why Cisco doesn't supports
    'set next-hop interface' with object tracking or even possibility to
    redistribute routes depending of tracking object status...

    B.R.
    Igor


    "Vincent C Jones" <> wrote in message
    news:dnklfd$f18$...
    > Igor Mamuzic <> wrote:
    >>Vince,
    >>
    >>If you don't think on PBR with tracking option, can you provide some links

    >
    > Could you rephrase the clause leading up to the first comma? I
    > can't parse it, which makes it hard to reply.
    >
    >>for "ping based routing"?... I didn't know until now that this feature

    >
    > http://www.cisco.com/en/US/tech/tk364/technologies_configuration_example09186a0080211f5c.shtml
    >
    >>exists... I used before only PBR with tracking option and Cisco IP SLA
    >>monitoring.

    >
    > In Cisco IOS, "ping based routing" can be done using PBR with
    > tracking option, so I think we're using different terms for the same
    > features. When first introduced, Cisco called it their "Response
    > Time Recorder" (RTR) feature.
    >
    >>
    >>Thanks in advance...
    >>B.R.
    >>Igor
    >>
    >>"Vincent C Jones" <> wrote in message
    >>news:dnkdhh$h6s$...
    >>> In article <>,
    >>> Guyster <> wrote:
    >>>>Morning all,
    >>>>
    >>>>I am trying to configure an 1841 router to give ADSL access to an ISP
    >>>>with an ISDN backup in case the ADSL fails. I have just about got it
    >>>>working using the backup interface command on the ATM interface. The
    >>>>problem is that when simulating an ADSL failure by pulling the cable,
    >>>>the BRI interface comes up and the dialer connects but the ADSL dialer
    >>>>stays up which leaves the route out via the ADSL dialer in the routing
    >>>>table so no traffic can get out. Any one got any ideas?
    >>>
    >>> You need to take a different approach to failover. Backup interface
    >>> requires the interface being backed up to fail but dialer interfaces
    >>> never go down, they are either UP (for real) or UP (spoofing).
    >>>
    >>> You need to design your backup scheme using a mechanism which does
    >>> not depend on the dialer going down. Normally, this is done through a
    >>> routing protocol, but that is rarely an option with ADSL ISPs. Most
    >>> people in your situation use "ping based routing" to detect loss of
    >>> the ADSL link (a fringe benefit of Cisco's Response Time Recorder
    >>> feature) and use that to activate/deactivate the default route
    >>> through the ADSL link. A floating static route can then be used
    >>> to activate the ISDN backup. But be aware that this approach has
    >>> some nasty side effects if you are performing NAT on both ADSL and
    >>> ISDN paths inside the router. It also may require you to manually
    >>> reactivate the ADSL link before its return to action can be detected.
    >>>
    >>> Good luck and have fun!
    >>> --
    >>> Vincent C Jones, Consultant

    >
    > --
    > Vincent C Jones, Consultant Expert advice and a helping hand
    > Networking Unlimited, Inc. for those who want to manage and
    > Tenafly, NJ Phone: 201 568-7810 control their networking destiny
    > http://www.networkingunlimited.com
     
    Igor Mamuzic, Dec 13, 2005
    #11
  12. Guyster

    Guest

    Hi Guyster,

    If my memory serves me right, the way to do this is to interchange your
    floating static. Use the dialer interface of isdn as primary and the
    adsl as secondary. The rest, let the backup interface do the job of
    making the dialer interface to be on standby. "backup int dialer #".
    This will make the adsl as the active route while the isdn is down.

    Cheers,
    Jeff
     
    , Dec 13, 2005
    #12
  13. Guyster

    Guyster Guest

    Hi guys,
    I have just found out that the ISP at this site don't support this kind
    of setup - they have public IP addresses inside the router and the ISP
    route all the traffic to this subnet via the IP address that is
    assigned to the ADSL interface, so it wont work anyway!! The guys at
    the site are looking for service that will deliver on their
    requirements. I take it with the PBR option you are only using ping to
    check the availability of the ADSL otherwise it would rack up the bill
    on the ISDN line!

    Cheers
    Guy
     
    Guyster, Dec 14, 2005
    #13
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Darren Summers
    Replies:
    4
    Views:
    3,320
    admin too
    Jun 22, 2004
  2. Replies:
    3
    Views:
    4,091
  3. Replies:
    0
    Views:
    2,943
  4. Hillel
    Replies:
    8
    Views:
    670
    Vincent C Jones
    Feb 18, 2006
  5. sync
    Replies:
    0
    Views:
    582
Loading...

Share This Page