ADSL disconnects randomly on 2600.

Discussion in 'Cisco' started by Joe Hancock, Jul 11, 2005.

  1. Joe Hancock

    Joe Hancock Guest

    I've got some issues with an adsl setup.

    I'm using PPPoA as I'm in the UK. After 2 - 5mins I get the following
    error message, and the atm link goes down.


    *Mar  1 00:01:32: %LINK-3-UPDOWN: Interface ATM0/0, changed state to down
    *Mar  1 00:01:32: %ATM-5-UPDOWN: Changing VC 0/38 VC-state to PVC deactivated.
    *Mar  1 00:01:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    ATM0/0, changed state to down
    *Mar  1 00:01:33: %LINK-3-UPDOWN: Interface Virtual-Access1, changed
    state to down
    *Mar  1 00:01:33: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
    *Mar  1 00:01:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    Virtual-Access1, changed state to down

    I also get:

    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32359
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -103
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32357
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -98
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32360
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32359
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32360
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32354
    *Mar  1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -103

    These happen before the link goes down.

    It's a 2600, with a Wic 1 ADSL.

    In the 5 mins its up, I can route traffic and the nat works fine.

    running-config:

    Current configuration : 1332 bytes
    !
    version 12.2
    service timestamps debug datetime
    service timestamps log datetime
    no service password-encryption
    !
    hostname main-gw
    !
    aaa new-model
    !
    !
    aaa session-id common
    enable secret 5 xxxx
    !
    username joe password 0 xxx
    ip subnet-zero
    !
    !
    !
    ip audit notify log
    ip audit po max-events 100
    ip ssh time-out 60
    !
    !
    !
    !
    !
    !
    !
    !
    fax interface-type fax-mail
    mta receive maximum-recipients 0
    !
    !
    !
    !
    interface ATM0/0
     no ip address
     no atm ilmi-keepalive
     pvc 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
     dsl operating-mode auto
     no fair-queue
    !
    interface Ethernet0/0
     ip address 10.0.0.3 255.255.255.0
     ip nat inside
     half-duplex
    !
    interface Dialer1
     ip address 22.22.22.22 255.255.255.248
     ip nat outside
     encapsulation ppp
     dialer pool 1
     dialer idle-timeout 0
     dialer persistent
     ppp chap hostname
     ppp chap password 0 xxxx
     ppp pap sent-username password 0 xxxx
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    ip pim bidir-enable
    !        
    !
    access-list 1 permit 10.0.0.0 0.0.0.255
    !
    call rsvp-sync
    !
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
     password xxx
    line aux 0
    line vty 0 4
     password xxx
     transport input ssh
    !
    !
    end

    22.22.22.22 is the external address.

    Any ideas?
     
    Joe Hancock, Jul 11, 2005
    #1
    1. Advertising

  2. Joe Hancock

    Noodles Guest

    I dont use these two lines in my dialer section on an identical setup
    (2600&WIC) and never have had a problem;

    dialer idle-timeout 0
    dialer persistent

    other than that my config looks similar and I couldn't see a reason for
    it myself although Im no guru :)
     
    Noodles, Jul 11, 2005
    #2
    1. Advertising

  3. Joe Hancock

    Martin Kayes Guest

    Hi,

    put 'no dialer idle-timeout' under your dialer1 interface to remove the
    command.

    you already have 'dialer persistent' in place and that should keep the
    interface always up.

    I would also consider putting the following commands in to prevent large
    packets from being dropped on the DSLAM:

    interface dialer1
    ip mtu 1492
    ip tcp adjust-mss 1452
    !
    interface Ethernet0/0
    ip tcp adjust-mss 1452

    The PPP overhead makes the packet too large and it is often dropped if you
    don't restrict the size.

    Regards,

    Martin



    "Joe Hancock" <> wrote in message
    news:2005071123325175249%jrh2@aberacuk...
    > I've got some issues with an adsl setup.
    >
    > I'm using PPPoA as I'm in the UK. After 2 - 5mins I get the following
    > error message, and the atm link goes down.
    >
    >
    > *Mar 1 00:01:32: %LINK-3-UPDOWN: Interface ATM0/0, changed state to down
    > *Mar 1 00:01:32: %ATM-5-UPDOWN: Changing VC 0/38 VC-state to PVC
    > deactivated.
    > *Mar 1 00:01:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0,
    > changed state to down
    > *Mar 1 00:01:33: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state
    > to down
    > *Mar 1 00:01:33: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
    > *Mar 1 00:01:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    > Virtual-Access1, changed state to down
    >
    > I also get:
    >
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32359
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -103
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32357
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -98
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32360
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32240
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32359
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32360
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -32354
    > *Mar 1 00:04:55: nATM(ATM0/0): num_tsis is -ve after adding
    > DSLSAR_MAX_TSI_SEQ_NUM, num_tsis = -103
    >
    > These happen before the link goes down.
    >
    > It's a 2600, with a Wic 1 ADSL.
    >
    > In the 5 mins its up, I can route traffic and the nat works fine.
    >
    > running-config:
    >
    > Current configuration : 1332 bytes
    > !
    > version 12.2
    > service timestamps debug datetime
    > service timestamps log datetime
    > no service password-encryption
    > !
    > hostname main-gw
    > !
    > aaa new-model
    > !
    > !
    > aaa session-id common
    > enable secret 5 xxxx
    > !
    > username joe password 0 xxx
    > ip subnet-zero
    > !
    > !
    > !
    > ip audit notify log
    > ip audit po max-events 100
    > ip ssh time-out 60
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > fax interface-type fax-mail
    > mta receive maximum-recipients 0
    > !
    > !
    > !
    > !
    > interface ATM0/0
    > no ip address
    > no atm ilmi-keepalive
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > dsl operating-mode auto
    > no fair-queue
    > !
    > interface Ethernet0/0
    > ip address 10.0.0.3 255.255.255.0
    > ip nat inside
    > half-duplex
    > !
    > interface Dialer1
    > ip address 22.22.22.22 255.255.255.248
    > ip nat outside
    > encapsulation ppp
    > dialer pool 1
    > dialer idle-timeout 0
    > dialer persistent
    > ppp chap hostname
    > ppp chap password 0 xxxx
    > ppp pap sent-username password 0 xxxx
    > !
    > ip nat inside source list 1 interface Dialer1 overload
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer1
    > no ip http server
    > ip pim bidir-enable
    > ! !
    > access-list 1 permit 10.0.0.0 0.0.0.255
    > !
    > call rsvp-sync
    > !
    > !
    > mgcp profile default
    > !
    > dial-peer cor custom
    > !
    > !
    > !
    > !
    > !
    > line con 0
    > password xxx
    > line aux 0
    > line vty 0 4
    > password xxx
    > transport input ssh
    > !
    > !
    > end
    >
    > 22.22.22.22 is the external address.
    >
    > Any ideas?
    >
     
    Martin Kayes, Jul 13, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. King Fu

    WIFI connection randomly/non randomly disconnects

    King Fu, Oct 21, 2004, in forum: Wireless Networking
    Replies:
    2
    Views:
    17,132
    Carey Holzman
    Nov 10, 2004
  2. Replies:
    1
    Views:
    546
  3. Philip

    Unwanted disconnects from ADSL

    Philip, Dec 31, 2005, in forum: NZ Computing
    Replies:
    18
    Views:
    779
    Aaron Lawrence
    Jan 5, 2006
  4. Dreamweaver

    Wireless connection disconnects randomly

    Dreamweaver, Apr 18, 2008, in forum: Wireless Networking
    Replies:
    8
    Views:
    1,043
    Jack [MVP-Networking]
    May 5, 2010
  5. Replies:
    2
    Views:
    835
Loading...

Share This Page