Address Aging Issue

Discussion in 'Cisco' started by Dan, Jan 21, 2004.

  1. Dan

    Dan Guest

    Is anyone familiar with the address aging issue between a Catalyst 1900
    and a Catalyst 2900. Specifically, if a laptop is disconnected for a
    1900 port to a 2900, the use can't login to the network. The work
    around is too go into the 1900's Address Aging field and change it from
    18000 to 300 and the wait 5 minutes and laptop can connect. Then change
    the aging back to 18000. Here is what firmware/ios is running:

    1900 Firmware v 7.02

    2900 V 11.2(8.6)sa6

    Is there a way to fix this issue as it is very annoying.

    TIA, Dan
    Dan, Jan 21, 2004
    #1
    1. Advertising

  2. In article <>, Dan <> writes:
    >Is anyone familiar with the address aging issue between a Catalyst 1900
    >and a Catalyst 2900. Specifically, if a laptop is disconnected for a
    >1900 port to a 2900, the use can't login to the network. The work
    >around is too go into the 1900's Address Aging field and change it from
    >18000 to 300 and the wait 5 minutes and laptop can connect. Then change
    >the aging back to 18000. Here is what firmware/ios is running:
    >
    > 1900 Firmware v 7.02
    >
    > 2900 V 11.2(8.6)sa6
    >
    >Is there a way to fix this issue as it is very annoying.


    Why do you change the aging time back? The important thing is to have the same
    aging time on all your switches in the network. 18000 seems a bit too high for
    me. I would suggest something like 30 minutes.

    Regards,
    Christoph Gartmann

    --
    Max-Planck-Institut fuer Phone : +49-761-5108-464 Fax: -452
    Immunbiologie
    Postfach 1169 Internet: gartmann@immunbio dot mpg dot de
    D-79011 Freiburg, Germany
    http://www.immunbio.mpg.de/home/menue.html
    Christoph Gartmann, Jan 21, 2004
    #2
    1. Advertising

  3. Dan

    Dan Guest

    On 1/21/2004 2:41 AM, Christoph Gartmann wrote:
    > In article <>, Dan <> writes:
    >
    >>Is anyone familiar with the address aging issue between a Catalyst 1900
    >>and a Catalyst 2900. Specifically, if a laptop is disconnected for a
    >>1900 port to a 2900, the use can't login to the network. The work
    >>around is too go into the 1900's Address Aging field and change it from
    >>18000 to 300 and the wait 5 minutes and laptop can connect. Then change
    >>the aging back to 18000. Here is what firmware/ios is running:
    >>
    >> 1900 Firmware v 7.02
    >>
    >> 2900 V 11.2(8.6)sa6
    >>
    >>Is there a way to fix this issue as it is very annoying.

    >
    >
    > Why do you change the aging time back? The important thing is to have the same
    > aging time on all your switches in the network. 18000 seems a bit too high for
    > me. I would suggest something like 30 minutes.
    >
    > Regards,
    > Christoph Gartmann
    >


    I think 1800 seconds (300 minutes) was the default. But even changing
    it to 30 minutes is not going to fix the problem will it if done on all
    3 routers?. I don't know how to change the Address Aging on the 2900 as
    it has a command line which commands i am not too familiar with.

    Also, what about upgrading the firmware in the 1900s and IOS in the 2900?

    TIA, Dan
    Dan, Jan 22, 2004
    #3
  4. Dan

    AnyBody43 Guest

    (Christoph Gartmann) wrote in message news:<buldvh$li4$-freiburg.de>...
    > In article <>, Dan <> writes:
    > >Is anyone familiar with the address aging issue between a Catalyst 1900
    > >and a Catalyst 2900. Specifically, if a laptop is disconnected for a
    > >1900 port to a 2900, the use can't login to the network. The work
    > >around is too go into the 1900's Address Aging field and change it from
    > >18000 to 300 and the wait 5 minutes and laptop can connect. Then change
    > >the aging back to 18000. Here is what firmware/ios is running:
    > >
    > > 1900 Firmware v 7.02
    > >
    > > 2900 V 11.2(8.6)sa6
    > >
    > >Is there a way to fix this issue as it is very annoying.

    >
    > Why do you change the aging time back? The important thing is to have the same
    > aging time on all your switches in the network. 18000 seems a bit too high for
    > me. I would suggest something like 30 minutes.
    >
    > Regards,
    > Christoph Gartmann



    This may not be 100% but I think that it is not too bad.

    The original solution to this behviour (I don't think that it is a
    'problem') is to relay on the Spanning Tree Protocol
    which is enabled by default.

    STP sent (note past tense) a Topology Change Notification (TCN)
    whenever a port was brought up or went down (I think both).

    This caused the forwarding database (terminology from 802.1d,
    sorry) to be put into fast aging which is, IIRC, 15 seconds.

    I cannot now recall exactly but I suspect that ports with
    portfast enabled do not result in TCN on state change.

    Anyway to your issue, the default aging time is 300s and
    unless there was a sepcific problem being experienced
    I see no need to change it.

    If you have STP off you could consider turning it on which
    would enable fast aging.

    I do not have time right now to look up the portfast vs
    fast aging thing.

    Finally remember that 802.1d protocol was designed
    when there was the real prospect of a 2000 node (or more)
    bridged network and processors were less fast and memory was
    much more costly. Modern stuff is really (perhaps I should
    say Absolutely) fabulous in comparison. It would be most unusual
    consider increasing the aging time from the default.

    Good luck.
    AnyBody43, Jan 22, 2004
    #4
  5. In article <trIPb.97608$-kc.rr.com>, Dan <> writes:
    >I think 1800 seconds (300 minutes) was the default. But even changing
    >it to 30 minutes is not going to fix the problem will it if done on all
    >3 routers?.


    I just noticed: 1800 seconds is already 30 minutes. So try something like
    300 (5 minutes). At least there shouldn't be a problem when moving a computer
    if you wait 30 or five minutes before reconnecting it.

    >I don't know how to change the Address Aging on the 2900 as it has a command
    >line which commands i am not too familiar with.


    Connect to it, then at the prompt:
    > enable

    ...
    # configure terminal
    (config)# interface ethernet 0
    (config-if)# arp timeout 300
    (config-if)# end
    (config)# end
    # write mem

    >Also, what about upgrading the firmware in the 1900s and IOS in the 2900?


    Not a bad idea either.

    Regards,
    Christoph Gartmann

    --
    Max-Planck-Institut fuer Phone : +49-761-5108-464 Fax: -452
    Immunbiologie
    Postfach 1169 Internet: gartmann@immunbio dot mpg dot de
    D-79011 Freiburg, Germany
    http://www.immunbio.mpg.de/home/menue.html
    Christoph Gartmann, Jan 22, 2004
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Martin Bilgrav

    C6000 MAC aging problem

    Martin Bilgrav, Dec 1, 2005, in forum: Cisco
    Replies:
    2
    Views:
    4,006
    Martin Bilgrav
    Dec 2, 2005
  2. Karl Engel

    XP on an aging PIII?

    Karl Engel, Aug 12, 2005, in forum: Computer Support
    Replies:
    10
    Views:
    794
    kenny
    Aug 14, 2005
  3. Dave L

    CMOS image aging

    Dave L, Apr 11, 2005, in forum: Digital Photography
    Replies:
    2
    Views:
    386
    Don Stauffer
    Apr 18, 2005
  4. BD

    Question: Artificially aging digital photos

    BD, Jul 11, 2005, in forum: Digital Photography
    Replies:
    8
    Views:
    348
    male1960
    Jul 15, 2005
  5. RandyM

    Digital aging of subject in photo

    RandyM, Mar 17, 2007, in forum: Digital Photography
    Replies:
    4
    Views:
    1,188
    Bill Again
    Mar 18, 2007
Loading...

Share This Page