Ad hoc wireless network - file sharing

Discussion in 'Wireless Networking' started by =?Utf-8?B?UmV4?=, Jan 10, 2006.

  1. I have 2 laptops with win xp home and norton internet security 2005 with
    internal intel pro 2200 b/g wireless cards.

    After a lot of googling was i able to get my ad hoc wireless network online
    i.e. the other laptop and my laptop wireless lan icons in the system tray
    show "connected".

    But despite have shared folders on both laptops I am not able to see the
    other laptop in the "network neighbourhood" or for that matter any of the
    shared folders.

    Will somebody please give me step by step instructions as to how to enable
    file sharing
    P.S. Step by step means 'really step by step'... I'm a little slow at this.
    --
    I Must; I Can & Therefore I WILL!
     
    =?Utf-8?B?UmV4?=, Jan 10, 2006
    #1
    1. Advertising

  2. =?Utf-8?B?UmV4?=

    Malke Guest

    Rex wrote:

    > I have 2 laptops with win xp home and norton internet security 2005
    > with internal intel pro 2200 b/g wireless cards.
    >
    > After a lot of googling was i able to get my ad hoc wireless network
    > online i.e. the other laptop and my laptop wireless lan icons in the
    > system tray show "connected".
    >
    > But despite have shared folders on both laptops I am not able to see
    > the other laptop in the "network neighbourhood" or for that matter any
    > of the shared folders.
    >
    > Will somebody please give me step by step instructions as to how to
    > enable file sharing
    > P.S. Step by step means 'really step by step'... I'm a little slow at
    > this.


    If you can get online with both computers, then you know the network is
    operating correctly. You just need to set up your Local Area Network
    (lan) sharing.

    Run the Network Setup Wizard on both computers, making sure you enable
    File & Printer Sharing. Reboot each machine. Now go to the Control
    Panel and open the Windows Firewall applet (I'm assuming you have
    Service Pack 2 on both machines) and disable it.

    Now open Norton Internet Security and configure the firewall to allow
    your lan traffic as trusted. I can't tell you exactly where to look for
    this, but it should be fairly obvious or you can read NIS's Help file.
    In third-party firewalls like that, I usually set the lan's IP range as
    trusted. Mine looks like 192.168.1.0-192.168.1.254. Substitute your
    correct subnet.

    Now create shares on each computer. XP Home will not allow you to share
    users' home directories (My Documents) or the Program Files directory,
    but you can share folders inside those directories. Or just put items
    you want to share in the Shared Documents folder.

    It can take up to 15 minutes for Network Places to populate with the
    shares you've made.

    Here are some links that may also help:

    http://winhlp.com/wxnet.htm - Small Network Troubleshooter by Hans-Georg
    Michna
    http://www.practicallynetworked.com/sharing/xp/filesharing.htm (Home)
    http://www.bcmaven.com/networking/faq.htm
    http://www.bcmaven.com/networking/myths.htm

    Malke
    --
    Elephant Boy Computers
    www.elephantboycomputers.com
    "Don't Panic!"
    MS-MVP Windows - Shell/User
     
    Malke, Jan 10, 2006
    #2
    1. Advertising

  3. First I want to thank you malke for helping me out. But I still seem to be a
    little stuck; Can you please help me out here too?

    I dont have an internet connection available at any of the laptops so I cant
    try to check whether the network really works or not; but the wireless lan
    icon in the system tray does indicate connected and the other laptop detects
    my network and also indicates connected.

    Both the laptops have also been configured to be in the same workgroup. But
    despite all this neither of the 2 laptops show anything in their network
    neighbourhoods (absolutely blank).

    On starting the network setup wizard I get a error message which says that
    some of the networking hardware might not be connected and shows only the
    ethernet cable connection with absolutely no reference to the wireless
    network! What do I do now?

    --
    I Must; I Can & Therefore I WILL!


    "Malke" wrote:

    > Rex wrote:
    >
    > > I have 2 laptops with win xp home and norton internet security 2005
    > > with internal intel pro 2200 b/g wireless cards.
    > >
    > > After a lot of googling was i able to get my ad hoc wireless network
    > > online i.e. the other laptop and my laptop wireless lan icons in the
    > > system tray show "connected".
    > >
    > > But despite have shared folders on both laptops I am not able to see
    > > the other laptop in the "network neighbourhood" or for that matter any
    > > of the shared folders.
    > >
    > > Will somebody please give me step by step instructions as to how to
    > > enable file sharing
    > > P.S. Step by step means 'really step by step'... I'm a little slow at
    > > this.

    >
    > If you can get online with both computers, then you know the network is
    > operating correctly. You just need to set up your Local Area Network
    > (lan) sharing.
    >
    > Run the Network Setup Wizard on both computers, making sure you enable
    > File & Printer Sharing. Reboot each machine. Now go to the Control
    > Panel and open the Windows Firewall applet (I'm assuming you have
    > Service Pack 2 on both machines) and disable it.
    >
    > Now open Norton Internet Security and configure the firewall to allow
    > your lan traffic as trusted. I can't tell you exactly where to look for
    > this, but it should be fairly obvious or you can read NIS's Help file.
    > In third-party firewalls like that, I usually set the lan's IP range as
    > trusted. Mine looks like 192.168.1.0-192.168.1.254. Substitute your
    > correct subnet.
    >
    > Now create shares on each computer. XP Home will not allow you to share
    > users' home directories (My Documents) or the Program Files directory,
    > but you can share folders inside those directories. Or just put items
    > you want to share in the Shared Documents folder.
    >
    > It can take up to 15 minutes for Network Places to populate with the
    > shares you've made.
    >
    > Here are some links that may also help:
    >
    > http://winhlp.com/wxnet.htm - Small Network Troubleshooter by Hans-Georg
    > Michna
    > http://www.practicallynetworked.com/sharing/xp/filesharing.htm (Home)
    > http://www.bcmaven.com/networking/faq.htm
    > http://www.bcmaven.com/networking/myths.htm
    >
    > Malke
    > --
    > Elephant Boy Computers
    > www.elephantboycomputers.com
    > "Don't Panic!"
    > MS-MVP Windows - Shell/User
    >
     
    =?Utf-8?B?UmV4?=, Jan 10, 2006
    #3
  4. =?Utf-8?B?UmV4?=

    Lem Guest

    Rex wrote:

    > First I want to thank you malke for helping me out. But I still seem to be a
    > little stuck; Can you please help me out here too?
    >
    > I dont have an internet connection available at any of the laptops so I cant
    > try to check whether the network really works or not; but the wireless lan
    > icon in the system tray does indicate connected and the other laptop detects
    > my network and also indicates connected.
    >
    > Both the laptops have also been configured to be in the same workgroup. But
    > despite all this neither of the 2 laptops show anything in their network
    > neighbourhoods (absolutely blank).
    >
    > On starting the network setup wizard I get a error message which says that
    > some of the networking hardware might not be connected and shows only the
    > ethernet cable connection with absolutely no reference to the wireless
    > network! What do I do now?
    >
    > --
    > I Must; I Can & Therefore I WILL!
    >
    > "Malke" wrote:
    >
    > > Rex wrote:
    > >
    > > > I have 2 laptops with win xp home and norton internet security 2005
    > > > with internal intel pro 2200 b/g wireless cards.
    > > >
    > > > After a lot of googling was i able to get my ad hoc wireless network
    > > > online i.e. the other laptop and my laptop wireless lan icons in the
    > > > system tray show "connected".
    > > >
    > > > But despite have shared folders on both laptops I am not able to see
    > > > the other laptop in the "network neighbourhood" or for that matter any
    > > > of the shared folders.
    > > >
    > > > Will somebody please give me step by step instructions as to how to
    > > > enable file sharing
    > > > P.S. Step by step means 'really step by step'... I'm a little slow at
    > > > this.

    > >
    > > If you can get online with both computers, then you know the network is
    > > operating correctly. You just need to set up your Local Area Network
    > > (lan) sharing.
    > >
    > > Run the Network Setup Wizard on both computers, making sure you enable
    > > File & Printer Sharing. Reboot each machine. Now go to the Control
    > > Panel and open the Windows Firewall applet (I'm assuming you have
    > > Service Pack 2 on both machines) and disable it.
    > >
    > > Now open Norton Internet Security and configure the firewall to allow
    > > your lan traffic as trusted. I can't tell you exactly where to look for
    > > this, but it should be fairly obvious or you can read NIS's Help file.
    > > In third-party firewalls like that, I usually set the lan's IP range as
    > > trusted. Mine looks like 192.168.1.0-192.168.1.254. Substitute your
    > > correct subnet.
    > >
    > > Now create shares on each computer. XP Home will not allow you to share
    > > users' home directories (My Documents) or the Program Files directory,
    > > but you can share folders inside those directories. Or just put items
    > > you want to share in the Shared Documents folder.
    > >
    > > It can take up to 15 minutes for Network Places to populate with the
    > > shares you've made.
    > >
    > > Here are some links that may also help:
    > >
    > > http://winhlp.com/wxnet.htm - Small Network Troubleshooter by Hans-Georg
    > > Michna
    > > http://www.practicallynetworked.com/sharing/xp/filesharing.htm (Home)
    > > http://www.bcmaven.com/networking/faq.htm
    > > http://www.bcmaven.com/networking/myths.htm
    > >
    > > Malke
    > > --
    > > Elephant Boy Computers
    > > www.elephantboycomputers.com
    > > "Don't Panic!"
    > > MS-MVP Windows - Shell/User
    > >


    As far as I can tell, the "connected" status reported by WinXP is pretty much
    meaningless for ad hoc networks. That is, in my experience, the icon reports
    "connected" even though it's the only one turned on.

    The network SSID is more important than the workgroup name. Also ensure that
    both laptops are on the same wireless channel. If neither laptop is connected
    to the Internet, I would disable Norton Internet Security (if, in fact, these
    laptops will never be connected to the Internet, I'd uninstall NIS). Assuming
    that you have WinXP sp2, also ensure that the Windows Firewall is turned off.
    And finally, first set up things with no encryption security.

    Once you get things working, you can add back layers of security, starting with
    encryption and then turning on either the Windows firewall or NIS.

    This is a pretty good guide to setting up an ad hoc network with Win XP
    http://www.microsoft.com/windowsxp/using/networking/expert/bowman_02april08.mspx

    (the one bit of advice from Barb Bowman that I would definitely NOT follow,
    however, is the suggestion to obtain updated drivers from Microsoft update.
    Don't do it. You'll be sorry.)
     
    Lem, Jan 10, 2006
    #4
  5. =?Utf-8?B?UmV4?=

    Lem Guest

    Rex wrote:

    > First I want to thank you malke for helping me out. But I still seem to be a
    > little stuck; Can you please help me out here too?
    >
    > I dont have an internet connection available at any of the laptops so I cant
    > try to check whether the network really works or not; but the wireless lan
    > icon in the system tray does indicate connected and the other laptop detects
    > my network and also indicates connected.
    >
    > Both the laptops have also been configured to be in the same workgroup. But
    > despite all this neither of the 2 laptops show anything in their network
    > neighbourhoods (absolutely blank).
    >
    > On starting the network setup wizard I get a error message which says that
    > some of the networking hardware might not be connected and shows only the
    > ethernet cable connection with absolutely no reference to the wireless
    > network! What do I do now?
    >
    > --
    > I Must; I Can & Therefore I WILL!
    >
    > "Malke" wrote:
    >
    > > Rex wrote:
    > >
    > > > I have 2 laptops with win xp home and norton internet security 2005
    > > > with internal intel pro 2200 b/g wireless cards.
    > > >
    > > > After a lot of googling was i able to get my ad hoc wireless network
    > > > online i.e. the other laptop and my laptop wireless lan icons in the
    > > > system tray show "connected".
    > > >
    > > > But despite have shared folders on both laptops I am not able to see
    > > > the other laptop in the "network neighbourhood" or for that matter any
    > > > of the shared folders.
    > > >
    > > > Will somebody please give me step by step instructions as to how to
    > > > enable file sharing
    > > > P.S. Step by step means 'really step by step'... I'm a little slow at
    > > > this.

    > >
    > > If you can get online with both computers, then you know the network is
    > > operating correctly. You just need to set up your Local Area Network
    > > (lan) sharing.
    > >
    > > Run the Network Setup Wizard on both computers, making sure you enable
    > > File & Printer Sharing. Reboot each machine. Now go to the Control
    > > Panel and open the Windows Firewall applet (I'm assuming you have
    > > Service Pack 2 on both machines) and disable it.
    > >
    > > Now open Norton Internet Security and configure the firewall to allow
    > > your lan traffic as trusted. I can't tell you exactly where to look for
    > > this, but it should be fairly obvious or you can read NIS's Help file.
    > > In third-party firewalls like that, I usually set the lan's IP range as
    > > trusted. Mine looks like 192.168.1.0-192.168.1.254. Substitute your
    > > correct subnet.
    > >
    > > Now create shares on each computer. XP Home will not allow you to share
    > > users' home directories (My Documents) or the Program Files directory,
    > > but you can share folders inside those directories. Or just put items
    > > you want to share in the Shared Documents folder.
    > >
    > > It can take up to 15 minutes for Network Places to populate with the
    > > shares you've made.
    > >
    > > Here are some links that may also help:
    > >
    > > http://winhlp.com/wxnet.htm - Small Network Troubleshooter by Hans-Georg
    > > Michna
    > > http://www.practicallynetworked.com/sharing/xp/filesharing.htm (Home)
    > > http://www.bcmaven.com/networking/faq.htm
    > > http://www.bcmaven.com/networking/myths.htm
    > >
    > > Malke
    > > --
    > > Elephant Boy Computers
    > > www.elephantboycomputers.com
    > > "Don't Panic!"
    > > MS-MVP Windows - Shell/User
    > >


    Once you think you have both laptops configured properly, on each laptop, click
    Start -> Run, type "cmd" (without quotes) and press Enter.
    In the command window that opens, type ipconfig
    One of the lines that will be displayed is "IP Address" This will be of the
    form 169.254.x.y. Write it down.
    Go to the other laptop and do the same thing. Write the IP address of the
    second laptop down also.

    In the same command window on laptop 2, type: ping "laptop1 IP address"
    As an example, if the IP Address for laptop 1 was 169.254.45.69 then from laptop
    2 type
    ping 169.254.45.69
    You should get back four lines showing reply from laptop1 with time < 10 ms. If
    you do, then you have indeed successfully connected your ad hoc network. For
    completeness, you might want to try the same ping test from a command window on
    laptop 1.

    If the results from the ping show "Request timed out," then there is something
    wrong with your setup. Post back, including as much detail as you can and
    someone will try to help.
     
    Lem, Jan 10, 2006
    #5
  6. =?Utf-8?B?UmV4?=

    Malke Guest

    Lem wrote:

    >
    > Once you think you have both laptops configured properly, on each
    > laptop, click Start -> Run, type "cmd" (without quotes) and press
    > Enter. In the command window that opens, type ipconfig
    > One of the lines that will be displayed is "IP Address" This will be
    > of the
    > form 169.254.x.y. Write it down.
    > Go to the other laptop and do the same thing. Write the IP address of
    > the second laptop down also.
    >
    > In the same command window on laptop 2, type: ping "laptop1 IP
    > address" As an example, if the IP Address for laptop 1 was
    > 169.254.45.69 then from laptop 2 type
    > ping 169.254.45.69
    > You should get back four lines showing reply from laptop1 with time <
    > 10 ms. If
    > you do, then you have indeed successfully connected your ad hoc
    > network. For completeness, you might want to try the same ping test
    > from a command window on laptop 1.


    Thanks for picking this one up, Lem. I really know squat about ad hoc
    wireless networking and I would have sent the OP to Barb Bowman's site,
    too. I thought from his original post that he did have his network
    going OK.

    Just as an aside to Rex, getting a consumer wireless router like a
    Linksys, Netgear, etc. and not doing ad hoc really makes life easier.
    If you have a setup where you can do this, I'd highly suggest just
    getting a router and doing a "normal" networking setup.

    Otherwise, I leave you to Lem, who has far more expertise with ad hoc
    networking than I do.

    Malke
    --
    Elephant Boy Computers
    www.elephantboycomputers.com
    "Don't Panic!"
    MS-MVP Windows - Shell/User
     
    Malke, Jan 11, 2006
    #6
  7. Thanks a lot guys for all your help; am going to try all that u advised and i
    have a feeling that this time its gonna work.

    By the way Malke, I'm not really in favour of buying a router as the 2
    laptops are pretty close and money is a little tight at this end.... see?

    --
    I Must; I Can & Therefore I WILL!


    "Malke" wrote:

    > Lem wrote:
    >
    > >
    > > Once you think you have both laptops configured properly, on each
    > > laptop, click Start -> Run, type "cmd" (without quotes) and press
    > > Enter. In the command window that opens, type ipconfig
    > > One of the lines that will be displayed is "IP Address" This will be
    > > of the
    > > form 169.254.x.y. Write it down.
    > > Go to the other laptop and do the same thing. Write the IP address of
    > > the second laptop down also.
    > >
    > > In the same command window on laptop 2, type: ping "laptop1 IP
    > > address" As an example, if the IP Address for laptop 1 was
    > > 169.254.45.69 then from laptop 2 type
    > > ping 169.254.45.69
    > > You should get back four lines showing reply from laptop1 with time <
    > > 10 ms. If
    > > you do, then you have indeed successfully connected your ad hoc
    > > network. For completeness, you might want to try the same ping test
    > > from a command window on laptop 1.

    >
    > Thanks for picking this one up, Lem. I really know squat about ad hoc
    > wireless networking and I would have sent the OP to Barb Bowman's site,
    > too. I thought from his original post that he did have his network
    > going OK.
    >
    > Just as an aside to Rex, getting a consumer wireless router like a
    > Linksys, Netgear, etc. and not doing ad hoc really makes life easier.
    > If you have a setup where you can do this, I'd highly suggest just
    > getting a router and doing a "normal" networking setup.
    >
    > Otherwise, I leave you to Lem, who has far more expertise with ad hoc
    > networking than I do.
    >
    > Malke
    > --
    > Elephant Boy Computers
    > www.elephantboycomputers.com
    > "Don't Panic!"
    > MS-MVP Windows - Shell/User
    >
     
    =?Utf-8?B?UmV4?=, Jan 11, 2006
    #7
  8. =?Utf-8?B?UmV4?=

    Snow Bear Guest

    I am certaintly NOT an expert at this. I just got down installing a
    Linksys Wireless network on my computers, I may have lost part of hair
    in the process, but I got it to work, that is except for the conflicts
    with Norton as of yet. Like you I searched all over the internet for
    help. But it is only a bit here or a bit here. There was not ONE
    location that explain this in detail or a total solution to it. Found
    a lot about ping and stub. And I am like - say what? But I figured
    out how to do it. So here goes.

    It does involve multiple steps:
    (1) Each drive or folder needs to be slated for sharing. It appears
    you know how to do this.
    (2) You need to map the drives to the network. Press [Start], then
    Press [My network places]. If you can not see [My network places] then
    do this. Press [Start], [Control Panel] [Network Connections] [my
    network places]. Once there you need to map the drive. On the top
    menu bar, press [Tools] [Map Network Drive]. This will pop up with the
    Window asking for the network drive name. If you already have one,
    select that, else make one up. Then you need to indicate the folder
    name. In order to see a whole drive you would select //{computer
    name}/{drive letter}. Computer name is what ever name you assigned
    your computer, and drive letter is what ever drive you want this
    computer to see. Then press [Finish]. This should establish a Network
    drive for you to see when you select [My Computer].

    (3) You need to establish file sharing. [Start] [Control Panel]
    {Network Connections] - then right click your network. Then select
    properties. Here you will find the ability to indicate various file
    sharing protocols. If you have a Linksys network setup the AEGIS file
    sharing conflicts with Linksys, so do not install that file sharing
    option. Otherwise I installed everything I could.

    So far my system is working just fine.

    I hope this was helpful.
     
    Snow Bear, Jan 12, 2006
    #8
  9. =?Utf-8?B?UmV4?=

    Snow Bear Guest

    An added word. I also went into the command prompt and issued to two
    commands. To access the command prompt go to [Start] [Run] and type
    in the three characters 'Cmd' and hit [Enter]. I then typed in (i
    believe , do not quote me on this] IPConfig Release, then I followed
    this up with IPConfig renew. It has something to do with releasing
    addresses and renewing those addresses.
     
    Snow Bear, Jan 12, 2006
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?S2VpdGg=?=

    Very slow file transfer on wireless-g ad-hoc network

    =?Utf-8?B?S2VpdGg=?=, Sep 7, 2004, in forum: Wireless Networking
    Replies:
    0
    Views:
    3,217
    =?Utf-8?B?S2VpdGg=?=
    Sep 7, 2004
  2. =?Utf-8?B?ZGFubnlfYmhveQ==?=

    Sharing internet Connection via Ad Hoc network

    =?Utf-8?B?ZGFubnlfYmhveQ==?=, Oct 25, 2004, in forum: Wireless Networking
    Replies:
    1
    Views:
    934
  3. =?Utf-8?B?SmFyZWQ=?=

    Wireless Ad-Hoc File Sharing

    =?Utf-8?B?SmFyZWQ=?=, Aug 30, 2005, in forum: Wireless Networking
    Replies:
    0
    Views:
    3,774
    =?Utf-8?B?SmFyZWQ=?=
    Aug 30, 2005
  4. Ad hoc file sharing

    , Apr 6, 2006, in forum: Wireless Networking
    Replies:
    2
    Views:
    2,974
  5. pantagruel
    Replies:
    2
    Views:
    519
    Jack \(MVP-Networking\).
    Sep 16, 2007
Loading...

Share This Page