Access to Client running PEAP with Remote Desktop

Discussion in 'Wireless Networking' started by =?Utf-8?B?Q2h1Y2sgTmV2aWxsZQ==?=, Feb 1, 2005.

  1. I am running W 2003 with IAS on a wireless network using PEAP. My machines
    will join the network based on computer and/or user like they should.

    I need to get to remote machines using Remote Desktop to service them. When
    Remote Desktop connects to a machine, the connectivity to the wireless
    network is lost, the computer is locked with the account I logged in with.
    The account I log in with has rights to access the network via wireless. Is
    there any way around this?

    Hopefully, this is enough info.
    =?Utf-8?B?Q2h1Y2sgTmV2aWxsZQ==?=, Feb 1, 2005
    #1
    1. Advertising

  2. Hi Chuck,

    The scenario you describe (trying to Remote Desktop to a wirless client
    machine) is currently an unsupported scenario. The problem lies with the
    interaction of the Remote Desktop user and 802.1x authentication. The issue
    is known and will be solved in Longhorn. I believe a knowledge base article
    is in the works as well. The only way around this is to either not use
    802.1x authentication or to use a wired interface.


    "Chuck Neville" <> wrote in message
    news:...
    >I am running W 2003 with IAS on a wireless network using PEAP. My machines
    > will join the network based on computer and/or user like they should.
    >
    > I need to get to remote machines using Remote Desktop to service them.
    > When
    > Remote Desktop connects to a machine, the connectivity to the wireless
    > network is lost, the computer is locked with the account I logged in with.
    > The account I log in with has rights to access the network via wireless.
    > Is
    > there any way around this?
    >
    > Hopefully, this is enough info.
    Peter Bui[MS], Feb 2, 2005
    #2
    1. Advertising

  3. =?Utf-8?B?Q2h1Y2sgTmV2aWxsZQ==?=

    Mark Gamache Guest

    Depending on the exact nature of your work and security model, you can use
    the following registry key change. It will authenticate the connection in
    the context of the computers domain account and never try to switch to
    authenticating in the user's context.

    Just make sure that you understand that this is neutering your per user
    authentication.

    The setting of the AuthMode registry entry controls the computer and user
    authentication behavior of Windows XP and Windows Server 2003.

    Registry path
    HKEY_LOCAL_MACHINE\Software\Microsoft\EAPOL\Parameters\General\Global\AuthMode

    Version Windows XP and Windows Server 2003

    AuthMode has the following values:

    0 - Computer authentication mode. If computer authentication is successful,
    no user authentication is attempted. If the user logon is successful before
    computer authentication, user authentication is performed. This is the
    default setting for Windows XP (prior to Service Pack 1).
    1 - Computer authentication with re-authentication. If computer
    authentication is successful, a subsequent user logon results in a
    re-authentication with user credentials. The user logon has to complete in
    60 seconds or the existing network connectivity is terminated. The user
    credentials are used for subsequent authentication or re-authentication.
    Computer authentication is not attempted again until the user logs off the
    computer. This is the default setting for Windows XP Service Pack 1 (SP1)
    and Windows Server 2003.
    2 - Computer authentication only. When a user logs on, it has no effect on
    the connection. Only computer authentication is performed. The exception to
    this behavior is when a user successfully logs on, and then roams between
    wireless APs. In that case, user authentication is performed. For changes to
    this setting to take effect, restart the Wireless Zero Configuration service
    for Windows XP or Windows Server 2003.

    Cheers,

    --
    Mark Gamache
    Certified Security Solutions
    http://www.css-security.com



    "Peter Bui[MS]" <> wrote in message
    news:...
    > Hi Chuck,
    >
    > The scenario you describe (trying to Remote Desktop to a wirless client
    > machine) is currently an unsupported scenario. The problem lies with the
    > interaction of the Remote Desktop user and 802.1x authentication. The
    > issue is known and will be solved in Longhorn. I believe a knowledge base
    > article is in the works as well. The only way around this is to either
    > not use 802.1x authentication or to use a wired interface.
    >
    >
    > "Chuck Neville" <> wrote in message
    > news:...
    >>I am running W 2003 with IAS on a wireless network using PEAP. My machines
    >> will join the network based on computer and/or user like they should.
    >>
    >> I need to get to remote machines using Remote Desktop to service them.
    >> When
    >> Remote Desktop connects to a machine, the connectivity to the wireless
    >> network is lost, the computer is locked with the account I logged in
    >> with.
    >> The account I log in with has rights to access the network via wireless.
    >> Is
    >> there any way around this?
    >>
    >> Hopefully, this is enough info.

    >
    >
    Mark Gamache, Feb 2, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jester
    Replies:
    1
    Views:
    1,760
    Vivek
    Dec 20, 2005
  2. Dave Marden
    Replies:
    16
    Views:
    10,688
    Dave Marden
    Jan 24, 2004
  3. Rohan
    Replies:
    1
    Views:
    1,364
    tweety
    Nov 29, 2006
  4. =?Utf-8?B?RGVsb24=?=

    How to uninstall Cisco PEAP supplicant to use XP default PEAP

    =?Utf-8?B?RGVsb24=?=, May 25, 2007, in forum: Wireless Networking
    Replies:
    0
    Views:
    891
    =?Utf-8?B?RGVsb24=?=
    May 25, 2007
  5. BF
    Replies:
    2
    Views:
    748
Loading...

Share This Page