A problem, a solution, a question

Discussion in 'Windows 64bit' started by Carlos, Jul 21, 2008.

  1. Carlos

    Carlos Guest

    Vista x64 SP1 installed in partition C:, D: partition for data, backups, etc.
    RAID0, running on a jmicron chipset controller, gigabyte mobo #GA-MA790FX-DS5

    Problem:
    Partition D: randomly starts in read-only mode not allowing any write
    operation on it.
    A simple reboot fixes it temporarily, until next reboot.

    Solution (or patch):
    A little of googling took me her
    http://forums.microsoft.com/technet...tid=2617353&sb=0&d=1&at=7&ft=11&tf=0&pageid=0
    where Greg Knight from MSFT offered a solution in page 2, admitting it is a
    Vista problem.
    Somehow Vista gets confused when mounting the 2nd partition and sets it
    randomly to read-only.
    Running this command in an elevated prompt
    fsutil volume dismount d:
    fixes it instantaneously without the need of a reboot and stays like that
    until next reboot.

    Question:
    Is there a simple way (registry or startup entry) that allows to
    automatically run that command with administrator rights on every reboot?

    All the usual stuff was tried before getting to this point, i.e.,
    - Delete the partition, format and load data back onto it
    - Take ownership of every single folder in the partition
    - Now matter what, on next reboot there were 50% chances that it was going
    to be read-only again
    - Install Vista again, use different sizes for the partitions, new RAID
    driver, you name it

    :)
    Carlos
    Carlos, Jul 21, 2008
    #1
    1. Advertising

  2. The easiest solution probably would be to put a *.BAT file (or something?)
    in your:

    C:\Documents and Settings\[USERNAME]\Start Menu\Programs\Startup

    folder, and have that execute the command? At least as long as you're not
    going to use hundreds of commands like that.

    You'd probably see the faint shape of a black window flashing when you log
    in, but I think there's a 'silence' option switch to disable that. (Not
    sure).


    Tony. . .
    Tony Sperling, Jul 21, 2008
    #2
    1. Advertising

  3. Carlos

    Carlos Guest

    Tony,
    I wish it were that simple.
    If you right-click on the .bat file and go to the "Compatibility" tab, the
    square box for checking (and enabling) the batch with Administrator
    privileges is greyed out.
    :(
    Keep thinking, I know something will come out. Maybe after a gooood
    Glenfoyle, uh?
    :)
    Carlos

    "Tony Sperling" wrote:

    > The easiest solution probably would be to put a *.BAT file (or something?)
    > in your:
    >
    > C:\Documents and Settings\[USERNAME]\Start Menu\Programs\Startup
    >
    > folder, and have that execute the command? At least as long as you're not
    > going to use hundreds of commands like that.
    >
    > You'd probably see the faint shape of a black window flashing when you log
    > in, but I think there's a 'silence' option switch to disable that. (Not
    > sure).
    >
    >
    > Tony. . .
    >
    >
    >
    >
    Carlos, Jul 21, 2008
    #3
  4. Ah, I admit that I forgot you mentioned the elevated command, but the greyed
    text is strange all the same - did you create the actual *.bat from an
    elevated command window? It has got EDIT has it not?


    Tony. . .


    "Carlos" <> wrote in message
    news:...
    > Tony,
    > I wish it were that simple.
    > If you right-click on the .bat file and go to the "Compatibility" tab, the
    > square box for checking (and enabling) the batch with Administrator
    > privileges is greyed out.
    > :(
    > Keep thinking, I know something will come out. Maybe after a gooood
    > Glenfoyle, uh?
    > :)
    > Carlos
    >
    > "Tony Sperling" wrote:
    >
    > > The easiest solution probably would be to put a *.BAT file (or

    something?)
    > > in your:
    > >
    > > C:\Documents and Settings\[USERNAME]\Start Menu\Programs\Startup
    > >
    > > folder, and have that execute the command? At least as long as you're

    not
    > > going to use hundreds of commands like that.
    > >
    > > You'd probably see the faint shape of a black window flashing when you

    log
    > > in, but I think there's a 'silence' option switch to disable that. (Not
    > > sure).
    > >
    > >
    > > Tony. . .
    > >
    > >
    > >
    > >
    Tony Sperling, Jul 21, 2008
    #4
  5. Carlos

    Carlos Guest

    Tony,
    I did not create the *.bat from an elevated command prompt window.
    I had not thought about that!
    There's no EDIT command in Vista x64 cmd prompt window.
    I will try with Notepad or the old "copy con" command (remember it?)
    My results will have to wait a few hours, I am at work now.
    Carlos

    "Tony Sperling" wrote:

    > Ah, I admit that I forgot you mentioned the elevated command, but the greyed
    > text is strange all the same - did you create the actual *.bat from an
    > elevated command window? It has got EDIT has it not?
    >
    >
    > Tony. . .
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    > > Tony,
    > > I wish it were that simple.
    > > If you right-click on the .bat file and go to the "Compatibility" tab, the
    > > square box for checking (and enabling) the batch with Administrator
    > > privileges is greyed out.
    > > :(
    > > Keep thinking, I know something will come out. Maybe after a gooood
    > > Glenfoyle, uh?
    > > :)
    > > Carlos
    > >
    > > "Tony Sperling" wrote:
    > >
    > > > The easiest solution probably would be to put a *.BAT file (or

    > something?)
    > > > in your:
    > > >
    > > > C:\Documents and Settings\[USERNAME]\Start Menu\Programs\Startup
    > > >
    > > > folder, and have that execute the command? At least as long as you're

    > not
    > > > going to use hundreds of commands like that.
    > > >
    > > > You'd probably see the faint shape of a black window flashing when you

    > log
    > > > in, but I think there's a 'silence' option switch to disable that. (Not
    > > > sure).
    > > >
    > > >
    > > > Tony. . .
    > > >
    > > >
    > > >
    > > >

    >
    >
    >
    Carlos, Jul 21, 2008
    #5
  6. I really have no idea if this is the way to do it, but if you use N-Pad you
    should probably execute it from inside that command window - copy con is
    probably the more natural interface (yes, I remember, but I am not sure I
    remember how to drive it?) On the other hand, I am sure you must have
    EDLIN - Ha, ha, ha!!!

    Being the lazy type, I would probably do DIR > SOME.BAT and replace the
    contents with that of your command in notepad later???

    The Glenfoyle sadly, has evaporated - I shall have to make do with the far
    more expensive Caol Ila (an Islay malt - pronounced as "Cull Eela").


    Tony. . .



    "Carlos" <> wrote in message
    news:...
    > Tony,
    > I did not create the *.bat from an elevated command prompt window.
    > I had not thought about that!
    > There's no EDIT command in Vista x64 cmd prompt window.
    > I will try with Notepad or the old "copy con" command (remember it?)
    > My results will have to wait a few hours, I am at work now.
    > Carlos
    >
    > "Tony Sperling" wrote:
    >
    > > Ah, I admit that I forgot you mentioned the elevated command, but the

    greyed
    > > text is strange all the same - did you create the actual *.bat from an
    > > elevated command window? It has got EDIT has it not?
    > >
    > >
    > > Tony. . .
    > >
    > >
    > > "Carlos" <> wrote in message
    > > news:...
    > > > Tony,
    > > > I wish it were that simple.
    > > > If you right-click on the .bat file and go to the "Compatibility" tab,

    the
    > > > square box for checking (and enabling) the batch with Administrator
    > > > privileges is greyed out.
    > > > :(
    > > > Keep thinking, I know something will come out. Maybe after a gooood
    > > > Glenfoyle, uh?
    > > > :)
    > > > Carlos
    > > >
    > > > "Tony Sperling" wrote:
    > > >
    > > > > The easiest solution probably would be to put a *.BAT file (or

    > > something?)
    > > > > in your:
    > > > >
    > > > > C:\Documents and Settings\[USERNAME]\Start

    Menu\Programs\Startup
    > > > >
    > > > > folder, and have that execute the command? At least as long as

    you're
    > > not
    > > > > going to use hundreds of commands like that.
    > > > >
    > > > > You'd probably see the faint shape of a black window flashing when

    you
    > > log
    > > > > in, but I think there's a 'silence' option switch to disable that.

    (Not
    > > > > sure).
    > > > >
    > > > >
    > > > > Tony. . .
    > > > >
    > > > >
    > > > >
    > > > >

    > >
    > >
    > >
    Tony Sperling, Jul 21, 2008
    #6
  7. Carlos

    Carlos Guest

    Tony,
    It didn't work.
    I started an elevated command prompt, did the "copy con" thing: no dice,
    started notepad from there: no dice.
    I still cannot enable that freaking *.bat to Run as Admin.
    I have prepared myself a "Negroni", 1/3 of gin + 1/3 of Campari + 1/3 of Red
    Martini
    Life looks different now!
    :-S
    hic, hic, hic!
    Carlos

    "Tony Sperling" wrote:

    > I really have no idea if this is the way to do it, but if you use N-Pad you
    > should probably execute it from inside that command window - copy con is
    > probably the more natural interface (yes, I remember, but I am not sure I
    > remember how to drive it?) On the other hand, I am sure you must have
    > EDLIN - Ha, ha, ha!!!
    >
    > Being the lazy type, I would probably do DIR > SOME.BAT and replace the
    > contents with that of your command in notepad later???
    >
    > The Glenfoyle sadly, has evaporated - I shall have to make do with the far
    > more expensive Caol Ila (an Islay malt - pronounced as "Cull Eela").
    >
    >
    > Tony. . .
    >
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    > > Tony,
    > > I did not create the *.bat from an elevated command prompt window.
    > > I had not thought about that!
    > > There's no EDIT command in Vista x64 cmd prompt window.
    > > I will try with Notepad or the old "copy con" command (remember it?)
    > > My results will have to wait a few hours, I am at work now.
    > > Carlos
    > >
    > > "Tony Sperling" wrote:
    > >
    > > > Ah, I admit that I forgot you mentioned the elevated command, but the

    > greyed
    > > > text is strange all the same - did you create the actual *.bat from an
    > > > elevated command window? It has got EDIT has it not?
    > > >
    > > >
    > > > Tony. . .
    > > >
    > > >
    > > > "Carlos" <> wrote in message
    > > > news:...
    > > > > Tony,
    > > > > I wish it were that simple.
    > > > > If you right-click on the .bat file and go to the "Compatibility" tab,

    > the
    > > > > square box for checking (and enabling) the batch with Administrator
    > > > > privileges is greyed out.
    > > > > :(
    > > > > Keep thinking, I know something will come out. Maybe after a gooood
    > > > > Glenfoyle, uh?
    > > > > :)
    > > > > Carlos
    > > > >
    > > > > "Tony Sperling" wrote:
    > > > >
    > > > > > The easiest solution probably would be to put a *.BAT file (or
    > > > something?)
    > > > > > in your:
    > > > > >
    > > > > > C:\Documents and Settings\[USERNAME]\Start

    > Menu\Programs\Startup
    > > > > >
    > > > > > folder, and have that execute the command? At least as long as

    > you're
    > > > not
    > > > > > going to use hundreds of commands like that.
    > > > > >
    > > > > > You'd probably see the faint shape of a black window flashing when

    > you
    > > > log
    > > > > > in, but I think there's a 'silence' option switch to disable that.

    > (Not
    > > > > > sure).
    > > > > >
    > > > > >
    > > > > > Tony. . .
    > > > > >
    > > > > >
    > > > > >
    > > > > >
    > > >
    > > >
    > > >

    >
    >
    >
    Carlos, Jul 21, 2008
    #7
  8. Hmm - too bad, check this one out though:


    http://blogs.msdn.com/tims/archive/...levated-command-prompt-in-six-keystrokes.aspx

    and do not jump the comments.

    Probably not more than you are aware of, but a few disparate things
    collected in one place, I find.

    There has to be an answer - in the mean-time, "au santé", my friend!


    Tony. . .



    "Carlos" <> wrote in message
    news:...
    > Tony,
    > It didn't work.
    > I started an elevated command prompt, did the "copy con" thing: no dice,
    > started notepad from there: no dice.
    > I still cannot enable that freaking *.bat to Run as Admin.
    > I have prepared myself a "Negroni", 1/3 of gin + 1/3 of Campari + 1/3 of

    Red
    > Martini
    > Life looks different now!
    > :-S
    > hic, hic, hic!
    > Carlos
    >
    > "Tony Sperling" wrote:
    >
    > > I really have no idea if this is the way to do it, but if you use N-Pad

    you
    > > should probably execute it from inside that command window - copy con is
    > > probably the more natural interface (yes, I remember, but I am not sure

    I
    > > remember how to drive it?) On the other hand, I am sure you must have
    > > EDLIN - Ha, ha, ha!!!
    > >
    > > Being the lazy type, I would probably do DIR > SOME.BAT and replace the
    > > contents with that of your command in notepad later???
    > >
    > > The Glenfoyle sadly, has evaporated - I shall have to make do with the

    far
    > > more expensive Caol Ila (an Islay malt - pronounced as "Cull Eela").
    > >
    > >
    > > Tony. . .
    > >
    > >
    > >
    > > "Carlos" <> wrote in message
    > > news:...
    > > > Tony,
    > > > I did not create the *.bat from an elevated command prompt window.
    > > > I had not thought about that!
    > > > There's no EDIT command in Vista x64 cmd prompt window.
    > > > I will try with Notepad or the old "copy con" command (remember it?)
    > > > My results will have to wait a few hours, I am at work now.
    > > > Carlos
    > > >
    > > > "Tony Sperling" wrote:
    > > >
    > > > > Ah, I admit that I forgot you mentioned the elevated command, but

    the
    > > greyed
    > > > > text is strange all the same - did you create the actual *.bat from

    an
    > > > > elevated command window? It has got EDIT has it not?
    > > > >
    > > > >
    > > > > Tony. . .
    > > > >
    > > > >
    > > > > "Carlos" <> wrote in message
    > > > > news:...
    > > > > > Tony,
    > > > > > I wish it were that simple.
    > > > > > If you right-click on the .bat file and go to the "Compatibility"

    tab,
    > > the
    > > > > > square box for checking (and enabling) the batch with

    Administrator
    > > > > > privileges is greyed out.
    > > > > > :(
    > > > > > Keep thinking, I know something will come out. Maybe after a

    gooood
    > > > > > Glenfoyle, uh?
    > > > > > :)
    > > > > > Carlos
    > > > > >
    > > > > > "Tony Sperling" wrote:
    > > > > >
    > > > > > > The easiest solution probably would be to put a *.BAT file (or
    > > > > something?)
    > > > > > > in your:
    > > > > > >
    > > > > > > C:\Documents and Settings\[USERNAME]\Start

    > > Menu\Programs\Startup
    > > > > > >
    > > > > > > folder, and have that execute the command? At least as long as

    > > you're
    > > > > not
    > > > > > > going to use hundreds of commands like that.
    > > > > > >
    > > > > > > You'd probably see the faint shape of a black window flashing

    when
    > > you
    > > > > log
    > > > > > > in, but I think there's a 'silence' option switch to disable

    that.
    > > (Not
    > > > > > > sure).
    > > > > > >
    > > > > > >
    > > > > > > Tony. . .
    > > > > > >
    > > > > > >
    > > > > > >
    > > > > > >
    > > > >
    > > > >
    > > > >

    > >
    > >
    > >
    Tony Sperling, Jul 22, 2008
    #8
  9. Tony Sperling, Jul 22, 2008
    #9
  10. Carlos

    Carlos Guest

    Carlos, Jul 22, 2008
    #10
  11. Carlos

    Carlos Guest

    Tony,
    Thanks for your help, this link is very good.
    I finally gave up on putting it in the startup group as Windows Defender
    relentlessly blocks it.
    It works, but I have to allow Defender to execute which is more or less the
    same that executing my "old" batch file manually.
    Carlos

    "Tony Sperling" wrote:

    > Ah - not to mention this one:
    >
    >
    > http://www.wintellect.com/cs/blogs/...e-a-process-at-the-command-line-in-vista.aspx
    >
    >
    > Would that meet your needs?
    >
    >
    > Tony. . .
    >
    >
    >
    >
    Carlos, Jul 23, 2008
    #11
  12. O.K. - that's interesting, and since there is no real UI to Defender, there
    is not much anyone can do about that, except perhaps delay it's execution?
    I'm thinking, since you are running Avast too, have you noticed that it has
    an option to delay running the AV (and I am assuming they are refering to
    the 'Service' parts of the system) as the last thing being activated at
    log-in? They are not using magic doing this, so there has to be a mechanism
    for that.

    Also, what happens if you use *.CMD as the filename extension instead of
    *.BAT, I don't really believe there should be any difference, but they must
    have had a somewhat good reason to introduce an alternative filename so, who
    knows?

    Have you checked all imaginable batch file execution switches? I am getting
    curious, and if I had the time I would investigate this myself, but time is
    a substance with a property for evaporation just like many other precious
    things in life.

    Did you put the batch file in the root directory, or a directory that is on
    the 'PATH'?

    Just freewheeling a bit for you, Carlos - don't take it too seriously!


    Tony. . .



    "Carlos" <> wrote in message
    news:D...
    > Tony,
    > Thanks for your help, this link is very good.
    > I finally gave up on putting it in the startup group as Windows Defender
    > relentlessly blocks it.
    > It works, but I have to allow Defender to execute which is more or less

    the
    > same that executing my "old" batch file manually.
    > Carlos
    >
    > "Tony Sperling" wrote:
    >
    > > Ah - not to mention this one:
    > >
    > >
    > >

    http://www.wintellect.com/cs/blogs/...e-a-process-at-the-command-line-in-vista.aspx
    > >
    > >
    > > Would that meet your needs?
    > >
    > >
    > > Tony. . .
    > >
    > >
    > >
    > >
    Tony Sperling, Jul 23, 2008
    #12
  13. Carlos

    Carlos Guest

    Tony,
    The problem is that Windows Defender doesn't "like" the Elevate.exe command.
    The options for enabling it are greyed out, even if I start Defender as Admin.
    It has no issues with the bat or shortcut, it even added the small shield
    drawing in the shortcut icon recongnizing that elevate.exe was to be run as
    admin.
    :)
    Carlos

    "Tony Sperling" wrote:

    > O.K. - that's interesting, and since there is no real UI to Defender, there
    > is not much anyone can do about that, except perhaps delay it's execution?
    > I'm thinking, since you are running Avast too, have you noticed that it has
    > an option to delay running the AV (and I am assuming they are refering to
    > the 'Service' parts of the system) as the last thing being activated at
    > log-in? They are not using magic doing this, so there has to be a mechanism
    > for that.
    >
    > Also, what happens if you use *.CMD as the filename extension instead of
    > *.BAT, I don't really believe there should be any difference, but they must
    > have had a somewhat good reason to introduce an alternative filename so, who
    > knows?
    >
    > Have you checked all imaginable batch file execution switches? I am getting
    > curious, and if I had the time I would investigate this myself, but time is
    > a substance with a property for evaporation just like many other precious
    > things in life.
    >
    > Did you put the batch file in the root directory, or a directory that is on
    > the 'PATH'?
    >
    > Just freewheeling a bit for you, Carlos - don't take it too seriously!
    >
    >
    > Tony. . .
    >
    >
    >
    > "Carlos" <> wrote in message
    > news:D...
    > > Tony,
    > > Thanks for your help, this link is very good.
    > > I finally gave up on putting it in the startup group as Windows Defender
    > > relentlessly blocks it.
    > > It works, but I have to allow Defender to execute which is more or less

    > the
    > > same that executing my "old" batch file manually.
    > > Carlos
    > >
    > > "Tony Sperling" wrote:
    > >
    > > > Ah - not to mention this one:
    > > >
    > > >
    > > >

    > http://www.wintellect.com/cs/blogs/...e-a-process-at-the-command-line-in-vista.aspx
    > > >
    > > >
    > > > Would that meet your needs?
    > > >
    > > >
    > > > Tony. . .
    > > >
    > > >
    > > >
    > > >

    >
    >
    >
    Carlos, Jul 23, 2008
    #13
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. wwp
    Replies:
    2
    Views:
    653
    Boomer
    Aug 19, 2003
  2. wwp
    Replies:
    4
    Views:
    9,675
    boikin
    Sep 4, 2006
  3. Sharon

    Solution to Windows Update Problem

    Sharon, Dec 13, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    397
    Sharon
    Dec 13, 2003
  4. Pete Holland Jr.

    Following Up: Unusual Solution To Vid Capture Problem

    Pete Holland Jr., Dec 31, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    546
    Pete Holland Jr.
    Dec 31, 2003
  5. geopelia

    Hotmail inbox problem - solution?

    geopelia, Feb 17, 2004, in forum: Computer Support
    Replies:
    5
    Views:
    6,862
    shchitrali
    Jul 17, 2012
Loading...

Share This Page