A little help from my friends!

Discussion in 'Windows 64bit' started by Carlos, Jun 26, 2008.

  1. Carlos

    Carlos Guest

    This is a sharing issue but I hope my buddies will be able to help me.
    I have 3 hard disks in my PC.
    One is standalone SATA (I:) and there's where I keep my documents, favorites
    and e-mail.
    The two others are raid-0 SATA, having Vista in Primary Partition C: and 4
    other partitions for different tasks. (D:, E:, F: G:)
    So far I have been sharing in my home network only one folder in the
    standalone disk (I:).
    I can access to that folder from the other PCs by having added the user
    "Guest" ("Invitado" in Spanish) in the sharing options.
    When working locally on that folder I have full R/W rights and when
    accessing remotely I can only read.
    So far so good.
    Now here's the issue.
    Whenever I share a folder in any of the other 4 partitions (D:, E:, F:, G:)
    I immediately lose writing rights on that folder.
    I, locally, can only read but not write or delete or rename.
    Even un-sharing is denied.
    And the only possible recovery of rights is by going to Disk Management,
    delete the partition, recreate it again and not sharing it!
    Any ideas?
    Carlos
    Carlos, Jun 26, 2008
    #1
    1. Advertising

  2. Carlos

    Carlos Guest

    Well, I could finally sort it out, thanks to Google and MVP Jimmy Brush
    I want to share what I did so that anybody having this issue will solve it
    quickly (quoting from what I found in Google)

    "- Click start
    - Type explorer
    - Right-click windows explorer under programs when it comes up, then click
    run as administrator

    So far, so good ... Now, on Vista formatted NTFS drives, it doesn't give
    permission to edit permissions to Administrators ... OK, I have been fairly
    supportive of the new security things so far... but THIS IS REDICULOUS! lol.

    So, we have to get around that ...

    - Browse to Computer
    - Right-click on the drive in question
    - Click Properties
    - Click Security Tab
    - Click Edit
    - Click Advanced
    - Click Owner
    - Click Administrators
    - Click OK
    - Click OK
    - Click OK

    All right .. we now have ownership of the drive, which overrides NTFS
    settings and allows us to change permissions (Sheesh)...

    - Right-click the drive
    - Click Properties
    - Click Security tab
    - Click Edit

    Allright ... from this screen you should now be able to edit the NTFS
    security on your drive

    - Click Add
    - Type your username and press enter
    - Select full control
    - Click OK

    You will get a warning about changing security settings on a drive. Click
    Yes to continue. It will then propagate down the filesystem to every folder
    file that you have access to and that doesn't have overridden settings."

    Carlos
    "Carlos" wrote:

    > This is a sharing issue but I hope my buddies will be able to help me.
    > I have 3 hard disks in my PC.
    > One is standalone SATA (I:) and there's where I keep my documents, favorites
    > and e-mail.
    > The two others are raid-0 SATA, having Vista in Primary Partition C: and 4
    > other partitions for different tasks. (D:, E:, F: G:)
    > So far I have been sharing in my home network only one folder in the
    > standalone disk (I:).
    > I can access to that folder from the other PCs by having added the user
    > "Guest" ("Invitado" in Spanish) in the sharing options.
    > When working locally on that folder I have full R/W rights and when
    > accessing remotely I can only read.
    > So far so good.
    > Now here's the issue.
    > Whenever I share a folder in any of the other 4 partitions (D:, E:, F:, G:)
    > I immediately lose writing rights on that folder.
    > I, locally, can only read but not write or delete or rename.
    > Even un-sharing is denied.
    > And the only possible recovery of rights is by going to Disk Management,
    > delete the partition, recreate it again and not sharing it!
    > Any ideas?
    > Carlos
    Carlos, Jun 26, 2008
    #2
    1. Advertising

  3. Wow!

    Reading this, had me break into a sweat, more or less. Amazing bit of
    detective-work, there. Let's hope doing it once takes care of all the
    instances when it would present an obstacle.


    Tony. . .


    "Carlos" <> wrote in message
    news:...
    > Well, I could finally sort it out, thanks to Google and MVP Jimmy Brush
    > I want to share what I did so that anybody having this issue will solve it
    > quickly (quoting from what I found in Google)
    >
    > "- Click start
    > - Type explorer
    > - Right-click windows explorer under programs when it comes up, then click
    > run as administrator
    >
    > So far, so good ... Now, on Vista formatted NTFS drives, it doesn't give
    > permission to edit permissions to Administrators ... OK, I have been

    fairly
    > supportive of the new security things so far... but THIS IS REDICULOUS!

    lol.
    >
    > So, we have to get around that ...
    >
    > - Browse to Computer
    > - Right-click on the drive in question
    > - Click Properties
    > - Click Security Tab
    > - Click Edit
    > - Click Advanced
    > - Click Owner
    > - Click Administrators
    > - Click OK
    > - Click OK
    > - Click OK
    >
    > All right .. we now have ownership of the drive, which overrides NTFS
    > settings and allows us to change permissions (Sheesh)...
    >
    > - Right-click the drive
    > - Click Properties
    > - Click Security tab
    > - Click Edit
    >
    > Allright ... from this screen you should now be able to edit the NTFS
    > security on your drive
    >
    > - Click Add
    > - Type your username and press enter
    > - Select full control
    > - Click OK
    >
    > You will get a warning about changing security settings on a drive. Click
    > Yes to continue. It will then propagate down the filesystem to every

    folder
    > file that you have access to and that doesn't have overridden settings."
    >
    > Carlos
    > "Carlos" wrote:
    >
    > > This is a sharing issue but I hope my buddies will be able to help me.
    > > I have 3 hard disks in my PC.
    > > One is standalone SATA (I:) and there's where I keep my documents,

    favorites
    > > and e-mail.
    > > The two others are raid-0 SATA, having Vista in Primary Partition C: and

    4
    > > other partitions for different tasks. (D:, E:, F: G:)
    > > So far I have been sharing in my home network only one folder in the
    > > standalone disk (I:).
    > > I can access to that folder from the other PCs by having added the user
    > > "Guest" ("Invitado" in Spanish) in the sharing options.
    > > When working locally on that folder I have full R/W rights and when
    > > accessing remotely I can only read.
    > > So far so good.
    > > Now here's the issue.
    > > Whenever I share a folder in any of the other 4 partitions (D:, E:, F:,

    G:)
    > > I immediately lose writing rights on that folder.
    > > I, locally, can only read but not write or delete or rename.
    > > Even un-sharing is denied.
    > > And the only possible recovery of rights is by going to Disk Management,
    > > delete the partition, recreate it again and not sharing it!
    > > Any ideas?
    > > Carlos
    Tony Sperling, Jun 27, 2008
    #3
  4. Hello,
    Well there are some commandline tool options to do this as well.
    See this article's steps at bottom of the article:
    929833 Some Windows Vista functions may not work, or Windows Vista may stop
    responding
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;929833

    This is an file example from the article:

    1. At an elevated command prompt, type the following command, and then
    press ENTER:
    takeown /f Path_And_File_Name
    For example, type takeown /f E:\windows\system32\jscript.dll .
    2. Type the following command, and then press ENTER to grant
    administrators full access to the file:
    icacls Path_And_File_Name /GRANT ADMINISTRATORS:F
    For example, type icacls E:\windows\system32\jscript.dll /grant
    administrators:F .
    3. Type the following command to replace the file with a known good copy
    of the file:
    Copy Path_And_File_Name_Of_Source_File Path_And_File_Name_Of_Destination
    For example, type copy E:\temp\jscript.dll E:\windows\system32\jscript.dll
    ..


    If you like working from the commandline rather than the UI.

    Thanks,
    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    --------------------
    | >From: "Tony Sperling" <>
    | >References: <>
    <>
    | >Subject: Re: A little help from my friends!
    | >Date: Fri, 27 Jun 2008 01:17:30 +0200
    | >Lines: 92
    | >X-Priority: 3
    | >X-MSMail-Priority: Normal
    | >X-Newsreader: Microsoft Outlook Express 6.00.2800.1914
    | >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1914
    | >X-Antivirus: avast! (VPS 080626-1, 26-06-2008), Outbound message
    | >X-Antivirus-Status: Clean
    | >Message-ID: <e1JX4K#>
    | >Newsgroups: microsoft.public.windows.64bit.general
    | >NNTP-Posting-Host: 1385155113.dhcp.dbnet.dk 82.143.202.41
    | >Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP03.phx.gbl
    | >Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.64bit.general:18531
    | >X-Tomcat-NG: microsoft.public.windows.64bit.general
    | >
    | >Wow!
    | >
    | >Reading this, had me break into a sweat, more or less. Amazing bit of
    | >detective-work, there. Let's hope doing it once takes care of all the
    | >instances when it would present an obstacle.
    | >
    | >
    | >Tony. . .
    | >
    | >
    | >"Carlos" <> wrote in message
    | >news:...
    | >> Well, I could finally sort it out, thanks to Google and MVP Jimmy Brush
    | >> I want to share what I did so that anybody having this issue will
    solve it
    | >> quickly (quoting from what I found in Google)
    | >>
    | >> "- Click start
    | >> - Type explorer
    | >> - Right-click windows explorer under programs when it comes up, then
    click
    | >> run as administrator
    | >>
    | >> So far, so good ... Now, on Vista formatted NTFS drives, it doesn't
    give
    | >> permission to edit permissions to Administrators ... OK, I have been
    | >fairly
    | >> supportive of the new security things so far... but THIS IS REDICULOUS!
    | >lol.
    | >>
    | >> So, we have to get around that ...
    | >>
    | >> - Browse to Computer
    | >> - Right-click on the drive in question
    | >> - Click Properties
    | >> - Click Security Tab
    | >> - Click Edit
    | >> - Click Advanced
    | >> - Click Owner
    | >> - Click Administrators
    | >> - Click OK
    | >> - Click OK
    | >> - Click OK
    | >>
    | >> All right .. we now have ownership of the drive, which overrides NTFS
    | >> settings and allows us to change permissions (Sheesh)...
    | >>
    | >> - Right-click the drive
    | >> - Click Properties
    | >> - Click Security tab
    | >> - Click Edit
    | >>
    | >> Allright ... from this screen you should now be able to edit the NTFS
    | >> security on your drive
    | >>
    | >> - Click Add
    | >> - Type your username and press enter
    | >> - Select full control
    | >> - Click OK
    | >>
    | >> You will get a warning about changing security settings on a drive.
    Click
    | >> Yes to continue. It will then propagate down the filesystem to every
    | >folder
    | >> file that you have access to and that doesn't have overridden
    settings."
    | >>
    | >> Carlos
    | >> "Carlos" wrote:
    | >>
    | >> > This is a sharing issue but I hope my buddies will be able to help
    me.
    | >> > I have 3 hard disks in my PC.
    | >> > One is standalone SATA (I:) and there's where I keep my documents,
    | >favorites
    | >> > and e-mail.
    | >> > The two others are raid-0 SATA, having Vista in Primary Partition C:
    and
    | >4
    | >> > other partitions for different tasks. (D:, E:, F: G:)
    | >> > So far I have been sharing in my home network only one folder in the
    | >> > standalone disk (I:).
    | >> > I can access to that folder from the other PCs by having added the
    user
    | >> > "Guest" ("Invitado" in Spanish) in the sharing options.
    | >> > When working locally on that folder I have full R/W rights and when
    | >> > accessing remotely I can only read.
    | >> > So far so good.
    | >> > Now here's the issue.
    | >> > Whenever I share a folder in any of the other 4 partitions (D:, E:,
    F:,
    | >G:)
    | >> > I immediately lose writing rights on that folder.
    | >> > I, locally, can only read but not write or delete or rename.
    | >> > Even un-sharing is denied.
    | >> > And the only possible recovery of rights is by going to Disk
    Management,
    | >> > delete the partition, recreate it again and not sharing it!
    | >> > Any ideas?
    | >> > Carlos
    | >
    | >
    | >
    Darrell Gorter[MSFT], Jun 27, 2008
    #4
  5. Carlos

    Carlos Guest

    Darrell,
    Thanks for your support. I still do like the command line thing as an old
    DOS user.
    So far my problems seem to have gone with Jimmy's tips.
    :)
    Carlos

    ""Darrell Gorter[MSFT]"" wrote:

    > Hello,
    > Well there are some commandline tool options to do this as well.
    > See this article's steps at bottom of the article:
    > 929833 Some Windows Vista functions may not work, or Windows Vista may stop
    > responding
    > http://support.microsoft.com/default.aspx?scid=kb;EN-US;929833
    >
    > This is an file example from the article:
    >
    > 1. At an elevated command prompt, type the following command, and then
    > press ENTER:
    > takeown /f Path_And_File_Name
    > For example, type takeown /f E:\windows\system32\jscript.dll .
    > 2. Type the following command, and then press ENTER to grant
    > administrators full access to the file:
    > icacls Path_And_File_Name /GRANT ADMINISTRATORS:F
    > For example, type icacls E:\windows\system32\jscript.dll /grant
    > administrators:F .
    > 3. Type the following command to replace the file with a known good copy
    > of the file:
    > Copy Path_And_File_Name_Of_Source_File Path_And_File_Name_Of_Destination
    > For example, type copy E:\temp\jscript.dll E:\windows\system32\jscript.dll
    > .
    >
    >
    > If you like working from the commandline rather than the UI.
    >
    > Thanks,
    > Darrell Gorter[MSFT]
    >
    > This posting is provided "AS IS" with no warranties, and confers no rights
    > --------------------
    > | >From: "Tony Sperling" <>
    > | >References: <>
    > <>
    > | >Subject: Re: A little help from my friends!
    > | >Date: Fri, 27 Jun 2008 01:17:30 +0200
    > | >Lines: 92
    > | >X-Priority: 3
    > | >X-MSMail-Priority: Normal
    > | >X-Newsreader: Microsoft Outlook Express 6.00.2800.1914
    > | >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1914
    > | >X-Antivirus: avast! (VPS 080626-1, 26-06-2008), Outbound message
    > | >X-Antivirus-Status: Clean
    > | >Message-ID: <e1JX4K#>
    > | >Newsgroups: microsoft.public.windows.64bit.general
    > | >NNTP-Posting-Host: 1385155113.dhcp.dbnet.dk 82.143.202.41
    > | >Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP03.phx.gbl
    > | >Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.64bit.general:18531
    > | >X-Tomcat-NG: microsoft.public.windows.64bit.general
    > | >
    > | >Wow!
    > | >
    > | >Reading this, had me break into a sweat, more or less. Amazing bit of
    > | >detective-work, there. Let's hope doing it once takes care of all the
    > | >instances when it would present an obstacle.
    > | >
    > | >
    > | >Tony. . .
    > | >
    > | >
    > | >"Carlos" <> wrote in message
    > | >news:...
    > | >> Well, I could finally sort it out, thanks to Google and MVP Jimmy Brush
    > | >> I want to share what I did so that anybody having this issue will
    > solve it
    > | >> quickly (quoting from what I found in Google)
    > | >>
    > | >> "- Click start
    > | >> - Type explorer
    > | >> - Right-click windows explorer under programs when it comes up, then
    > click
    > | >> run as administrator
    > | >>
    > | >> So far, so good ... Now, on Vista formatted NTFS drives, it doesn't
    > give
    > | >> permission to edit permissions to Administrators ... OK, I have been
    > | >fairly
    > | >> supportive of the new security things so far... but THIS IS REDICULOUS!
    > | >lol.
    > | >>
    > | >> So, we have to get around that ...
    > | >>
    > | >> - Browse to Computer
    > | >> - Right-click on the drive in question
    > | >> - Click Properties
    > | >> - Click Security Tab
    > | >> - Click Edit
    > | >> - Click Advanced
    > | >> - Click Owner
    > | >> - Click Administrators
    > | >> - Click OK
    > | >> - Click OK
    > | >> - Click OK
    > | >>
    > | >> All right .. we now have ownership of the drive, which overrides NTFS
    > | >> settings and allows us to change permissions (Sheesh)...
    > | >>
    > | >> - Right-click the drive
    > | >> - Click Properties
    > | >> - Click Security tab
    > | >> - Click Edit
    > | >>
    > | >> Allright ... from this screen you should now be able to edit the NTFS
    > | >> security on your drive
    > | >>
    > | >> - Click Add
    > | >> - Type your username and press enter
    > | >> - Select full control
    > | >> - Click OK
    > | >>
    > | >> You will get a warning about changing security settings on a drive.
    > Click
    > | >> Yes to continue. It will then propagate down the filesystem to every
    > | >folder
    > | >> file that you have access to and that doesn't have overridden
    > settings."
    > | >>
    > | >> Carlos
    > | >> "Carlos" wrote:
    > | >>
    > | >> > This is a sharing issue but I hope my buddies will be able to help
    > me.
    > | >> > I have 3 hard disks in my PC.
    > | >> > One is standalone SATA (I:) and there's where I keep my documents,
    > | >favorites
    > | >> > and e-mail.
    > | >> > The two others are raid-0 SATA, having Vista in Primary Partition C:
    > and
    > | >4
    > | >> > other partitions for different tasks. (D:, E:, F: G:)
    > | >> > So far I have been sharing in my home network only one folder in the
    > | >> > standalone disk (I:).
    > | >> > I can access to that folder from the other PCs by having added the
    > user
    > | >> > "Guest" ("Invitado" in Spanish) in the sharing options.
    > | >> > When working locally on that folder I have full R/W rights and when
    > | >> > accessing remotely I can only read.
    > | >> > So far so good.
    > | >> > Now here's the issue.
    > | >> > Whenever I share a folder in any of the other 4 partitions (D:, E:,
    > F:,
    > | >G:)
    > | >> > I immediately lose writing rights on that folder.
    > | >> > I, locally, can only read but not write or delete or rename.
    > | >> > Even un-sharing is denied.
    > | >> > And the only possible recovery of rights is by going to Disk
    > Management,
    > | >> > delete the partition, recreate it again and not sharing it!
    > | >> > Any ideas?
    > | >> > Carlos
    > | >
    > | >
    > | >
    >
    >
    Carlos, Jun 27, 2008
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Saine

    Friends, really i need your help!

    Saine, Jul 2, 2003, in forum: Microsoft Certification
    Replies:
    1
    Views:
    1,499
    Dandy WEYN
    Jul 2, 2003
  2. NTL NEWS

    Help wanted for a friends daughter please????

    NTL NEWS, Feb 20, 2004, in forum: Computer Support
    Replies:
    3
    Views:
    599
    Dan Shea
    Feb 22, 2004
  3. Puzzled

    little red X in little white box

    Puzzled, Dec 12, 2004, in forum: Computer Support
    Replies:
    8
    Views:
    8,567
    Blinky the Shark
    Dec 13, 2004
  4. =?ISO-8859-1?Q?R=F4g=EAr?=

    Friends don't let friends drink and fly through space

    =?ISO-8859-1?Q?R=F4g=EAr?=, Jul 27, 2007, in forum: Computer Support
    Replies:
    6
    Views:
    782
    =?utf-8?B?4paAU2xhY2s=?=
    Jul 29, 2007
  5. Lawrence D'Oliveiro

    Friends Don’t Let Friends Do IE6

    Lawrence D'Oliveiro, Feb 5, 2010, in forum: NZ Computing
    Replies:
    33
    Views:
    1,061
    Lawrence D'Oliveiro
    Feb 11, 2010
Loading...

Share This Page