98 Workgroups and XP network neigborhood

Discussion in 'Computer Support' started by bagman, Feb 5, 2004.

  1. bagman

    bagman Guest

    I have been having the same problem that many dozens of people seem to be
    having with windows XP in an mixed win98 xp workgroup (no server). Nobody
    can view any computers in NETWORK NEIGBORHOOD!

    They all have fixed ips, and the same workgroup name, and file and print
    sharing installed, and a folder shared. There is a adsl router. TCP/IP is
    the only protocol and netbios over tcp has been enabled on the XP machine.
    Every one except which ever computer is the master browser gets the message
    like there is no master browser. (unable to access). No problems pinging
    every computer from every other one, but name resolution just does not work.
    I have a work around (lmhosts file) but it doesn't fix the problem. I have
    installed netbuei and that only fixes the problem if the XP machines are
    turned on before the 98.
    I have tried "rigging" the master browser election and nbtstat shows one of
    the xp machines is the master browser , but still no network neighbourhood.
    There are no firewalls or unusual applications, just word and excel etc.

    I have read dozens of other messages from people with the same problems on
    the net, but none of the solutions seems to work (except installing netbeui
    and turning xp on first). Has xp broken 98 net view on purpose

    Also in the rare occasion a 98 machine shows on an xp network places - view
    workgroup computers, double clicking on it gets an error saying the computer
    can't be found or you don't have permission to access it, but if I create an
    lmhosts file it works fine.

    Any solutions or explanations?

    thanks.
     
    bagman, Feb 5, 2004
    #1
    1. Advertising

  2. bagman

    Gil Guest

    "bagman" <> wrote in message
    news:...
    > I have been having the same problem that many dozens of people seem to be
    > having with windows XP in an mixed win98 xp workgroup (no server). Nobody
    > can view any computers in NETWORK NEIGBORHOOD!
    >
    > They all have fixed ips, and the same workgroup name, and file and print
    > sharing installed, and a folder shared. There is a adsl router. TCP/IP is
    > the only protocol and netbios over tcp has been enabled on the XP machine.
    > Every one except which ever computer is the master browser gets the

    message
    > like there is no master browser. (unable to access). No problems pinging
    > every computer from every other one, but name resolution just does not

    work.
    > I have a work around (lmhosts file) but it doesn't fix the problem. I have
    > installed netbuei and that only fixes the problem if the XP machines are
    > turned on before the 98.
    > I have tried "rigging" the master browser election and nbtstat shows one

    of
    > the xp machines is the master browser , but still no network

    neighbourhood.
    > There are no firewalls or unusual applications, just word and excel etc.
    >
    > I have read dozens of other messages from people with the same problems on
    > the net, but none of the solutions seems to work (except installing

    netbeui
    > and turning xp on first). Has xp broken 98 net view on purpose
    >
    > Also in the rare occasion a 98 machine shows on an xp network places -

    view
    > workgroup computers, double clicking on it gets an error saying the

    computer
    > can't be found or you don't have permission to access it, but if I create

    an
    > lmhosts file it works fine.
    >
    > Any solutions or explanations?
    >
    > thanks.
    >
    > You might give this a try.


    To access the Internet using a Connection Sharing computer, ensure that
    the TCP/IP settings for your network adapter are set correctly by
    carrying out the following steps.

    1. In the Control Panel, double-click the Network icon.
    2. In the list of network components, click TCP/IP associated with your
    network adapter, and then click Properties.
    3. Select the "Obtain an IP address automatically" check box.
    4. Click the WINS Configuration tab, and then select the check box
    next to "Use DHCP for WINS Resolution".
    5. Click the Gateway tab, and then remove any installed gateways if any
    are listed.
    6. Click the DNS Configuration tab, and then select the check box next
    to "Disable DNS".
    7. Click OK to accept the new TCP/IP settings
    8. Click OK to update your new network configuration.

    NOTE: These changes require restarting your computer for changes to take
    effect. When you are finished, the computer will restart.
     
    Gil, Feb 5, 2004
    #2
    1. Advertising

  3. bagman

    Gil Guest

    "bagman" <> wrote in message
    news:...
    > I have been having the same problem that many dozens of people seem to be
    > having with windows XP in an mixed win98 xp workgroup (no server). Nobody
    > can view any computers in NETWORK NEIGBORHOOD!


    These settings are for use with Linksys hub but parts of it still apply to
    setup when using a router.
    When i changed from dialup to cable and switched to a router this
    worked ok for me.
    I am also using XP on the main computer and 98se on the others.
    You probably will only need the WORKGROUP section.Good luck. Gil

    Load drivers

    Insert Linksys program disk number one into floppy disk drive and right
    click
    on my computer.
    Go to properties and click on device manager then double click on. pci
    ethernet controller.
    Click on reinstall driver then click next. click next again
    Uncheck cd rom drive and click next.
    On update device driver wizard click next.
    Program will ask for Windows 98se CD.
    When asked if you want to keep the existing file click yes.
    When asked if you want to restart your computer, remove all disks and click
    yes.

    After reboot, right click on netwoek neighborhood and go to properties.
    In primary network logon dropdown box set to windows logon.
    Click on file and print sharing and put check mark in BOTH boxes and
    click OK.
    When asked to insert Windows 98se disk into cd rom drive, insert disk and
    click ok.
    When finished, Remove 2nd edition disk and reboot

    Go to start-settings-control panel andclick internet options.
    click connections tab and check never dial a connection. Apply OK.
    Right click on network neighborhood and go to properties and
    click on identification tab. In computer name type in a name that is
    different from other computers in the network.
    In workgroup type in a workgroup name that will be the same on all computers
    in the network. The workgroup name will be case sensitive so be sure that if
    you use all upper case on the server that all other computers in the network
    will be in upper case also.
    In computer description type in a user name. This is optional. You can leave
    it as unknown user if you wish.

    Go to control panel and click on add/remove programs.
    Click on windows setup tab and double click on internet tools and put a
    check mark in internet connections sharing.
    Somewhere in this area you will be asked to make a client configuration for
    internet connection sharing.

    May be asked to insert 98se disk.
    Then go to control panel and open internet options and click on connections
    tab.
    In the connections window click on sharing tab.
    In connect to internet using, Select the adaptor that goes with your
    internet service provider................GOOD LUCK!!!!!!!
     
    Gil, Feb 5, 2004
    #3
  4. bagman

    Dan Shea Guest

    Hi bagman,

    On Thu, 5 Feb 2004 21:42:33 +0800, "bagman" <>
    wrote:

    >I have been having the same problem that many dozens of people seem to be
    >having with windows XP in an mixed win98 xp workgroup (no server). Nobody
    >can view any computers in NETWORK NEIGBORHOOD!
    >They all have fixed ips, and the same workgroup name, and file and print
    >sharing installed, and a folder shared. There is a adsl router. TCP/IP is
    >the only protocol and netbios over tcp has been enabled on the XP machine.
    >Every one except which ever computer is the master browser gets the message
    >like there is no master browser. (unable to access). No problems pinging
    >every computer from every other one, but name resolution just does not work.
    >I have a work around (lmhosts file) but it doesn't fix the problem.


    It wouldn't. You should have those entries in HOSTS, not LHOSTS.

    I can think of a couple other things, but try that for starters.

    Cheers,
    dan
     
    Dan Shea, Feb 5, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?VmlyZ2lsaWp1cw==?=

    Missing workgroups

    =?Utf-8?B?VmlyZ2lsaWp1cw==?=, Jan 16, 2006, in forum: Wireless Networking
    Replies:
    3
    Views:
    463
    Malke
    Jan 18, 2006
  2. AlanG

    multiple workgroups with win98

    AlanG, Sep 13, 2003, in forum: Computer Support
    Replies:
    4
    Views:
    567
    AlanG
    Sep 14, 2003
  3. =?Utf-8?B?Z2VtaW5p?=

    Workgroups

    =?Utf-8?B?Z2VtaW5p?=, Aug 16, 2006, in forum: Wireless Networking
    Replies:
    2
    Views:
    464
    Jack \(MVP-Networking\).
    Aug 17, 2006
  4. Ernie Werbel

    Who here still uses Windows for Workgroups 3.11?

    Ernie Werbel, Jul 31, 2006, in forum: Computer Information
    Replies:
    7
    Views:
    638
    Travis
    Aug 3, 2006
  5. Mark

    Workgroups???

    Mark, Oct 14, 2007, in forum: Wireless Networking
    Replies:
    2
    Views:
    389
    Jack \(MVP-Networking\).
    Oct 14, 2007
Loading...

Share This Page