871W Cannot Get DHCP Address - Cable Modem

Discussion in 'Cisco' started by tom, Mar 6, 2006.

  1. tom

    tom Guest

    I am having difficulties getting my Cisco 871W SOHO router to get a
    DHCP address over its FE4 interface. If I statically assign the IP
    that my previous SOHO router had received through DHCP, I get Internet
    connectivity with no problem. However, an address is never assigned
    via DHCP.

    Are there any tricks to getting a Cisco device to successfully get a
    DHCP address? I am sure the commands are correct, since I have used
    SDM to set the interfaces.

    Thanks
     
    tom, Mar 6, 2006
    #1
    1. Advertising

  2. tom

    Merv Guest

    interface FastEthernet 0
    description interface connected to cable modem
    ip address dhcp client-id FastEthernet 0



    ! if the above does not work the ISP may require the use of the SOHO
    router MAC address

    interface FastEthernet 0/0

    ! mac-address format is 12 hex digits hhhh.hhh.hhhh

    ! mac-address <place MAC address of old SOHO router>

    mac-address hhhh.hhhh.hhhh
     
    Merv, Mar 6, 2006
    #2
    1. Advertising

  3. tom

    Merv Guest

    BTW

    What is the make and model of the SOHO router

    Who is the ISP?
     
    Merv, Mar 6, 2006
    #3
  4. tom

    tom Guest

    Merv wrote:
    > BTW
    >
    > What is the make and model of the SOHO router
    >
    > Who is the ISP?


    Um, the SOHO router is the Cisco 871W that I referenced earlier. If
    you're talking about the one that I am replacing, it's a DLink or
    somesuch.

    The ISP is Cox. I've talked with them, and they tell me that they
    don't care about anything on my end of the cable modem - no need to
    reset MACs.

    Thanks
     
    tom, Mar 7, 2006
    #4
  5. tom

    Merv Guest

    1. If DHCP problem is still persisting, then I would suggest the
    following steps.


    2. Enable internal logging on router

    conf t
    logging buffer 10000 debug
    no logging console
    exit

    wri mem


    3. Turn on debugging for DHCP requests to ISP

    debug dhcp detail


    4. Power cycle the modem and the 871W, in that order, waiting until the

    cable modem's LEDs indicate that it has reloaded and is
    functioning.


    5. Capture the output of the following command and post here

    show log
     
    Merv, Mar 7, 2006
    #5
  6. tom

    tom Guest

    Merv wrote:
    > 1. If DHCP problem is still persisting, then I would suggest the
    > following steps.
    >
    >
    > 2. Enable internal logging on router
    >
    > conf t
    > logging buffer 10000 debug
    > no logging console
    > exit
    >
    > wri mem
    >
    >
    > 3. Turn on debugging for DHCP requests to ISP
    >
    > debug dhcp detail
    >
    >
    > 4. Power cycle the modem and the 871W, in that order, waiting until the
    >
    > cable modem's LEDs indicate that it has reloaded and is
    > functioning.
    >
    >
    > 5. Capture the output of the following command and post here
    >
    > show log



    Thanks for your help with this - I am at a total loss.. Here is the
    DHCP debug log:

    Log Buffer (10000 bytes):
    9 PCTime: %DOT11-7-AUTH_FAILED: Station 000b.7d0b.0c60 Authentication
    failed
    000202: *Feb 28 17:18:36.863 PCTime: %LINK-3-UPDOWN: Interface
    FastEthernet4, changed state to up
    000203: *Feb 28 17:18:37.863 PCTime: %LINEPROTO-5-UPDOWN: Line protocol
    on Interface FastEthernet4, changed state to up
    000204: *Feb 28 17:18:37.979 PCTime: DHCP: SDiscover attempt # 2 for
    entry:
    000205: *Feb 28 17:18:37.979 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000206: *Feb 28 17:18:37.979 PCTime: Temp sub net mask: 0.0.0.0
    000207: *Feb 28 17:18:37.979 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000208: *Feb 28 17:18:37.979 PCTime: DHCP transaction id: 172F
    000209: *Feb 28 17:18:37.979 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000210: *Feb 28 17:18:37.979 PCTime: Next timer fires after:
    00:00:04
    000211: *Feb 28 17:18:37.979 PCTime: Retry count: 2 Client-ID:
    0015.c653.9062
    000212: *Feb 28 17:18:37.979 PCTime: Client-ID hex dump:
    0015C6539062
    000213: *Feb 28 17:18:37.979 PCTime: Hostname: cisco871
    000214: *Feb 28 17:18:37.979 PCTime: DHCP: SDiscover: sending 277 byte
    length DHCP packet
    --More--  000215: *Feb 28 17:18:37.979
    PCTime: DHCP: SDiscover 277 bytes
    000216: *Feb 28 17:18:37.979 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000217: *Feb 28 17:18:41.979 PCTime: DHCP: SDiscover attempt # 3 for
    entry:
    000218: *Feb 28 17:18:41.979 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000219: *Feb 28 17:18:41.979 PCTime: Temp sub net mask: 0.0.0.0
    000220: *Feb 28 17:18:41.979 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000221: *Feb 28 17:18:41.979 PCTime: DHCP transaction id: 172F
    000222: *Feb 28 17:18:41.979 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000223: *Feb 28 17:18:41.979 PCTime: Next timer fires after:
    00:00:04
    000224: *Feb 28 17:18:41.979 PCTime: Retry count: 3 Client-ID:
    0015.c653.9062
    000225: *Feb 28 17:18:41.979 PCTime: Client-ID hex dump:
    0015C6539062
    000226: *Feb 28 17:18:41.979 PCTime: Hostname: cisco871
    000227: *Feb 28 17:18:41.979 PCTime: DHCP: SDiscover: sending 277 byte
    length DHCP packet
    000228: *Feb 28 17:18:41.979 PCTime: DHCP: SDiscover 277 bytes
    000229: *Feb 28 17:18:41.979 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000230: *Feb 28 17:18:45.979 PCTime: DHCP: QScan: Timed out Selecting
    state%Unknown DHCP problem.. No allocation possible
    --More--  000231: *Feb 28 17:18:55.359
    PCTime: DHCP: Waiting for 5 seconds on interface FastEthernet4
    000232: *Feb 28 17:19:00.359 PCTime: DHCP: Try 2 to acquire address for
    FastEthernet4
    000233: *Feb 28 17:19:00.359 PCTime: DHCP: allocate request
    000234: *Feb 28 17:19:00.359 PCTime: DHCP: zapping entry in DHC_PURGING
    state for Fa4
    000235: *Feb 28 17:19:00.359 PCTime: DHCP: deleting entry 829CB158
    0.0.0.0 from list
    000236: *Feb 28 17:19:00.363 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000237: *Feb 28 17:19:00.363 PCTime: Temp sub net mask: 0.0.0.0
    000238: *Feb 28 17:19:00.363 PCTime: DHCP Lease server: 0.0.0.0,
    state: 9 Purging
    000239: *Feb 28 17:19:00.363 PCTime: DHCP transaction id: 172F
    000240: *Feb 28 17:19:00.363 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000241: *Feb 28 17:19:00.363 PCTime: Next timer fires after:
    00:00:26
    000242: *Feb 28 17:19:00.363 PCTime: Retry count: 0 Client-ID:
    0015.c653.9062
    000243: *Feb 28 17:19:00.363 PCTime: Client-ID hex dump:
    0015C6539062
    000244: *Feb 28 17:19:00.363 PCTime: Hostname: cisco871
    000245: *Feb 28 17:19:00.363 PCTime: DHCP: new entry. add to queue,
    interface FastEthernet4
    --More--  000246: *Feb 28 17:19:00.363
    PCTime: DHCP: SDiscover attempt # 1 for entry:
    000247: *Feb 28 17:19:00.363 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000248: *Feb 28 17:19:00.363 PCTime: Temp sub net mask: 0.0.0.0
    000249: *Feb 28 17:19:00.363 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000250: *Feb 28 17:19:00.363 PCTime: DHCP transaction id: 1730
    000251: *Feb 28 17:19:00.363 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000252: *Feb 28 17:19:00.363 PCTime: Next timer fires after:
    00:00:04
    000253: *Feb 28 17:19:00.363 PCTime: Retry count: 1 Client-ID:
    0015.c653.9062
    000254: *Feb 28 17:19:00.363 PCTime: Client-ID hex dump:
    0015C6539062
    000255: *Feb 28 17:19:00.363 PCTime: Hostname: cisco871
    000256: *Feb 28 17:19:00.363 PCTime: DHCP: SDiscover: sending 277 byte
    length DHCP packet
    000257: *Feb 28 17:19:00.363 PCTime: DHCP: SDiscover 277 bytes
    000258: *Feb 28 17:19:00.363 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000259: *Feb 28 17:19:03.979 PCTime: DHCP: SDiscover attempt # 2 for
    entry:
    000260: *Feb 28 17:19:03.979 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000261: *Feb 28 17:19:03.979 PCTime: Temp sub net mask: 0.0.0.0
    --More--  000262: *Feb 28 17:19:03.979
    PCTime: DHCP Lease server: 0.0.0.0, state: 1 Selecting
    000263: *Feb 28 17:19:03.979 PCTime: DHCP transaction id: 1730
    000264: *Feb 28 17:19:03.979 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000265: *Feb 28 17:19:03.979 PCTime: Next timer fires after:
    00:00:04
    000266: *Feb 28 17:19:03.979 PCTime: Retry count: 2 Client-ID:
    0015.c653.9062
    000267: *Feb 28 17:19:03.979 PCTime: Client-ID hex dump:
    0015C6539062
    000268: *Feb 28 17:19:03.979 PCTime: Hostname: cisco871
    000269: *Feb 28 17:19:03.979 PCTime: DHCP: SDiscover: sending 277 byte
    length DHCP packet
    000270: *Feb 28 17:19:03.979 PCTime: DHCP: SDiscover 277 bytes
    000271: *Feb 28 17:19:03.979 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000272: *Feb 28 17:19:04.799 PCTime: %DOT11-7-AUTH_FAILED: Station
    000b.7d0b.0c60 Authentication failed
    000273: *Feb 28 17:19:07.715 PCTime: %DOT11-7-AUTH_FAILED: Station
    000b.7d0b.0c60 Authentication failed
    000274: *Feb 28 17:19:07.979 PCTime: DHCP: SDiscover attempt # 3 for
    entry:
    000275: *Feb 28 17:19:07.979 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000276: *Feb 28 17:19:07.979 PCTime: Temp sub net mask: 0.0.0.0
    --More--  000277: *Feb 28 17:19:07.979
    PCTime: DHCP Lease server: 0.0.0.0, state: 1 Selecting
    000278: *Feb 28 17:19:07.979 PCTime: DHCP transaction id: 1730
    000279: *Feb 28 17:19:07.979 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000280: *Feb 28 17:19:07.979 PCTime: Next timer fires after:
    00:00:04
    000281: *Feb 28 17:19:07.979 PCTime: Retry count: 3 Client-ID:
    0015.c653.9062
    000282: *Feb 28 17:19:07.979 PCTime: Client-ID hex dump:
    0015C6539062
    000283: *Feb 28 17:19:07.979 PCTime: Hostname: cisco871
    000284: *Feb 28 17:19:07.979 PCTime: DHCP: SDiscover: sending 277 byte
    length DHCP packet
    000285: *Feb 28 17:19:07.979 PCTime: DHCP: SDiscover 277 bytes
    000286: *Feb 28 17:19:07.979 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000287: *Feb 28 17:19:10.723 PCTime: %DOT11-7-AUTH_FAILED: Station
    000b.7d0b.0c60 Authentication failed
    000288: *Feb 28 17:19:11.979 PCTime: DHCP: QScan: Timed out Selecting
    state
    000289: *Feb 28 17:19:18.135 PCTime: DHCP: Release IPL called for
    interface FastEthernet4 in state 9
    000290: *Feb 28 17:19:18.135 PCTime: RAC: DHCP stopped on interface
    FastEthernet4
    000291: *Feb 28 17:19:20.135 PCTime: %LINK-5-CHANGED: Interface
    FastEthernet4, changed state to administratively down
    --More--  000292: *Feb 28 17:19:21.135
    PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4,
    changed state to down
    000293: *Feb 28 17:19:22.791 PCTime: DHCP: DHCP client process started:
    10
    000294: *Feb 28 17:19:22.791 PCTime: RAC: Starting DHCP discover on
    FastEthernet4
    000295: *Feb 28 17:19:22.791 PCTime: DHCP: Try 1 to acquire address for
    FastEthernet4
    000296: *Feb 28 17:19:22.795 PCTime: DHCP: allocate request
    000297: *Feb 28 17:19:22.795 PCTime: DHCP: zapping entry in DHC_PURGING
    state for Fa4
    000298: *Feb 28 17:19:22.795 PCTime: DHCP: deleting entry 82053D6C
    0.0.0.0 from list
    000299: *Feb 28 17:19:22.795 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000300: *Feb 28 17:19:22.795 PCTime: Temp sub net mask: 0.0.0.0
    000301: *Feb 28 17:19:22.795 PCTime: DHCP Lease server: 0.0.0.0,
    state: 9 Purging
    000302: *Feb 28 17:19:22.795 PCTime: DHCP transaction id: 1730
    000303: *Feb 28 17:19:22.795 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000304: *Feb 28 17:19:22.795 PCTime: Next timer fires after:
    00:00:21
    000305: *Feb 28 17:19:22.795 PCTime: Retry count: 0 Client-ID:
    0015.c653.9062
    --More--  000306: *Feb 28 17:19:22.795
    PCTime: Client-ID hex dump: 0015C6539062
    000307: *Feb 28 17:19:22.795 PCTime: Hostname: cisco871
    000308: *Feb 28 17:19:22.795 PCTime: DHCP: new entry. add to queue,
    interface FastEthernet4
    000309: *Feb 28 17:19:22.795 PCTime: DHCP: SDiscover attempt # 1 for
    entry:
    000310: *Feb 28 17:19:22.799 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000311: *Feb 28 17:19:22.799 PCTime: Temp sub net mask: 0.0.0.0
    000312: *Feb 28 17:19:22.799 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000313: *Feb 28 17:19:22.799 PCTime: DHCP transaction id: 1300
    000314: *Feb 28 17:19:22.799 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000315: *Feb 28 17:19:22.799 PCTime: Next timer fires after:
    00:00:04
    000316: *Feb 28 17:19:22.799 PCTime: Retry count: 1 Client-ID:
    0015.c653.9062
    000317: *Feb 28 17:19:22.799 PCTime: Client-ID hex dump:
    0015C6539062
    000318: *Feb 28 17:19:22.799 PCTime: Hostname: cisco871
    000319: *Feb 28 17:19:22.799 PCTime: DHCP: SDiscover: sending 277 byte
    length DHCP packet
    000320: *Feb 28 17:19:22.799 PCTime: DHCP: SDiscover 277 bytes
     
    tom, Mar 11, 2006
    #6
  7. tom

    Merv Guest

    The DHCP debug showsthat the 871W is sending DHCP Discovery messages
    and not receiving any response.


    What is the MAC address for the Dlink router that you used previously ?

    What is the model number of the Dlink router


    Try
    conf t
    interface FastEthernet 0/0

    ! mac-address format is 12 hex digits hhhh.hhh.hhhh

    ! mac-address <place MAC address of old SOHO router>

    mac-address hhhh.hhhh.hhhh
    end wri mem

    disconnect cable to fast 0/0 and then reconnect
     
    Merv, Mar 11, 2006
    #7
  8. tom

    Merv Guest

    1. Please post the output of "show version"


    2. Post your current config


    3. Capture configuring and using IP address you used previously on
    the Fastethernet 4 (outside) interface

    enable
    conf t
    int fa 4
    ip address x.x.x.x m.m.m.m
    exit

    wri mem

    clear counter fa 4

    ping y.y.y.y ! where y.y.y.y is the COX upstream router

    sh ip arp y.y.y.y

    sh int fa 4
     
    Merv, Mar 11, 2006
    #8
  9. tom

    Merv Guest

    For an overview of the DHCP packets that should be exchanged between
    the Cisco 871W and the COX DHCP server, see
    web.syr.edu/~djmolta/ist452/ch_08.ppt

    In the debug trace once DHCP is working proeprly you should see the
    following packet
    exchange :
    1. DHCP Discovery --->
    2. DHCP Offer <---
    3. DHCP Request --->
    4. DHCP Ack <---

    What is in the debug trace currently is just retries of sending DHCP
    Discovery packets and getting no DHCP response from COX
     
    Merv, Mar 11, 2006
    #9
  10. tom

    Merv Guest

    When you got your COX service did you have to register your PC or your
    DLINK device with COX by sighing on to their web site ?
     
    Merv, Mar 11, 2006
    #10
  11. tom

    Merv Guest

    Merv, Mar 11, 2006
    #11
  12. tom

    tom Guest

    Merv wrote:
    > On your DLINK router did you use the "Clone MAC" button?
    >
    > see
    >
    > http://support.dlink.com/faq/print.asp?productid=428


    The problem I see with any question of the old router's MAC being the
    issue, is that I am now online by statically assigning the IP address
    received via DHCP to the DLink, on the Cisco. In fact, the DLink is
    now dead, so the only way I am able to get online is to statically
    assign that IP to the Cisco. Kinda rules the MAC address out, no?



    Output of commands:

    show ru
    cisco871#show running-config
    Building configuration...

    Current configuration : 4946 bytes
    !
    version 12.3
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname cisco871
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 10000 debugging
    no logging console
    enable secret 5 $1$NeSs$DSY2bKyVqOJN1L79VeRVc0
    !
    username admin privilege 15 secret 5 $1$sw3n$xgQc7G3SBHFK5vtmYTTSY0
    clock timezone PCTime -8
    --More--  clock summer-time PCTime date Apr 6
    2003 2:00 Oct 26 2003 2:00
    no aaa new-model
    ip subnet-zero
    ip cef
    ip dhcp excluded-address 192.168.0.1 192.168.0.49
    !
    ip dhcp pool sdm-pool1
    import all
    network 192.168.0.0 255.255.255.0
    dns-server 4.2.2.2
    default-router 192.168.0.3
    !
    !
    ip inspect name DEFAULT100 cuseeme
    ip inspect name DEFAULT100 ftp
    ip inspect name DEFAULT100 h323
    ip inspect name DEFAULT100 icmp
    ip inspect name DEFAULT100 netshow
    ip inspect name DEFAULT100 rcmd
    ip inspect name DEFAULT100 realaudio
    ip inspect name DEFAULT100 rtsp
    ip inspect name DEFAULT100 esmtp
    ip inspect name DEFAULT100 sqlnet
    --More--  ip inspect name DEFAULT100
    streamworks
    ip inspect name DEFAULT100 tftp
    ip inspect name DEFAULT100 tcp
    ip inspect name DEFAULT100 udp
    ip inspect name DEFAULT100 vdolive
    ip tcp synwait-time 10
    ip domain name yourdomain.com
    ip name-server 4.2.2.2
    ip ssh time-out 60
    ip ssh authentication-retries 2
    no ftp-server write-enable
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    interface FastEthernet0
    no ip address
    no cdp enable
    !
    --More--  interface FastEthernet1
    no ip address
    no cdp enable
    !
    interface FastEthernet2
    no ip address
    no cdp enable
    !
    interface FastEthernet3
    no ip address
    no cdp enable
    !
    interface FastEthernet4
    description $FW_OUTSIDE$$ETH-WAN$$ES_WAN$
    ip address 68.6.120.REMOVED 255.255.252.0
    ip access-group 101 in
    ip inspect DEFAULT100 out
    ip nat outside
    ip virtual-reassembly
    ip route-cache flow
    duplex auto
    speed auto
    no cdp enable
    --More--  !
    interface Dot11Radio0
    no ip address
    !
    encryption key 1 size 40bit 7 XXXXXXXXXX transmit-key
    encryption mode wep mandatory
    !
    ssid donotconnect
    authentication open
    guest-mode
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0
    36.0 48.0 54.0
    station-role root
    no dot11 extension aironet
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    --More--  interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
    no ip address
    bridge-group 1
    !
    interface BVI1
    description $ES_LAN$$FW_INSIDE$
    ip address 192.168.0.3 255.255.255.0
    ip access-group 100 in
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 68.6.120.1
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 5 life 86400 requests 10000
    ip nat inside source list 1 interface FastEthernet4 overload
    ip nat inside source static tcp 192.168.0.99 XXXX interface
    FastEthernet4 XXXX
    !
    --More--  logging trap debugging
    access-list 1 remark INSIDE_IF=BVI1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 100 remark auto-generated by Cisco SDM Express firewall
    configuration
    access-list 100 remark SDM_ACL Category=1
    access-list 100 deny ip host 255.255.255.255 any
    access-list 100 deny ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 101 remark auto-generated by Cisco SDM Express firewall
    configuration
    access-list 101 remark SDM_ACL Category=1
    access-list 101 permit tcp any host 68.6.120.REMOVED eq www
    access-list 101 permit udp host 4.2.2.2 eq domain any
    access-list 101 deny ip 192.168.0.0 0.0.0.255 any
    access-list 101 permit icmp any any echo-reply
    access-list 101 permit icmp any any time-exceeded
    access-list 101 permit icmp any any unreachable
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip 127.0.0.0 0.255.255.255 any
    --More--  access-list 101 deny ip host
    255.255.255.255 any
    access-list 101 deny ip any any
    access-list 701 permit 000e.3b04.a26c 0000.0000.0000
    access-list 701 permit 000b.7d0b.0c60 0000.0000.0000
    access-list 701 deny 0000.0000.0000 ffff.ffff.ffff
    no cdp run
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
    login local
    no modem enable
    transport preferred all
    transport output telnet
    line aux 0
    login local
    transport preferred all
    transport output telnet
    --More--  line vty 0 4
    privilege level 15
    login local
    transport preferred all
    transport input telnet ssh
    transport output all
    !
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end

    cisco871#  show version
    Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version
    12.3(8)YI2, RELEASE SOFTWARE (fc1)
    Synched to technology version 12.3(10.3)T2

    ROM: System Bootstrap, Version 12.3(8r)YI, RELEASE SOFTWARE
    ROM: Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version
    12.3(8)YI2, RELEASE SOFTWARE (fc1)

    cisco871 uptime is 12 hours, 23 minutes
    System returned to ROM by power-on
    System image file is "flash:c870-advsecurityk9-mz.123-8.YI2.bin"



    Cisco 871W (MPC8272) processor (revision 0x100) with 118784K/12288K
    bytes of memory.
    MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
    5 FastEthernet interfaces
    1 802.11 Radio
    128K bytes of non-volatile configuration memory.
    24576K bytes of processor board System flash (Intel Strataflash)

    Configuration register is 0x2102

    cisco871#ping 68.6.120.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 68.6.120.1, timeout is 2 seconds:
    !.!.!
    Success rate is 60 percent (3/5), round-trip min/avg/max = 12/12/12 ms
    cisco871#
     
    tom, Mar 11, 2006
    #12
  13. tom

    tom Guest

    > On your DLINK router did you use the "Clone MAC" button?

    No, I had never used this feature.

    > When you got your COX service did you have to register your PC or your
    > DLINK device with COX by sighing on to their web site ?


    Nope

    I think I should try using a local DHCP server to see if the device
    gets an IP from it. However, even if it does, I still won't know how
    to proceed with the problem, since the ISP has already told me that
    they don't reset anything on their end when a new router is in place on
    my end . . .
     
    tom, Mar 11, 2006
    #13
  14. tom

    tom Guest

    Well, it won't get an IP using DHCP from a local server either . . .

    ------------


    sow  how log
    Syslog logging: enabled (0 messages dropped, 2 messages rate-limited,
    0 flushes, 0 overruns, xml disabled, filtering
    disabled)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
    filtering disabled
    Buffer logging: level debugging, 1884 messages logged, xml
    disabled,
    filtering disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled

    No active filter modules.

    Trap logging: level debugging, 1014 message lines logged
    --More--  
    Log Buffer (10000 bytes):
    393036322D466134
    000879: *Mar 1 06:47:55.792 PCTime: Hostname: cisco871
    000880: *Mar 1 06:47:55.792 PCTime: DHCP: SDiscover: sending 295 byte
    length DHCP packet
    000881: *Mar 1 06:47:55.792 PCTime: DHCP: SDiscover 295 bytes
    000882: *Mar 1 06:47:55.792 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000883: *Mar 1 06:47:59.932 PCTime: DHCP: QScan: Timed out Selecting
    state%Unknown DHCP problem.. No allocation possible
    000884: *Mar 1 06:48:09.224 PCTime: DHCP: Waiting for 10 seconds on
    interface FastEthernet4
    000885: *Mar 1 06:48:19.224 PCTime: DHCP: Try 3 to acquire address for
    FastEthernet4
    000886: *Mar 1 06:48:19.224 PCTime: DHCP: allocate request
    000887: *Mar 1 06:48:19.224 PCTime: DHCP: zapping entry in DHC_PURGING
    state for Fa4
    000888: *Mar 1 06:48:19.224 PCTime: DHCP: deleting entry 8238A634
    0.0.0.0 from list
    000889: *Mar 1 06:48:19.228 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000890: *Mar 1 06:48:19.228 PCTime: Temp sub net mask: 0.0.0.0
    --More--  000891: *Mar 1 06:48:19.228
    PCTime: DHCP Lease server: 0.0.0.0, state: 9 Purging
    000892: *Mar 1 06:48:19.228 PCTime: DHCP transaction id: 1F68
    000893: *Mar 1 06:48:19.228 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000894: *Mar 1 06:48:19.228 PCTime: Next timer fires after:
    00:00:21
    000895: *Mar 1 06:48:19.228 PCTime: Retry count: 0 Client-ID:
    cisco-0015.c653.9062-Fa4
    000896: *Mar 1 06:48:19.228 PCTime: Client-ID hex dump:
    636973636F2D303031352E633635332E
    000897: *Mar 1 06:48:19.228 PCTime:
    393036322D466134
    000898: *Mar 1 06:48:19.228 PCTime: Hostname: cisco871
    000899: *Mar 1 06:48:19.228 PCTime: DHCP: new entry. add to queue,
    interface FastEthernet4
    000900: *Mar 1 06:48:19.228 PCTime: DHCP: SDiscover attempt # 1 for
    entry:
    000901: *Mar 1 06:48:19.228 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000902: *Mar 1 06:48:19.228 PCTime: Temp sub net mask: 0.0.0.0
    000903: *Mar 1 06:48:19.228 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000904: *Mar 1 06:48:19.228 PCTime: DHCP transaction id: 1F69
    000905: *Mar 1 06:48:19.228 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    --More--  000906: *Mar 1 06:48:19.228
    PCTime: Next timer fires after: 00:00:04
    000907: *Mar 1 06:48:19.228 PCTime: Retry count: 1 Client-ID:
    cisco-0015.c653.9062-Fa4
    000908: *Mar 1 06:48:19.228 PCTime: Client-ID hex dump:
    636973636F2D303031352E633635332E
    000909: *Mar 1 06:48:19.228 PCTime:
    393036322D466134
    000910: *Mar 1 06:48:19.232 PCTime: Hostname: cisco871
    000911: *Mar 1 06:48:19.232 PCTime: DHCP: SDiscover: sending 295 byte
    length DHCP packet
    000912: *Mar 1 06:48:19.232 PCTime: DHCP: SDiscover 295 bytes
    000913: *Mar 1 06:48:19.232 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000914: *Mar 1 06:48:22.932 PCTime: DHCP: SDiscover attempt # 2 for
    entry:
    000915: *Mar 1 06:48:22.932 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000916: *Mar 1 06:48:22.932 PCTime: Temp sub net mask: 0.0.0.0
    000917: *Mar 1 06:48:22.932 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000918: *Mar 1 06:48:22.932 PCTime: DHCP transaction id: 1F69
    000919: *Mar 1 06:48:22.932 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000920: *Mar 1 06:48:22.932 PCTime: Next timer fires after:
    00:00:04
    000921: *Mar 1 06:48:22.932 PCTime: Retry count: 2 Client-ID:
    cisco-0015.c653.9062-Fa4
    --More--  000922: *Mar 1 06:48:22.932
    PCTime: Client-ID hex dump: 636973636F2D303031352E633635332E
    000923: *Mar 1 06:48:22.932 PCTime:
    393036322D466134
    000924: *Mar 1 06:48:22.932 PCTime: Hostname: cisco871
    000925: *Mar 1 06:48:22.932 PCTime: DHCP: SDiscover: sending 295 byte
    length DHCP packet
    000926: *Mar 1 06:48:22.932 PCTime: DHCP: SDiscover 295 bytes
    000927: *Mar 1 06:48:22.932 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000928: *Mar 1 06:48:26.932 PCTime: DHCP: SDiscover attempt # 3 for
    entry:
    000929: *Mar 1 06:48:26.932 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000930: *Mar 1 06:48:26.932 PCTime: Temp sub net mask: 0.0.0.0
    000931: *Mar 1 06:48:26.932 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000932: *Mar 1 06:48:26.932 PCTime: DHCP transaction id: 1F69
    000933: *Mar 1 06:48:26.932 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000934: *Mar 1 06:48:26.932 PCTime: Next timer fires after:
    00:00:04
    000935: *Mar 1 06:48:26.932 PCTime: Retry count: 3 Client-ID:
    cisco-0015.c653.9062-Fa4
    000936: *Mar 1 06:48:26.932 PCTime: Client-ID hex dump:
    636973636F2D303031352E633635332E
    --More--  000937: *Mar 1 06:48:26.932
    PCTime: 393036322D466134
    000938: *Mar 1 06:48:26.932 PCTime: Hostname: cisco871
    000939: *Mar 1 06:48:26.932 PCTime: DHCP: SDiscover: sending 295 byte
    length DHCP packet
    000940: *Mar 1 06:48:26.932 PCTime: DHCP: SDiscover 295 bytes
    000941: *Mar 1 06:48:26.932 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000942: *Mar 1 06:48:30.932 PCTime: DHCP: QScan: Timed out Selecting
    state%Unknown DHCP problem.. No allocation possible
    000943: *Mar 1 06:48:39.712 PCTime: DHCP: Waiting for 15 seconds on
    interface FastEthernet4
    000944: *Mar 1 06:48:54.712 PCTime: DHCP: Try 4 to acquire address for
    FastEthernet4
    000945: *Mar 1 06:48:54.712 PCTime: DHCP: allocate request
    000946: *Mar 1 06:48:54.716 PCTime: DHCP: zapping entry in DHC_PURGING
    state for Fa4
    000947: *Mar 1 06:48:54.716 PCTime: DHCP: deleting entry 8238A634
    0.0.0.0 from list
    000948: *Mar 1 06:48:54.716 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000949: *Mar 1 06:48:54.716 PCTime: Temp sub net mask: 0.0.0.0
    000950: *Mar 1 06:48:54.716 PCTime: DHCP Lease server: 0.0.0.0,
    state: 9 Purging
    --More--  000951: *Mar 1 06:48:54.716
    PCTime: DHCP transaction id: 1F69
    000952: *Mar 1 06:48:54.716 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000953: *Mar 1 06:48:54.716 PCTime: Next timer fires after:
    00:00:16
    000954: *Mar 1 06:48:54.716 PCTime: Retry count: 0 Client-ID:
    cisco-0015.c653.9062-Fa4
    000955: *Mar 1 06:48:54.716 PCTime: Client-ID hex dump:
    636973636F2D303031352E633635332E
    000956: *Mar 1 06:48:54.716 PCTime:
    393036322D466134
    000957: *Mar 1 06:48:54.716 PCTime: Hostname: cisco871
    000958: *Mar 1 06:48:54.716 PCTime: DHCP: new entry. add to queue,
    interface FastEthernet4
    000959: *Mar 1 06:48:54.716 PCTime: DHCP: SDiscover attempt # 1 for
    entry:
    000960: *Mar 1 06:48:54.716 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000961: *Mar 1 06:48:54.716 PCTime: Temp sub net mask: 0.0.0.0
    000962: *Mar 1 06:48:54.716 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000963: *Mar 1 06:48:54.716 PCTime: DHCP transaction id: 1F6A
    000964: *Mar 1 06:48:54.716 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000965: *Mar 1 06:48:54.716 PCTime: Next timer fires after:
    00:00:04
    000966: *Mar 1 06:48:54.716 PCTime: Retry count: 1 Client-ID:
    cisco-0015.c653.9062-Fa4
    --More--  000967: *Mar 1 06:48:54.716
    PCTime: Client-ID hex dump: 636973636F2D303031352E633635332E
    000968: *Mar 1 06:48:54.720 PCTime:
    393036322D466134
    000969: *Mar 1 06:48:54.720 PCTime: Hostname: cisco871
    000970: *Mar 1 06:48:54.720 PCTime: DHCP: SDiscover: sending 295 byte
    length DHCP packet
    000971: *Mar 1 06:48:54.720 PCTime: DHCP: SDiscover 295 bytes
    000972: *Mar 1 06:48:54.720 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000973: *Mar 1 06:48:57.932 PCTime: DHCP: SDiscover attempt # 2 for
    entry:
    000974: *Mar 1 06:48:57.932 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000975: *Mar 1 06:48:57.932 PCTime: Temp sub net mask: 0.0.0.0
    000976: *Mar 1 06:48:57.932 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000977: *Mar 1 06:48:57.932 PCTime: DHCP transaction id: 1F6A
    000978: *Mar 1 06:48:57.932 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000979: *Mar 1 06:48:57.932 PCTime: Next timer fires after:
    00:00:04
    000980: *Mar 1 06:48:57.932 PCTime: Retry count: 2 Client-ID:
    cisco-0015.c653.9062-Fa4
    000981: *Mar 1 06:48:57.932 PCTime: Client-ID hex dump:
    636973636F2D303031352E633635332E
    --More--  000982: *Mar 1 06:48:57.932
    PCTime: 393036322D466134
    000983: *Mar 1 06:48:57.932 PCTime: Hostname: cisco871
    000984: *Mar 1 06:48:57.932 PCTime: DHCP: SDiscover: sending 295 byte
    length DHCP packet
    000985: *Mar 1 06:48:57.932 PCTime: DHCP: SDiscover 295 bytes
    000986: *Mar 1 06:48:57.932 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    000987: *Mar 1 06:49:01.932 PCTime: DHCP: SDiscover attempt # 3 for
    entry:
    000988: *Mar 1 06:49:01.932 PCTime: Temp IP addr: 0.0.0.0 for peer on
    Interface: FastEthernet4
    000989: *Mar 1 06:49:01.932 PCTime: Temp sub net mask: 0.0.0.0
    000990: *Mar 1 06:49:01.932 PCTime: DHCP Lease server: 0.0.0.0,
    state: 1 Selecting
    000991: *Mar 1 06:49:01.932 PCTime: DHCP transaction id: 1F6A
    000992: *Mar 1 06:49:01.932 PCTime: Lease: 0 secs, Renewal: 0
    secs, Rebind: 0 secs
    000993: *Mar 1 06:49:01.932 PCTime: Next timer fires after:
    00:00:04
    000994: *Mar 1 06:49:01.932 PCTime: Retry count: 3 Client-ID:
    cisco-0015.c653.9062-Fa4
    000995: *Mar 1 06:49:01.932 PCTime: Client-ID hex dump:
    636973636F2D303031352E633635332E
    000996: *Mar 1 06:49:01.932 PCTime:
    393036322D466134
    000997: *Mar 1 06:49:01.932 PCTime: Hostname: cisco871
    --More--  000998: *Mar 1 06:49:01.932
    PCTime: DHCP: SDiscover: sending 295 byte length DHCP packet
    000999: *Mar 1 06:49:01.932 PCTime: DHCP: SDiscover 295 bytes
    001000: *Mar 1 06:49:01.932 PCTime: B'cast on
    FastEthernet4 interface from 0.0.0.0
    001001: *Mar 1 06:49:05.932 PCTime: DHCP: QScan: Timed out Selecting
    state
    cisco871#

    ---------------------

    Ideas?

    Thanks
     
    tom, Mar 11, 2006
    #14
  15. tom

    Merv Guest

    For testing purposes pull the access-list 101 from int fa 4 and try
    getting a dhcp address from COX again

    conf t
    int fa 4
    no ip access-group 101 in
    exit

    It is very common for cable ISP to use network 10.0.0.0 for theiur
    internal infrastructure, so the DHCP server response may have a network
    10 address.


    Quite often the manufacturer's put the MAC address and the serial
    number on an external label. A MAC address is 12 Hexadecimal digit.
    D-LINK vendor code is 0080C8 which should be the first six digits of
    the MAC address

    Did you use a PC directly connected to the COX cable modem when you
    first go the service or did you always have the D-LINK connected to the
    COX cabl emodem?

    Do you have a Windows PC that you can put a DHCP server on along with
    Etherreal so we can get a packe trace of the DHCP packets that the
    Cisco 871W is sending ?

    For testing purposes pull the access-list from FA 4
     
    Merv, Mar 11, 2006
    #15
  16. tom

    tom Guest

    You did it! It was the access-control that was the problem.

    Thank you so much.

    I tried to send some $ via paypal, but your email address is not
    registered with them. How about an Amazon Gift Certificate?

    -----------------
    000045: *Mar 1 09:31:39.255 PCTime: %DHCP-6-ADDRESS_ASSIGN: Interface
    FastEther
    net4 assigned DHCP address 68.6.112.XX, mask 255.255.252.0, hostname
    cisco871
    -----------------
     
    tom, Mar 11, 2006
    #16
  17. tom

    Merv Guest

    Glad it worked - that ia reward enough.

    I had done a trace of DHCP on my sister-in-laws cable modem and the
    DHCP server had a an IP address of 10.x.x.x So when I saw your
    access-list, I wondered if that might be the issue.
     
    Merv, Mar 11, 2006
    #17
  18. tom

    Merv Guest

    Also see if you can use this form of default static route

    ip route 0.0.0.0 0.0.0.0 dhcp
     
    Merv, Mar 11, 2006
    #18
  19. tom

    tom Guest

    Will do.

    Thanks a million.
     
    tom, Mar 11, 2006
    #19
  20. tom

    Merv Guest

    BTW where did that access-list come from - did you hand-confgiure or
    was it generated by SDM?

    If it was SDM this should be reported to Cisco because it will cause
    issues for others using SDM in a cable modem environment.

    Cable operators use network 10 for as much of their infrastructure to
    conserve their registered IP address space which is a crtiical resource
    for them. So for example each cable modem get a network 10 address for
    managment purposes.
     
    Merv, Mar 12, 2006
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?SGVpbkQ=?=

    Wireless DHCP clients cannot obtain an IP address from the DHCP se

    =?Utf-8?B?SGVpbkQ=?=, Jan 8, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    2,871
    =?Utf-8?B?SGVpbkQ=?=
    Jan 8, 2006
  2. tom
    Replies:
    15
    Views:
    1,046
  3. tom
    Replies:
    2
    Views:
    697
  4. Replies:
    3
    Views:
    1,552
  5. Art Feagles
    Replies:
    0
    Views:
    469
    Art Feagles
    Oct 15, 2007
Loading...

Share This Page