802.1Q trunk and native vlan command.

Discussion in 'Cisco' started by Amy L., Dec 5, 2003.

  1. Amy L.

    Amy L. Guest

    So let me see if I understand this correctly.

    Say I have a trunk link between Switch A and Switch B that carries
    VLAN 10 & 11. Normally when I hook a client up to a port on switch A
    I assign it to a vlan (either 10 or 11).

    Now if I didnt put that port in either VLAN 10 or 11 and that users
    packet crosses the trunk link would it be assigned to the "native
    vlan". Although, if I didnt assign the port a vlan wouldn't that port
    still be in its native vlan of the switch which would be vlan 1.

    I am having a hard time seeing the use for this command, because every
    switch port on these switches would be in some vlan either deafult or
    assigned manually.

    Thanks
    Amy.

    (Pete Mainwaring) wrote in message news:<>...
    > (Amy L.) wrote in message news:<>...
    > > For 802.1Q trunk links I noticed the following command can be used
    > >
    > > Switch(config-if)# switchport trunk native vlan vlan_num
    > >
    > > Can someone explain exactly what that command is for?
    > >
    > > I normally configure a trunk link as follows
    > >
    > > interface GigabitEthernet2/1
    > > description Trunk Connection To 3550-STACKA gig0/1
    > > switchport access vlan 42
    > > switchport trunk encapsulation dot1q
    > > switchport trunk pruning vlan none
    > > switchport mode trunk
    > > no logging event link-status
    > >
    > > Thanks
    > > Amy.

    >
    > It changes the VLAN that you are going to use as the native VLAN.
    >
    > <SNIP from Cisco web page>
    > In 802.1q trunking, all VLAN packets are tagged on the trunk link,
    > except the native VLAN. The native VLAN packets are sent untagged on
    > the trunk link. Therefore, the native VLAN should be the same on both
    > switches configured for trunking. This way, you can deduce to which
    > VLAN a frame belongs when you receive a frame with no tag. By default,
    > VLAN 1 is the native VLAN on all switches.
    >
    > In CatOS, the native VLAN can be changed by issuing the set vlan
    > <vlan-id><mod/port> command, where <mod/port > is the trunk port.
    >
    > In native IOS, the native VLAN can be changed by issuing the
    > switchport trunk native vlan <vlan-id> interface command which is
    > configured on the trunk port.
    >
    > Pete
     
    Amy L., Dec 5, 2003
    #1
    1. Advertising

  2. "Amy L." <> wrote in message
    news:...

    > I am having a hard time seeing the use for this command, because every
    > switch port on these switches would be in some vlan either deafult or
    > assigned manually.


    It would think it useful in cases where there is a differnet administrative
    authority on each side of the trunk. If you don't want their default VLAN
    polluting your default VLAN, so you can shunt untagged (default) packets to
    a VLAN other than your own default of 1. Or you might want to make it so
    that any default-default VLAN ("1") is explicitly enumerated on the trunk.
    If you have strict control over your VLANs and never expect to see a VLAN 1,
    this may help find rogue VLAN members.

    But I am really just guessing :cool:
     
    Phillip Remaker, Dec 5, 2003
    #2
    1. Advertising

  3. Amy L.

    KR Guest

    Amy L. wrote:
    >
    > Now if I didnt put that port in either VLAN 10 or 11 and that users
    > packet crosses the trunk link would it be assigned to the "native
    > vlan". Although, if I didnt assign the port a vlan wouldn't that port
    > still be in its native vlan of the switch which would be vlan 1.
    >
    > I am having a hard time seeing the use for this command, because every
    > switch port on these switches would be in some vlan either deafult or
    > assigned manually.
    >


    The command decides what will happen to an untagged frame that arrives
    on a trunk port.

    In your example, that will (or at least should) never happen, as you
    have two trunk ports interconnected. But if you have a client directly
    connected to a trunk port, and that client is sending both untagged and
    tagged frames (say, a Cisco IP phone tagging VoIP traffic with 802.1p),
    the command makes sense.
     
    KR, Dec 6, 2003
    #3
  4. Amy L.

    shope Guest

    "Amy L." <> wrote in message
    news:...
    > So let me see if I understand this correctly.
    >
    > Say I have a trunk link between Switch A and Switch B that carries
    > VLAN 10 & 11. Normally when I hook a client up to a port on switch A
    > I assign it to a vlan (either 10 or 11).
    >
    > Now if I didnt put that port in either VLAN 10 or 11 and that users
    > packet crosses the trunk link would it be assigned to the "native
    > vlan". Although, if I didnt assign the port a vlan wouldn't that port
    > still be in its native vlan of the switch which would be vlan 1.


    If VLAN 1 is "native for that port - you can change this on various devices.
    >
    > I am having a hard time seeing the use for this command, because every
    > switch port on these switches would be in some vlan either deafult or
    > assigned manually.


    But one of the issue you can get with a large VLAN structure is that the tag
    numbers are not used consistantly - this is one way to alter tag numbers as
    they cross the system since native vlan tag doesnt get included in the
    frame.

    Having said that the most common use seems to be in IP telephony, where a
    non tag aware device sites on a switch embedded in an IP phone and uses a
    single connection shared between the 2. The phone uses tags for its
    traffic - hey presto logically distinct voice and data traffic in different
    vlans.
    >
    > Thanks
    > Amy.
    >
    > (Pete Mainwaring) wrote in message

    news:<>...
    > > (Amy L.) wrote in message

    news:<>...
    > > > For 802.1Q trunk links I noticed the following command can be used
    > > >
    > > > Switch(config-if)# switchport trunk native vlan vlan_num
    > > >
    > > > Can someone explain exactly what that command is for?
    > > >
    > > > I normally configure a trunk link as follows
    > > >
    > > > interface GigabitEthernet2/1
    > > > description Trunk Connection To 3550-STACKA gig0/1
    > > > switchport access vlan 42
    > > > switchport trunk encapsulation dot1q
    > > > switchport trunk pruning vlan none
    > > > switchport mode trunk
    > > > no logging event link-status
    > > >
    > > > Thanks
    > > > Amy.

    > >
    > > It changes the VLAN that you are going to use as the native VLAN.
    > >
    > > <SNIP from Cisco web page>
    > > In 802.1q trunking, all VLAN packets are tagged on the trunk link,
    > > except the native VLAN. The native VLAN packets are sent untagged on
    > > the trunk link. Therefore, the native VLAN should be the same on both
    > > switches configured for trunking. This way, you can deduce to which
    > > VLAN a frame belongs when you receive a frame with no tag. By default,
    > > VLAN 1 is the native VLAN on all switches.
    > >
    > > In CatOS, the native VLAN can be changed by issuing the set vlan
    > > <vlan-id><mod/port> command, where <mod/port > is the trunk port.
    > >
    > > In native IOS, the native VLAN can be changed by issuing the
    > > switchport trunk native vlan <vlan-id> interface command which is
    > > configured on the trunk port.
    > >
    > > Pete

    --
    Regards

    Stephen Hope - remove xx from email to reply
     
    shope, Dec 6, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Amy L.
    Replies:
    5
    Views:
    29,797
    Francois Labreque
    Dec 5, 2003
  2. PS2 gamer
    Replies:
    1
    Views:
    1,079
    Ivan Ostres
    May 28, 2004
  3. Andy
    Replies:
    1
    Views:
    12,093
    Walter Roberson
    Sep 21, 2005
  4. Silverstrand
    Replies:
    0
    Views:
    1,039
    Silverstrand
    Apr 17, 2006
  5. Replies:
    4
    Views:
    1,045
Loading...

Share This Page