802.1q header removed in catalyst?

Discussion in 'Cisco' started by Roel Villerius, Jun 15, 2006.

  1. Hello,

    I have question, I'm trying to setup a 802.1q vlan lab envirement. I see
    PC 1 sending a ICMP package to the catalyst switch, it includes the 802.1q
    bytes. from the switch towards PC 2 I see the ICMP package comming out but
    with the 802.1q bytes removed.

    On the catalyst I have a simple configuration:

    Switch#show running-config
    Building configuration...

    Current configuration:
    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    !
    !
    !
    !
    no spanning-tree vlan 1
    ip subnet-zero
    !
    !
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 666
    switchport mode trunk
    !
    interface FastEthernet0/9
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 666
    switchport mode trunk
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface VLAN1
    no ip directed-broadcast
    no ip route-cache
    !
    !
    line con 0
    transport input none
    stopbits 1
    line vty 0 4
    login
    line vty 5 15
    login
    !
    end


    What is wrong, the 802.1q bytes should be in the header during the
    complete transport? From client till Destination?

    Who can help me.


    thx.

    CU

    Roel Villerius
     
    Roel Villerius, Jun 15, 2006
    #1
    1. Advertising

  2. Roel Villerius wrote:

    > !
    > interface FastEthernet0/8
    > switchport trunk encapsulation dot1q
    > switchport trunk native vlan 666
    > switchport mode trunk
    > !
    > interface FastEthernet0/9
    > switchport trunk encapsulation dot1q
    > switchport trunk native vlan 666
    > switchport mode trunk
    >
    > What is wrong, the 802.1q bytes should be in the header during the
    > complete transport? From client till Destination?


    I suppose that PC1 is sending frames with VLAN 666. You specified on
    Fa0/8 and Fa0/9 that the native VLAN is 666, the switch will remove this
    tag when forwarding a packet in the native VLAN.

    Two solutions to have the tags :
    * use another native VLAN (by default it is VLAN 1)
    * use "vlan dot1q tag native" to tag the native VLAN.
     
    Christophe Fillot, Jun 15, 2006
    #2
    1. Advertising

  3. Roel Villerius

    jw Guest

    vlan header as noted below will be stripped, but would not be if it was an
    isl trunk, (native only vlan 1) as far as I recall.

    "Christophe Fillot" <> wrote in message
    news:e6smne$jjc$...
    > Roel Villerius wrote:
    >
    >> !
    >> interface FastEthernet0/8
    >> switchport trunk encapsulation dot1q
    >> switchport trunk native vlan 666
    >> switchport mode trunk
    >> !
    >> interface FastEthernet0/9
    >> switchport trunk encapsulation dot1q
    >> switchport trunk native vlan 666
    >> switchport mode trunk
    >>
    >> What is wrong, the 802.1q bytes should be in the header during the
    >> complete transport? From client till Destination?

    >
    > I suppose that PC1 is sending frames with VLAN 666. You specified on
    > Fa0/8 and Fa0/9 that the native VLAN is 666, the switch will remove this
    > tag when forwarding a packet in the native VLAN.
    >
    > Two solutions to have the tags :
    > * use another native VLAN (by default it is VLAN 1)
    > * use "vlan dot1q tag native" to tag the native VLAN.
     
    jw, Jun 18, 2006
    #3
  4. jw wrote:
    > vlan header as noted below will be stripped, but would not be if it was an
    > isl trunk, (native only vlan 1) as far as I recall.


    Indeed there is no concept of native VLAN with ISL. All VLANs are
    systematically tagged.
     
    Christophe Fillot, Jun 18, 2006
    #4
  5. Keep in mind however, that not all Catalyst switches support ISL.
    Newer ones no longer support ISL in favor of 802.1q.

    On Sun, 18 Jun 2006 09:27:18 +0200, Christophe Fillot <>
    wrote:

    >jw wrote:
    >> vlan header as noted below will be stripped, but would not be if it was an
    >> isl trunk, (native only vlan 1) as far as I recall.

    >
    >Indeed there is no concept of native VLAN with ISL. All VLANs are
    >systematically tagged.
     
    Robert B. Phillips, II, Jun 20, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Oli
    Replies:
    3
    Views:
    854
  2. Tony Warburton

    difference between 802.3b and 802.11b

    Tony Warburton, Nov 25, 2004, in forum: Wireless Networking
    Replies:
    2
    Views:
    3,547
    =?Utf-8?B?UGF2ZWwgQS4=?=
    Nov 25, 2004
  3. kd

    802.11 to 802.15.4 bridge

    kd, Mar 20, 2005, in forum: Wireless Networking
    Replies:
    1
    Views:
    503
    S. Pidgorny
    Mar 25, 2005
  4. RobertABowie

    802.11b vs 802.11g

    RobertABowie, Jan 1, 2004, in forum: Cisco
    Replies:
    3
    Views:
    1,494
    Walter Roberson
    Jan 1, 2004
  5. Todd Blum

    802.1d and 802.11b

    Todd Blum, Jan 4, 2004, in forum: Cisco
    Replies:
    2
    Views:
    3,851
    Ron Bandes
    Jan 6, 2004
Loading...

Share This Page