3845 and l2tpv3 pseudowire problem

Discussion in 'Cisco' started by Dmitry Melekhov, May 12, 2008.

  1. Hello!

    I have following configuration on cisco 3660 on one side :

    l2tp-class sberbank

    pseudowire-class eth-sberbank
    encapsulation l2tpv3
    protocol l2tpv3 sberbank
    ip local interface Loopback0

    interface Loopback0
    ip address 192.168.200.249 255.255.255.252

    interface FastEthernet0/0.4
    description sberbank
    encapsulation dot1Q 4
    no cdp enable
    xconnect 192.168.200.250 1 pw-class eth-sberbank


    and mirror configuration on another side on 2801.

    Now I want to migrate from 3660 to 3845.

    l2tpv3 connection starts
    p100-cr3845-2#sh l2tun

    %No active L2F tunnels

    L2TP Tunnel and Session Information Total tunnels 1 sessions 1

    LocID RemID Remote Name State Remote Address Port Sessions L2TP
    Class/
    VPDN
    Group
    37042 9051 xnet-cr2801-2 est 192.168.200.250 0 1
    sberbank

    LocID RemID TunID Username, Intf/ State Last Chg
    Uniq ID
    Vcid,
    Circuit
    11288 43070 37042 1, Gi0/0.4:4 est 00:00:06
    2


    but traffic don't pass.

    I can see only arp requests pass this tunnel with tcpdump on both
    sides.
    What can be wrong?
     
    Dmitry Melekhov, May 12, 2008
    #1
    1. Advertising

  2. Dmitry Melekhov

    Merv Guest

    > Now I want to migrate from 3660 to 3845.
    >
    > but traffic don't pass.
    >
    > I can see only arp requests pass this tunnel with tcpdump on both
    > sides.
    > What can be wrong?



    1. The configurations wrt to the tunnel on the 3660 and 3845 are
    identical ?

    2. what is the IOS version in use on 3660 ?

    3. what is the IOS version in use on 3845 ?
     
    Merv, May 12, 2008
    #2
    1. Advertising

  3. On 12 ÍÁÊ, 18:19, Merv <> wrote:
    > > Now I want to migrate from 3660 to 3845.

    >
    > > but traffic don't pass.

    >
    > > I can see only arp requests pass this tunnel with tcpdump on both
    > > sides.
    > > What can be wrong?

    >
    > 1. The configurations wrt to the tunnel on the 3660 and 3845 are
    > identical ?
    >


    Yes, shure

    > 2. what is the IOS version in use on 3660 ?
    >

    12.4.10

    > 3. what is the IOS version in use on 3845 ?

    I tried 12.4.18 and 12.4.19

    btw, 2801 on another side runs 12.4.17a
     
    Dmitry Melekhov, May 12, 2008
    #3
  4. Dmitry Melekhov

    Merv Guest

    On May 12, 1:12 pm, Dmitry Melekhov <> wrote:
    > On 12 ÍÁÊ, 18:19, Merv <> wrote:
    >
    > > > Now I want to migrate from 3660 to 3845.

    >
    > > > but traffic don't pass.

    >
    > > > I can see only arp requests pass this tunnel with tcpdump on both
    > > > sides.
    > > > What can be wrong?

    >
    > > 1. The configurations wrt to the tunnel on the 3660 and 3845 are
    > > identical ?

    >
    > Yes, shure
    >
    > > 2. what is the IOS version in use on 3660 ?

    >
    > 12.4.10
    >
    > > 3. what is the IOS version in use on 3845 ?

    >
    > I tried 12.4.18 and 12.4.19
    >
    > btw, 2801 on another side runs 12.4.17a



    Is CEF enabled on the 3845 ?
     
    Merv, May 12, 2008
    #4
  5. On 12 ÍÁÊ, 23:33, Merv <> wrote:

    >
    > Is CEF enabled on the 3845 ?


    Yes, it is enabled.
    Very strange thing is that arp requests pass (this mean that l2
    connection exists), but other traffic not.
    May be something is wrong with switches?
    I don't phisically replaced 3660 with 3845, they both are connected
    now.
    But I tried to change connection from 2801 to 2811 on other side (they
    are both connected too) and there are no problems...
     
    Dmitry Melekhov, May 13, 2008
    #5
  6. On 13 ÍÁÊ, 07:21, Dmitry Melekhov <> wrote:

    > Very strange thing is that arp requests pass (this mean that l2
    > connection exists), but other traffic not.
    > May be something is wrong with switches?


    I tested, switches works OK, mac address from far point moves to 3845
    when I turn loopback 0 no shutdown and shutdown on 3660...
     
    Dmitry Melekhov, May 13, 2008
    #6
  7. Dmitry Melekhov

    Merv Guest

    On May 13, 1:00 am, Dmitry Melekhov <> wrote:
    > On 13 ÍÁÊ, 07:21, Dmitry Melekhov <> wrote:
    >
    > > Very strange thing is that arp requests pass (this mean that l2
    > > connection exists), but other traffic not.
    > > May be something is wrong with switches?

    >
    > I tested, switches works OK, mac address from far point moves to 3845
    > when I turn loopback 0 no shutdown and shutdown on 3660...



    Are ARP replies being received ie. is the tunnel passing both
    broadcast request and unicast response ?

    Post

    sh xconnect all detail

    sh l2tun summary al

    sh l2tun sess all
     
    Merv, May 13, 2008
    #7
  8. On 13 ÍÁÊ, 12:10, Merv <> wrote:

    > Are ARP replies being received ie. is the tunnel passing both
    > broadcast request and unicast response ?
    >


    Just because I see mac addresses in arp tables on both sides I'm shure
    that response pass.

    > Post
    >
    > sh xconnect all detail
    >
    > sh l2tun summary al
    >


    There are no above commands . at least in 2.4.19...

    > sh l2tun sess all

    %No active L2F tunnels

    L2TP Session Information Total tunnels 1 sessions 1

    Session id 46479 is up, tunnel id 11028
    Call serial number is 4900004
    Remote tunnel name is xnet-cr2801-2
    Internet address is 192.168.200.250
    Session is L2TP signalled
    Session state is established, time since change 00:08:36
    964 Packets sent, 442 received
    78038 Bytes sent, 30971 received
    Last clearing of "show vpdn" counters never
    Receive packets dropped:
    out-of-order: 0
    total: 0
    Send packets dropped:
    exceeded session MTU: 0
    total: 0
    Session vcid is 1
    Session Layer 2 circuit, type is Ethernet Vlan, name is
    GigabitEthernet0/0.4:4
    Circuit state is UP
    Remote session id is 43109, remote tunnel id 56034
    DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
    No session cookie information available
    UDP checksums are disabled
    SSS switching enabled
    Sequencing is off
    Unique ID is 19

    %No active PPTP tunnels
     
    Dmitry Melekhov, May 13, 2008
    #8
  9. On 13 ÍÁÊ, 15:22, Dmitry Melekhov <> wrote:

    well, I installed vtun on linux servers and shall try to forget about
    cisco's buggy l2tpv3 ;-)
     
    Dmitry Melekhov, May 14, 2008
    #9
  10. Dmitry Melekhov

    Gordonian

    Joined:
    Feb 9, 2011
    Messages:
    1
    If you have any non Ethernet connections between the L3 devices you will need to change the internetworking on the pseudowire-class to ip. This should be done at both ends of the pseudowire:


    pseudowire-class eth-sberbank
    encapsulation l2tpv3
    interworking ip
    protocol l2tpv3 sberbank
    ip local interface Loopback0
     
    Gordonian, Feb 9, 2011
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ian MacDougall

    l2tpv3 and vlans

    Ian MacDougall, Dec 9, 2003, in forum: Cisco
    Replies:
    8
    Views:
    1,146
    Ian MacDougall
    Dec 15, 2003
  2. davidb
    Replies:
    0
    Views:
    2,488
    davidb
    Dec 23, 2004
  3. pfisterfarm

    L2TPv3 tunnel and SSS

    pfisterfarm, Jun 20, 2008, in forum: Cisco
    Replies:
    0
    Views:
    493
    pfisterfarm
    Jun 20, 2008
  4. pfisterfarm

    L2TPv3 and vlans

    pfisterfarm, Jun 20, 2008, in forum: Cisco
    Replies:
    0
    Views:
    600
    pfisterfarm
    Jun 20, 2008
  5. pfisterfarm

    Question on 802.1q trunks and L2TPv3

    pfisterfarm, Jul 7, 2008, in forum: Cisco
    Replies:
    1
    Views:
    1,012
Loading...

Share This Page