3750 VLAN routing problem and Access Point 1131 AG multiple SSID?

Discussion in 'Cisco' started by midejan, May 2, 2010.

  1. midejan

    midejan

    Joined:
    May 2, 2010
    Messages:
    1
    PROBLEM 1: We have two Layer3 stacked switches acting as “Inter Vlan Routing” device together with multiple Layer2 switches acting as access switches. ASA 5530 firewall will be delivered soon but till then we need routing between all VLANs. Here is part of the configuration:
    Cisco 3750 L3 switch:
    - created VLANs with appropriate addresses
    - its acting as VTP Server and propagates VLANs to others 2960 VTP clients
    - configured as a DHCP server for some VLANs
    - STP globaly enabled because there are redundant links
    - Ip routing enabled and on show ip route all Vlans are (C) directly connected
    - Interfaces are in trunk mode with allowed all VLANs

    ip routing
    ip dhcp pool AccessPool
    network 10.1.103.0 255.255.255.0
    default-router 10.1.103.1
    ip dhcp pool Computers
    network 10.1.101.0 255.255.255.0
    default-router 10.1.101.1
    spanning-tree mode pvst
    interface GigabitEthernet1/0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface Vlan101
    description Computers
    ip address 10.1.101.1 255.255.255.0
    interface Vlan102
    description Cameras
    ip address 10.1.102.1 255.255.255.0
    interface Vlan103
    description AccessPoints
    ip address 10.1.103.1 255.255.255.0
    ip classless

    Cisco 2960 switch:
    - as VTP client
    - STP globaly enabled because there are redundant links
    - Two Interfaces are in trunk mode with allowed all VLANs
    interface FastEthernet0/2
    switchport access vlan 101
    switchport mode access
    interface FastEthernet0/13
    switchport access vlan 103
    switchport mode access
    interface GigabitEthernet0/1
    switchport mode trunk
    Everything is working fine: VTP propagates VLANs, DHCP is assigning addresses (no dns for now) but routing between VLANs doesn’t working. For example I can’t access from PC in vlan101 to Access Points in vlan 103, or any other vlan. From L3 switch I can ping all clients in all subnets, but from L2 switch where are for example vlan 101,102 I can’t ping clients on other L2 switch where is only vlan 103. All links to L3 switch are in trunk mode allowing all vlans. HELP?

    PROBLEM 2: On L2 switches in some access ports (vlan 103-dhcp server is on L3 switch ) we have connected 1131 AG AccessPoints. We didn't assigned vlan on SSID because it is working without it and wireless clients get addresses. For now only one SSID is broadcasting, but we want two SSIDs in two vlans (for example 103 and 107 both created in L3 switch with dhcp parameters) to broadcast. Question is: do I have to put ports on L2 switch attached to AP in trunk mode allowing vlan 103 and 107, and how to manage on AP to broadcast two visible SSIDs (one for guests and one for employes). HELP?
    midejan, May 2, 2010
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. David Sudjiman
    Replies:
    0
    Views:
    1,062
    David Sudjiman
    Jun 8, 2006
  2. avraham.shirel@gmail.com
    Replies:
    1
    Views:
    809
    Aaron Leonard
    Jun 22, 2007
  3. Arthur Brain

    Inter-VLAN routing on 3750 switches:

    Arthur Brain, Jul 11, 2007, in forum: Cisco
    Replies:
    1
    Views:
    1,128
    Brian V
    Jul 11, 2007
  4. pacmas72@gmail.com

    cisco ap 1131, vlan and dhcp service

    pacmas72@gmail.com, Mar 10, 2008, in forum: Cisco
    Replies:
    2
    Views:
    5,200
    Aaron Leonard
    Mar 11, 2008
  5. kamal1352
    Replies:
    2
    Views:
    1,168
    kamal1352
    Apr 6, 2008
Loading...

Share This Page