3620 boot from tftp

Discussion in 'Cisco' started by Sasa, Sep 7, 2006.

  1. Sasa

    Sasa Guest

    I have 3620 cisco router and would like to boot IOS from tftp server
    because another IOS is to big for 8MB flash memory.

    System Bootstrap, Version 11.1(20)AA2
    IOS (tm) 3600 Software (C3620-I-M), Version 12.3(16a)

    I was try with command

    boot-start-marker
    boot bootstrap flash flash:c3620-i-mz.123-16a.bin
    boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    boot-end-marker

    and configuration register 0x2102

    After reboot router goes to romm monitor and configuration register is
    changed to 0x0

    Same is with

    boot bootstrap flash:c3620-i-mz.123-16a.bin


    How to solve this problem!

    Thanks.


    Sasa
    Sasa, Sep 7, 2006
    #1
    1. Advertising

  2. Sasa

    LinkWaves Guest

    Did you turn on your Ethernet Interface yet?

    We buy sell all Cisco
    LinkWaves Corp
    29980 Technology Drive, Suite 6
    Murrieta, CA 92563
    http://www.linkwaves.com/requestquote.asp
    http://www.linkwaves.com/




    Sasa wrote:
    > I have 3620 cisco router and would like to boot IOS from tftp server
    > because another IOS is to big for 8MB flash memory.
    >
    > System Bootstrap, Version 11.1(20)AA2
    > IOS (tm) 3600 Software (C3620-I-M), Version 12.3(16a)
    >
    > I was try with command
    >
    > boot-start-marker
    > boot bootstrap flash flash:c3620-i-mz.123-16a.bin
    > boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    > boot-end-marker
    >
    > and configuration register 0x2102
    >
    > After reboot router goes to romm monitor and configuration register is
    > changed to 0x0
    >
    > Same is with
    >
    > boot bootstrap flash:c3620-i-mz.123-16a.bin
    >
    >
    > How to solve this problem!
    >
    > Thanks.
    >
    >
    > Sasa
    LinkWaves, Sep 7, 2006
    #2
    1. Advertising

  3. Sasa

    Sasa Guest

    Did you meen turn on ethernet Interface "no shutdown"?

    Here is "show run" of router.

    Router#sh run
    Building configuration...

    Current configuration : 808 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot system flash flash:c3620-i-mz.123-16a.bin
    boot-end-marker
    !
    !
    memory-size iomem 10
    no aaa new-model
    ip subnet-zero
    !
    !
    ip cef
    !
    !
    interface FastEthernet0/0
    ip address 10.0.0.82 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    shutdown
    clock rate 2000000
    no fair-queue
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto



    interface BRI1/0
    no ip address
    shutdown


    !
    interface Ethernet1/0
    no ip address
    shutdown
    half-duplex
    !
    ip http server
    ip classless
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end


    Sasa



    On 7 Sep 2006 10:42:50 -0700, "LinkWaves" <>
    wrote:

    >Did you turn on your Ethernet Interface yet?
    >
    >We buy sell all Cisco
    >LinkWaves Corp
    >29980 Technology Drive, Suite 6
    >Murrieta, CA 92563
    >http://www.linkwaves.com/requestquote.asp
    >http://www.linkwaves.com/
    >
    >
    >
    >
    >Sasa wrote:
    >> I have 3620 cisco router and would like to boot IOS from tftp server
    >> because another IOS is to big for 8MB flash memory.
    >>
    >> System Bootstrap, Version 11.1(20)AA2
    >> IOS (tm) 3600 Software (C3620-I-M), Version 12.3(16a)
    >>
    >> I was try with command
    >>
    >> boot-start-marker
    >> boot bootstrap flash flash:c3620-i-mz.123-16a.bin
    >> boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    >> boot-end-marker
    >>
    >> and configuration register 0x2102
    >>
    >> After reboot router goes to romm monitor and configuration register is
    >> changed to 0x0
    >>
    >> Same is with
    >>
    >> boot bootstrap flash:c3620-i-mz.123-16a.bin
    >>
    >>
    >> How to solve this problem!
    >>
    >> Thanks.
    >>
    >>
    >> Sasa
    Sasa, Sep 8, 2006
    #3
  4. Sasa

    Merv Guest

    with

    boot-start-marker
    boot bootstrap flash flash:c3620-i-mz.123-16a.bin
    boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    boot-end-marker

    configured what does the output of "how bootvar" display ?
    Merv, Sep 8, 2006
    #4
  5. Sasa

    Sasa Guest

    I don`t have that command "how bootvar"

    Sasa


    On 8 Sep 2006 05:14:57 -0700, "Merv" <> wrote:

    >with
    >
    >boot-start-marker
    >boot bootstrap flash flash:c3620-i-mz.123-16a.bin
    >boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    >boot-end-marker
    >
    >configured what does the output of "how bootvar" display ?
    Sasa, Sep 8, 2006
    #5
  6. Sasa

    Merv Guest

    show bootvar
    Merv, Sep 8, 2006
    #6
  7. Sasa

    Sasa Guest

    Yes, I no that goes "show bootvar" but I don`t have that command!
    Is that any other command except that?

    Sasa

    On 8 Sep 2006 14:16:08 -0700, "Merv" <> wrote:

    >show bootvar
    Sasa, Sep 9, 2006
    #7
  8. Sasa

    Merv Guest

    does "show boot" display anything

    "show bootvar" has replaced " show boot"
    Merv, Sep 9, 2006
    #8
  9. Sasa

    Merv Guest

    try:


    config t
    no boot bootstrap flash flash:c3620-i-mz.123-16a.bin
    no boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195

    boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    end

    wri mem

    reload


    Capture the seesion log and post it if this does not work for you
    Merv, Sep 9, 2006
    #9
  10. Sasa

    Sasa Guest

    I try that!
    And routed goes to romm monitor mode.

    I read from internet that i must first boot IOS from flash and then
    from tftp, because IOS from flash set up interfaces, and then boot
    from tftp.
    I need command to first boot from flash then from tftp.

    If you no another way tell me!

    Thanks,

    Sasa

    On 9 Sep 2006 05:54:39 -0700, "Merv" <> wrote:

    >
    >try:
    >
    >
    >config t
    >no boot bootstrap flash flash:c3620-i-mz.123-16a.bin
    >no boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    >
    >boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    >end
    >
    >wri mem
    >
    >reload
    >
    >
    >Capture the seesion log and post it if this does not work for you
    Sasa, Sep 9, 2006
    #10
  11. Sasa

    Merv Guest


    > I read from internet that i must first boot IOS from flash and then
    > from tftp, because IOS from flash set up interfaces, and then boot
    > from tftp.
    > I need command to first boot from flash then from tftp.



    It is tru that 3600 must boot an image from flash first.

    However what I would do is put a valid image as the first file in flash
    so that the system can find it but I would not put a boot command fro
    that image in the running-config/startup-config.

    If you have not tried this scenario please do
    Merv, Sep 9, 2006
    #11
  12. Sasa

    Sasa Guest

    Ok, this is the situation.

    Router#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) 3600 Software (C3620-I-M), Version 12.3(16a), RELEASE
    SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2005 by cisco Systems, Inc.
    Compiled Thu 10-Nov-05 03:19 by evmiller
    Image text-base: 0x60008B00, data-base: 0x60CE2000

    ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (f
    c1)
    ROM: 3600 Software (C3620-I-M), Version 12.3(16a), RELEASE SOFTWARE
    (fc2)

    Router uptime is 1 minute
    System returned to ROM by reload
    System image file is "flash:c3620-i-mz.123-16a.bin"

    cisco 3620 (R4700) processor (revision 0x81) with 45056K/4096K bytes
    of memory.
    Processor board ID 24364364
    R4700 CPU at 80MHz, Implementation 33, Rev 1.0
    Bridging software.
    X.25 software, Version 3.0.0.
    Basic Rate ISDN software, Version 1.1.
    1 Ethernet/IEEE 802.3 interface(s)
    2 FastEthernet/IEEE 802.3 interface(s)
    2 Serial network interface(s)
    1 ISDN Basic Rate interface(s)
    DRAM configuration is 32 bits wide with parity disabled.
    29K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)

    Configuration register is 0x0

    Router#sh boot
    ^
    % Invalid input detected at '^' marker.

    Router#sh bootvar
    ^
    % Invalid input detected at '^' marker.

    Router#show bootvar
    ^
    % Invalid input detected at '^' marker.


    1. situation
    boot-start-marker
    boot system flash flash:c3620-i-mz.123-16a.bin
    boot-end-marker

    Boot OK!

    2. situation
    boot-start-marker
    boot-end-marker

    Boot OK!

    3. situation
    boot-start-marker
    boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    boot-end-marker

    Go to romm monitor mode!

    4. situation
    boot-start-marker
    boot bootstrap flash:c3620-i-mz.123-16a.bin
    boot system tftp c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    boot-end-marker

    Go to romm monitor mode!

    System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (fc1)
    C3600 processor with 49152 Kbytes of main memory
    Main memory is configured to 32 bit mode with parity disabled

    program load complete, entry point: 0x80008000, size: 0x75f414
    Self decompressing the image :
    #################################################
    #################################### [OK]

    Smart Init is disabled. IOMEM set to: 10

    Using iomem percentage: 10

    System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (fc1)
    C3600 processor with 49152 Kbytes of main memory
    Main memory is configured to 32 bit mode with parity disabled

    rommon 1 >

    Router#sh run
    Building configuration...

    Current configuration : 761 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    memory-size iomem 10
    no aaa new-model
    ip subnet-zero
    !
    !
    ip cef
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.0.0.82 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    shutdown
    clock rate 2000000
    no fair-queue
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/1
    no ip address
    shutdown
    clock rate 2000000
    !
    interface BRI1/0
    no ip address
    shutdown
    !
    interface Ethernet1/0
    no ip address
    shutdown
    half-duplex
    !
    ip http server
    ip classless
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    Sasa


    On 9 Sep 2006 07:47:29 -0700, "Merv" <> wrote:

    >
    >> I read from internet that i must first boot IOS from flash and then
    >> from tftp, because IOS from flash set up interfaces, and then boot
    >> from tftp.
    >> I need command to first boot from flash then from tftp.

    >
    >
    >It is tru that 3600 must boot an image from flash first.
    >
    >However what I would do is put a valid image as the first file in flash
    >so that the system can find it but I would not put a boot command fro
    >that image in the running-config/startup-config.
    >
    >If you have not tried this scenario please do
    Sasa, Sep 9, 2006
    #12
  13. Sasa

    Merv Guest

    1. retry one of the test that ends up in ROMMON mode and capture the
    output of the ROMMON set command

    ROMMON 1>
    set

    post output

    from ROMMON mode can you boot the taget image from the tftp server
    using the boot command ?


    boot <image name> <tftp server IP address>

    you may have to set boot variables ( see below)

    again a session log should be posted with outcome




    ++++++++++++++++++++++++++++++++++++++++++++


    If the tftpdnld ROMmon command recovery procedure fails, verify that
    the following conditions are met:

    * The TFTP server is running.

    * The Cisco IOSĀ® file is in the root directory of the TFTP server.

    * The filesize of the Cisco IOS image being uploaded is correct.

    * If using Cisco TFTP Server 1.1, deselect the two check boxes in
    View > Options for logging and file transfer progress.

    * If possible, connect directly to the PC running the TFTP server
    with a crossover cable.

    * The file being uploaded is compatible with hardware and memory
    requirements.

    * If the router has two built-in Ethernet or fast Ethernet
    interfaces, always use the first interface (usually 0/0). You must use
    the built-in interface. For example, if a Cisco 1700 series router has
    a WIC-1ENET card installed, the tftpdnld ROMmon command does not work
    with that card.

    * All variable commands must be upper case. The variable itself is
    case sensitive as in the case of a filename, as shown in the following
    example:

    rommon11>TFTP_FILE=c2600-i-mz.120-7.T.bin

    * TFTP_FILE= must be upper case and c2600-i-mz.120-7.T.bin is case
    sensitive.

    * The DEFAULT_GATEWAY= address should not be the same address as
    the IP_ADDRESS= variable. This causes the process to fail. Set the
    DEFAULT_GATEWAY= variable to the address of the TFTP server.

    The following example shows how to perform a tftpdnld ROMmon command
    recovery procedure with a TFTP server at the 10.1.1.2 address, a
    255.255.255.0 subnet mask, and a filename of c2600-is-mz.120-7.T.bin.:

    rommon 16 > IP_ADDRESS=10.1.1.1
    !--- This is the temporary IP address assigned to the router.
    rommon 17 > IP_SUBNET_MASK=255.255.255.0
    !--- Same as on the TFTP server.
    rommon 18 > DEFAULT_GATEWAY=10.1.1.2
    !--- Use the IP address of the TFTP server.
    rommon 19 > TFTP_SERVER=10.1.1.2
    !--- TFTP server's IP address.
    rommon 20 > TFTP_FILE=c2600-is-mz.120-7.T.bin
    Merv, Sep 9, 2006
    #13
  14. Sasa

    Sasa Guest

    I do what you say!

    System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (fc1)
    C3600 processor with 49152 Kbytes of main memory
    Main memory is configured to 32 bit mode with parity disabled

    rommon 1 > set
    PS1=rommon ! >
    ?=0
    BSI=0
    BOOT=tftp:c3620-ik9o3s-mz.122-37.bin 10.0.0.195,12;
    RET_2_RTS=
    RET_2_RCALTS=

    After command "boot <image name> <tftp server IP address>"!

    System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (fc1)
    C3600 processor with 49152 Kbytes of main memory
    Main memory is configured to 32 bit mode with parity disabled

    rommon 1 > boot c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    program load complete, entry point: 0x80008000, size: 0x75f414
    Self decompressing the image :
    #################################################
    #################################### [OK]

    Smart Init is disabled. IOMEM set to: 10

    Using iomem percentage: 10

    System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (fc1)
    C3600 processor with 49152 Kbytes of main memory
    Main memory is configured to 32 bit mode with parity disabled

    rommon 1 >

    After seting boot variables!

    rommon 2 > IP_ADDRESS=10.0.0.82
    rommon 3 > IP_SUBNET_MASK=255.255.255.0
    rommon 4 > DEFAULT_GATEWAY=10.0.0.1
    rommon 5 > TFTP_SERVER=10.0.0.195
    rommon 6 > TFTP_FILE=c3620-ik9o3s-mz.122-37.bin
    rommon 7 >
    rommon 8 > set
    PS1=rommon ! >
    BSI=0
    BOOT=tftp:c3620-ik9o3s-mz.122-37.bin 10.0.0.195,12;
    RET_2_RTS=
    RET_2_RCALTS=
    ?=0
    IP_ADDRESS=10.0.0.82
    DEFAULT_GATEWAY=10.0.0.155.0
    TFTP_SERVER=10.0.0.195
    TFTP_FILE=c3620-ik9o3s-mz.122-37.bin

    rommon 9 > boot c3620-ik9o3s-mz.122-37.bin 10.0.0.195
    program load complete, entry point: 0x80008000, size: 0x75f414
    Self decompressing the image :
    #################################################
    #################################### [OK]

    Smart Init is disabled. IOMEM set to: 10

    Using iomem percentage: 10

    System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (fc1)
    C3600 processor with 49152 Kbytes of main memory
    Main memory is configured to 32 bit mode with parity disabled

    rommon 1 >

    I don`t no what to do next!
    How to solve this problem?

    Sasa


    On 9 Sep 2006 12:26:47 -0700, "Merv" <> wrote:

    >
    >
    >1. retry one of the test that ends up in ROMMON mode and capture the
    >output of the ROMMON set command
    >
    >ROMMON 1>
    >set
    >
    >post output
    >
    >from ROMMON mode can you boot the taget image from the tftp server
    >using the boot command ?
    >
    >
    >boot <image name> <tftp server IP address>
    >
    >you may have to set boot variables ( see below)
    >
    >again a session log should be posted with outcome
    >
    >
    >
    >
    >++++++++++++++++++++++++++++++++++++++++++++
    >
    >
    > If the tftpdnld ROMmon command recovery procedure fails, verify that
    >the following conditions are met:
    >
    > * The TFTP server is running.
    >
    > * The Cisco IOSĀ® file is in the root directory of the TFTP server.
    >
    > * The filesize of the Cisco IOS image being uploaded is correct.
    >
    > * If using Cisco TFTP Server 1.1, deselect the two check boxes in
    >View > Options for logging and file transfer progress.
    >
    > * If possible, connect directly to the PC running the TFTP server
    >with a crossover cable.
    >
    > * The file being uploaded is compatible with hardware and memory
    >requirements.
    >
    > * If the router has two built-in Ethernet or fast Ethernet
    >interfaces, always use the first interface (usually 0/0). You must use
    >the built-in interface. For example, if a Cisco 1700 series router has
    >a WIC-1ENET card installed, the tftpdnld ROMmon command does not work
    >with that card.
    >
    > * All variable commands must be upper case. The variable itself is
    >case sensitive as in the case of a filename, as shown in the following
    >example:
    >
    > rommon11>TFTP_FILE=c2600-i-mz.120-7.T.bin
    >
    > * TFTP_FILE= must be upper case and c2600-i-mz.120-7.T.bin is case
    >sensitive.
    >
    > * The DEFAULT_GATEWAY= address should not be the same address as
    >the IP_ADDRESS= variable. This causes the process to fail. Set the
    >DEFAULT_GATEWAY= variable to the address of the TFTP server.
    >
    >The following example shows how to perform a tftpdnld ROMmon command
    >recovery procedure with a TFTP server at the 10.1.1.2 address, a
    >255.255.255.0 subnet mask, and a filename of c2600-is-mz.120-7.T.bin.:
    >
    >rommon 16 > IP_ADDRESS=10.1.1.1
    >!--- This is the temporary IP address assigned to the router.
    >rommon 17 > IP_SUBNET_MASK=255.255.255.0
    >!--- Same as on the TFTP server.
    >rommon 18 > DEFAULT_GATEWAY=10.1.1.2
    >!--- Use the IP address of the TFTP server.
    >rommon 19 > TFTP_SERVER=10.1.1.2
    >!--- TFTP server's IP address.
    >rommon 20 > TFTP_FILE=c2600-is-mz.120-7.T.bin
    Sasa, Sep 11, 2006
    #14
  15. Sasa

    Merv Guest

    I doubt that it matters but the default gateway should be set to the IP
    address of the TFTP server as per the example previously posted:

    IP_ADDRESS=10.0.0.82
    DEFAULT_GATEWAY=10.0.0.195
    TFTP_SERVER=10.0.0.195


    Unfortunately I do not have access to a 3620 to test. Perhaps someone
    who does could give this test scenario a whirl.
    Merv, Sep 11, 2006
    #15
  16. Sasa

    garboon

    Joined:
    Feb 24, 2009
    Messages:
    1
    When you use the boot system global configuration command on the Cisco 1600 series, Cisco 3600 series, and Cisco 7000 family, you affect only the running configuration. You must save the BOOT variable settings to your startup configuration to place the information under ROM monitor control and to have the variable function as expected. Use the copy system:running-config nvram:startup-config EXEC command to save the variable from your running configuration to your startup configuration.
    garboon, Feb 24, 2009
    #16
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. hdu

    3620 boot from tftp

    hdu, Jan 28, 2004, in forum: Cisco
    Replies:
    15
    Views:
    4,413
  2. AM
    Replies:
    3
    Views:
    705
  3. AM
    Replies:
    2
    Views:
    707
  4. ken2000
    Replies:
    4
    Views:
    812
    ken2000
    Dec 8, 2006
  5. Sharad
    Replies:
    0
    Views:
    625
    Sharad
    Feb 13, 2007
Loading...

Share This Page