3560 Limit rate port

Discussion in 'Cisco' started by terrydoc@o2.ie, Apr 22, 2010.

  1. Guest

    Can any describe a simple method to rate limit a fastethernet on a
    3560 - I have seen and tried Police , srr queue commands but I have
    only been anle to achieve the desired rate limit on the inside of the
    port - it appears to still use the full bandwidth on its egress side.

    !
    !
    policy-map POLICY_5Mb
    class CLASS_5Mb
    police 5000000 100000 exceed-action drop
    !
    !
    interface FastEthernet0/1
    bandwidth 5000
    srr-queue bandwidth limit 90
    service-policy input POLICY_5Mb
    !

    service-policy output POLICY_5Mb
    police command is not supported for this interface
    The interface does not support the specified policy configuration and/
    or parameter values.
    Warning: Assigning a policy map to the output side of an interface not
    supported

    I am sharing Internet bandwidth between different people ...thanks
     
    , Apr 22, 2010
    #1
    1. Advertising

  2. "" <> writes:
    >Can any describe a simple method to rate limit a fastethernet on a
    >3560 - I have seen and tried Police , srr queue commands but I have
    >only been anle to achieve the desired rate limit on the inside of the
    >port - it appears to still use the full bandwidth on its egress side.


    No simple way like you are trying, but it is possible, detailed here..

    http://blog.ine.com/2008/03/03/bridging-the-gap-between-3550-and-3560-qos-part-i/
    http://blog.ine.com/2008/03/26/bridging-the-gap-between-3550-and-3560-qos-part-ii/
    http://blog.ine.com/2008/06/26/quick-notes-on-the-3560-egress-queuing/
     
    Doug McIntyre, Apr 22, 2010
    #2
    1. Advertising

  3. Guest

    On Apr 22, 8:34 pm, Doug McIntyre <> wrote:
    > "" <> writes:
    > >Can any describe a simple method to rate limit a fastethernet on a
    > >3560 - I have seen and tried Police , srr queue commands but I have
    > >only been anle to achieve the desired rate limit on the inside of the
    > >port - it appears to still use the full bandwidth on its egress side.

    >
    > No simple way like you are trying, but it is possible, detailed here..
    >
    > http://blog.ine.com/2008/03/03/brid...06/26/quick-notes-on-the-3560-egress-queuing/


    Thanks for the reply, I have made some progress:
    !
    interface FastEthernet0/1
    srr-queue bandwidth limit 10
    service-policy input POLICY_5Mb
    !
    - gives download 6.1Mbs upload 3.2 Mbs

    When I try to setup a "10Mb" policy I appear to have a problem...
    !
    interface FastEthernet0/2
    srr-queue bandwidth limit 10
    spanning-tree portfast
    service-policy input POLICY_10Mb
    !
    - gives download 6.1Mbs upload 67Mbs

    the config details are:
    !
    class-map match-all CLASS_5Mb
    match access-group name ACL_5Mb
    class-map match-any CLASS_10mb
    match any
    class-map match-any CLASS_5mb
    match any
    class-map match-all CLASS_10Mb
    match access-group name ACL_10Mb
    !
    !
    policy-map POLICY_5Mb
    class CLASS_5Mb
    police 5000000 100000 exceed-action drop
    policy-map POLICY_10Mb
    class CLASS_10Mb
    police 10000000 100000 exceed-action drop
    !
    Any apparent problem here? Thanks...
     
    , Apr 23, 2010
    #3
  4. "" <> writes:
    >On Apr 22, 8:34=A0pm, Doug McIntyre <> wrote:
    >> "" <> writes:
    >> >Can any describe a simple method to rate limit a fastethernet on a
    >> >3560 - I have seen and tried Police , srr queue commands but I have
    >> >only been anle to achieve the desired rate limit on the inside of the
    >> >port - it appears to still use the full bandwidth on its egress side.

    >>
    >> No simple way like you are trying, but it is possible, detailed here..
    >>
    >> http://blog.ine.com/2008/03/03/bridging-the-gap-between-3550-and-3560...h=

    >ttp://blog.ine.com/2008/03/26/bridging-the-gap-between-3550-and-3560...http=
    >://blog.ine.com/2008/06/26/quick-notes-on-the-3560-egress-queuing/


    >Thanks for the reply, I have made some progress:
    >!
    >interface FastEthernet0/1
    > srr-queue bandwidth limit 10
    > service-policy input POLICY_5Mb
    >!
    >- gives download 6.1Mbs upload 3.2 Mbs


    >When I try to setup a "10Mb" policy I appear to have a problem...


    >interface FastEthernet0/2
    > srr-queue bandwidth limit 10
    > spanning-tree portfast
    > service-policy input POLICY_10Mb

    ....
    >policy-map POLICY_10Mb
    > class CLASS_10Mb
    > police 10000000 100000 exceed-action drop


    > gives download 6.1Mbs upload 67Mbs


    I've found that in real life, you have to adjust your burst size
    according to your traffic mix, and tweak things up and down based on
    actually measuring the traffic throughput.

    Running through the theory is all grand, but to dial it in, you have
    to do some experimentation back and forth to get it to register the
    way you like..

    I've also found the 4500/SupIVs or Vs to be much more forgiving for
    doing what you are trying to do.
     
    Doug McIntyre, Apr 23, 2010
    #4
  5. Guest

    On Apr 23, 6:39 pm, Doug McIntyre <> wrote:
    > "" <> writes:
    > >On Apr 22, 8:34=A0pm, Doug McIntyre <> wrote:
    > >> "" <> writes:
    > >> >Can any describe a simple method to rate limit a fastethernet on a
    > >> >3560 - I have seen and tried Police , srr queue commands but I have
    > >> >only been anle to achieve the desired rate limit on the inside of the
    > >> >port - it appears to still use the full bandwidth on its egress side.

    >
    > >> No simple way like you are trying, but it is possible, detailed here..

    >
    > >>http://blog.ine.com/2008/03/03/bridging-the-gap-between-3550-and-3560....

    > >ttp://blog.ine.com/2008/03/26/bridging-the-gap-between-3550-and-3560...http=
    > >://blog.ine.com/2008/06/26/quick-notes-on-the-3560-egress-queuing/
    > >Thanks for the reply, I have made some progress:
    > >!
    > >interface FastEthernet0/1
    > > srr-queue bandwidth limit 10
    > > service-policy input POLICY_5Mb
    > >!
    > >- gives download 6.1Mbs  upload 3.2  Mbs
    > >When I try to setup a "10Mb" policy I appear to have a problem...
    > >interface FastEthernet0/2
    > > srr-queue bandwidth limit 10
    > > spanning-tree portfast
    > > service-policy input POLICY_10Mb

    > ...
    > >policy-map POLICY_10Mb
    > > class CLASS_10Mb
    > >  police 10000000 100000 exceed-action drop
    > > gives download  6.1Mbs  upload 67Mbs

    >
    > I've found that in real life, you have to adjust your burst size
    > according to your traffic mix, and tweak things up and down based on
    > actually measuring the traffic throughput.
    >
    > Running through the theory is all grand, but to dial it in, you have
    > to do some experimentation back and forth to get it to register the
    > way you like..
    >
    > I've also found the 4500/SupIVs or Vs to be much more forgiving for
    > doing what you are trying to do.


    ____________________

    I have spent a long time now trying various combinations of values to
    get my traffic shaping ploicies working but cannot crack it. To recap
    - I want to slice up Internet Bandwidth between different ports on my
    switch; my first policy is:
    policy-map POLICY_5Mb
    class CLASS_5Mb
    police 5000000 100000 exceed-action drop

    - I have this working on !
    interface FastEthernet0/1
    speed 10
    srr-queue bandwidth limit 50
    spanning-tree portfast
    service-policy input POLICY_5Mb
    !
    and I get it working with upload speed of 3.2Mbs and download of
    6.1Mbs - this is good and what I was looking for.
    However when I try to create a policy for 10Mb

    policy-map POLICY_10Mb
    class CLASS_10Mb
    police 8000 8000 exceed-action drop
    ! !
    interface FastEthernet0/2
    speed 100
    srr-queue bandwidth limit 10
    spanning-tree portfast
    service-policy input POLICY_10Mb
    !
    I get upload of 6Mbs but download of 61Mbs - so it appears to be using
    ALL the bandwidth. I have tried various settings for the "police
    command" ...... 8000 8000 to 10000000 10000000 - but theses never
    appear to impact the upload download rates achieved - am I missing
    something vital ?
    !
    !
    class-map match-all CLASS_5Mb
    match access-group name ACL_5Mb
    class-map match-all CLASS_10Mb
    match access-group name ACL_10Mb
    !
    !
    policy-map POLICY_5Mb
    class CLASS_5Mb
    police 5000000 100000 exceed-action drop
    policy-map POLICY_10Mb
    class CLASS_10Mb
    police 8000 8000 exceed-action drop
    !
    !
    interface FastEthernet0/1
    speed 10
    srr-queue bandwidth limit 50
    spanning-tree portfast
    service-policy input POLICY_5Mb
    !
    interface FastEthernet0/2
    speed 100
    srr-queue bandwidth limit 10
    spanning-tree portfast
    service-policy input POLICY_10Mb
    !
     
    , Apr 26, 2010
    #5
  6. bod43 Guest

    On 26 Apr, 15:50, "" <> wrote:
    > On Apr 23, 6:39 pm, Doug McIntyre <> wrote:
    >
    >
    >
    > > "" <> writes:
    > > >On Apr 22, 8:34=A0pm, Doug McIntyre <> wrote:
    > > >> "" <> writes:
    > > >> >Can any describe a simple method to rate limit a fastethernet on a
    > > >> >3560 - I have seen and tried Police , srr queue commands but I have
    > > >> >only been anle to achieve the desired rate limit on the inside of the
    > > >> >port - it appears to still use the full bandwidth on its egress side.

    >
    > > >> No simple way like you are trying, but it is possible, detailed here...

    >
    > > >>http://blog.ine.com/2008/03/03/bridging-the-gap-between-3550-and-3560....
    > > >ttp://blog.ine.com/2008/03/26/bridging-the-gap-between-3550-and-3560....http=
    > > >://blog.ine.com/2008/06/26/quick-notes-on-the-3560-egress-queuing/
    > > >Thanks for the reply, I have made some progress:
    > > >!
    > > >interface FastEthernet0/1
    > > > srr-queue bandwidth limit 10
    > > > service-policy input POLICY_5Mb
    > > >!
    > > >- gives download 6.1Mbs  upload 3.2  Mbs
    > > >When I try to setup a "10Mb" policy I appear to have a problem...
    > > >interface FastEthernet0/2
    > > > srr-queue bandwidth limit 10
    > > > spanning-tree portfast
    > > > service-policy input POLICY_10Mb

    > > ...
    > > >policy-map POLICY_10Mb
    > > > class CLASS_10Mb
    > > >  police 10000000 100000 exceed-action drop
    > > > gives download  6.1Mbs  upload 67Mbs

    >
    > > I've found that in real life, you have to adjust your burst size
    > > according to your traffic mix, and tweak things up and down based on
    > > actually measuring the traffic throughput.

    >
    > > Running through the theory is all grand, but to dial it in, you have
    > > to do some experimentation back and forth to get it to register the
    > > way you like..

    >
    > > I've also found the 4500/SupIVs or Vs to be much more forgiving for
    > > doing what you are trying to do.

    >
    > ____________________
    >
    > I have spent a long time now trying various combinations of values to
    > get my traffic shaping ploicies working but cannot crack it. To recap
    > - I want to slice up Internet Bandwidth between different ports on my
    > switch; my first policy is:



    I did some work on this years ago and have a config I will post.
    The idea was to prioritise outbound voice traffic into a DSL (likely
    512kbps). Switch was 3560.

    Of course the voice traffic was already DSCP marked
    and we just had to preserve the marking (by default the switch
    discards the marking) and then do queuing on the output.

    The idea might have been to limit the non phone traffic (maybe
    to say 300kbps) leaving enough room for the voice or maybe to
    do output shaping on the switch of non voice traffic. Not sure
    which is configured here.

    I cannot at present explain how it was supposed to work
    in detail since I forget - it was over 4 years ago.

    The config is hopefully called Config-dscp-pass-through-
    WORKING-with---QOS-As-in-use--3560-2006-02-07

    As I recall input queuing seems of no use to me.
    It's a plain switch L2 configuration, no routing.

    Here are the bits that seem to matter:-

    Some config elements are UNUSED but I have left them in
    in case it gives you any ideas.
    version 12.1

    mls qos map cos-dscp 0 8 16 26 32 46 48 56
    mls qos srr-queue input bandwidth 50 50
    mls qos srr-queue input cos-map queue 1 threshold 2 1
    mls qos srr-queue input cos-map queue 1 threshold 3 0
    mls qos srr-queue input cos-map queue 2 threshold 1 2
    mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
    mls qos srr-queue input cos-map queue 2 threshold 3 3 5
    mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14
    15
    mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
    mls qos srr-queue input dscp-map queue 1 threshold 3 32
    mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20
    21 22 23
    mls qos srr-queue input dscp-map queue 2 threshold 2 26 33 34 35 36
    37 38 39
    mls qos srr-queue input dscp-map queue 2 threshold 2 48 49 50 51 52
    53 54 55
    mls qos srr-queue input dscp-map queue 2 threshold 2 56 57 58 59 60
    61 62 63
    mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 27 28 29
    30 31 40
    mls qos srr-queue input dscp-map queue 2 threshold 3 41 42 43 44 45
    46 47
    mls qos srr-queue output cos-map queue 1 threshold 3 3 5
    mls qos srr-queue output cos-map queue 2 threshold 3 0 1 2 4 6 7
    mls qos srr-queue output dscp-map queue 1 threshold 3 24 26 46
    mls qos srr-queue output dscp-map queue 2 threshold 2 9 10 11 12 13
    14 15
    mls qos srr-queue output dscp-map queue 2 threshold 3 0 1 2 3 4 5 6 7
    mls qos srr-queue output dscp-map queue 2 threshold 3 16 17 18 19 20
    21 22 23
    mls qos srr-queue output dscp-map queue 2 threshold 3 25 27 28 29 30
    31 32 33
    mls qos srr-queue output dscp-map queue 2 threshold 3 34 35 36 37 38
    39 40 41
    mls qos srr-queue output dscp-map queue 2 threshold 3 42 43 44 45 47
    48 49 50
    mls qos srr-queue output dscp-map queue 2 threshold 3 51 52 53 54 55
    56 57 58
    mls qos srr-queue output dscp-map queue 2 threshold 3 59 60 61 62 63
    mls qos queue-set output 1 buffers 20 20 20 40
    mls qos queue-set output 2 buffers 40 40 10 10
    mls qos



    !! I dont think there are in use in the config
    !! but were part of earlier tests

    class-map match-any CM-tointernet2
    match input-interface FastEthernet0/2
    class-map match-any CM-tointernet
    match access-group name ACL-tointernet
    class-map match-any CM-voice
    match any
    !
    !
    policy-map PM-tointernet2
    class CM-tointernet
    trust dscp
    policy-map PM-tointernet
    class CM-tointernet
    trust dscp


    interface FastEthernet0/6
    description To Internet
    no ip address
    srr-queue bandwidth shape 25 60 0 0
    srr-queue bandwidth limit 10
    queue-set 2
    priority-queue out
    no mdix auto



    interface FastEthernet0/9
    no ip address
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    mls qos trust device cisco-phone
    no mdix auto
    auto qos voip cisco-phone


    interface FastEthernet0/14
    no ip address
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    mls qos trust device cisco-phone
    no mdix auto
    auto qos voip cisco-phone


    interface FastEthernet0/15
    description IP Phone Port
    no ip address
    duplex full
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    mls qos trust device cisco-phone
    mls qos trust cos
    no mdix auto
    auto qos voip cisco-phone
     
    bod43, Apr 27, 2010
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John
    Replies:
    5
    Views:
    35,965
    area0
    Apr 8, 2010
  2. David Hill

    rate-limit

    David Hill, Jul 22, 2003, in forum: Cisco
    Replies:
    0
    Views:
    653
    David Hill
    Jul 22, 2003
  3. Radium
    Replies:
    1
    Views:
    1,749
    dadiOH
    Jul 18, 2007
  4. Patrick Cervicek
    Replies:
    0
    Views:
    901
    Patrick Cervicek
    Aug 7, 2007
  5. Morph

    port rate limit on 3750

    Morph, Nov 19, 2007, in forum: Cisco
    Replies:
    5
    Views:
    1,938
    stephen
    Nov 21, 2007
Loading...

Share This Page