3550 switch + rate-limiting. Help!

Discussion in 'Cisco' started by Mat Sharpe, Jun 18, 2004.

  1. Mat Sharpe

    Mat Sharpe Guest

    Ok, I have a 3550. Its running EMI code: c3550-i5q3l2-mz.121-8.EA1c.bin

    I'm trying to apply some kind of rate-limit for one of my customers to stop
    them killing our bandwidth. The switch is operating purely as a Layer 2
    device, so no routing or anything clever.

    So far, from poking around in various places, I have come up with the
    following:

    !
    mls qos
    !
    class-map match-any any
    match any
    !
    !
    policy-map 64kbps
    class any
    police 64000 64000 exceed-action drop
    !
    ........
    interface FastEthernet0/24
    switchport access vlan 5
    switchport mode access
    no ip address
    duplex full
    speed 100
    service-policy input 64kbps
    service-policy output 64kbps
    no cdp enable
    ....

    But...it doesn't do anything!

    'show mls qos int fa0/24 stat' gives the following:
    FastEthernet0/24
    Ingress
    dscp: incoming no_change classified policed dropped (in bytes)
    Others: 900750579 841373 899909206 0 0
    Egress
    dscp: incoming no_change classified policed dropped (in bytes)
    Others: 1110768778 n/a n/a 0 0

    Which is nice, except 'dropped' shouldn't be zero, I would have thought! :)

    I can still transfer data at full speed in both directions.

    Any assistance gratefully recieved!

    Cheers,
    Mat
     
    Mat Sharpe, Jun 18, 2004
    #1
    1. Advertising

  2. Mat Sharpe

    Steinar Haug Guest

    ["Mat Sharpe"]

    | I'm trying to apply some kind of rate-limit for one of my customers to stop
    | them killing our bandwidth. The switch is operating purely as a Layer 2
    | device, so no routing or anything clever.
    |
    | So far, from poking around in various places, I have come up with the
    | following:
    |
    | !
    | mls qos
    | !
    | class-map match-any any
    | match any

    I've never gotten "match any" to work properly here. Try

    access-list 100 permit ip any any
    class-map match-any any
    match access-group 100

    In most cases you can also get the same effect with

    class-map match-any any
    match ip dscp 0

    Steinar Haug, Nethelp consulting,
     
    Steinar Haug, Jun 18, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Craig Whitmore

    Rate Limiting on a 3550/2950 combo

    Craig Whitmore, Jul 20, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,775
    Craig Whitmore
    Jul 20, 2003
  2. Rick
    Replies:
    10
    Views:
    12,169
    riteshmahajan1
    Dec 17, 2008
  3. Peter Cafs

    3550 - SMI Rate Limiting

    Peter Cafs, Feb 26, 2004, in forum: Cisco
    Replies:
    1
    Views:
    813
    Steinar Haug
    Feb 26, 2004
  4. raptor
    Replies:
    3
    Views:
    5,024
    Walter Roberson
    Oct 27, 2004
  5. Patrick Cervicek
    Replies:
    0
    Views:
    816
    Patrick Cervicek
    Aug 7, 2007
Loading...

Share This Page