3550 routing

Discussion in 'Cisco' started by Jo Knight, May 8, 2004.

  1. Jo Knight

    Jo Knight Guest

    Hi,

    Would someone be so kind as to look at the configuration below and tell me
    why I cannot route between VLAN's on my 3550. I have enabled ip routing and
    rip, but I still cannot ping or connect across the VLAN's.

    Many thanks,

    Jo

    -------------------------START CONFIG----------------------

    version 12.1

    no service pad

    service timestamps debug uptime

    service timestamps log uptime

    service password-encryption

    !

    hostname HC_CORE_2

    !

    enable secret 5 $1$qZkH$dBbMbdhIz14oUTs2xZzvv1

    !

    ip subnet-zero

    ip routing

    !

    no ip domain-lookup

    !

    spanning-tree mode pvst

    spanning-tree extend system-id

    !

    !

    interface FastEthernet0/1

    no switchport

    no ip address

    !

    interface FastEthernet0/4

    switchport access vlan 192

    switchport mode dynamic desirable

    no ip address

    !

    interface FastEthernet0/24

    switchport access vlan 22

    switchport mode dynamic desirable

    no ip address

    interface Vlan1

    no ip address

    shutdown

    !

    interface Vlan22

    ip address 192.168.22.250 255.255.255.0

    !

    interface Vlan192

    ip address 192.168.1.1 255.255.255.0

    !

    router rip

    network 192.168.1.0

    network 192.168.22.0

    !

    ip default-gateway 192.168.22.4

    no ip classless

    no ip http server

    !

    end
     
    Jo Knight, May 8, 2004
    #1
    1. Advertising

  2. Jo Knight

    Steinar Haug Guest

    ["Jo Knight"]

    | Would someone be so kind as to look at the configuration below and tell me
    | why I cannot route between VLAN's on my 3550. I have enabled ip routing and
    | rip, but I still cannot ping or connect across the VLAN's.

    Why on earth do you have "no ip classless"?

    Also, you don't need "router rip" for the 3550 to perform routing.

    Steinar Haug, Nethelp consulting,
     
    Steinar Haug, May 8, 2004
    #2
    1. Advertising

  3. Jo Knight

    Jo Knight Guest

    So are you saying take out no ip classless and remove rip and it will work?


    "Steinar Haug" <> wrote in message
    news:...
    > ["Jo Knight"]
    >
    > | Would someone be so kind as to look at the configuration below and

    tell me
    > | why I cannot route between VLAN's on my 3550. I have enabled ip

    routing and
    > | rip, but I still cannot ping or connect across the VLAN's.
    >
    > Why on earth do you have "no ip classless"?
    >
    > Also, you don't need "router rip" for the 3550 to perform routing.
    >
    > Steinar Haug, Nethelp consulting,
     
    Jo Knight, May 8, 2004
    #3
  4. Jo Knight

    Steinar Haug Guest

    ["Jo Knight"]

    | So are you saying take out no ip classless and remove rip and it will work?

    Whether you need to run RIP depends on *other factors*, for instance
    whether this switch needs to propagate routing information to and from
    other routers. It is completely irrelevant for routing between two SVIs
    (two VLAN interfaces) on the same switch.

    I would take out the "no ip classless", and also verify that your two
    VLANs 22 and 192 have indeed been created.

    Steinar Haug, Nethelp consulting,


    |
    |
    | "Steinar Haug" <> wrote in message
    | news:...
    | > ["Jo Knight"]
    | >
    | > | Would someone be so kind as to look at the configuration below and
    | tell me
    | > | why I cannot route between VLAN's on my 3550. I have enabled ip
    | routing and
    | > | rip, but I still cannot ping or connect across the VLAN's.
    | >
    | > Why on earth do you have "no ip classless"?
    | >
    | > Also, you don't need "router rip" for the 3550 to perform routing.
    | >
    | > Steinar Haug, Nethelp consulting,
    |
    |
     
    Steinar Haug, May 8, 2004
    #4
  5. Jo Knight

    Jo Knight Guest

    "Steinar Haug" <> wrote in message
    news:...

    > I would take out the "no ip classless", and also verify that your two
    > VLANs 22 and 192 have indeed been created.


    I will give it a try.

    One thing I didnt mention I have the SMI version, routing is enabled in this
    version isnt it?
     
    Jo Knight, May 8, 2004
    #5
  6. In article <zB5nc.14743$>, Jo Knight
    <> wrote:
    > "Steinar Haug" <> wrote in message
    > news:...
    >
    > > I would take out the "no ip classless", and also verify that your two
    > > VLANs 22 and 192 have indeed been created.

    >
    > I will give it a try.
    >
    > One thing I didnt mention I have the SMI version, routing is enabled in
    > this version isnt it?


    Basic routing (static and RIP) is available in the SMI image from IOS
    release 12.1(11)EA1. Images earlier than this require an EMI image for
    basic routing.

    Cheers,

    Matt

    --
    Matthew Melbourne
     
    Matthew Melbourne, May 8, 2004
    #6
  7. Jo Knight

    mh Guest

    Did you add the vlan to the vlan database?

    conf t
    vlan database
    vlan 22
    vlan 192
    apply
    exit


    What do the following commands display:

    sh vlan

    sh ip int brief

    sh ip route

    sh arp


    Can you ping from within the switch to devices on subnet 192.168.1.0
    or subnet 192.168.22.0 ?
     
    mh, May 8, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. desdronox
    Replies:
    1
    Views:
    2,952
    Terry Baranski
    Jul 10, 2003
  2. JohnNews
    Replies:
    10
    Views:
    6,793
    One Step Beyond
    Oct 20, 2003
  3. Steinar Haug
    Replies:
    0
    Views:
    784
    Steinar Haug
    Oct 20, 2003
  4. Ori
    Replies:
    12
    Views:
    12,097
    Kenny D
    Dec 4, 2003
  5. joeblow
    Replies:
    3
    Views:
    1,275
    Philip D'Ath
    Mar 14, 2005
Loading...

Share This Page