32 bit Program Compatibility Icon

Discussion in 'Windows 64bit' started by =?Utf-8?B?UnVzcyBTdmVuZHNlbg==?=, Feb 7, 2006.

  1. I have a program that is 32 bit. And we would like to run this on windows
    2003 x64 terminal server. And it does if the program compatibility icon is
    set to windows xp. I copied this icon to the all users folder. And it does
    appear on other users desktops. however the compatibility properties do not
    stay for the user. They lose there settings. Is there a way to fix this?
    =?Utf-8?B?UnVzcyBTdmVuZHNlbg==?=, Feb 7, 2006
    #1
    1. Advertising

  2. Well, its 32-bit it should run without any issues anyway, I know that it
    sticks as a local user when you check box and select an appropriate
    operating system from the list box. Its possible this scenario is not
    supported over Terminal sessesion.
    --
    --
    Andre
    Windows Connect | http://www.windowsconnected.com
    Extended64 | http://www.extended64.com
    Blog | http://www.extended64.com/blogs/andre
    http://spaces.msn.com/members/adacosta
    FAQ for MS AntiSpy http://www.geocities.com/marfer_mvp/FAQ_MSantispy.htm
    "Russ Svendsen" <Russ > wrote in message
    news:...
    >I have a program that is 32 bit. And we would like to run this on windows
    > 2003 x64 terminal server. And it does if the program compatibility icon is
    > set to windows xp. I copied this icon to the all users folder. And it does
    > appear on other users desktops. however the compatibility properties do
    > not
    > stay for the user. They lose there settings. Is there a way to fix this?
    Andre Da Costa, Feb 7, 2006
    #2
    1. Advertising

  3. I'm not positive this will work, but it's an old Terminal Server trick that
    does work for a lot of things. First, create it as you want it, and get it
    working. Use an account at the level that it will need to run as. Then, copy
    that profile to the default user profile. (Log in as an administrator,
    select user profiles from system properties, advanced. Highlight the source
    profile, click Copy, browse to Default User. Then select Permitted to Use
    and set to All users.) Now, when new user profiles are created, you'll get
    this along with it. Test on a new account to make sure it does what you
    need, then delete existing profiles to force users to get a new copy of the
    default profile, after warning your users, of course.

    --
    Charlie.
    http://msmvps.com/xperts64

    Russ Svendsen wrote:
    > I have a program that is 32 bit. And we would like to run this on windows
    > 2003 x64 terminal server. And it does if the program compatibility icon is
    > set to windows xp. I copied this icon to the all users folder. And it does
    > appear on other users desktops. however the compatibility properties do
    > not stay for the user. They lose there settings. Is there a way to fix
    > this?
    Charlie Russel - MVP, Feb 7, 2006
    #3
  4. I got it thanks for your help guys. I monitored the registry Andre wsa right
    it is local to the user. And in

    HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

    A key with the Full path and exe is created. Example
    "c:\program files\office\word\winword.exe" And a value is set to "WINXP"
    I wrote a script that runs when the user logins via gpo. And the icon then
    works correctly.

    Thanks for you help again.

    "Charlie Russel - MVP" wrote:

    > I'm not positive this will work, but it's an old Terminal Server trick that
    > does work for a lot of things. First, create it as you want it, and get it
    > working. Use an account at the level that it will need to run as. Then, copy
    > that profile to the default user profile. (Log in as an administrator,
    > select user profiles from system properties, advanced. Highlight the source
    > profile, click Copy, browse to Default User. Then select Permitted to Use
    > and set to All users.) Now, when new user profiles are created, you'll get
    > this along with it. Test on a new account to make sure it does what you
    > need, then delete existing profiles to force users to get a new copy of the
    > default profile, after warning your users, of course.
    >
    > --
    > Charlie.
    > http://msmvps.com/xperts64
    >
    > Russ Svendsen wrote:
    > > I have a program that is 32 bit. And we would like to run this on windows
    > > 2003 x64 terminal server. And it does if the program compatibility icon is
    > > set to windows xp. I copied this icon to the all users folder. And it does
    > > appear on other users desktops. however the compatibility properties do
    > > not stay for the user. They lose there settings. Is there a way to fix
    > > this?

    >
    >
    >
    =?Utf-8?B?UnVzcyBTdmVuZHNlbg==?=, Feb 7, 2006
    #4
  5. Glad you got everything in order. :)
    --
    Andre
    Extended64 | http://www.extended64.com
    Blog | http://www.extended64.com/blogs/andre
    http://spaces.msn.com/members/adacosta
    FAQ for MS AntiSpy http://www.geocities.com/marfer_mvp/FAQ_MSantispy.htm

    "Russ Svendsen" <> wrote in message
    news:...
    >I got it thanks for your help guys. I monitored the registry Andre wsa
    >right
    > it is local to the user. And in
    >
    > HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
    >
    > A key with the Full path and exe is created. Example
    > "c:\program files\office\word\winword.exe" And a value is set to "WINXP"
    > I wrote a script that runs when the user logins via gpo. And the icon
    > then
    > works correctly.
    >
    > Thanks for you help again.
    >
    > "Charlie Russel - MVP" wrote:
    >
    >> I'm not positive this will work, but it's an old Terminal Server trick
    >> that
    >> does work for a lot of things. First, create it as you want it, and get
    >> it
    >> working. Use an account at the level that it will need to run as. Then,
    >> copy
    >> that profile to the default user profile. (Log in as an administrator,
    >> select user profiles from system properties, advanced. Highlight the
    >> source
    >> profile, click Copy, browse to Default User. Then select Permitted to Use
    >> and set to All users.) Now, when new user profiles are created, you'll
    >> get
    >> this along with it. Test on a new account to make sure it does what you
    >> need, then delete existing profiles to force users to get a new copy of
    >> the
    >> default profile, after warning your users, of course.
    >>
    >> --
    >> Charlie.
    >> http://msmvps.com/xperts64
    >>
    >> Russ Svendsen wrote:
    >> > I have a program that is 32 bit. And we would like to run this on
    >> > windows
    >> > 2003 x64 terminal server. And it does if the program compatibility icon
    >> > is
    >> > set to windows xp. I copied this icon to the all users folder. And it
    >> > does
    >> > appear on other users desktops. however the compatibility properties do
    >> > not stay for the user. They lose there settings. Is there a way to fix
    >> > this?

    >>
    >>
    >>
    Andre Da Costa [Extended64], Feb 7, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RFdhdHNvbg==?=

    64 bit hardware, compatibility with 32 bit OS

    =?Utf-8?B?RFdhdHNvbg==?=, Apr 14, 2007, in forum: Windows 64bit
    Replies:
    4
    Views:
    454
    =?Utf-8?B?RFdhdHNvbg==?=
    Apr 14, 2007
  2. =?Utf-8?B?Smlucw==?=

    running 32-bit program on a 64-bit OS.??

    =?Utf-8?B?Smlucw==?=, Oct 11, 2007, in forum: Windows 64bit
    Replies:
    3
    Views:
    701
    R. C. White
    Oct 19, 2007
  3. BP
    Replies:
    2
    Views:
    1,074
    PhilSweet
    Dec 19, 2008
  4. Homer J. Simpson
    Replies:
    5
    Views:
    718
    Jim Barry
    Jan 19, 2009
  5. David B.
    Replies:
    0
    Views:
    458
    David B.
    Jan 20, 2009
Loading...

Share This Page