2950 trunk

Discussion in 'Cisco' started by John Tressle, Apr 2, 2007.

  1. John Tressle

    John Tressle Guest

    Help! I'm trying to setup a trunk between 2 x 2950 switches so that I can
    access all vlans from both switches. Devices patched into vlan1 can see each
    other no problem but I can't seem to get any other vlans working over the
    trunk. I'm testing by pinging the devices patched into the appropriate vlans
    on the other switch - there's no routing involved. Configs of both switches
    are below - any help would be greatly appreciated!

    Cheers,
    John

    SWITCH1#show running-config
    Building configuration...

    Current configuration : 3339 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log datetime
    no service password-encryption
    service sequence-numbers
    !
    hostname SWITCH1
    !
    enable secret 5 -------------------
    enable password -------------------
    !
    ip subnet-zero
    no ip finger
    !
    !
    no spanning-tree vlan 2
    no spanning-tree vlan 3
    no spanning-tree vlan 4
    no spanning-tree vlan 5
    no spanning-tree vlan 6
    !
    !
    interface FastEthernet0/1
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/2
    switchport access vlan 5
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/3
    switchport mode access
    !
    interface FastEthernet0/4
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/5
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/6
    switchport mode access
    !
    interface FastEthernet0/7
    switchport mode access
    !
    interface FastEthernet0/8
    switchport mode access
    !
    interface FastEthernet0/9
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 10
    !
    interface FastEthernet0/10
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/11
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/12
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/13
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 10
    !
    interface FastEthernet0/14
    switchport access vlan 2
    switchport mode access
    duplex full
    speed 10
    !
    interface FastEthernet0/15
    switchport access vlan 2
    switchport mode access
    duplex full
    speed 10
    !
    interface FastEthernet0/16
    switchport access vlan 2
    switchport mode access
    duplex full
    speed 10
    !
    interface FastEthernet0/17
    switchport access vlan 2
    switchport mode access
    duplex full
    speed 10
    !
    interface FastEthernet0/18
    switchport access vlan 5
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/19
    switchport access vlan 5
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/20
    switchport mode trunk
    switchport nonegotiate
    duplex full
    speed 10
    !
    interface FastEthernet0/21
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/22
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/23
    switchport access vlan 4
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/24
    switchport access vlan 6
    switchport mode access
    !
    interface Vlan1
    ip address 192.168.1.3 255.255.255.0
    no ip route-cache
    !
    ip http server
    !
    line con 0
    transport input none
    line vty 0 4
    password ----------
    login
    line vty 5 15
    password M----------
    login
    !
    end



    SWITCH1#show interface trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/20 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/20 1-1005

    Port Vlans allowed and active in management domain
    Fa0/20 1-5,99

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/20 1-5,99


    ----------------------------------------------------------------------------------------

    SWITCH2#show running-config
    Building configuration...

    Current configuration : 1346 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname SWITCH2
    !
    enable secret 5 -------------------
    enable password -------------------
    !
    ip subnet-zero
    !
    !
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    no spanning-tree vlan 2-6
    !
    !
    !
    !
    interface FastEthernet0/1
    switchport mode trunk
    switchport nonegotiate
    speed 10
    duplex full
    spanning-tree bpduguard disable
    !
    interface FastEthernet0/2
    switchport mode access
    speed 100
    duplex full
    !
    interface FastEthernet0/3
    switchport mode access
    speed 100
    duplex full
    !
    interface FastEthernet0/4
    switchport access vlan 2
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/5
    switchport access vlan 2
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/6
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/7
    switchport access vlan 3
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/8
    switchport access vlan 4
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/9
    switchport access vlan 4
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/10
    switchport access vlan 5
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/11
    switchport access vlan 5
    switchport mode access
    duplex full
    speed 100
    !
    interface FastEthernet0/12
    speed 100
    duplex full
    !
    interface Vlan1
    ip address 192.168.1.2 255.255.255.0
    no ip route-cache
    !
    ip http server
    !
    line con 0
    line vty 0 4
    password ----------
    login
    line vty 5 15
    password ----------
    login
    !
    !
    end



    SWITCH2#show interface trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/1 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/1 1-4094

    Port Vlans allowed and active in management domain
    Fa0/1 1-5,99

    Port Vlans in spanning tree forwarding state and not pruned
     
    John Tressle, Apr 2, 2007
    #1
    1. Advertising

  2. John Tressle

    BernieM Guest

    "John Tressle" <> wrote in message
    news:cgdQh.20693$...
    > Help! I'm trying to setup a trunk between 2 x 2950 switches so that I can
    > access all vlans from both switches. Devices patched into vlan1 can see
    > each other no problem but I can't seem to get any other vlans working over
    > the trunk. I'm testing by pinging the devices patched into the appropriate
    > vlans on the other switch - there's no routing involved. Configs of both
    > switches are below - any help would be greatly appreciated!
    >
    > Cheers,
    > John
    >
    > SWITCH1#show running-config
    > Building configuration...
    >
    > Current configuration : 3339 bytes
    > !
    > version 12.1
    > no service pad
    > service timestamps debug uptime
    > service timestamps log datetime
    > no service password-encryption
    > service sequence-numbers
    > !
    > hostname SWITCH1
    > !
    > enable secret 5 -------------------
    > enable password -------------------
    > !
    > ip subnet-zero
    > no ip finger
    > !
    > !
    > no spanning-tree vlan 2
    > no spanning-tree vlan 3
    > no spanning-tree vlan 4
    > no spanning-tree vlan 5
    > no spanning-tree vlan 6
    > !
    > !
    > interface FastEthernet0/1
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/2
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/3
    > switchport mode access
    > !
    > interface FastEthernet0/4
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/6
    > switchport mode access
    > !
    > interface FastEthernet0/7
    > switchport mode access
    > !
    > interface FastEthernet0/8
    > switchport mode access
    > !
    > interface FastEthernet0/9
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/10
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/11
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/12
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/13
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/14
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/15
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/16
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/17
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/18
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/19
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/20
    > switchport mode trunk
    > switchport nonegotiate
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/21
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/22
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/23
    > switchport access vlan 4
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/24
    > switchport access vlan 6
    > switchport mode access
    > !
    > interface Vlan1
    > ip address 192.168.1.3 255.255.255.0
    > no ip route-cache
    > !
    > ip http server
    > !
    > line con 0
    > transport input none
    > line vty 0 4
    > password ----------
    > login
    > line vty 5 15
    > password M----------
    > login
    > !
    > end
    >
    >
    >
    > SWITCH1#show interface trunk
    >
    > Port Mode Encapsulation Status Native vlan
    > Fa0/20 on 802.1q trunking 1
    >
    > Port Vlans allowed on trunk
    > Fa0/20 1-1005
    >
    > Port Vlans allowed and active in management domain
    > Fa0/20 1-5,99
    >
    > Port Vlans in spanning tree forwarding state and not pruned
    > Fa0/20 1-5,99
    >
    >
    > ----------------------------------------------------------------------------------------
    >
    > SWITCH2#show running-config
    > Building configuration...
    >
    > Current configuration : 1346 bytes
    > !
    > version 12.1
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname SWITCH2
    > !
    > enable secret 5 -------------------
    > enable password -------------------
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > spanning-tree mode pvst
    > no spanning-tree optimize bpdu transmission
    > spanning-tree extend system-id
    > no spanning-tree vlan 2-6
    > !
    > !
    > !
    > !
    > interface FastEthernet0/1
    > switchport mode trunk
    > switchport nonegotiate
    > speed 10
    > duplex full
    > spanning-tree bpduguard disable
    > !
    > interface FastEthernet0/2
    > switchport mode access
    > speed 100
    > duplex full
    > !
    > interface FastEthernet0/3
    > switchport mode access
    > speed 100
    > duplex full
    > !
    > interface FastEthernet0/4
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/5
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/6
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/7
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/8
    > switchport access vlan 4
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/9
    > switchport access vlan 4
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/10
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/11
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/12
    > speed 100
    > duplex full
    > !
    > interface Vlan1
    > ip address 192.168.1.2 255.255.255.0
    > no ip route-cache
    > !
    > ip http server
    > !
    > line con 0
    > line vty 0 4
    > password ----------
    > login
    > line vty 5 15
    > password ----------
    > login
    > !
    > !
    > end
    >
    >
    >
    > SWITCH2#show interface trunk
    >
    > Port Mode Encapsulation Status Native vlan
    > Fa0/1 on 802.1q trunking 1
    >
    > Port Vlans allowed on trunk
    > Fa0/1 1-4094
    >
    > Port Vlans allowed and active in management domain
    > Fa0/1 1-5,99
    >
    > Port Vlans in spanning tree forwarding state and not pruned


    Have you actually created the other vlans on the switches?
     
    BernieM, Apr 3, 2007
    #2
    1. Advertising

  3. John Tressle

    Trendkill Guest

    On Apr 2, 3:59 pm, "John Tressle" <> wrote:
    > Help! I'm trying to setup a trunk between 2 x 2950 switches so that I can
    > access all vlans from both switches. Devices patched into vlan1 can see each
    > other no problem but I can't seem to get any other vlans working over the
    > trunk. I'm testing by pinging the devices patched into the appropriate vlans
    > on the other switch - there's no routing involved. Configs of both switches
    > are below - any help would be greatly appreciated!
    >
    > Cheers,
    > John
    >
    > SWITCH1#show running-config
    > Building configuration...
    >
    > Current configuration : 3339 bytes
    > !
    > version 12.1
    > no service pad
    > service timestamps debug uptime
    > service timestamps log datetime
    > no service password-encryption
    > service sequence-numbers
    > !
    > hostname SWITCH1
    > !
    > enable secret 5 -------------------
    > enable password -------------------
    > !
    > ip subnet-zero
    > no ip finger
    > !
    > !
    > no spanning-tree vlan 2
    > no spanning-tree vlan 3
    > no spanning-tree vlan 4
    > no spanning-tree vlan 5
    > no spanning-tree vlan 6
    > !
    > !
    > interface FastEthernet0/1
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/2
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/3
    > switchport mode access
    > !
    > interface FastEthernet0/4
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/6
    > switchport mode access
    > !
    > interface FastEthernet0/7
    > switchport mode access
    > !
    > interface FastEthernet0/8
    > switchport mode access
    > !
    > interface FastEthernet0/9
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/10
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/11
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/12
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/13
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/14
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/15
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/16
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/17
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/18
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/19
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/20
    > switchport mode trunk
    > switchport nonegotiate
    > duplex full
    > speed 10
    > !
    > interface FastEthernet0/21
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/22
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/23
    > switchport access vlan 4
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/24
    > switchport access vlan 6
    > switchport mode access
    > !
    > interface Vlan1
    > ip address 192.168.1.3 255.255.255.0
    > no ip route-cache
    > !
    > ip http server
    > !
    > line con 0
    > transport input none
    > line vty 0 4
    > password ----------
    > login
    > line vty 5 15
    > password M----------
    > login
    > !
    > end
    >
    > SWITCH1#show interface trunk
    >
    > Port Mode Encapsulation Status Native vlan
    > Fa0/20 on 802.1q trunking 1
    >
    > Port Vlans allowed on trunk
    > Fa0/20 1-1005
    >
    > Port Vlans allowed and active in management domain
    > Fa0/20 1-5,99
    >
    > Port Vlans in spanning tree forwarding state and not pruned
    > Fa0/20 1-5,99
    >
    > ----------------------------------------------------------------------------------------
    >
    > SWITCH2#show running-config
    > Building configuration...
    >
    > Current configuration : 1346 bytes
    > !
    > version 12.1
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname SWITCH2
    > !
    > enable secret 5 -------------------
    > enable password -------------------
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > spanning-tree mode pvst
    > no spanning-tree optimize bpdu transmission
    > spanning-tree extend system-id
    > no spanning-tree vlan 2-6
    > !
    > !
    > !
    > !
    > interface FastEthernet0/1
    > switchport mode trunk
    > switchport nonegotiate
    > speed 10
    > duplex full
    > spanning-tree bpduguard disable
    > !
    > interface FastEthernet0/2
    > switchport mode access
    > speed 100
    > duplex full
    > !
    > interface FastEthernet0/3
    > switchport mode access
    > speed 100
    > duplex full
    > !
    > interface FastEthernet0/4
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/5
    > switchport access vlan 2
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/6
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/7
    > switchport access vlan 3
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/8
    > switchport access vlan 4
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/9
    > switchport access vlan 4
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/10
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/11
    > switchport access vlan 5
    > switchport mode access
    > duplex full
    > speed 100
    > !
    > interface FastEthernet0/12
    > speed 100
    > duplex full
    > !
    > interface Vlan1
    > ip address 192.168.1.2 255.255.255.0
    > no ip route-cache
    > !
    > ip http server
    > !
    > line con 0
    > line vty 0 4
    > password ----------
    > login
    > line vty 5 15
    > password ----------
    > login
    > !
    > !
    > end
    >
    > SWITCH2#show interface trunk
    >
    > Port Mode Encapsulation Status Native vlan
    > Fa0/1 on 802.1q trunking 1
    >
    > Port Vlans allowed on trunk
    > Fa0/1 1-4094
    >
    > Port Vlans allowed and active in management domain
    > Fa0/1 1-5,99
    >
    > Port Vlans in spanning tree forwarding state and not pruned


    You need to run VTP. Second, you need to make sure that the VLANs are
    showing as up/up in show ip int brief. This will require either an
    interface that is up in those VLANs, or a configured layer 3 interface.
     
    Trendkill, Apr 3, 2007
    #3
  4. John Tressle

    John Tressle Guest

    >
    > You need to run VTP. Second, you need to make sure that the VLANs are
    > showing as up/up in show ip int brief. This will require either an
    > interface that is up in those VLANs, or a configured layer 3 interface.
    >


    I deleted all VLANS on switch2, configured switch1 as a VTP server and
    switch2 as a VTP client - both in the same VTP domain. I can see the VLANS
    have been transferred to switch2 and if I plug 2 devices into the same VLAN
    on switch2 (e.g. vlan2) they can ping each other. They still can't ping a
    device plugged into vlan2 on switch1 however. Devices patched into vlan1
    only can ping each other across the link.

    Is there anything else I'm missing here? - I'm at my wits end!

    Many thanks,
    John
     
    John Tressle, Apr 3, 2007
    #4
  5. John Tressle

    Trendkill Guest

    On Apr 3, 2:20 pm, "John Tressle" <> wrote:
    > > You need to run VTP. Second, you need to make sure that the VLANs are
    > > showing as up/up in show ip int brief. This will require either an
    > > interface that is up in those VLANs, or a configured layer 3 interface.

    >
    > I deleted all VLANS on switch2, configured switch1 as a VTP server and
    > switch2 as a VTP client - both in the same VTP domain. I can see the VLANS
    > have been transferred to switch2 and if I plug 2 devices into the same VLAN
    > on switch2 (e.g. vlan2) they can ping each other. They still can't ping a
    > device plugged into vlan2 on switch1 however. Devices patched into vlan1
    > only can ping each other across the link.
    >
    > Is there anything else I'm missing here? - I'm at my wits end!
    >
    > Many thanks,
    > John


    paste configs again please. Along with show ip int brief, show int
    trunk, show spanning-tree vlan 1 and show spanning-tree vlan 2 on the
    switches.

    What ip range is vlan 1 vs. 2?
     
    Trendkill, Apr 3, 2007
    #5
  6. John Tressle

    Brian V Guest

    "John Tressle" <> wrote in message
    news:wVwQh.29891$...
    > >
    >> You need to run VTP. Second, you need to make sure that the VLANs are
    >> showing as up/up in show ip int brief. This will require either an
    >> interface that is up in those VLANs, or a configured layer 3 interface.
    >>

    >
    > I deleted all VLANS on switch2, configured switch1 as a VTP server and
    > switch2 as a VTP client - both in the same VTP domain. I can see the VLANS
    > have been transferred to switch2 and if I plug 2 devices into the same
    > VLAN on switch2 (e.g. vlan2) they can ping each other. They still can't
    > ping a device plugged into vlan2 on switch1 however. Devices patched into
    > vlan1 only can ping each other across the link.
    >
    > Is there anything else I'm missing here? - I'm at my wits end!
    >
    > Many thanks,
    > John


    what are you using to route the vlans? The 2950 is only a layer 2 switch,
    the vlans will never be able to talk to eachother without a layer 3 device.
     
    Brian V, Apr 3, 2007
    #6
  7. John Tressle

    Smokey Guest

    Brian V wrote:
    >
    > what are you using to route the vlans? The 2950 is only a layer 2 switch,
    > the vlans will never be able to talk to eachother without a layer 3 device.
    >
    >


    You should be able to create vlans on 2 switches and communicate as long
    as the 2 devices are in the same vlan. you do not need a layer 3 device
    unless you are routing to a different vlan.
     
    Smokey, Apr 3, 2007
    #7
  8. John Tressle

    BernieM Guest

    "John Tressle" <> wrote in message
    news:wVwQh.29891$...
    > >
    >> You need to run VTP. Second, you need to make sure that the VLANs are
    >> showing as up/up in show ip int brief. This will require either an
    >> interface that is up in those VLANs, or a configured layer 3 interface.
    >>

    >
    > I deleted all VLANS on switch2, configured switch1 as a VTP server and
    > switch2 as a VTP client - both in the same VTP domain. I can see the VLANS
    > have been transferred to switch2 and if I plug 2 devices into the same
    > VLAN on switch2 (e.g. vlan2) they can ping each other. They still can't
    > ping a device plugged into vlan2 on switch1 however. Devices patched into
    > vlan1 only can ping each other across the link.
    >
    > Is there anything else I'm missing here? - I'm at my wits end!
    >
    > Many thanks,
    > John


    There's no specific requirement to run vtp at all. We run a network of
    6500's, 3750's, 3560's and 2950's and do not use vtp. I'd steer away from
    the default values ie. instead of assuming "switchport trunk allowed vlan
    all" is active, actually configure what vlans you want trunked ...
    "switchport trunk allowed vlan <vlan list>".

    I'm curious as to why you have disabled spanning tree. If you're concerned
    about delays with ports becoming active just configure "spanning-tree
    portfast" on access ports. With spanning-tree enabled you'll be able to see
    the layer-2 topology using "show spanning-tree vlan <vlan id>".

    BernieM
     
    BernieM, Apr 3, 2007
    #8
  9. John Tressle

    linkwood Guest

    Hi John,

    why do you use 10Mbps for the trunk?
    I'm not shure whether 802.1q is running on 10Mbps.

    If it doesn't help:
    send an overview, something like
    PC - fa0/1 - switchA - fa0/20 - fa0/1 - switchB - fa0/24 PC
    send also a "show cdp neigh"
    and of course the config (if you've allredy changed something)

    lw
     
    linkwood, Apr 3, 2007
    #9
  10. John Tressle

    John Tressle Guest

    >
    > why do you use 10Mbps for the trunk?
    > I'm not shure whether 802.1q is running on 10Mbps.
    >
    > If it doesn't help:
    > send an overview, something like
    > PC - fa0/1 - switchA - fa0/20 - fa0/1 - switchB - fa0/24 PC
    > send also a "show cdp neigh"
    > and of course the config (if you've allredy changed something)
    >
    > lw


    Thanks for your help with this so far - it's really appreciated. The trunk
    ports are currently set to 10Mb because the link between the 2 switches is
    actually a leased line which is presented as 10Mb on both ends - should this
    make a difference?

    The connection is not routed - up until this point we've been using the
    connection specifically for vlan1 traffic with devices on the same subnet
    (192.168.1.0/24) connected on both ends without a problem. We're
    implementing the trunk because we now need devices on the 2nd switch on
    other vlans (again no routing involved - devices within vlans on both
    switches are configured in the same subnet). To confirm - since implementing
    the trunk, devices on vlan1 can ping each other over the trunk - but no
    devices in other vlans will see each other. Spanning Tree is disabled
    because we had problems connecting our Internet connection (VLAN2 on switch
    1) and were recommended to disable by the provider.

    I've attached show interface trunk, the current vlans, show cdp neighbor and
    show ip interface brief:

    Thanks again for your assistance,
    John



    SWITCH1#show interface trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/20 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/20 1-1005

    Port Vlans allowed and active in management domain
    Fa0/20 1-6,99

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/20 1,6




    SWITCH1#show cdp neigh
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
    S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    SWITCH2 Fas 0/20 125 S I WS-C2950-1Fas 0/1
    SWITCH3 Fas 0/18 172 S I WS-C2950-2Fas 0/20


    SWITCH1 (vlan)#show current
    VLAN ISL Id: 1
    Name: default
    Media Type: Ethernet
    VLAN 802.10 Id: 100001
    State: Operational
    MTU: 1500

    VLAN ISL Id: 2
    Name: VLAN0002
    Media Type: Ethernet
    VLAN 802.10 Id: 100002
    State: Operational
    MTU: 1500

    VLAN ISL Id: 3
    Name: VLAN0003
    Media Type: Ethernet
    VLAN 802.10 Id: 100003
    State: Operational
    MTU: 1500

    VLAN ISL Id: 4
    Name: VLAN0004
    Media Type: Ethernet
    VLAN 802.10 Id: 100004
    State: Operational
    MTU: 1500

    VLAN ISL Id: 5
    Name: VLAN0005
    Media Type: Ethernet
    VLAN 802.10 Id: 100005
    State: Operational
    MTU: 1500

    VLAN ISL Id: 6
    Name: VLAN0006
    Media Type: Ethernet
    VLAN 802.10 Id: 100006
    State: Operational
    MTU: 1500

    VLAN ISL Id: 99
    Name: Autotest_Lab
    Media Type: Ethernet
    VLAN 802.10 Id: 100099
    State: Operational
    MTU: 1500

    VLAN ISL Id: 1002
    Name: fddi-default
    Media Type: FDDI
    VLAN 802.10 Id: 101002
    State: Operational
    MTU: 1500
    Ring Number: 0

    VLAN ISL Id: 1003
    Name: token-ring-default
    Media Type: Token Ring
    VLAN 802.10 Id: 101003
    State: Operational
    MTU: 1500
    Ring Number: 0

    VLAN ISL Id: 1004
    Name: fddinet-default
    Media Type: FDDI Net
    VLAN 802.10 Id: 101004
    State: Operational
    MTU: 1500
    Bridge Number: 1
    STP Type: IEEE

    VLAN ISL Id: 1005
    Name: trnet-default
    Media Type: Token Ring Net
    VLAN 802.10 Id: 101005
    State: Operational
    MTU: 1500
    STP Type: IBM


    SWITCH1#show ip interface brief
    Interface IP-Address OK? Method Status
    Protocol
    Vlan1 192.168.1.3 YES NVRAM up
    up

    FastEthernet0/1 unassigned YES unset up
    up

    FastEthernet0/2 unassigned YES unset up
    up

    FastEthernet0/3 unassigned YES unset up
    up

    FastEthernet0/4 unassigned YES unset up
    up

    FastEthernet0/5 unassigned YES unset up
    up

    FastEthernet0/6 unassigned YES unset up
    down

    FastEthernet0/7 unassigned YES unset up
    up

    FastEthernet0/8 unassigned YES unset up
    up

    FastEthernet0/9 unassigned YES unset up
    up

    FastEthernet0/10 unassigned YES unset up
    up

    FastEthernet0/11 unassigned YES unset up
    up

    FastEthernet0/12 unassigned YES unset up
    up

    FastEthernet0/13 unassigned YES unset up
    up

    FastEthernet0/14 unassigned YES unset up
    up

    FastEthernet0/15 unassigned YES unset up
    up

    FastEthernet0/16 unassigned YES unset up
    up

    FastEthernet0/17 unassigned YES unset up
    up

    FastEthernet0/18 unassigned YES unset up
    up

    FastEthernet0/19 unassigned YES unset up
    up

    FastEthernet0/20 unassigned YES unset up
    up

    FastEthernet0/21 unassigned YES unset up
    down

    FastEthernet0/22 unassigned YES unset up
    down

    FastEthernet0/23 unassigned YES unset up
    down

    FastEthernet0/24 unassigned YES unset up
    down



    SWITCH2#show interface trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/1 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/1 1-4094

    Port Vlans allowed and active in management domain
    Fa0/1 1-6,99

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/1 1-3,5-6



    SWITCH2#show cdp neigh
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
    S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    SWITCH1 Fas 0/1 155 S I WS-C2950-2Fas 0/20



    SWITCH2(vlan)#show current
    VLAN ISL Id: 1
    Name: default
    Media Type: Ethernet
    VLAN 802.10 Id: 100001
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 2
    Name: VLAN0002
    Media Type: Ethernet
    VLAN 802.10 Id: 100002
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 3
    Name: VLAN0003
    Media Type: Ethernet
    VLAN 802.10 Id: 100003
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 4
    Name: VLAN0004
    Media Type: Ethernet
    VLAN 802.10 Id: 100004
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 5
    Name: VLAN0005
    Media Type: Ethernet
    VLAN 802.10 Id: 100005
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 6
    Name: VLAN0006
    Media Type: Ethernet
    VLAN 802.10 Id: 100006
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 99
    Name: Autotest_Lab
    Media Type: Ethernet
    VLAN 802.10 Id: 100099
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 1002
    Name: fddi-default
    Media Type: FDDI
    VLAN 802.10 Id: 101002
    State: Operational
    MTU: 1500
    Bridge Type: SRB
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 1003
    Name: token-ring-default
    Media Type: Token Ring
    VLAN 802.10 Id: 101003
    State: Operational
    MTU: 1500
    Bridge Type: SRB
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 1004
    Name: fddinet-default
    Media Type: FDDI Net
    VLAN 802.10 Id: 101004
    State: Operational
    MTU: 1500
    Bridge Number: 1
    STP Type: IEEE
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    VLAN ISL Id: 1005
    Name: trnet-default
    Media Type: Token Ring Net
    VLAN 802.10 Id: 101005
    State: Operational
    MTU: 1500
    Bridge Number: 1
    STP Type: IBM
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

    SWITCH2#show ip int brief
    Interface IP-Address OK? Method Status
    Protocol
    Vlan1 192.168.1.2 YES manual up
    up

    FastEthernet0/1 unassigned YES unset up
    up

    FastEthernet0/2 unassigned YES unset up
    up

    FastEthernet0/3 unassigned YES unset up
    up

    FastEthernet0/4 unassigned YES unset up
    up

    FastEthernet0/5 unassigned YES unset up
    up

    FastEthernet0/6 unassigned YES unset up
    up

    FastEthernet0/7 unassigned YES unset up
    up

    FastEthernet0/8 unassigned YES unset up
    up

    FastEthernet0/9 unassigned YES unset up
    up

    FastEthernet0/10 unassigned YES unset up
    up

    FastEthernet0/11 unassigned YES unset up
    up

    FastEthernet0/12 unassigned YES unset up
    up
     
    John Tressle, Apr 3, 2007
    #10
  11. John Tressle

    Brian V Guest

    "Smokey" <> wrote in message
    news:...
    > Brian V wrote:
    >>
    >> what are you using to route the vlans? The 2950 is only a layer 2 switch,
    >> the vlans will never be able to talk to eachother without a layer 3
    >> device.

    >
    > You should be able to create vlans on 2 switches and communicate as long
    > as the 2 devices are in the same vlan. you do not need a layer 3 device
    > unless you are routing to a different vlan.


    Obviously. I misread his statement, I thought he said devices within the
    same vlan could ping eachother but could not ping other vlans which would
    imply a layer 3 device is needed.
     
    Brian V, Apr 4, 2007
    #11
  12. John Tressle

    BernieM Guest

    "John Tressle" <> wrote in message
    news:s0AQh.32296$...
    > >
    >> why do you use 10Mbps for the trunk?
    >> I'm not shure whether 802.1q is running on 10Mbps.
    >>
    >> If it doesn't help:
    >> send an overview, something like
    >> PC - fa0/1 - switchA - fa0/20 - fa0/1 - switchB - fa0/24 PC
    >> send also a "show cdp neigh"
    >> and of course the config (if you've allredy changed something)
    >>
    >> lw

    >
    > Thanks for your help with this so far - it's really appreciated. The trunk
    > ports are currently set to 10Mb because the link between the 2 switches is
    > actually a leased line which is presented as 10Mb on both ends - should
    > this make a difference?
    >


    I think you'll find it's what makes the difference. Does your vendor
    support the trunking of 'non-default vlans'? ie. provide for the other
    vlans being trunked through their equipment.

    BernieM
     
    BernieM, Apr 4, 2007
    #12
  13. John Tressle

    Peter Guest

    Hi John,

    > Thanks for your help with this so far - it's really appreciated. The trunk
    > ports are currently set to 10Mb because the link between the 2 switches is
    > actually a leased line which is presented as 10Mb on both ends - should this
    > make a difference?


    What format is this "Leased Line" presented in, is it capable of
    passing data as a TRUNK or is it presented as a simple VLAN itself? If
    it is a simple VLAN, then it will only be capable of delivering the
    DEFAULT vlan for the switch, which is VLAN 1, as your TRUNK port will
    be treated as an ACCESS port by the WAN link. You could test this by
    changing the DEFAULT VLAN on the switch and see if that one is passed
    instead of VLAN 1.

    Cheers.................pk.


    --
    Peter from Auckland.
     
    Peter, Apr 4, 2007
    #13
  14. John Tressle

    John Tressle Guest

    > Hi John,
    >
    >> Thanks for your help with this so far - it's really appreciated. The
    >> trunk
    >> ports are currently set to 10Mb because the link between the 2 switches
    >> is
    >> actually a leased line which is presented as 10Mb on both ends - should
    >> this
    >> make a difference?

    >
    > What format is this "Leased Line" presented in, is it capable of
    > passing data as a TRUNK or is it presented as a simple VLAN itself? If
    > it is a simple VLAN, then it will only be capable of delivering the
    > DEFAULT vlan for the switch, which is VLAN 1, as your TRUNK port will
    > be treated as an ACCESS port by the WAN link. You could test this by
    > changing the DEFAULT VLAN on the switch and see if that one is passed
    > instead of VLAN 1.
    >
    > Cheers.................pk.
    >
    >
    > --
    > Peter from Auckland.


    Guys - thanks for all your help with this. I've spoken with the provider of
    the leased line and that is indeed where the problem lies. Hopefully they'll
    be able to enable this on the line which should sort out my issue. Thanks
    again - you've saved my a great deal of time.

    Cheers,
    John
     
    John Tressle, Apr 4, 2007
    #14
  15. John Tressle

    linkwood Guest

    Hi John,

    I guess your provider somehow drops 802.1q tagged frames.
    (Since vlan1 is native it's not tagged and therefor it works)
    This could be due to the fact that the provider provides a vlan to you.
    So if this provider vlan should support transport of your vlans your
    provider needs to support Q-in-Q tagging.

    Best way is to check this with your provider since as far as I can see
    your config should work.

    Regards
    lw
     
    linkwood, Apr 4, 2007
    #15
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Siegbert =?iso-8859-1?Q?M=FCller?=

    Re: cat 5000 trunk poort error disabled.

    Siegbert =?iso-8859-1?Q?M=FCller?=, Jul 8, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,323
    Siegbert =?iso-8859-1?Q?M=FCller?=
    Jul 8, 2003
  2. J
    Replies:
    3
    Views:
    3,499
  3. filouchke
    Replies:
    0
    Views:
    744
    filouchke
    Nov 15, 2006
  4. Tacobell
    Replies:
    5
    Views:
    4,550
  5. nbywater

    2950 to 7200 trunk

    nbywater, Jul 3, 2007, in forum: Cisco
    Replies:
    0
    Views:
    460
    nbywater
    Jul 3, 2007
Loading...

Share This Page