2924 + vlans

Discussion in 'Cisco' started by turnip, Oct 2, 2007.

  1. turnip

    turnip Guest

    I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    the trunks between switches set up via port group 1 on 2 interfaces on
    each swithc. It seems to work well


    on switch 2, I have defined a vlan for ports 17-24, however after
    doing so, i cannot access any network resources.

    We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    have to upgrade it.. however my question is this

    I never found a place to define the netowrk range for the second
    vlan..
    Reading up, intervace vlan2 ip add.. is just for management.

    So here it is..

    Can I configure this second switch (which is trunked up to the main,
    and hte main goes to the router) to pass all vlans upstream ? Or do I
    need a subinterface on the router with dotq encap and a vlan
    defined ?

    I am a newb to vlans, the switches work just fine, it is just those 8
    ports in vlan 2 that do me no good.

    I have this on both trunks

    interface FastEthernet1/1
    port group 1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,2,1002-1005
    switchport mode trunk
    !
    interface FastEthernet1/2
    port group 1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,2,1002-1005
    switchport mode trunk


    vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    this. But if you have time and dont mind it would rock for some help..

    router -> switch1 <- trunk -> switch2

    the vlan is defined on switch 2.
    turnip, Oct 2, 2007
    #1
    1. Advertising

  2. turnip

    Trendkill Guest

    On Oct 2, 9:48 am, turnip <> wrote:
    > I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    > the trunks between switches set up via port group 1 on 2 interfaces on
    > each swithc. It seems to work well
    >
    > on switch 2, I have defined a vlan for ports 17-24, however after
    > doing so, i cannot access any network resources.
    >
    > We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    > have to upgrade it.. however my question is this
    >
    > I never found a place to define the netowrk range for the second
    > vlan..
    > Reading up, intervace vlan2 ip add.. is just for management.
    >
    > So here it is..
    >
    > Can I configure this second switch (which is trunked up to the main,
    > and hte main goes to the router) to pass all vlans upstream ? Or do I
    > need a subinterface on the router with dotq encap and a vlan
    > defined ?
    >
    > I am a newb to vlans, the switches work just fine, it is just those 8
    > ports in vlan 2 that do me no good.
    >
    > I have this on both trunks
    >
    > interface FastEthernet1/1
    > port group 1
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,2,1002-1005
    > switchport mode trunk
    > !
    > interface FastEthernet1/2
    > port group 1
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,2,1002-1005
    > switchport mode trunk
    >
    > vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    > this. But if you have time and dont mind it would rock for some help..
    >
    > router -> switch1 <- trunk -> switch2
    >
    > the vlan is defined on switch 2.


    I could be off base here, but I thought you could not create more than
    one vlan on a 2924? Doesn't it allow only one SVI? I thought you
    have to create some place else and trunk it in, and then assign the
    ports...but could be wrong...don't work with small switches too often,
    so forgive me if I am off base.

    You may need to create a sub int on the router (unless your other
    switch is something that has more L3 capability, then trunk it from
    the router to switch 1, and then trunk the vlans between the two
    switches.

    Perhaps someone else can help add clarity.
    Trendkill, Oct 2, 2007
    #2
    1. Advertising

  3. turnip

    turnip Guest

    On Oct 2, 10:49 am, Trendkill <> wrote:
    > On Oct 2, 9:48 am, turnip <> wrote:
    >
    >
    >
    >
    >
    > > I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    > > the trunks between switches set up via port group 1 on 2 interfaces on
    > > each swithc. It seems to work well

    >
    > > on switch 2, I have defined a vlan for ports 17-24, however after
    > > doing so, i cannot access any network resources.

    >
    > > We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    > > have to upgrade it.. however my question is this

    >
    > > I never found a place to define the netowrk range for the second
    > > vlan..
    > > Reading up, intervace vlan2 ip add.. is just for management.

    >
    > > So here it is..

    >
    > > Can I configure this second switch (which is trunked up to the main,
    > > and hte main goes to the router) to pass all vlans upstream ? Or do I
    > > need a subinterface on the router with dotq encap and a vlan
    > > defined ?

    >
    > > I am a newb to vlans, the switches work just fine, it is just those 8
    > > ports in vlan 2 that do me no good.

    >
    > > I have this on both trunks

    >
    > > interface FastEthernet1/1
    > > port group 1
    > > switchport trunk encapsulation dot1q
    > > switchport trunk allowed vlan 1,2,1002-1005
    > > switchport mode trunk
    > > !
    > > interface FastEthernet1/2
    > > port group 1
    > > switchport trunk encapsulation dot1q
    > > switchport trunk allowed vlan 1,2,1002-1005
    > > switchport mode trunk

    >
    > > vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    > > this. But if you have time and dont mind it would rock for some help..

    >
    > > router -> switch1 <- trunk -> switch2

    >
    > > the vlan is defined on switch 2.

    >
    > I could be off base here, but I thought you could not create more than
    > one vlan on a 2924? Doesn't it allow only one SVI? I thought you
    > have to create some place else and trunk it in, and then assign the
    > ports...but could be wrong...don't work with small switches too often,
    > so forgive me if I am off base.
    >
    > You may need to create a sub int on the router (unless your other
    > switch is something that has more L3 capability, then trunk it from
    > the router to switch 1, and then trunk the vlans between the two
    > switches.
    >
    > Perhaps someone else can help add clarity.- Hide quoted text -
    >
    > - Show quoted text -


    Building configuration...

    Current configuration:
    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname 192_sub
    !
    enable secret 5 $1$V8a5$.pOnSyDIEGBo01iFaQVZp/
    !
    !
    !
    !
    !
    !
    ip subnet-zero
    ip dhcp-server 192.168.0.111
    !
    !
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface FastEthernet2/1
    port group 1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,2,1002-1005
    switchport mode trunk
    !
    interface FastEthernet2/2
    port group 1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,2,1002-1005
    switchport mode trunk
    !
    interface FastEthernet2/3
    !
    interface FastEthernet2/4
    !
    interface VLAN1
    ip address 192.168.0.249 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    !
    ip default-gateway 192.168.0.253
    snmp-server engineID local 00000009020000D0C0F257C0
    snmp-server community private RW
    snmp-server community public RO
    !
    line con 0
    exec-timeout 0 0
    transport input none
    stopbits 1
    line vty 0 4
    password
    login
    line vty 5 15
    password
    login
    !
    end



    User Access Verification

    Password:
    office_192_main>en
    Password:
    office_192_main#sho vlan
    VLAN Name Status Ports
    ---- -------------------------------- ---------
    -------------------------------
    1 default active Fa0/1, Fa0/2, Fa0/3,
    Fa0/4,
    Fa0/5, Fa0/6, Fa0/7,
    Fa0/8,
    Fa0/9, Fa0/10, Fa0/11,
    Fa0/12,
    Fa0/13, Fa0/14,
    Fa0/15, Fa0/16,
    Fa1/3, Fa1/4
    2 it-dept active Fa0/17, Fa0/18,
    Fa0/19, Fa0/20,
    Fa0/21, Fa0/22,
    Fa0/23, Fa0/24
    1002 fddi-default active
    1003 token-ring-default active
    1004 fddinet-default active
    1005 trnet-default active

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode
    Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- --------
    ------ ------
    1 enet 100001 1500 - - - - -
    0 0
    2 enet 100002 1500 - - - - -
    0 0
    1002 fddi 101002 1500 - - - - -
    0 0
    1003 tr 101003 1500 - - - - srb
    0 0
    1004 fdnet 101004 1500 - - - ieee -
    0 0
    1005 trnet 101005 1500 - - - ibm -
    0 0
    office_192_main#


    that implys it supports more then 1 vlan or am I wrong ?

    The upstream router does not support encap dotq, it doesnt have ipplus
    flash and lacks the mem for it... I am hoping to do this in the switch
    if possible
    turnip, Oct 2, 2007
    #3
  4. turnip

    Trendkill Guest

    On Oct 2, 11:09 am, turnip <> wrote:
    > On Oct 2, 10:49 am, Trendkill <> wrote:
    >
    >
    >
    > > On Oct 2, 9:48 am, turnip <> wrote:

    >
    > > > I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    > > > the trunks between switches set up via port group 1 on 2 interfaces on
    > > > each swithc. It seems to work well

    >
    > > > on switch 2, I have defined a vlan for ports 17-24, however after
    > > > doing so, i cannot access any network resources.

    >
    > > > We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    > > > have to upgrade it.. however my question is this

    >
    > > > I never found a place to define the netowrk range for the second
    > > > vlan..
    > > > Reading up, intervace vlan2 ip add.. is just for management.

    >
    > > > So here it is..

    >
    > > > Can I configure this second switch (which is trunked up to the main,
    > > > and hte main goes to the router) to pass all vlans upstream ? Or do I
    > > > need a subinterface on the router with dotq encap and a vlan
    > > > defined ?

    >
    > > > I am a newb to vlans, the switches work just fine, it is just those 8
    > > > ports in vlan 2 that do me no good.

    >
    > > > I have this on both trunks

    >
    > > > interface FastEthernet1/1
    > > > port group 1
    > > > switchport trunk encapsulation dot1q
    > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > switchport mode trunk
    > > > !
    > > > interface FastEthernet1/2
    > > > port group 1
    > > > switchport trunk encapsulation dot1q
    > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > switchport mode trunk

    >
    > > > vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    > > > this. But if you have time and dont mind it would rock for some help..

    >
    > > > router -> switch1 <- trunk -> switch2

    >
    > > > the vlan is defined on switch 2.

    >
    > > I could be off base here, but I thought you could not create more than
    > > one vlan on a 2924? Doesn't it allow only one SVI? I thought you
    > > have to create some place else and trunk it in, and then assign the
    > > ports...but could be wrong...don't work with small switches too often,
    > > so forgive me if I am off base.

    >
    > > You may need to create a sub int on the router (unless your other
    > > switch is something that has more L3 capability, then trunk it from
    > > the router to switch 1, and then trunk the vlans between the two
    > > switches.

    >
    > > Perhaps someone else can help add clarity.- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > Building configuration...
    >
    > Current configuration:
    > !
    > version 12.0
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname 192_sub
    > !
    > enable secret 5 $1$V8a5$.pOnSyDIEGBo01iFaQVZp/
    > !
    > !
    > !
    > !
    > !
    > !
    > ip subnet-zero
    > ip dhcp-server 192.168.0.111
    > !
    > !
    > !
    > interface FastEthernet0/1
    > !
    > interface FastEthernet0/2
    > !
    > interface FastEthernet0/3
    > !
    > interface FastEthernet0/4
    > !
    > interface FastEthernet0/5
    > !
    > interface FastEthernet0/6
    > !
    > interface FastEthernet0/7
    > !
    > interface FastEthernet0/8
    > !
    > interface FastEthernet0/9
    > !
    > interface FastEthernet0/10
    > !
    > interface FastEthernet0/11
    > !
    > interface FastEthernet0/12
    > !
    > interface FastEthernet0/13
    > !
    > interface FastEthernet0/14
    > !
    > interface FastEthernet0/15
    > !
    > interface FastEthernet0/16
    > !
    > interface FastEthernet0/17
    > !
    > interface FastEthernet0/18
    > !
    > interface FastEthernet0/19
    > !
    > interface FastEthernet0/20
    > !
    > interface FastEthernet0/21
    > !
    > interface FastEthernet0/22
    > !
    > interface FastEthernet0/23
    > !
    > interface FastEthernet0/24
    > !
    > interface FastEthernet2/1
    > port group 1
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,2,1002-1005
    > switchport mode trunk
    > !
    > interface FastEthernet2/2
    > port group 1
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,2,1002-1005
    > switchport mode trunk
    > !
    > interface FastEthernet2/3
    > !
    > interface FastEthernet2/4
    > !
    > interface VLAN1
    > ip address 192.168.0.249 255.255.255.0
    > no ip directed-broadcast
    > no ip route-cache
    > !
    > ip default-gateway 192.168.0.253
    > snmp-server engineID local 00000009020000D0C0F257C0
    > snmp-server community private RW
    > snmp-server community public RO
    > !
    > line con 0
    > exec-timeout 0 0
    > transport input none
    > stopbits 1
    > line vty 0 4
    > password
    > login
    > line vty 5 15
    > password
    > login
    > !
    > end
    >
    > User Access Verification
    >
    > Password:
    > office_192_main>en
    > Password:
    > office_192_main#sho vlan
    > VLAN Name Status Ports
    > ---- -------------------------------- ---------
    > -------------------------------
    > 1 default active Fa0/1, Fa0/2, Fa0/3,
    > Fa0/4,
    > Fa0/5, Fa0/6, Fa0/7,
    > Fa0/8,
    > Fa0/9, Fa0/10, Fa0/11,
    > Fa0/12,
    > Fa0/13, Fa0/14,
    > Fa0/15, Fa0/16,
    > Fa1/3, Fa1/4
    > 2 it-dept active Fa0/17, Fa0/18,
    > Fa0/19, Fa0/20,
    > Fa0/21, Fa0/22,
    > Fa0/23, Fa0/24
    > 1002 fddi-default active
    > 1003 token-ring-default active
    > 1004 fddinet-default active
    > 1005 trnet-default active
    >
    > VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode
    > Trans1 Trans2
    > ---- ----- ---------- ----- ------ ------ -------- ---- --------
    > ------ ------
    > 1 enet 100001 1500 - - - - -
    > 0 0
    > 2 enet 100002 1500 - - - - -
    > 0 0
    > 1002 fddi 101002 1500 - - - - -
    > 0 0
    > 1003 tr 101003 1500 - - - - srb
    > 0 0
    > 1004 fdnet 101004 1500 - - - ieee -
    > 0 0
    > 1005 trnet 101005 1500 - - - ibm -
    > 0 0
    > office_192_main#
    >
    > that implys it supports more then 1 vlan or am I wrong ?
    >
    > The upstream router does not support encap dotq, it doesnt have ipplus
    > flash and lacks the mem for it... I am hoping to do this in the switch
    > if possible


    It supports trunking and multiple vlans, but not as the L3 SVI for
    multiple vlans, only one (at least that is what I think I remember
    about those switches). This means that another switch can trunk in
    the networks, and the 2924 can put ports in it, it just won't work as
    the router for more than one network. What is your other switch,
    anything more robust? Can you create the networks there and trunk it
    over?

    Overall, wait for one of these other guys to weigh in (there are some
    really good folks on here), but I don't think that switch supports
    what you want...hopefully I am wrong.
    Trendkill, Oct 2, 2007
    #4
  5. turnip

    Trendkill Guest

    On Oct 2, 11:09 am, turnip <> wrote:
    > On Oct 2, 10:49 am, Trendkill <> wrote:
    >
    >
    >
    > > On Oct 2, 9:48 am, turnip <> wrote:

    >
    > > > I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    > > > the trunks between switches set up via port group 1 on 2 interfaces on
    > > > each swithc. It seems to work well

    >
    > > > on switch 2, I have defined a vlan for ports 17-24, however after
    > > > doing so, i cannot access any network resources.

    >
    > > > We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    > > > have to upgrade it.. however my question is this

    >
    > > > I never found a place to define the netowrk range for the second
    > > > vlan..
    > > > Reading up, intervace vlan2 ip add.. is just for management.

    >
    > > > So here it is..

    >
    > > > Can I configure this second switch (which is trunked up to the main,
    > > > and hte main goes to the router) to pass all vlans upstream ? Or do I
    > > > need a subinterface on the router with dotq encap and a vlan
    > > > defined ?

    >
    > > > I am a newb to vlans, the switches work just fine, it is just those 8
    > > > ports in vlan 2 that do me no good.

    >
    > > > I have this on both trunks

    >
    > > > interface FastEthernet1/1
    > > > port group 1
    > > > switchport trunk encapsulation dot1q
    > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > switchport mode trunk
    > > > !
    > > > interface FastEthernet1/2
    > > > port group 1
    > > > switchport trunk encapsulation dot1q
    > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > switchport mode trunk

    >
    > > > vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    > > > this. But if you have time and dont mind it would rock for some help..

    >
    > > > router -> switch1 <- trunk -> switch2

    >
    > > > the vlan is defined on switch 2.

    >
    > > I could be off base here, but I thought you could not create more than
    > > one vlan on a 2924? Doesn't it allow only one SVI? I thought you
    > > have to create some place else and trunk it in, and then assign the
    > > ports...but could be wrong...don't work with small switches too often,
    > > so forgive me if I am off base.

    >
    > > You may need to create a sub int on the router (unless your other
    > > switch is something that has more L3 capability, then trunk it from
    > > the router to switch 1, and then trunk the vlans between the two
    > > switches.

    >
    > > Perhaps someone else can help add clarity.- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > Building configuration...
    >
    > Current configuration:
    > !
    > version 12.0
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname 192_sub
    > !
    > enable secret 5 $1$V8a5$.pOnSyDIEGBo01iFaQVZp/
    > !
    > !
    > !
    > !
    > !
    > !
    > ip subnet-zero
    > ip dhcp-server 192.168.0.111
    > !
    > !
    > !
    > interface FastEthernet0/1
    > !
    > interface FastEthernet0/2
    > !
    > interface FastEthernet0/3
    > !
    > interface FastEthernet0/4
    > !
    > interface FastEthernet0/5
    > !
    > interface FastEthernet0/6
    > !
    > interface FastEthernet0/7
    > !
    > interface FastEthernet0/8
    > !
    > interface FastEthernet0/9
    > !
    > interface FastEthernet0/10
    > !
    > interface FastEthernet0/11
    > !
    > interface FastEthernet0/12
    > !
    > interface FastEthernet0/13
    > !
    > interface FastEthernet0/14
    > !
    > interface FastEthernet0/15
    > !
    > interface FastEthernet0/16
    > !
    > interface FastEthernet0/17
    > !
    > interface FastEthernet0/18
    > !
    > interface FastEthernet0/19
    > !
    > interface FastEthernet0/20
    > !
    > interface FastEthernet0/21
    > !
    > interface FastEthernet0/22
    > !
    > interface FastEthernet0/23
    > !
    > interface FastEthernet0/24
    > !
    > interface FastEthernet2/1
    > port group 1
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,2,1002-1005
    > switchport mode trunk
    > !
    > interface FastEthernet2/2
    > port group 1
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,2,1002-1005
    > switchport mode trunk
    > !
    > interface FastEthernet2/3
    > !
    > interface FastEthernet2/4
    > !
    > interface VLAN1
    > ip address 192.168.0.249 255.255.255.0
    > no ip directed-broadcast
    > no ip route-cache
    > !
    > ip default-gateway 192.168.0.253
    > snmp-server engineID local 00000009020000D0C0F257C0
    > snmp-server community private RW
    > snmp-server community public RO
    > !
    > line con 0
    > exec-timeout 0 0
    > transport input none
    > stopbits 1
    > line vty 0 4
    > password
    > login
    > line vty 5 15
    > password
    > login
    > !
    > end
    >
    > User Access Verification
    >
    > Password:
    > office_192_main>en
    > Password:
    > office_192_main#sho vlan
    > VLAN Name Status Ports
    > ---- -------------------------------- ---------
    > -------------------------------
    > 1 default active Fa0/1, Fa0/2, Fa0/3,
    > Fa0/4,
    > Fa0/5, Fa0/6, Fa0/7,
    > Fa0/8,
    > Fa0/9, Fa0/10, Fa0/11,
    > Fa0/12,
    > Fa0/13, Fa0/14,
    > Fa0/15, Fa0/16,
    > Fa1/3, Fa1/4
    > 2 it-dept active Fa0/17, Fa0/18,
    > Fa0/19, Fa0/20,
    > Fa0/21, Fa0/22,
    > Fa0/23, Fa0/24
    > 1002 fddi-default active
    > 1003 token-ring-default active
    > 1004 fddinet-default active
    > 1005 trnet-default active
    >
    > VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode
    > Trans1 Trans2
    > ---- ----- ---------- ----- ------ ------ -------- ---- --------
    > ------ ------
    > 1 enet 100001 1500 - - - - -
    > 0 0
    > 2 enet 100002 1500 - - - - -
    > 0 0
    > 1002 fddi 101002 1500 - - - - -
    > 0 0
    > 1003 tr 101003 1500 - - - - srb
    > 0 0
    > 1004 fdnet 101004 1500 - - - ieee -
    > 0 0
    > 1005 trnet 101005 1500 - - - ibm -
    > 0 0
    > office_192_main#
    >
    > that implys it supports more then 1 vlan or am I wrong ?
    >
    > The upstream router does not support encap dotq, it doesnt have ipplus
    > flash and lacks the mem for it... I am hoping to do this in the switch
    > if possible


    And, I know you can configure multiple vlans and interfaces, but they
    just won't work. When I hit this issue (if I am correct on thinking
    this is the same model as when I did this a long time ago), I could
    create vlans and interfaces, but nothing would work outside of the
    first vlan interface. As I said, hopefully i am wrong.
    Trendkill, Oct 2, 2007
    #5
  6. turnip

    turnip Guest

    On Oct 2, 11:36 am, Trendkill <> wrote:
    > On Oct 2, 11:09 am, turnip <> wrote:
    >
    >
    >
    >
    >
    > > On Oct 2, 10:49 am, Trendkill <> wrote:

    >
    > > > On Oct 2, 9:48 am, turnip <> wrote:

    >
    > > > > I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    > > > > the trunks between switches set up via port group 1 on 2 interfaces on
    > > > > each swithc. It seems to work well

    >
    > > > > on switch 2, I have defined a vlan for ports 17-24, however after
    > > > > doing so, i cannot access any network resources.

    >
    > > > > We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    > > > > have to upgrade it.. however my question is this

    >
    > > > > I never found a place to define the netowrk range for the second
    > > > > vlan..
    > > > > Reading up, intervace vlan2 ip add.. is just for management.

    >
    > > > > So here it is..

    >
    > > > > Can I configure this second switch (which is trunked up to the main,
    > > > > and hte main goes to the router) to pass all vlans upstream ? Or do I
    > > > > need a subinterface on the router with dotq encap and a vlan
    > > > > defined ?

    >
    > > > > I am a newb to vlans, the switches work just fine, it is just those 8
    > > > > ports in vlan 2 that do me no good.

    >
    > > > > I have this on both trunks

    >
    > > > > interface FastEthernet1/1
    > > > > port group 1
    > > > > switchport trunk encapsulation dot1q
    > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > switchport mode trunk
    > > > > !
    > > > > interface FastEthernet1/2
    > > > > port group 1
    > > > > switchport trunk encapsulation dot1q
    > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > switchport mode trunk

    >
    > > > > vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    > > > > this. But if you have time and dont mind it would rock for some help..

    >
    > > > > router -> switch1 <- trunk -> switch2

    >
    > > > > the vlan is defined on switch 2.

    >
    > > > I could be off base here, but I thought you could not create more than
    > > > one vlan on a 2924? Doesn't it allow only one SVI? I thought you
    > > > have to create some place else and trunk it in, and then assign the
    > > > ports...but could be wrong...don't work with small switches too often,
    > > > so forgive me if I am off base.

    >
    > > > You may need to create a sub int on the router (unless your other
    > > > switch is something that has more L3 capability, then trunk it from
    > > > the router to switch 1, and then trunk the vlans between the two
    > > > switches.

    >
    > > > Perhaps someone else can help add clarity.- Hide quoted text -

    >
    > > > - Show quoted text -

    >
    > > Building configuration...

    >
    > > Current configuration:
    > > !
    > > version 12.0
    > > no service pad
    > > service timestamps debug uptime
    > > service timestamps log uptime
    > > no service password-encryption
    > > !
    > > hostname 192_sub
    > > !
    > > enable secret 5 $1$V8a5$.pOnSyDIEGBo01iFaQVZp/
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > ip subnet-zero
    > > ip dhcp-server 192.168.0.111
    > > !
    > > !
    > > !
    > > interface FastEthernet0/1
    > > !
    > > interface FastEthernet0/2
    > > !
    > > interface FastEthernet0/3
    > > !
    > > interface FastEthernet0/4
    > > !
    > > interface FastEthernet0/5
    > > !
    > > interface FastEthernet0/6
    > > !
    > > interface FastEthernet0/7
    > > !
    > > interface FastEthernet0/8
    > > !
    > > interface FastEthernet0/9
    > > !
    > > interface FastEthernet0/10
    > > !
    > > interface FastEthernet0/11
    > > !
    > > interface FastEthernet0/12
    > > !
    > > interface FastEthernet0/13
    > > !
    > > interface FastEthernet0/14
    > > !
    > > interface FastEthernet0/15
    > > !
    > > interface FastEthernet0/16
    > > !
    > > interface FastEthernet0/17
    > > !
    > > interface FastEthernet0/18
    > > !
    > > interface FastEthernet0/19
    > > !
    > > interface FastEthernet0/20
    > > !
    > > interface FastEthernet0/21
    > > !
    > > interface FastEthernet0/22
    > > !
    > > interface FastEthernet0/23
    > > !
    > > interface FastEthernet0/24
    > > !
    > > interface FastEthernet2/1
    > > port group 1
    > > switchport trunk encapsulation dot1q
    > > switchport trunk allowed vlan 1,2,1002-1005
    > > switchport mode trunk
    > > !
    > > interface FastEthernet2/2
    > > port group 1
    > > switchport trunk encapsulation dot1q
    > > switchport trunk allowed vlan 1,2,1002-1005
    > > switchport mode trunk
    > > !
    > > interface FastEthernet2/3
    > > !
    > > interface FastEthernet2/4
    > > !
    > > interface VLAN1
    > > ip address 192.168.0.249 255.255.255.0
    > > no ip directed-broadcast
    > > no ip route-cache
    > > !
    > > ip default-gateway 192.168.0.253
    > > snmp-server engineID local 00000009020000D0C0F257C0
    > > snmp-server community private RW
    > > snmp-server community public RO
    > > !
    > > line con 0
    > > exec-timeout 0 0
    > > transport input none
    > > stopbits 1
    > > line vty 0 4
    > > password
    > > login
    > > line vty 5 15
    > > password
    > > login
    > > !
    > > end

    >
    > > User Access Verification

    >
    > > Password:
    > > office_192_main>en
    > > Password:
    > > office_192_main#sho vlan
    > > VLAN Name Status Ports
    > > ---- -------------------------------- ---------
    > > -------------------------------
    > > 1 default active Fa0/1, Fa0/2, Fa0/3,
    > > Fa0/4,
    > > Fa0/5, Fa0/6, Fa0/7,
    > > Fa0/8,
    > > Fa0/9, Fa0/10, Fa0/11,
    > > Fa0/12,
    > > Fa0/13, Fa0/14,
    > > Fa0/15, Fa0/16,
    > > Fa1/3, Fa1/4
    > > 2 it-dept active Fa0/17, Fa0/18,
    > > Fa0/19, Fa0/20,
    > > Fa0/21, Fa0/22,
    > > Fa0/23, Fa0/24
    > > 1002 fddi-default active
    > > 1003 token-ring-default active
    > > 1004 fddinet-default active
    > > 1005 trnet-default active

    >
    > > VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode
    > > Trans1 Trans2
    > > ---- ----- ---------- ----- ------ ------ -------- ---- --------
    > > ------ ------
    > > 1 enet 100001 1500 - - - - -
    > > 0 0
    > > 2 enet 100002 1500 - - - - -
    > > 0 0
    > > 1002 fddi 101002 1500 - - - - -
    > > 0 0
    > > 1003 tr 101003 1500 - - - - srb
    > > 0 0
    > > 1004 fdnet 101004 1500 - - - ieee -
    > > 0 0
    > > 1005 trnet 101005 1500 - - - ibm -
    > > 0 0
    > > office_192_main#

    >
    > > that implys it supports more then 1 vlan or am I wrong ?

    >
    > > The upstream router does not support encap dotq, it doesnt have ipplus
    > > flash and lacks the mem for it... I am hoping to do this in the switch
    > > if possible

    >
    > It supports trunking and multiple vlans, but not as the L3 SVI for
    > multiple vlans, only one (at least that is what I think I remember
    > about those switches). This means that another switch can trunk in
    > the networks, and the 2924 can put ports in it, it just won't work as
    > the router for more than one network. What is your other switch,
    > anything more robust? Can you create the networks there and trunk it
    > over?
    >
    > Overall, wait for one of these other guys to weigh in (there are some
    > really good folks on here), but I don't think that switch supports
    > what you want...hopefully I am wrong.- Hide quoted text -
    >
    > - Show quoted text -


    the upstream main switch is the same model (small company) =)
    turnip, Oct 2, 2007
    #6
  7. turnip

    turnip Guest

    On Oct 2, 11:54 am, turnip <> wrote:
    > On Oct 2, 11:36 am, Trendkill <> wrote:
    >
    >
    >
    >
    >
    > > On Oct 2, 11:09 am, turnip <> wrote:

    >
    > > > On Oct 2, 10:49 am, Trendkill <> wrote:

    >
    > > > > On Oct 2, 9:48 am, turnip <> wrote:

    >
    > > > > > I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    > > > > > the trunks between switches set up via port group 1 on 2 interfaces on
    > > > > > each swithc. It seems to work well

    >
    > > > > > on switch 2, I have defined a vlan for ports 17-24, however after
    > > > > > doing so, i cannot access any network resources.

    >
    > > > > > We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    > > > > > have to upgrade it.. however my question is this

    >
    > > > > > I never found a place to define the netowrk range for the second
    > > > > > vlan..
    > > > > > Reading up, intervace vlan2 ip add.. is just for management.

    >
    > > > > > So here it is..

    >
    > > > > > Can I configure this second switch (which is trunked up to the main,
    > > > > > and hte main goes to the router) to pass all vlans upstream ? Or do I
    > > > > > need a subinterface on the router with dotq encap and a vlan
    > > > > > defined ?

    >
    > > > > > I am a newb to vlans, the switches work just fine, it is just those 8
    > > > > > ports in vlan 2 that do me no good.

    >
    > > > > > I have this on both trunks

    >
    > > > > > interface FastEthernet1/1
    > > > > > port group 1
    > > > > > switchport trunk encapsulation dot1q
    > > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > > switchport mode trunk
    > > > > > !
    > > > > > interface FastEthernet1/2
    > > > > > port group 1
    > > > > > switchport trunk encapsulation dot1q
    > > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > > switchport mode trunk

    >
    > > > > > vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    > > > > > this. But if you have time and dont mind it would rock for some help..

    >
    > > > > > router -> switch1 <- trunk -> switch2

    >
    > > > > > the vlan is defined on switch 2.

    >
    > > > > I could be off base here, but I thought you could not create more than
    > > > > one vlan on a 2924? Doesn't it allow only one SVI? I thought you
    > > > > have to create some place else and trunk it in, and then assign the
    > > > > ports...but could be wrong...don't work with small switches too often,
    > > > > so forgive me if I am off base.

    >
    > > > > You may need to create a sub int on the router (unless your other
    > > > > switch is something that has more L3 capability, then trunk it from
    > > > > the router to switch 1, and then trunk the vlans between the two
    > > > > switches.

    >
    > > > > Perhaps someone else can help add clarity.- Hide quoted text -

    >
    > > > > - Show quoted text -

    >
    > > > Building configuration...

    >
    > > > Current configuration:
    > > > !
    > > > version 12.0
    > > > no service pad
    > > > service timestamps debug uptime
    > > > service timestamps log uptime
    > > > no service password-encryption
    > > > !
    > > > hostname 192_sub
    > > > !
    > > > enable secret 5 $1$V8a5$.pOnSyDIEGBo01iFaQVZp/
    > > > !
    > > > !
    > > > !
    > > > !
    > > > !
    > > > !
    > > > ip subnet-zero
    > > > ip dhcp-server 192.168.0.111
    > > > !
    > > > !
    > > > !
    > > > interface FastEthernet0/1
    > > > !
    > > > interface FastEthernet0/2
    > > > !
    > > > interface FastEthernet0/3
    > > > !
    > > > interface FastEthernet0/4
    > > > !
    > > > interface FastEthernet0/5
    > > > !
    > > > interface FastEthernet0/6
    > > > !
    > > > interface FastEthernet0/7
    > > > !
    > > > interface FastEthernet0/8
    > > > !
    > > > interface FastEthernet0/9
    > > > !
    > > > interface FastEthernet0/10
    > > > !
    > > > interface FastEthernet0/11
    > > > !
    > > > interface FastEthernet0/12
    > > > !
    > > > interface FastEthernet0/13
    > > > !
    > > > interface FastEthernet0/14
    > > > !
    > > > interface FastEthernet0/15
    > > > !
    > > > interface FastEthernet0/16
    > > > !
    > > > interface FastEthernet0/17
    > > > !
    > > > interface FastEthernet0/18
    > > > !
    > > > interface FastEthernet0/19
    > > > !
    > > > interface FastEthernet0/20
    > > > !
    > > > interface FastEthernet0/21
    > > > !
    > > > interface FastEthernet0/22
    > > > !
    > > > interface FastEthernet0/23
    > > > !
    > > > interface FastEthernet0/24
    > > > !
    > > > interface FastEthernet2/1
    > > > port group 1
    > > > switchport trunk encapsulation dot1q
    > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > switchport mode trunk
    > > > !
    > > > interface FastEthernet2/2
    > > > port group 1
    > > > switchport trunk encapsulation dot1q
    > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > switchport mode trunk
    > > > !
    > > > interface FastEthernet2/3
    > > > !
    > > > interface FastEthernet2/4
    > > > !
    > > > interface VLAN1
    > > > ip address 192.168.0.249 255.255.255.0
    > > > no ip directed-broadcast
    > > > no ip route-cache
    > > > !
    > > > ip default-gateway 192.168.0.253
    > > > snmp-server engineID local 00000009020000D0C0F257C0
    > > > snmp-server community private RW
    > > > snmp-server community public RO
    > > > !
    > > > line con 0
    > > > exec-timeout 0 0
    > > > transport input none
    > > > stopbits 1
    > > > line vty 0 4
    > > > password
    > > > login
    > > > line vty 5 15
    > > > password
    > > > login
    > > > !
    > > > end

    >
    > > > User Access Verification

    >
    > > > Password:
    > > > office_192_main>en
    > > > Password:
    > > > office_192_main#sho vlan
    > > > VLAN Name Status Ports
    > > > ---- -------------------------------- ---------
    > > > -------------------------------
    > > > 1 default active Fa0/1, Fa0/2, Fa0/3,
    > > > Fa0/4,
    > > > Fa0/5, Fa0/6, Fa0/7,
    > > > Fa0/8,
    > > > Fa0/9, Fa0/10, Fa0/11,
    > > > Fa0/12,
    > > > Fa0/13, Fa0/14,
    > > > Fa0/15, Fa0/16,
    > > > Fa1/3, Fa1/4
    > > > 2 it-dept active Fa0/17, Fa0/18,
    > > > Fa0/19, Fa0/20,
    > > > Fa0/21, Fa0/22,
    > > > Fa0/23, Fa0/24
    > > > 1002 fddi-default active
    > > > 1003 token-ring-default active
    > > > 1004 fddinet-default active
    > > > 1005 trnet-default active

    >
    > > > VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode
    > > > Trans1 Trans2
    > > > ---- ----- ---------- ----- ------ ------ -------- ---- --------
    > > > ------ ------
    > > > 1 enet 100001 1500 - - - - -
    > > > 0 0
    > > > 2 enet 100002 1500 - - - - -
    > > > 0 0
    > > > 1002 fddi 101002 1500 - - - - -
    > > > 0 0
    > > > 1003 tr 101003 1500 - - - - srb
    > > > 0 0
    > > > 1004 fdnet 101004 1500 - - - ieee -
    > > > 0 0
    > > > 1005 trnet 101005 1500 - - - ibm -
    > > > 0 0
    > > > office_192_main#

    >
    > > > that implys it supports more then 1 vlan or am I wrong ?

    >
    > > > The upstream router does not support encap dotq, it doesnt have ipplus
    > > > flash and lacks the mem for it... I am hoping to do this in the switch
    > > > if possible

    >
    > > It supports trunking and multiple vlans, but not as the L3 SVI for
    > > multiple vlans, only one (at least that is what I think I remember
    > > about those switches). This means that another switch can trunk in
    > > the networks, and the 2924 can put ports in it, it just won't work as
    > > the router for more than one network. What is your other switch,
    > > anything more robust? Can you create the networks there and trunk it
    > > over?

    >
    > > Overall, wait for one of these other guys to weigh in (there are some
    > > really good folks on here), but I don't think that switch supports
    > > what you want...hopefully I am wrong.- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > the upstream main switch is the same model (small company) =)- Hide quoted text -
    >
    > - Show quoted text -


    I was able to update the router IOS, create a sub interface, assign it
    to a vlan. and then trunk one port on the second vlan up to it..

    All is working. But id love more info on these switches..
    turnip, Oct 2, 2007
    #7
  8. turnip

    Trendkill Guest

    On Oct 2, 2:45 pm, turnip <> wrote:
    > On Oct 2, 11:54 am, turnip <> wrote:
    >
    >
    >
    > > On Oct 2, 11:36 am, Trendkill <> wrote:

    >
    > > > On Oct 2, 11:09 am, turnip <> wrote:

    >
    > > > > On Oct 2, 10:49 am, Trendkill <> wrote:

    >
    > > > > > On Oct 2, 9:48 am, turnip <> wrote:

    >
    > > > > > > I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    > > > > > > the trunks between switches set up via port group 1 on 2 interfaces on
    > > > > > > each swithc. It seems to work well

    >
    > > > > > > on switch 2, I have defined a vlan for ports 17-24, however after
    > > > > > > doing so, i cannot access any network resources.

    >
    > > > > > > We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    > > > > > > have to upgrade it.. however my question is this

    >
    > > > > > > I never found a place to define the netowrk range for the second
    > > > > > > vlan..
    > > > > > > Reading up, intervace vlan2 ip add.. is just for management.

    >
    > > > > > > So here it is..

    >
    > > > > > > Can I configure this second switch (which is trunked up to the main,
    > > > > > > and hte main goes to the router) to pass all vlans upstream ? Or do I
    > > > > > > need a subinterface on the router with dotq encap and a vlan
    > > > > > > defined ?

    >
    > > > > > > I am a newb to vlans, the switches work just fine, it is just those 8
    > > > > > > ports in vlan 2 that do me no good.

    >
    > > > > > > I have this on both trunks

    >
    > > > > > > interface FastEthernet1/1
    > > > > > > port group 1
    > > > > > > switchport trunk encapsulation dot1q
    > > > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > > > switchport mode trunk
    > > > > > > !
    > > > > > > interface FastEthernet1/2
    > > > > > > port group 1
    > > > > > > switchport trunk encapsulation dot1q
    > > > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > > > switchport mode trunk

    >
    > > > > > > vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    > > > > > > this. But if you have time and dont mind it would rock for some help..

    >
    > > > > > > router -> switch1 <- trunk -> switch2

    >
    > > > > > > the vlan is defined on switch 2.

    >
    > > > > > I could be off base here, but I thought you could not create more than
    > > > > > one vlan on a 2924? Doesn't it allow only one SVI? I thought you
    > > > > > have to create some place else and trunk it in, and then assign the
    > > > > > ports...but could be wrong...don't work with small switches too often,
    > > > > > so forgive me if I am off base.

    >
    > > > > > You may need to create a sub int on the router (unless your other
    > > > > > switch is something that has more L3 capability, then trunk it from
    > > > > > the router to switch 1, and then trunk the vlans between the two
    > > > > > switches.

    >
    > > > > > Perhaps someone else can help add clarity.- Hide quoted text -

    >
    > > > > > - Show quoted text -

    >
    > > > > Building configuration...

    >
    > > > > Current configuration:
    > > > > !
    > > > > version 12.0
    > > > > no service pad
    > > > > service timestamps debug uptime
    > > > > service timestamps log uptime
    > > > > no service password-encryption
    > > > > !
    > > > > hostname 192_sub
    > > > > !
    > > > > enable secret 5 $1$V8a5$.pOnSyDIEGBo01iFaQVZp/
    > > > > !
    > > > > !
    > > > > !
    > > > > !
    > > > > !
    > > > > !
    > > > > ip subnet-zero
    > > > > ip dhcp-server 192.168.0.111
    > > > > !
    > > > > !
    > > > > !
    > > > > interface FastEthernet0/1
    > > > > !
    > > > > interface FastEthernet0/2
    > > > > !
    > > > > interface FastEthernet0/3
    > > > > !
    > > > > interface FastEthernet0/4
    > > > > !
    > > > > interface FastEthernet0/5
    > > > > !
    > > > > interface FastEthernet0/6
    > > > > !
    > > > > interface FastEthernet0/7
    > > > > !
    > > > > interface FastEthernet0/8
    > > > > !
    > > > > interface FastEthernet0/9
    > > > > !
    > > > > interface FastEthernet0/10
    > > > > !
    > > > > interface FastEthernet0/11
    > > > > !
    > > > > interface FastEthernet0/12
    > > > > !
    > > > > interface FastEthernet0/13
    > > > > !
    > > > > interface FastEthernet0/14
    > > > > !
    > > > > interface FastEthernet0/15
    > > > > !
    > > > > interface FastEthernet0/16
    > > > > !
    > > > > interface FastEthernet0/17
    > > > > !
    > > > > interface FastEthernet0/18
    > > > > !
    > > > > interface FastEthernet0/19
    > > > > !
    > > > > interface FastEthernet0/20
    > > > > !
    > > > > interface FastEthernet0/21
    > > > > !
    > > > > interface FastEthernet0/22
    > > > > !
    > > > > interface FastEthernet0/23
    > > > > !
    > > > > interface FastEthernet0/24
    > > > > !
    > > > > interface FastEthernet2/1
    > > > > port group 1
    > > > > switchport trunk encapsulation dot1q
    > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > switchport mode trunk
    > > > > !
    > > > > interface FastEthernet2/2
    > > > > port group 1
    > > > > switchport trunk encapsulation dot1q
    > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > switchport mode trunk
    > > > > !
    > > > > interface FastEthernet2/3
    > > > > !
    > > > > interface FastEthernet2/4
    > > > > !
    > > > > interface VLAN1
    > > > > ip address 192.168.0.249 255.255.255.0
    > > > > no ip directed-broadcast
    > > > > no ip route-cache
    > > > > !
    > > > > ip default-gateway 192.168.0.253
    > > > > snmp-server engineID local 00000009020000D0C0F257C0
    > > > > snmp-server community private RW
    > > > > snmp-server community public RO
    > > > > !
    > > > > line con 0
    > > > > exec-timeout 0 0
    > > > > transport input none
    > > > > stopbits 1
    > > > > line vty 0 4
    > > > > password
    > > > > login
    > > > > line vty 5 15
    > > > > password
    > > > > login
    > > > > !
    > > > > end

    >
    > > > > User Access Verification

    >
    > > > > Password:
    > > > > office_192_main>en
    > > > > Password:
    > > > > office_192_main#sho vlan
    > > > > VLAN Name Status Ports
    > > > > ---- -------------------------------- ---------
    > > > > -------------------------------
    > > > > 1 default active Fa0/1, Fa0/2, Fa0/3,
    > > > > Fa0/4,
    > > > > Fa0/5, Fa0/6, Fa0/7,
    > > > > Fa0/8,
    > > > > Fa0/9, Fa0/10, Fa0/11,
    > > > > Fa0/12,
    > > > > Fa0/13, Fa0/14,
    > > > > Fa0/15, Fa0/16,
    > > > > Fa1/3, Fa1/4
    > > > > 2 it-dept active Fa0/17, Fa0/18,
    > > > > Fa0/19, Fa0/20,
    > > > > Fa0/21, Fa0/22,
    > > > > Fa0/23, Fa0/24
    > > > > 1002 fddi-default active
    > > > > 1003 token-ring-default active
    > > > > 1004 fddinet-default active
    > > > > 1005 trnet-default active

    >
    > > > > VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode
    > > > > Trans1 Trans2
    > > > > ---- ----- ---------- ----- ------ ------ -------- ---- --------
    > > > > ------ ------
    > > > > 1 enet 100001 1500 - - - - -
    > > > > 0 0
    > > > > 2 enet 100002 1500 - - - - -
    > > > > 0 0
    > > > > 1002 fddi 101002 1500 - - - - -
    > > > > 0 0
    > > > > 1003 tr 101003 1500 - - - - srb
    > > > > 0 0
    > > > > 1004 fdnet 101004 1500 - - - ieee -
    > > > > 0 0
    > > > > 1005 trnet 101005 1500 - - - ibm -
    > > > > 0 0
    > > > > office_192_main#

    >
    > > > > that implys it supports more then 1 vlan or am I wrong ?

    >
    > > > > The upstream router does not support encap dotq, it doesnt have ipplus
    > > > > flash and lacks the mem for it... I am hoping to do this in the switch
    > > > > if possible

    >
    > > > It supports trunking and multiple vlans, but not as the L3 SVI for
    > > > multiple vlans, only one (at least that is what I think I remember
    > > > about those switches). This means that another switch can trunk in
    > > > the networks, and the 2924 can put ports in it, it just won't work as
    > > > the router for more than one network. What is your other switch,
    > > > anything more robust? Can you create the networks there and trunk it
    > > > over?

    >
    > > > Overall, wait for one of these other guys to weigh in (there are some
    > > > really good folks on here), but I don't think that switch supports
    > > > what you want...hopefully I am wrong.- Hide quoted text -

    >
    > > > - Show quoted text -

    >
    > > the upstream main switch is the same model (small company) =)- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > I was able to update the router IOS, create a sub interface, assign it
    > to a vlan. and then trunk one port on the second vlan up to it..
    >
    > All is working. But id love more info on these switches..


    That's good news. I'm sure someone will pipe up and provide the
    answer you need on the 2924, just seems like a slow day for the heavy
    hitters ;-) other than myself. If I get some time, I will do some
    searching on Cisco, and will let you know if/when I find
    something....take care.
    Trendkill, Oct 2, 2007
    #8
  9. turnip

    Trendkill Guest

    On Oct 2, 3:00 pm, Trendkill <> wrote:
    > On Oct 2, 2:45 pm, turnip <> wrote:
    >
    >
    >
    > > On Oct 2, 11:54 am, turnip <> wrote:

    >
    > > > On Oct 2, 11:36 am, Trendkill <> wrote:

    >
    > > > > On Oct 2, 11:09 am, turnip <> wrote:

    >
    > > > > > On Oct 2, 10:49 am, Trendkill <> wrote:

    >
    > > > > > > On Oct 2, 9:48 am, turnip <> wrote:

    >
    > > > > > > > I have 2 2924's with the WS-X2924-XL-V expansion port in each. I have
    > > > > > > > the trunks between switches set up via port group 1 on 2 interfaces on
    > > > > > > > each swithc. It seems to work well

    >
    > > > > > > > on switch 2, I have defined a vlan for ports 17-24, however after
    > > > > > > > doing so, i cannot access any network resources.

    >
    > > > > > > > We have a 2600 upstream, and it doesnt support encapsulation atm, ill
    > > > > > > > have to upgrade it.. however my question is this

    >
    > > > > > > > I never found a place to define the netowrk range for the second
    > > > > > > > vlan..
    > > > > > > > Reading up, intervace vlan2 ip add.. is just for management.

    >
    > > > > > > > So here it is..

    >
    > > > > > > > Can I configure this second switch (which is trunked up to the main,
    > > > > > > > and hte main goes to the router) to pass all vlans upstream ? Or do I
    > > > > > > > need a subinterface on the router with dotq encap and a vlan
    > > > > > > > defined ?

    >
    > > > > > > > I am a newb to vlans, the switches work just fine, it is just those 8
    > > > > > > > ports in vlan 2 that do me no good.

    >
    > > > > > > > I have this on both trunks

    >
    > > > > > > > interface FastEthernet1/1
    > > > > > > > port group 1
    > > > > > > > switchport trunk encapsulation dot1q
    > > > > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > > > > switchport mode trunk
    > > > > > > > !
    > > > > > > > interface FastEthernet1/2
    > > > > > > > port group 1
    > > > > > > > switchport trunk encapsulation dot1q
    > > > > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > > > > switchport mode trunk

    >
    > > > > > > > vlan 1 routes just fine, vlan 2 dies hehe. I understand if you ignore
    > > > > > > > this. But if you have time and dont mind it would rock for some help..

    >
    > > > > > > > router -> switch1 <- trunk -> switch2

    >
    > > > > > > > the vlan is defined on switch 2.

    >
    > > > > > > I could be off base here, but I thought you could not create more than
    > > > > > > one vlan on a 2924? Doesn't it allow only one SVI? I thought you
    > > > > > > have to create some place else and trunk it in, and then assign the
    > > > > > > ports...but could be wrong...don't work with small switches too often,
    > > > > > > so forgive me if I am off base.

    >
    > > > > > > You may need to create a sub int on the router (unless your other
    > > > > > > switch is something that has more L3 capability, then trunk it from
    > > > > > > the router to switch 1, and then trunk the vlans between the two
    > > > > > > switches.

    >
    > > > > > > Perhaps someone else can help add clarity.- Hide quoted text -

    >
    > > > > > > - Show quoted text -

    >
    > > > > > Building configuration...

    >
    > > > > > Current configuration:
    > > > > > !
    > > > > > version 12.0
    > > > > > no service pad
    > > > > > service timestamps debug uptime
    > > > > > service timestamps log uptime
    > > > > > no service password-encryption
    > > > > > !
    > > > > > hostname 192_sub
    > > > > > !
    > > > > > enable secret 5 $1$V8a5$.pOnSyDIEGBo01iFaQVZp/
    > > > > > !
    > > > > > !
    > > > > > !
    > > > > > !
    > > > > > !
    > > > > > !
    > > > > > ip subnet-zero
    > > > > > ip dhcp-server 192.168.0.111
    > > > > > !
    > > > > > !
    > > > > > !
    > > > > > interface FastEthernet0/1
    > > > > > !
    > > > > > interface FastEthernet0/2
    > > > > > !
    > > > > > interface FastEthernet0/3
    > > > > > !
    > > > > > interface FastEthernet0/4
    > > > > > !
    > > > > > interface FastEthernet0/5
    > > > > > !
    > > > > > interface FastEthernet0/6
    > > > > > !
    > > > > > interface FastEthernet0/7
    > > > > > !
    > > > > > interface FastEthernet0/8
    > > > > > !
    > > > > > interface FastEthernet0/9
    > > > > > !
    > > > > > interface FastEthernet0/10
    > > > > > !
    > > > > > interface FastEthernet0/11
    > > > > > !
    > > > > > interface FastEthernet0/12
    > > > > > !
    > > > > > interface FastEthernet0/13
    > > > > > !
    > > > > > interface FastEthernet0/14
    > > > > > !
    > > > > > interface FastEthernet0/15
    > > > > > !
    > > > > > interface FastEthernet0/16
    > > > > > !
    > > > > > interface FastEthernet0/17
    > > > > > !
    > > > > > interface FastEthernet0/18
    > > > > > !
    > > > > > interface FastEthernet0/19
    > > > > > !
    > > > > > interface FastEthernet0/20
    > > > > > !
    > > > > > interface FastEthernet0/21
    > > > > > !
    > > > > > interface FastEthernet0/22
    > > > > > !
    > > > > > interface FastEthernet0/23
    > > > > > !
    > > > > > interface FastEthernet0/24
    > > > > > !
    > > > > > interface FastEthernet2/1
    > > > > > port group 1
    > > > > > switchport trunk encapsulation dot1q
    > > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > > switchport mode trunk
    > > > > > !
    > > > > > interface FastEthernet2/2
    > > > > > port group 1
    > > > > > switchport trunk encapsulation dot1q
    > > > > > switchport trunk allowed vlan 1,2,1002-1005
    > > > > > switchport mode trunk
    > > > > > !
    > > > > > interface FastEthernet2/3
    > > > > > !
    > > > > > interface FastEthernet2/4
    > > > > > !
    > > > > > interface VLAN1
    > > > > > ip address 192.168.0.249 255.255.255.0
    > > > > > no ip directed-broadcast
    > > > > > no ip route-cache
    > > > > > !
    > > > > > ip default-gateway 192.168.0.253
    > > > > > snmp-server engineID local 00000009020000D0C0F257C0
    > > > > > snmp-server community private RW
    > > > > > snmp-server community public RO
    > > > > > !
    > > > > > line con 0
    > > > > > exec-timeout 0 0
    > > > > > transport input none
    > > > > > stopbits 1
    > > > > > line vty 0 4
    > > > > > password
    > > > > > login
    > > > > > line vty 5 15
    > > > > > password
    > > > > > login
    > > > > > !
    > > > > > end

    >
    > > > > > User Access Verification

    >
    > > > > > Password:
    > > > > > office_192_main>en
    > > > > > Password:
    > > > > > office_192_main#sho vlan
    > > > > > VLAN Name Status Ports
    > > > > > ---- -------------------------------- ---------
    > > > > > -------------------------------
    > > > > > 1 default active Fa0/1, Fa0/2, Fa0/3,
    > > > > > Fa0/4,
    > > > > > Fa0/5, Fa0/6, Fa0/7,
    > > > > > Fa0/8,
    > > > > > Fa0/9, Fa0/10, Fa0/11,
    > > > > > Fa0/12,
    > > > > > Fa0/13, Fa0/14,
    > > > > > Fa0/15, Fa0/16,
    > > > > > Fa1/3, Fa1/4
    > > > > > 2 it-dept active Fa0/17, Fa0/18,
    > > > > > Fa0/19, Fa0/20,
    > > > > > Fa0/21, Fa0/22,
    > > > > > Fa0/23, Fa0/24
    > > > > > 1002 fddi-default active
    > > > > > 1003 token-ring-default active
    > > > > > 1004 fddinet-default active
    > > > > > 1005 trnet-default active

    >
    > > > > > VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode
    > > > > > Trans1 Trans2
    > > > > > ---- ----- ---------- ----- ------ ------ -------- ---- --------
    > > > > > ------ ------
    > > > > > 1 enet 100001 1500 - - - - -
    > > > > > 0 0
    > > > > > 2 enet 100002 1500 - - - - -
    > > > > > 0 0
    > > > > > 1002 fddi 101002 1500 - - - - -
    > > > > > 0 0
    > > > > > 1003 tr 101003 1500 - - - - srb
    > > > > > 0 0
    > > > > > 1004 fdnet 101004 1500 - - - ieee -
    > > > > > 0 0
    > > > > > 1005 trnet 101005 1500 - - - ibm -
    > > > > > 0 0
    > > > > > office_192_main#

    >
    > > > > > that implys it supports more then 1 vlan or am I wrong ?

    >
    > > > > > The upstream router does not support encap dotq, it doesnt have ipplus
    > > > > > flash and lacks the mem for it... I am hoping to do this in the switch
    > > > > > if possible

    >
    > > > > It supports trunking and multiple vlans, but not as the L3 SVI for
    > > > > multiple vlans, only one (at least that is what I think I remember
    > > > > about those switches). This means that another switch can trunk in
    > > > > the networks, and the 2924 can put ports in it, it just won't work as
    > > > > the router for more than one network. What is your other switch,
    > > > > anything more robust? Can you create the networks there and trunk it
    > > > > over?

    >
    > > > > Overall, wait for one of these other guys to weigh in (there are some
    > > > > really good folks on here), but I don't think that switch supports
    > > > > what you want...hopefully I am wrong.- Hide quoted text -

    >
    > > > > - Show quoted text -

    >
    > > > the upstream main switch is the same model (small company) =)- Hide quoted text -

    >
    > > > - Show quoted text -

    >
    > > I was able to update the router IOS, create a sub interface, assign it
    > > to a vlan. and then trunk one port on the second vlan up to it..

    >
    > > All is working. But id love more info on these switches..

    >
    > That's good news. I'm sure someone will pipe up and provide the
    > answer you need on the 2924, just seems like a slow day for the heavy
    > hitters ;-) other than myself. If I get some time, I will do some
    > searching on Cisco, and will let you know if/when I find
    > something....take care.


    And here is a link related to previous posts about this topic...which
    is what is leading me to believe you can only have one routed
    interface on that switch, and its for mgmt only. Again, could be
    wrong and might depend on hardware, but this is along the lines of
    what I was thinking.

    http://groups.google.com/group/comp...q=2924 vlan interface&rnum=1#5ccf7a65ff3b8dbc
    Trendkill, Oct 2, 2007
    #9
  10. turnip

    Chris Guest


    >
    > And, I know you can configure multiple vlans and interfaces, but they
    > just won't work. When I hit this issue (if I am correct on thinking
    > this is the same model as when I did this a long time ago), I could
    > create vlans and interfaces, but nothing would work outside of the
    > first vlan interface. As I said, hopefully i am wrong.


    You are quite correct. The 2900 series supports only one SVI interface so
    by creating a second vlan for switch ports without any means of routing
    that subnet/vlan those ports will be cut off from the network. A trunk to a
    "router on a stick" is usually the answer. The 2924 is really just a layer2
    switch with one SVI interface designed for management.

    Chris.
    Chris, Oct 2, 2007
    #10
  11. turnip

    Trendkill Guest

    On Oct 2, 6:40 pm, Chris <> wrote:
    > > And, I know you can configure multiple vlans and interfaces, but they
    > > just won't work. When I hit this issue (if I am correct on thinking
    > > this is the same model as when I did this a long time ago), I could
    > > create vlans and interfaces, but nothing would work outside of the
    > > first vlan interface. As I said, hopefully i am wrong.

    >
    > You are quite correct. The 2900 series supports only one SVI interface so
    > by creating a second vlan for switch ports without any means of routing
    > that subnet/vlan those ports will be cut off from the network. A trunk to a
    > "router on a stick" is usually the answer. The 2924 is really just a layer2
    > switch with one SVI interface designed for management.
    >
    > Chris.


    That is what I was thinking. Sorry man! Hopefully you are at least
    ok with your new code and router on a stick. Let me know if there is
    anything else we can help with.
    Trendkill, Oct 3, 2007
    #11
  12. turnip

    turnip Guest

    On Oct 2, 7:39 pm, Trendkill <> wrote:
    > On Oct 2, 6:40 pm, Chris <> wrote:
    >
    > > > And, I know you can configure multiple vlans and interfaces, but they
    > > > just won't work. When I hit this issue (if I am correct on thinking
    > > > this is the same model as when I did this a long time ago), I could
    > > > create vlans and interfaces, but nothing would work outside of the
    > > > first vlan interface. As I said, hopefully i am wrong.

    >
    > > You are quite correct. The 2900 series supports only one SVI interface so
    > > by creating a second vlan for switch ports without any means of routing
    > > that subnet/vlan those ports will be cut off from the network. A trunk to a
    > > "router on a stick" is usually the answer. The 2924 is really just a layer2
    > > switch with one SVI interface designed for management.

    >
    > > Chris.

    >
    > That is what I was thinking. Sorry man! Hopefully you are at least
    > ok with your new code and router on a stick. Let me know if there is
    > anything else we can help with.


    Router on a stick is a router with one FE correct ?

    Out 26xx has a few interfaces, so its not a stick per say. I am ok
    with it, if its proper and correct. It does work, But I am too much of
    a Cisco switching newb to know weather this is an "incorrect" setup.

    Thank you all for the help, it is much appreciated.
    turnip, Oct 3, 2007
    #12
  13. turnip

    Trendkill Guest

    On Oct 3, 9:54 am, turnip <> wrote:
    > On Oct 2, 7:39 pm, Trendkill <> wrote:
    >
    >
    >
    > > On Oct 2, 6:40 pm, Chris <> wrote:

    >
    > > > > And, I know you can configure multiple vlans and interfaces, but they
    > > > > just won't work. When I hit this issue (if I am correct on thinking
    > > > > this is the same model as when I did this a long time ago), I could
    > > > > create vlans and interfaces, but nothing would work outside of the
    > > > > first vlan interface. As I said, hopefully i am wrong.

    >
    > > > You are quite correct. The 2900 series supports only one SVI interface so
    > > > by creating a second vlan for switch ports without any means of routing
    > > > that subnet/vlan those ports will be cut off from the network. A trunk to a
    > > > "router on a stick" is usually the answer. The 2924 is really just a layer2
    > > > switch with one SVI interface designed for management.

    >
    > > > Chris.

    >
    > > That is what I was thinking. Sorry man! Hopefully you are at least
    > > ok with your new code and router on a stick. Let me know if there is
    > > anything else we can help with.

    >
    > Router on a stick is a router with one FE correct ?
    >
    > Out 26xx has a few interfaces, so its not a stick per say. I am ok
    > with it, if its proper and correct. It does work, But I am too much of
    > a Cisco switching newb to know weather this is an "incorrect" setup.
    >
    > Thank you all for the help, it is much appreciated.


    Router on a stick means it is connected to some switches and provides
    the layer 3 functionality rather than a 6500 or enterprise class
    switch with MSFC. Generally its for small offices or retail
    locations, where the router connects to the WAN and then provides the
    layer 2/3 definition for small vlans for the actual office or retail
    machines (registers, etc). It is a fine design, its just not hugely
    scalable and should be re-architected when you start to get towards
    challenging requirements such as lots of machines, workstations, or
    large bandwidth. This is because ALL traffic inter-vlan goes up that
    uplink, and you can start to have performance issues since you only
    have one trunk. Even if you have two trunks, one will most likely be
    blocking due to spanning tree.

    In short, its a fine setup, just be careful as your requirements get
    larger or more complicated, as this will be the first thing you will
    probably want to address if that is the case.
    Trendkill, Oct 3, 2007
    #13
  14. turnip

    Sam Wilson Guest

    In article <>,
    Trendkill <> wrote:

    > On Oct 3, 9:54 am, turnip <> wrote:
    > > Router on a stick is a router with one FE correct ?
    > >

    >
    > Router on a stick means it is connected to some switches and provides
    > the layer 3 functionality rather than a 6500 or enterprise class
    > switch with MSFC. ...


    Nitpick - a router on a stick is where traffic between different logical
    interfaces travels goes to and from the same place, often on the same
    physical interface. You'd use one to link different logical subnets on
    a piece of equipment which is unable to provide the routing function
    itself, e.g. ethernet switch with VLANs, ATM or frame relay switch with
    different VCs.

    Sam
    Sam Wilson, Oct 4, 2007
    #14
  15. turnip

    Trendkill Guest

    On Oct 4, 5:10 am, Sam Wilson <> wrote:
    > In article <>,
    >
    > Trendkill <> wrote:
    > > On Oct 3, 9:54 am, turnip <> wrote:
    > > > Router on a stick is a router with one FE correct ?

    >
    > > Router on a stick means it is connected to some switches and provides
    > > the layer 3 functionality rather than a 6500 or enterprise class
    > > switch with MSFC. ...

    >
    > Nitpick - a router on a stick is where traffic between different logical
    > interfaces travels goes to and from the same place, often on the same
    > physical interface. You'd use one to link different logical subnets on
    > a piece of equipment which is unable to provide the routing function
    > itself, e.g. ethernet switch with VLANs, ATM or frame relay switch with
    > different VCs.
    >
    > Sam


    Yes I agree wholeheartedly, same interface. I don't deal with them
    too much, so just took a stab at a rough definition for the OP. Yours
    is much better/specific. Appreciate the clarification...don't want to
    steer anyone off. Take care Sam.
    Trendkill, Oct 5, 2007
    #15
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Oliver

    2924 VLANs and SNMP

    John Oliver, Aug 5, 2004, in forum: Cisco
    Replies:
    1
    Views:
    593
  2. John Oliver

    How to configure VLANs on 2924

    John Oliver, Dec 24, 2004, in forum: Cisco
    Replies:
    4
    Views:
    11,382
    Jean Figueiredo
    Jan 1, 2005
  3. John Oliver

    Question about VLANs on 2924

    John Oliver, Dec 24, 2004, in forum: Cisco
    Replies:
    3
    Views:
    535
    Doug McIntyre
    Dec 25, 2004
  4. Replies:
    0
    Views:
    550
  5. turnip
    Replies:
    8
    Views:
    858
    turnip
    Oct 6, 2007
Loading...

Share This Page