2811 router config- dissect

Discussion in 'Cisco' started by glearng@gmail.com, Jul 21, 2008.

  1. Guest

    Whats the best way to get a better understadning of whats going on in
    this configuration of a 2811. I am trying to dissect this
    configuration so that I can understand what is in there and why.
    Please guide me in a better direction. Ive included the config, took
    some stuff out just to not share whats not mine but would greatly
    appreciate any help. Even any references also.
    Thanks in advance,

    !
    service timestamps debug datetime localtime
    service timestamps log datetime localtime
    no service password-encryption
    !
    hostname xxxxxxxxx
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 65536 debugging
    enable secret 5 xxxxxxxxxxxxxxxxx
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone MST -7
    clock summer-time MDT recurring
    clock calendar-valid
    no network-clock-participate wic 0
    network-clock-participate aim 0
    ip subnet-zero
    !
    !
    ip cef
    !
    ip domain name xxxxxxxxxxxxxxx
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.101.20.1
    ip dhcp excluded-address 10.101.20.1
    !
    ip dhcp pool VOIP
    network 10.101.2.12 255.255.255.128
    default-router 10.101.20.12
    option 150 ip 10.2.1.5 10.2.1.6
    !
    ip dhcp pool DATA
    network 10.101.2.0 255.255.255.128
    default-router 10.10.2.1
    dns-server 10.4.0.1 10.4.0.1
    !
    !
    no ip domain lookup
    !
    voice-card 0
    no dspfarm
    !
    !
    controller T1 0/0/0
    mode atm aim 0
    framing esf
    linecode b8zs
    !
    !
    class-map match-all VOIP
    match ip dscp ef
    !
    !
    policy-map LLQ
    class VOIP
    priority 90
    class class-default
    fair-queue
    !
    !
    !
    !
    interface FastEthernet0/0
    description xxxxxxxxx fa 1/0/2
    no ip address
    duplex auto
    speed auto
    max-reserved-bandwidth 100
    service-policy output LLQ
    !
    interface FastEthernet0/0.1
    description DATA
    encapsulation dot1Q 1 native
    ip address 10.101.20.1 255.255.255.128
    no snmp trap link-status
    !
    interface FastEthernet0/0.10
    description VOIP
    encapsulation dot1Q 10
    ip address 10.101.20.1 255.255.255.128
    no snmp trap link-status
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    !
    interface ATM0/0/0
    description ATM Circuit 24.HCGJ.015522
    no ip address
    no scrambling-payload
    no atm ilmi-keepalive
    max-reserved-bandwidth 100
    service-policy output LLQ
    !
    interface ATM0/0/0.36 point-to-point
    description xxxxxxxxxxxxxx
    ip address 10.100.10.1 255.255.255.252
    pvc 1/36
    ubr 1382
    encapsulation aal5snap
    !
    !
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.100.100.161
    ip route 0.0.0.0 0.0.0.0 10.101.20.1
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    snmp-server community dwr RO
    snmp-server community rwd RW
    snmp-server enable traps tty
    !
    !
    !
    control-plane
    !
    !
    banner login ^C*****Your contact number is:
    ^C
    banner motd ^C*****Welcome!
    *****This router is the property of ;
    *****Use of this network device is restricted to our network team;
    *****Unauthorized access and/or use is prohibited!
    ^C
    !
    !
    voice-port 0/1/0
    timing hookflash-out 500
    !
    voice-port 0/1/1
    timing hookflash-out 500
    !
    voice-port 0/1/2
    timing hookflash-out 500
    !
    voice-port 0/1/3
    timing hookflash-out 500
    !
    voice-port 0/2/0
    !
    voice-port 0/2/1
    !
    voice-port 0/2/2
    !
    voice-port 0/2/3
    !
    ccm-manager fallback-mgcp
    ccm-manager redundant-host 10.2.1.5
    ccm-manager mgcp
    ccm-manager music-on-hold
    ccm-manager config server 10.2.1.6
    ccm-manager config
    !
    mgcp
    mgcp call-agent 10.2.1.6 2427 service-type mgcp version 0.1
    mgcp dtmf-relay voip codec all mode out-of-band
    mgcp rtp unreachable timeout 1000 action notify
    mgcp modem passthrough voip mode nse
    mgcp package-capability rtp-package
    no mgcp package-capability res-package
    mgcp package-capability sst-package
    no mgcp package-capability fxr-package
    mgcp package-capability pre-package
    no mgcp timer receive-rtcp
    mgcp sdp simple
    mgcp fax t38 inhibit
    mgcp rtp payload-type g726r16 static
    !
    mgcp profile default
    !
    !
    !
    dial-peer voice 999010 pots
    service mgcpapp
    port 0/1/0
    !
    dial-peer voice 999011 pots
    service mgcpapp
    port 0/1/1
    !
    dial-peer voice 999012 pots
    service mgcpapp
    port 0/1/2
    !
    dial-peer voice 999013 pots
    service mgcpapp
    port 0/1/3
    !
    !
    !
    call-manager-fallback
    max-conferences 8 gain -6
    !
    !
    line con 0
    password dnr
    logging synchronous
    login
    line aux 0
    password dnr
    logging synchronous
    login
    line vty 0 4
    password dnr
    logging synchronous
    login
    transport input telnet
    !
    scheduler allocate 20000 1000
    ntp update-calendar
    !
    !
     
    , Jul 21, 2008
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Hansang Bae

    Just installed my 1st 2811 router

    Hansang Bae, Dec 18, 2004, in forum: Cisco
    Replies:
    8
    Views:
    483
  2. Replies:
    0
    Views:
    1,054
  3. Replies:
    7
    Views:
    23,628
    Walter Roberson
    Dec 24, 2004
  4. Gordon Montgomery

    2811 Async config

    Gordon Montgomery, Jun 4, 2005, in forum: Cisco
    Replies:
    0
    Views:
    1,004
    Gordon Montgomery
    Jun 4, 2005
  5. bob
    Replies:
    1
    Views:
    1,591
    summi
    Jan 26, 2006
Loading...

Share This Page