2611XM basic routing problem

Discussion in 'Cisco' started by Stuart, Jan 23, 2004.

  1. Stuart

    Stuart Guest

    Hi all,

    Rookie alert here, I'm sure you're tired of these queries, I've
    checked and tried alsorts of settings but to no avail. I'm certain
    there's probably a single line I need to make this work.

    We have purchased a 2611XM with dual ethernet ports, with the
    intention of joining two different IP LANs together.

    Our main LAN has an IP range 192.9.200.0/24, the other
    193.133.192.0/24. Although both are not normal private (class C?)
    addresses, they are not connected to the internet, they are privately
    used.

    On port FE0/0 I have configured the router with 192.9.200.9, on port
    FE0/1 193.133.192.235. Both ports are uplinked to a switch on each
    network. FE0/0 can be pinged by clients on the 192.* network, and
    FE0/1 can be pinged by clients on the 193.* network.

    The clients have the correct gateways set, respectively, and they can
    also ping the ethernet interface of the router for the other network,
    but they cannot 'see' beyond that in either direction.

    From the console of the router, I can ping any device on either of the
    networks, but it seems clients cannot pass across the ethernet
    interface of the other side.

    I've tried adding a static route, which I think is shown on the
    config, but from what I've read this router should simply 'know' to
    route traffic to the other ethernet interface if it's configured with
    the relevant IP subnet details.

    Am I missing something obvious?
    Any advice would be greatly appreciated.

    Below is the 'wr t' output.

    Thanks

    Stuart.
    -------------------------
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.9.200.9 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 193.133.192.235 255.255.255.0
    duplex auto
    speed auto
    !
    ip classless
    ip route 192.9.200.0 255.255.255.0 FastEthernet0/0
    ip route 193.133.192.0 255.255.255.0 FastEthernet0/1
    no ip http server
    ip pim bidir-enable
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    !
    end
    Stuart, Jan 23, 2004
    #1
    1. Advertising

  2. Stuart

    POPQUIZ Guest

    On 23 Jan 2004 08:24:28 -0800, (Stuart) wrote:


    You've done a wonderful job of establishing networks, but you have no
    routing protocol running on the router to tell each network about each
    other.

    Add this to your config from exec. priv mode:

    router eigrp 7
    redistribute static
    network 192.9.200.0
    network 192.133.192.0
    no auto- sum

    Even though the router runs the IP protocol, you still need to run a
    routing protocol and in this case you are implementing EIGRP

    GC
    >Hi all,
    >
    >Rookie alert here, I'm sure you're tired of these queries, I've
    >checked and tried alsorts of settings but to no avail. I'm certain
    >there's probably a single line I need to make this work.
    >
    >We have purchased a 2611XM with dual ethernet ports, with the
    >intention of joining two different IP LANs together.
    >
    >Our main LAN has an IP range 192.9.200.0/24, the other
    >193.133.192.0/24. Although both are not normal private (class C?)
    >addresses, they are not connected to the internet, they are privately
    >used.
    >
    >On port FE0/0 I have configured the router with 192.9.200.9, on port
    >FE0/1 193.133.192.235. Both ports are uplinked to a switch on each
    >network. FE0/0 can be pinged by clients on the 192.* network, and
    >FE0/1 can be pinged by clients on the 193.* network.
    >
    >The clients have the correct gateways set, respectively, and they can
    >also ping the ethernet interface of the router for the other network,
    >but they cannot 'see' beyond that in either direction.
    >
    >From the console of the router, I can ping any device on either of the
    >networks, but it seems clients cannot pass across the ethernet
    >interface of the other side.
    >
    >I've tried adding a static route, which I think is shown on the
    >config, but from what I've read this router should simply 'know' to
    >route traffic to the other ethernet interface if it's configured with
    >the relevant IP subnet details.
    >
    >Am I missing something obvious?
    >Any advice would be greatly appreciated.
    >
    >Below is the 'wr t' output.
    >
    >Thanks
    >
    >Stuart.
    >-------------------------
    >version 12.2
    >service timestamps debug uptime
    >service timestamps log uptime
    >no service password-encryption
    >!
    >hostname Router
    >!
    >!
    >ip subnet-zero
    >!
    >!
    >!
    >!
    >!
    >!
    >interface FastEthernet0/0
    > ip address 192.9.200.9 255.255.255.0
    > duplex auto
    > speed auto
    >!
    >interface FastEthernet0/1
    > ip address 193.133.192.235 255.255.255.0
    > duplex auto
    > speed auto
    >!
    >ip classless
    >ip route 192.9.200.0 255.255.255.0 FastEthernet0/0
    >ip route 193.133.192.0 255.255.255.0 FastEthernet0/1
    >no ip http server
    >ip pim bidir-enable
    >!
    >!
    >!
    >line con 0
    >line aux 0
    >line vty 0 4
    >!
    >!
    >end
    POPQUIZ, Jan 23, 2004
    #2
    1. Advertising

  3. Stuart

    Brian V Guest

    you do NOT need a routing protocol nor do you need those static routes. They
    are directly connected interfaces, you do not need to advertise them in any
    way. The static routes themselves are what could be screwing you up. The
    only static you need is a default pointing to your internet router/firewall.

    You say the clients have the correct gateways configured....they ARE the
    interfaces of the 2611 right? It's possible that those clients are using a
    different device as their default gateway and trying to goto the internet
    rather than to the other interface of the 2611.


    "POPQUIZ" <> wrote in message
    news:p...
    > On 23 Jan 2004 08:24:28 -0800, (Stuart) wrote:
    >
    >
    > You've done a wonderful job of establishing networks, but you have no
    > routing protocol running on the router to tell each network about each
    > other.
    >
    > Add this to your config from exec. priv mode:
    >
    > router eigrp 7
    > redistribute static
    > network 192.9.200.0
    > network 192.133.192.0
    > no auto- sum
    >
    > Even though the router runs the IP protocol, you still need to run a
    > routing protocol and in this case you are implementing EIGRP
    >
    > GC
    > >Hi all,
    > >
    > >Rookie alert here, I'm sure you're tired of these queries, I've
    > >checked and tried alsorts of settings but to no avail. I'm certain
    > >there's probably a single line I need to make this work.
    > >
    > >We have purchased a 2611XM with dual ethernet ports, with the
    > >intention of joining two different IP LANs together.
    > >
    > >Our main LAN has an IP range 192.9.200.0/24, the other
    > >193.133.192.0/24. Although both are not normal private (class C?)
    > >addresses, they are not connected to the internet, they are privately
    > >used.
    > >
    > >On port FE0/0 I have configured the router with 192.9.200.9, on port
    > >FE0/1 193.133.192.235. Both ports are uplinked to a switch on each
    > >network. FE0/0 can be pinged by clients on the 192.* network, and
    > >FE0/1 can be pinged by clients on the 193.* network.
    > >
    > >The clients have the correct gateways set, respectively, and they can
    > >also ping the ethernet interface of the router for the other network,
    > >but they cannot 'see' beyond that in either direction.
    > >
    > >From the console of the router, I can ping any device on either of the
    > >networks, but it seems clients cannot pass across the ethernet
    > >interface of the other side.
    > >
    > >I've tried adding a static route, which I think is shown on the
    > >config, but from what I've read this router should simply 'know' to
    > >route traffic to the other ethernet interface if it's configured with
    > >the relevant IP subnet details.
    > >
    > >Am I missing something obvious?
    > >Any advice would be greatly appreciated.
    > >
    > >Below is the 'wr t' output.
    > >
    > >Thanks
    > >
    > >Stuart.
    > >-------------------------
    > >version 12.2
    > >service timestamps debug uptime
    > >service timestamps log uptime
    > >no service password-encryption
    > >!
    > >hostname Router
    > >!
    > >!
    > >ip subnet-zero
    > >!
    > >!
    > >!
    > >!
    > >!
    > >!
    > >interface FastEthernet0/0
    > > ip address 192.9.200.9 255.255.255.0
    > > duplex auto
    > > speed auto
    > >!
    > >interface FastEthernet0/1
    > > ip address 193.133.192.235 255.255.255.0
    > > duplex auto
    > > speed auto
    > >!
    > >ip classless
    > >ip route 192.9.200.0 255.255.255.0 FastEthernet0/0
    > >ip route 193.133.192.0 255.255.255.0 FastEthernet0/1
    > >no ip http server
    > >ip pim bidir-enable
    > >!
    > >!
    > >!
    > >line con 0
    > >line aux 0
    > >line vty 0 4
    > >!
    > >!
    > >end

    >
    Brian V, Jan 23, 2004
    #3
  4. In article <0FgQb.5032$U%5.28102@attbi_s03>, "Brian V" <> wrote:
    >you do NOT need a routing protocol nor do you need those static routes. They
    >are directly connected interfaces, you do not need to advertise them in any


    I would have to agree with this. Do not add the routing protocol and delete
    the static routes. Then on the clients make sure that.. ( see below )

    >> >interface FastEthernet0/0
    >> > ip address 192.9.200.9 255.255.255.0


    for the ones connected to this interface, use 192.9.200.9 as the default
    gateway and..

    >> >!
    >> >interface FastEthernet0/1
    >> > ip address 193.133.192.235 255.255.255.0


    for the ones connected to this interface, use 192.133.192.235 as the default
    gateway.

    That should work.


    Gordon Montgomery
    Living Scriptures, Inc
    (anti spam - replace lsi with livingscriptures)
    (801) 627-2000
    Gordon Montgomery, Jan 23, 2004
    #4
  5. Stuart

    joe Guest

    yes. never run a routing protocol unless you *absolutey have to*
    and then only run one your FULLY understand. You will never need
    to run EIGRP if you only have 1 router.

    (Gordon Montgomery) wrote in message news:<>...
    > In article <0FgQb.5032$U%5.28102@attbi_s03>, "Brian V" <> wrote:
    > >you do NOT need a routing protocol nor do you need those static routes. They
    > >are directly connected interfaces, you do not need to advertise them in any

    >
    > I would have to agree with this. Do not add the routing protocol and delete
    > the static routes. Then on the clients make sure that.. ( see below )
    >
    > >> >interface FastEthernet0/0
    > >> > ip address 192.9.200.9 255.255.255.0

    >
    > for the ones connected to this interface, use 192.9.200.9 as the default
    > gateway and..
    >
    > >> >!
    > >> >interface FastEthernet0/1
    > >> > ip address 193.133.192.235 255.255.255.0

    >
    > for the ones connected to this interface, use 192.133.192.235 as the default
    > gateway.
    >
    > That should work.
    >
    >
    > Gordon Montgomery
    > Living Scriptures, Inc
    > (anti spam - replace lsi with livingscriptures)
    > (801) 627-2000
    joe, Jan 24, 2004
    #5
  6. Stuart

    Stuart Guest

    > I would have to agree with this. Do not add the routing protocol and delete
    > the static routes. Then on the clients make sure that.. ( see below )


    > >> >interface FastEthernet0/0
    > >> > ip address 192.9.200.9 255.255.255.0

    > for the ones connected to this interface, use 192.9.200.9 as the default
    > gateway and..
    > >> >interface FastEthernet0/1
    > >> > ip address 193.133.192.235 255.255.255.0


    Thanks all, however this is what I have already tried. I found
    something else after my original post, but I still can't understand
    why this behaviour occurs.

    I've found that machines on the 192.* range can ping machines on the
    193.* without a problem, but those in the 193.* cannot ping any in the
    192.* range voluntarily unless a 192.* machine has already pinged a
    193 first.. does that make sense?

    It seems that some kind of one-way connection is going on perhaps.
    Any recommendations for clearing everything and starting from fresh?

    Thanks for your patience, I've just gotten back in so I'll update you
    later.

    Stuart.
    Stuart, Jan 24, 2004
    #6
  7. Stuart

    Stuart Guest

    Thanks all, it appears to be working fine now, the problem seems to be
    our PIX firewall that has been configured (not by me!! :) to do some
    strange routing for our other site (the one with the 193 range).

    Trouble is, the config on the PIX involves a VPN tunnel across the
    internet to the other site via DSL, whereas the 2611 is going to be
    used from the inside on a new seperate link (essentially a 10Mbs
    simulated ethernet link, acts like a long piece of ethernet between
    our sites). The idea was that the DSL will be used as a backup
    solution for the site, while the ethernet anywhere link will be the
    primary.

    I believe the issues I've encountered are to do with the PIX expecting
    traffic to arrive from 193 devices from 'outside' of our network, but
    when it sees packets arriving from 193 from within the LAN where the
    PIX is based (192.*) it drops them, perhaps.

    I think that's what it may have been, without the PIX as the gateway,
    etc, the router is working fine.

    Whatever the case we'll be getting our ISP fella's in soon to
    reconfigure our PIX anyway, we'll get them to look at it.

    Thanks for your time and suggestions all, much appreciated!

    Stuart.
    Stuart, Jan 24, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Eric Rees

    Re: Bridging on CISCO 2611XM

    Eric Rees, Jul 18, 2003, in forum: Cisco
    Replies:
    0
    Views:
    487
    Eric Rees
    Jul 18, 2003
  2. JCVD
    Replies:
    1
    Views:
    430
    Martin Gallagher
    Feb 13, 2004
  3. news
    Replies:
    9
    Views:
    3,299
    Steinar Haug
    Mar 4, 2004
  4. dritix

    How to install NM-1E on 2611XM

    dritix, Oct 16, 2004, in forum: Cisco
    Replies:
    5
    Views:
    969
    dritix
    Oct 18, 2004
  5. Steven

    Problem with 2611XM

    Steven, May 11, 2005, in forum: Cisco
    Replies:
    0
    Views:
    1,152
    Steven
    May 11, 2005
Loading...

Share This Page