2511 access server config or hardware going wrong?

Discussion in 'Cisco' started by Jasper Janssen, Nov 18, 2009.

  1. Hi,

    I recently acquired as part of a job lot a 2511 access server. I purchased
    the require CAB-OCTAL-ASYNC cables (albeit not the Cisco brand ones) for
    it, and they've just arrived. Now I'm not getting anything through those
    ports connected to a console that is known working with my console cable
    from my PC.

    I don't have any problems setting up reverse telnet sessions to the async
    lines, but I don't get anything, or only garbage, out of them.

    [first connected with console to a router]
    2501-1#
    [switching console cable to the 2511, and plugging cable 5 on port 1 into
    the console port I just had -- this is just an example, all ports do the
    same as far as I can tell]
    2511#R5
    Trying R5 (192.168.3.1, 2005)... Open
    [nothing, then in response to say, hitting <enter>, garbage characters]
    [ctrl-shift-6 X]
    2511#
    [switch console cable back to 2501-1, check command history]
    2501-1#`~~~~ [and more like that]

    So what appears to be happening is that there *is* physical data going out
    those cables, and some getting through back, but it is all garbled.

    Is this likely to be a configuration issue or a hardware issue? Hardware
    in question is a bit iffy[1], configuration is good AFAICT[2].
    Incidentally, line 17, the Aux, when connected via rollover to a console
    port, works just fine, including the reverse telnet bits, when I'm not
    using it to route packets over.


    Jasper

    [1] This 2511 initially refused to boot with a bad memory error, even with
    flash and dram simms removed. It was one of the 2511s with 2 megs onboard,
    which had the error, apparently. After removing those 4 memory chips from
    the motherboard, it booted again quite happily, using the simm, and I
    thought I'd fixed the problem. However, earlier today it was again giving
    memory errors, and stopped doing that only after I'd thumped it once or
    twice [percussive maintenance]. Also, the AUI interface simply doesn't
    work. IOW, I'm not that confident about the hardware. The cables I can't
    be 100 percent sure about, as I haven't (and can't) tested them on a
    separate machine, but it would be odd for two cables to fail on all 8
    ports simultaneously.

    [2] I've tried it both with the async lines configured as standard, or
    with explicitly setting speed 9600 databits 8 flow none stopbits 1, only
    the last of which comes up in the config at all.
     
    Jasper Janssen, Nov 18, 2009
    #1
    1. Advertising

  2. On Wed, 18 Nov 2009 15:36:46 +0100, Jasper Janssen
    <> wrote:

    Hm. I tried posting the full configuration in a reply, but for some reason
    those aren't showing up on my server. Did anyone else see them?

    Jasper
     
    Jasper Janssen, Nov 18, 2009
    #2
    1. Advertising

  3. On Wed, 18 Nov 2009 16:18:11 +0100, Jasper Janssen
    <> wrote:
    >On Wed, 18 Nov 2009 15:36:46 +0100, Jasper Janssen
    ><> wrote:
    >
    >Hm. I tried posting the full configuration in a reply, but for some reason
    >those aren't showing up on my server. Did anyone else see them?


    Hm. Oops. It appears it's been so long since I used usenet I forgot the
    keyboard shortcut is <F>ollow-up, not <R>eply to email.

    Oh well. Here it is after all:


    User Access Verification

    Password:
    2511>en
    Password:
    2511#sh run
    Building configuration...

    Current configuration:
    !
    version 11.0
    service udp-small-servers
    service tcp-small-servers
    !
    hostname 2511
    !
    enable password elided
    !
    !
    interface Loopback0
    ip address 192.168.3.1 255.255.255.0
    !
    interface Ethernet0
    no ip address
    shutdown
    !
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface Async17
    ip address 192.168.2.1 255.255.255.0
    encapsulation ppp
    async dynamic routing
    async mode dedicated
    no cdp enable
    !
    ip host R1 2001 192.168.3.1
    ip host R2 2002 192.168.3.1
    ip host R3 2003 192.168.3.1
    ip host R4 2004 192.168.3.1
    ip host S1 2008 192.168.3.1
    ip host S2 2007 192.168.3.1
    ip host S3 2006 192.168.3.1
    ip host FRS 2005 192.168.3.1
    ip host R16 2016 192.168.3.1
    ip host R15 2015 192.168.3.1
    ip host R13 2013 192.168.3.1
    ip host R14 2014 192.168.3.1
    ip host R12 2012 192.168.3.1
    ip host R11 2011 192.168.3.1
    ip host R10 2010 192.168.3.1
    ip host R9 2009 192.168.3.1
    ip host R8 2008 192.168.3.1
    ip host R7 2007 192.168.3.1
    ip host R6 2006 192.168.3.1
    ip host R5 2005 192.168.3.1
    ip route 0.0.0.0 0.0.0.0 192.168.2.2
    !
    line con 0
    no exec
    exec-timeout 0 0
    logging synchronous
    line 1 16
    session-timeout 20
    no exec
    exec-timeout 0 0
    transport input telnet
    line aux 0
    modem InOut
    transport input all
    rxspeed 38400
    txspeed 38400
    flowcontrol hardware
    line vty 0 4
    password elided
    logging synchronous
    login
    !
    end

    2511#
     
    Jasper Janssen, Nov 18, 2009
    #3
  4. On Wed, 18 Nov 2009 15:36:46 +0100, Jasper Janssen
    <> wrote:

    >The cables I can't
    >be 100 percent sure about, as I haven't (and can't) tested them on a
    >separate machine, but it would be odd for two cables to fail on all 8
    >ports simultaneously.


    Extra info: In another job lot, someone threw in a genuine cisco octal
    cable, same problem.

    Jasper
     
    Jasper Janssen, Nov 20, 2009
    #4
  5. Jasper Janssen

    tweety Guest

    On Nov 20, 12:58 pm, Jasper Janssen <> wrote:
    > On Wed, 18 Nov 2009 15:36:46 +0100, Jasper Janssen
    >
    > <> wrote:
    > >The cables I can't
    > >be 100 percent sure about, as I haven't (and can't) tested them on a
    > >separate machine, but it would be odd for two cables to fail on all 8
    > >ports simultaneously.

    >
    > Extra info: In another job lot, someone threw in a genuine cisco octal
    > cable, same problem.
    >
    > Jasper


    can you do a "show line" there should be an asterisk next to the lines
    in use

    try clear line tty 1, then R1

    also on the routers and switches etc under the line do a transport
    input all
     
    tweety, Nov 21, 2009
    #5
  6. Jasper Janssen

    Morph Guest

    In the message <> Jasper
    Janssen wrote:


    | On Wed, 18 Nov 2009 16:18:11 +0100, Jasper Janssen
    | <> wrote:
    | >On Wed, 18 Nov 2009 15:36:46 +0100, Jasper Janssen
    | ><> wrote:
    | >
    | >Hm. I tried posting the full configuration in a reply, but for some reason
    | >those aren't showing up on my server. Did anyone else see them?
    |
    | Hm. Oops. It appears it's been so long since I used usenet I forgot the
    | keyboard shortcut is <F>ollow-up, not <R>eply to email.
    |
    | Oh well. Here it is after all:
    |
    | ip host R1 2001 192.168.3.1

    I think the ports should start from 2002
    So your cable marked with zero would go into R1 and the config for that
    would be:
    ip host R1 2002 192.168.3.1
     
    Morph, Nov 21, 2009
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. robert mcfadzien

    CISCO 2511 - Dialin access / DTR

    robert mcfadzien, Jul 15, 2003, in forum: Cisco
    Replies:
    1
    Views:
    3,354
    Aaron Leonard
    Jul 17, 2003
  2. Jake Peters
    Replies:
    2
    Views:
    2,558
    premprakash
    Aug 12, 2009
  3. jchun
    Replies:
    0
    Views:
    2,920
    jchun
    May 17, 2006
  4. John Heitmuller
    Replies:
    1
    Views:
    774
    Doug McIntyre
    Apr 22, 2008
  5. Replies:
    2
    Views:
    453
Loading...

Share This Page