2 T-1 multilink ppp, inconsistent ping

Discussion in 'Cisco' started by Karnov, May 20, 2004.

  1. Karnov

    Karnov Guest

    Hi all,

    I've got a 2621XM with the c2600-ik9o3s-mz.123-6a.bin IOS. Using Multilink PPP
    on 2 T-1s, pinging the router's Multilink interface produces inconsistent ping
    times, 3-18ms from a nearby router. Everything else seems to work OK.

    What could cause this?

    Here's the config:

    interface Multilink3
    ip address 1.1.1.218 255.255.255.252
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    ppp multilink
    ppp multilink fragment disable
    ppp multilink group 3
    !
    interface FastEthernet0/0
    description LAN
    ip address 10.10.10.1 255.255.255.248
    ip nat inside
    duplex auto
    speed auto
    !
    interface Serial0/0
    description 1st T-1 to ISP
    no ip address
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    ppp multilink group 3
    !
    interface Serial0/1
    description 2nd T-1 to ISP
    no ip address
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    ppp multilink group 3
    !
    ip nat inside source list 1 interface Multilink3 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Multilink3

    Here's an example ping from behind the 2621XM router to another nearby one at
    1.1.1.18:

    Reply from 1.1.1.18: bytes=32 time=3ms TTL=251
    Reply from 1.1.1.18: bytes=32 time=9ms TTL=251
    Reply from 1.1.1.18: bytes=32 time=16ms TTL=251
    Reply from 1.1.1.18: bytes=32 time=8ms TTL=251
    Reply from 1.1.1.18: bytes=32 time=4ms TTL=251
    Reply from 1.1.1.18: bytes=32 time=7ms TTL=251
    Reply from 1.1.1.18: bytes=32 time=14ms TTL=251

    Karnov
     
    Karnov, May 20, 2004
    #1
    1. Advertising

  2. Karnov

    Karnov Guest

    ps - if I setup each interface separately using PPP or HDLC, each T-1 has
    consistent ping times. The T-1 lines are each physically OK. As soon as I turn
    on ppp multilink, even if one of the Serials is shutdown, the ping times are
    inconsistent. Also, there is never any packet loss, just inconsistent pings.

    In article <>, Karnov says...
    >
    >Hi all,
    >
    >I've got a 2621XM with the c2600-ik9o3s-mz.123-6a.bin IOS. Using Multilink PPP
    >on 2 T-1s, pinging the router's Multilink interface produces inconsistent ping
    >times, 3-18ms from a nearby router. Everything else seems to work OK.
    >
    >What could cause this?
    >
    >Here's the config:
    >
    >interface Multilink3
    > ip address 1.1.1.218 255.255.255.252
    > ip nat outside
    > no ip route-cache
    > no ip mroute-cache
    > ppp multilink
    > ppp multilink fragment disable
    > ppp multilink group 3
    >!
    >interface FastEthernet0/0
    > description LAN
    > ip address 10.10.10.1 255.255.255.248
    > ip nat inside
    > duplex auto
    > speed auto
    >!
    >interface Serial0/0
    > description 1st T-1 to ISP
    > no ip address
    > encapsulation ppp
    > no ip route-cache
    > no ip mroute-cache
    > no fair-queue
    > ppp multilink
    > ppp multilink group 3
    >!
    >interface Serial0/1
    > description 2nd T-1 to ISP
    > no ip address
    > encapsulation ppp
    > no ip route-cache
    > no ip mroute-cache
    > no fair-queue
    > ppp multilink
    > ppp multilink group 3
    >!
    >ip nat inside source list 1 interface Multilink3 overload
    >ip classless
    >ip route 0.0.0.0 0.0.0.0 Multilink3
    >
    >Here's an example ping from behind the 2621XM router to another nearby one at
    >1.1.1.18:
    >
    >Reply from 1.1.1.18: bytes=32 time=3ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=9ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=16ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=8ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=4ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=7ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=14ms TTL=251
    >
    >Karnov
    >
     
    Karnov, May 20, 2004
    #2
    1. Advertising

  3. Karnov

    Rob Guest

    Any particular reason you force process-switching by turning off
    route-cache?? You may also want to turn on "IP CEF" as well.



    On 20 May 2004 07:40:24 -0700, Karnov <> wrote:

    >Hi all,
    >
    >I've got a 2621XM with the c2600-ik9o3s-mz.123-6a.bin IOS. Using Multilink PPP
    >on 2 T-1s, pinging the router's Multilink interface produces inconsistent ping
    >times, 3-18ms from a nearby router. Everything else seems to work OK.
    >
    >What could cause this?
    >
    >Here's the config:
    >
    >interface Multilink3
    > ip address 1.1.1.218 255.255.255.252
    > ip nat outside
    > no ip route-cache
    > no ip mroute-cache
    > ppp multilink
    > ppp multilink fragment disable
    > ppp multilink group 3
    >!
    >interface FastEthernet0/0
    > description LAN
    > ip address 10.10.10.1 255.255.255.248
    > ip nat inside
    > duplex auto
    > speed auto
    >!
    >interface Serial0/0
    > description 1st T-1 to ISP
    > no ip address
    > encapsulation ppp
    > no ip route-cache
    > no ip mroute-cache
    > no fair-queue
    > ppp multilink
    > ppp multilink group 3
    >!
    >interface Serial0/1
    > description 2nd T-1 to ISP
    > no ip address
    > encapsulation ppp
    > no ip route-cache
    > no ip mroute-cache
    > no fair-queue
    > ppp multilink
    > ppp multilink group 3
    >!
    >ip nat inside source list 1 interface Multilink3 overload
    >ip classless
    >ip route 0.0.0.0 0.0.0.0 Multilink3
    >
    >Here's an example ping from behind the 2621XM router to another nearby one at
    >1.1.1.18:
    >
    >Reply from 1.1.1.18: bytes=32 time=3ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=9ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=16ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=8ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=4ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=7ms TTL=251
    >Reply from 1.1.1.18: bytes=32 time=14ms TTL=251
    >
    >Karnov
     
    Rob, May 20, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Gerd Thümmler

    ppp multilink lost many fragments

    Gerd Thümmler, Jul 11, 2003, in forum: Cisco
    Replies:
    0
    Views:
    2,855
    Gerd Thümmler
    Jul 11, 2003
  2. Klaus Kruse

    Re: ppp multilink on 2500/3600

    Klaus Kruse, Oct 23, 2003, in forum: Cisco
    Replies:
    1
    Views:
    662
    Aaron Leonard
    Oct 27, 2003
  3. Gerd Thuemmler
    Replies:
    0
    Views:
    2,329
    Gerd Thuemmler
    Nov 27, 2003
  4. Karnov
    Replies:
    1
    Views:
    8,447
    CCIE8122
    May 24, 2004
  5. Mike Dorn

    Multilink PPP vs ping times.

    Mike Dorn, Mar 27, 2007, in forum: Cisco
    Replies:
    1
    Views:
    1,075
    Vincent C Jones
    Mar 29, 2007
Loading...

Share This Page