2 ISP, Load balancing + NAT

Discussion in 'Cisco' started by angel, Mar 27, 2009.

  1. angel

    angel

    Joined:
    Mar 27, 2009
    Messages:
    1
    Hi all

    i have cisco 1841 with HWIC 4 port card installed on it. What i'm trying to setup is some load balancing between 2 ISP and do static nat to my internal network.
    So, first ISP is leased line with static public IP address (5Mbit) , and the second one pppoe (1,5Mbit) from which i also receive static public IP address.
    Vlan interface is configured for the internal network

    It looks something like this:
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    vpdn enable
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    description Wi-Fi PPPoE$ETH-WAN$
    no ip address
    duplex auto
    speed auto
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface FastEthernet0/1
    description ISA Leased Line$ETH-WAN$
    ip address ip addr netmask
    ip nat outside
    ip tcp adjust-mss 1412
    duplex auto
    speed auto
    !
    interface FastEthernet0/0/0
    !
    interface FastEthernet0/0/1
    !
    interface FastEthernet0/0/2
    !
    interface FastEthernet0/0/3
    description Test
    switchport access vlan 2
    !
    interface Vlan1
    no ip address
    ip nat inside
    !
    interface Vlan2
    ip address 10.10.5.1 255.255.255.240
    ip nat inside
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username username password password
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 public IP Leased Line
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    no ip http server
    ip nat inside source list 1 interface FastEthernet0/1 overload
    ip nat inside source route-map pppoe_nat interface Dialer1 overload (this is just a test)
    !
    access-list 1 permit 10.10.5.0 0.0.0.255
    access-list 2 permit any
    dialer-list 1 protocol ip permit

    Router is doing load balancing between the lines, if i switch off one of the ISP lines, the router is up with internet.
    I think my main problem is hidding in the NAT settings and access-lists.
    I'm not an cisco expert, so i hope u guys can help me somehow to solve this problem . :?

    Thanks in advance for any help
    Angel
     
    angel, Mar 27, 2009
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Terry Baranski

    Re: Load balancing 2 ISP's & BGP?

    Terry Baranski, Jul 24, 2003, in forum: Cisco
    Replies:
    2
    Views:
    1,258
    Barry Margolin
    Jul 24, 2003
  2. Rob
    Replies:
    6
    Views:
    1,000
    Barry Margolin
    Jul 25, 2003
  3. ciscortp@hotmail.com

    Load Balancing / Load Sharing over parallel paths

    ciscortp@hotmail.com, Nov 21, 2005, in forum: Cisco
    Replies:
    1
    Views:
    2,348
    Vincent C Jones
    Nov 21, 2005
  4. sada1981
    Replies:
    1
    Views:
    597
    Trendkill
    May 20, 2007
  5. palas_123
    Replies:
    1
    Views:
    2,109
    donjohnston
    Dec 28, 2009
Loading...

Share This Page