2 3550's on a Netgear Switch

Discussion in 'Cisco' started by Jo Knight, May 10, 2004.

  1. Jo Knight

    Jo Knight Guest

    Hello,

    I have a couple of 3550 switches that intend to use for an internal LAN
    using VLANs and HSRP for redundancy.

    I am just testing this configuration at the moment, and have so far got
    inter-VLAN routing going fine but now have run into a problem. My test
    network structure is as follows:

    2x 3550 switches (a and b for this example)

    hostA = 192.168.1.2
    port4 (VLAN 192) SVI = 192.168.1.1
    port24 (VLAN 22) SVI = 192.168.22.250
    hostB = 192.168.22.50

    hostA -> 3550a(port 4 VLAN 192) -> 3550a(port24 VLAN 22) -> Netgear Switch
    <- hostB

    With my current config I can connect between hostA and hostB with no
    problem. The problem comes when I plug an additional 3550 with VLAN
    interface (3550b port22 VLAN22 192.168.22.249) into the Netgear switch. I
    thought that both of the 3550's would be independent and just appear as two
    devices on the network (ie 2 routers) connected to the Netgear switch
    (192.168.22.0), but once I connect the 2nd 2550 to the Netgear I am unable
    to route from VLAN192 and VLAN22. I turned on some debugging and see these
    events just after the standby 3550(b) is plugged into the Netgear:

    01:38:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24,
    changed state to down
    01:38:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan22, changed
    state to down
    01:38:08: %STANDBY-6-STATECHANGE: Vlan22 Group 22 state Active -> Init
    01:38:08: is_up: 0 state: 4 sub state: 1 line: 0
    01:38:08: RT: interface Vlan22 removed from routing table
    01:38:08: RT: del 192.168.22.0 via 0.0.0.0, connected metric [0/0]
    01:38:08: RT: delete network route to 192.168.22.0
    01:38:11: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24,
    changed state to up

    It looks to me as if the primary 3550(a) is removing the route for the
    192.168.22.0 network once the standby 3550(b) is intorduced onto the Netgear
    switch. Why?

    So it would seem that for some reason, I cannot have interfaces from each of
    my 3550's on the same subnet which I find strange as I will need this so
    that I can implement HSRP correctly. Am I correct in thinking that I need to
    have 2 uplinks (1 to each of the 3550 ports configured on the 192.168.22.0
    network from the Netgear)

    Has anyone done something similar using a couple of 3550's for the VLANs and
    routing, connecting to a series of unmanaged switches like the Netgears.

    Thanks for any pointers.
    Jo

    (snipped configs follow) I can provide further output if required.

    ----- 3550a Config -----
    interface FastEthernet0/4
    switchport access vlan 192
    switchport mode dynamic desirable
    no ip address
    !
    interface FastEthernet0/24
    switchport access vlan 22
    switchport mode dynamic desirable
    no ip address
    !
    interface Vlan22
    ip address 192.168.22.250 255.255.255.0
    no ip redirects
    standby 22 ip 192.168.22.254
    !
    interface Vlan192
    ip address 192.168.1.1 255.255.255.0
    no ip redirects
    !
    !

    ----- 3550b config -----
    interface FastEthernet0/22
    switchport access vlan 22
    switchport mode dynamic desirable
    no ip address
    !
    interface Vlan22
    ip address 192.168.22.249 255.255.255.0
    no ip redirects
    standby 22 ip 192.168.22.254
    !
     
    Jo Knight, May 10, 2004
    #1
    1. Advertising

  2. In article <uDNnc.23$>,
    Jo Knight <> wrote:
    :I have a couple of 3550 switches that intend to use for an internal LAN
    :using VLANs and HSRP for redundancy.

    :The problem comes when I plug an additional 3550 with VLAN
    :interface (3550b port22 VLAN22 192.168.22.249) into the Netgear switch. I
    :thought that both of the 3550's would be independent and just appear as two
    :devices on the network (ie 2 routers) connected to the Netgear switch
    :(192.168.22.0), but once I connect the 2nd 2550 to the Netgear I am unable
    :to route from VLAN192 and VLAN22. I turned on some debugging and see these
    :events just after the standby 3550(b) is plugged into the Netgear:


    :01:38:08: RT: interface Vlan22 removed from routing table

    Sounds to me as if you have VTP configured on the 3550's, and that
    you have the same (perhaps default) VTP 'community') configured for both.
    One of your 3550's is then pushing your vlan policy to the other one.
    --
    Whose posting was this .signature Google'd from?
     
    Walter Roberson, May 10, 2004
    #2
    1. Advertising

  3. Jo Knight

    Jo Knight Guest

    Jo Knight wrote:
    > It looks to me as if the primary 3550(a) is removing the route for the
    > 192.168.22.0 network once the standby 3550(b) is introduced onto the

    Netgear
    > switch. Why?


    It would seem that if I changed 'switchport mode dynamic desirable' to
    'switchport mode access' on the Fa ports that connect to the Netgear it
    works OK
     
    Jo Knight, May 11, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    9
    Views:
    4,676
    Query Builder
    Mar 3, 2005
  2. desdronox
    Replies:
    1
    Views:
    2,915
    Terry Baranski
    Jul 10, 2003
  3. JohnNews
    Replies:
    10
    Views:
    6,732
    One Step Beyond
    Oct 20, 2003
  4. Steinar Haug
    Replies:
    0
    Views:
    703
    Steinar Haug
    Oct 20, 2003
  5. Jeff Knapp
    Replies:
    1
    Views:
    850
    =?iso-8859-1?q?BradReese.Com=AE_-_Leverage_Your_Ci
    Jun 12, 2006
Loading...

Share This Page