1721 with 1 Serial and 1 Ethernet on a Satellite linkup

Discussion in 'Cisco' started by Anubis, Nov 26, 2004.

  1. Anubis

    Anubis Guest

    Hello,

    I have a 1721 router with one Serial WAN card and one single port Ethernet
    WAN card.
    What I need to do is configure the router such that it routes all incoming
    (into my network) information from the Ethernet WAN card into my network and
    routes all the outgoing information to the Serial WAN card.

    I have a satellite linkup with TX and RX on separate devices thus requiring
    the above configuration.

    I also need to have all IP addresses and IP packets routed to my firewall
    which will perform the NAT for my network.

    Anyone who can provide assistance in this, could you please either reply to
    this post or contact me directly at

    Thanking any one in advance who can help!

    -Anubis
     
    Anubis, Nov 26, 2004
    #1
    1. Advertising

  2. Anubis

    PES Guest

    Anubis wrote:
    > Hello,
    >
    > I have a 1721 router with one Serial WAN card and one single port Ethernet
    > WAN card.
    > What I need to do is configure the router such that it routes all incoming
    > (into my network) information from the Ethernet WAN card into my network and
    > routes all the outgoing information to the Serial WAN card.
    >
    > I have a satellite linkup with TX and RX on separate devices thus requiring
    > the above configuration.
    >
    > I also need to have all IP addresses and IP packets routed to my firewall
    > which will perform the NAT for my network.
    >
    > Anyone who can provide assistance in this, could you please either reply to
    > this post or contact me directly at
    >
    > Thanking any one in advance who can help!
    >
    > -Anubis
    >
    >


    Just guessing here, I've not seen this done. I would configure my
    serical wic. Then on the ethernet I would use "ip unnumbered serial X".
    If it accepts the command, the ethernet and serial can share the
    address. Then set your default route for the next hop assigned to you
    by the isp. If it does something wierd (like trying to route every
    other packet out the ethernet, you may have to do something like policy
    routing on the fastethernet and set the next hop along with the output
    interface. Please let me know how this works out, it is an interesting
    scenario.

    --
    -------------------------
    Paul Stewart
    Lexnet Inc.
    Email address is in ROT13
     
    PES, Nov 27, 2004
    #2
    1. Advertising

  3. Anubis

    Erik Freitag Guest

    On Fri, 26 Nov 2004 11:55:59 +0000, Anubis wrote:

    > Hello,
    >
    > I have a 1721 router with one Serial WAN card and one single port Ethernet
    > WAN card.
    > What I need to do is configure the router such that it routes all incoming
    > (into my network) information from the Ethernet WAN card into my network and
    > routes all the outgoing information to the Serial WAN card.
    >
    > I have a satellite linkup with TX and RX on separate devices thus requiring
    > the above configuration.
    >
    > I also need to have all IP addresses and IP packets routed to my firewall
    > which will perform the NAT for my network.
    >
    > Anyone who can provide assistance in this, could you please either reply to
    > this post or contact me directly at
    >
    > Thanking any one in advance who can help!
    >
    > -Anubis


    I apologize for being dense, but if you have a router with two interfaces,
    and both of those interfaces are connected to your ISP/satellite
    connection, how do you connect the router to your internal network or
    firewall? Are you trunking the Ethernet?

    If you have another interface or VLAN facing your internal network, then
    this doesn't sound complicated. The router's default route would be
    configured to point to the serial (outbound) interface and incoming
    traffic over the RX Ethernet port could be directed to your internal
    firewall using a static route. Asymmetric routing, of course, but that's
    how your satellite provider designed it.

    I'm thinking something like this:

    (ethernet0) RX-\
    ROUTER-(ethernet1)-FIREWALL-INSIDE NETWORK
    (serial0) TX-/

    So, for instance if you have the following interfaces and addresses:

    TX interface is Serial 0 address 2.3.4.5/30
    RX interface is Ethernet 0 address 4.5.6.7/30
    inside interface is Ethernet 1 address 6.7.8.9/30
    firewall's outside interface is 6.7.8.10/30
    NAT address is 20.20.20.20/32

    the relevant configuration would be:

    ===

    interface Serial 0
    ip address 2.3.4.5 255.255.255.252

    interface Ethernet 0
    ip address 4.5.6.7 255.255.255.252

    interface Ethernet 1
    ip address 6.7.8.9 255.255.255.252

    ip route 0.0.0.0 0.0.0.0 serial0 (or ip route 0.0.0.0 0.0.0.0 2.3.4.6)
    ip route 20.20.20.20 255.255.255.255 6.7.8.10

    ===


    The firewall should forward all outbound traffic to 6.7.8.9
     
    Erik Freitag, Nov 27, 2004
    #3
  4. Anubis

    PES Guest

    Erik Freitag wrote:
    > On Fri, 26 Nov 2004 11:55:59 +0000, Anubis wrote:
    >
    >
    >>Hello,
    >>
    >>I have a 1721 router with one Serial WAN card and one single port Ethernet
    >>WAN card.
    >>What I need to do is configure the router such that it routes all incoming
    >>(into my network) information from the Ethernet WAN card into my network and
    >>routes all the outgoing information to the Serial WAN card.
    >>
    >>I have a satellite linkup with TX and RX on separate devices thus requiring
    >>the above configuration.
    >>
    >>I also need to have all IP addresses and IP packets routed to my firewall
    >>which will perform the NAT for my network.
    >>
    >>Anyone who can provide assistance in this, could you please either reply to
    >>this post or contact me directly at
    >>
    >>Thanking any one in advance who can help!
    >>
    >>-Anubis

    >
    >
    > I apologize for being dense, but if you have a router with two interfaces,
    > and both of those interfaces are connected to your ISP/satellite
    > connection, how do you connect the router to your internal network or
    > firewall? Are you trunking the Ethernet?
    >


    <snip>

    Tho original poster said he had a "Serial WAN card and one single port
    Ethernet WAN card". The 1721 has a built in fast etherenet port for a
    total of three interfaces.
    --
    -------------------------
    Paul Stewart
    Lexnet Inc.
    Email address is in ROT13
     
    PES, Nov 27, 2004
    #4
  5. Anubis

    Erik Freitag Guest

    On Sat, 27 Nov 2004 08:54:57 -0500, PES wrote:

    > Tho original poster said he had a "Serial WAN card and one single port
    > Ethernet WAN card". The 1721 has a built in fast etherenet port for a
    > total of three interfaces.


    Thanks - I knew I was missing something simple.
     
    Erik Freitag, Nov 27, 2004
    #5
  6. Anubis

    Ivan Ostreš Guest

    In article <jREpd.49197$>,
    says...
    > Hello,
    >
    > I have a 1721 router with one Serial WAN card and one single port Ethernet
    > WAN card.
    > What I need to do is configure the router such that it routes all incoming
    > (into my network) information from the Ethernet WAN card into my network and
    > routes all the outgoing information to the Serial WAN card.
    >
    > I have a satellite linkup with TX and RX on separate devices thus requiring
    > the above configuration.
    >
    > I also need to have all IP addresses and IP packets routed to my firewall
    > which will perform the NAT for my network.
    >
    > Anyone who can provide assistance in this, could you please either reply to
    > this post or contact me directly at
    >


    You can simply go like this:

    interface Ethernet 0
    transmit-interface Serial 0
    ip address 1.1.1.1 255.255.255.252

    .....or similar to this (the idea is "transmit-interface" command). You
    could also fix this by using policy routing, but you will have some
    other issues then, but they are solvable.

    HTH,

    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostreš, Nov 28, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter
    Replies:
    2
    Views:
    1,101
  2. Graeme
    Replies:
    17
    Views:
    2,996
    charter
    Dec 20, 2003
  3. Scooter
    Replies:
    1
    Views:
    926
    BradReeseCom
    Feb 25, 2005
  4. Marina

    Satellite TV 4 You: Free Satellite TV systems

    Marina, Dec 25, 2007, in forum: Digital Photography
    Replies:
    0
    Views:
    501
    Marina
    Dec 25, 2007
  5. Marina

    Satellite TV 4 You: Free Satellite TV systems

    Marina, Dec 25, 2007, in forum: Computer Support
    Replies:
    0
    Views:
    1,112
    Marina
    Dec 25, 2007
Loading...

Share This Page