1721 isdn router configuration problem

Discussion in 'Cisco' started by Mircea, Jan 27, 2004.

  1. Mircea

    Mircea Guest

    I tried to connect two location using two 1721 CISCO routers and two ISDN lines.
    This is the configuration that doesn't work and I am without ideas.
    Can you help me please to troubleshoot this ISDN settings:
    (mention - first time I tried with only 1 line)
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname XXX
    !
    enable secret 5 $1$Ke/r$UOB8Y9kHrgxWi2FAK7b2N1
    !
    username YYY password 7 03065419085A78 (the name of the second router)
    ip subnet-zero
    !
    no ip domain lookup
    !
    isdn switch-type basic-dms100
    !
    interface BRI0
    no ip address
    encapsulation ppp
    dialer rotary-group 0
    isdn switch-type basic-dms100
    isdn spid1 xxxxxxxxx100 xxxxxxxxx1
    isdn spid2 xxxxxxxxx200 xxxxxxxxx2
    no fair-queue
    no cdp enable
    !
    interface BRI1
    no ip address
    shutdown
    isdn switch-type basic-dms100
    !
    interface FastEthernet0
    ip address a.a.a.a 255.255.255.0
    speed auto
    half-duplex
    !
    interface Dialer0
    ip unnumbered FastEthernet0
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 300
    dialer map ip b.b.b.b name YYY XXXXXXXXX3 (IP, NAME, NO FOR THE SECOND ROUTER)
    dialer map ip b.b.b.b name YYY XXXXXXXXX4
    dialer hold-queue 10
    dialer load-threshold 200 either
    dialer-group 1
    no fair-queue
    ppp authentication chap
    ppp multilink
    !
    ip classless
    ip route ............ (static routing)
    no ip http server
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    line aux 0
    line vty 0 4
    password 7 02040B49055356
    login
    !
    end

    Thank you for help,
    M
    Mircea, Jan 27, 2004
    #1
    1. Advertising

  2. Mircea

    Guest

    Here mate I've send you a copy of both the server and the client cisco
    config this should help you sort this out.



    John.



    ISDN Router Server
    Building configuration...

    Current configuration:
    !
    version 12.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname xphub.xpplc.com
    !
    no logging console
    enable password madoka
    !
    username sweden password 0 madoka
    username norway2 password 0 madoka
    username bremen password 0 madoka
    username nijmegen password 0 madoka
    username milan password 0 madoka
    username brondby password 0 madoka
    username paris password 0 madoka
    username xptest password 0 madoka
    !
    !
    !
    !
    memory-size iomem 25
    ip subnet-zero
    ip ftp username cisco
    ip ftp password kid
    no ip domain-lookup
    !
    isdn switch-type basic-net3
    isdn voice-call-failure 0
    !
    !
    !
    interface Ethernet0/0
    description connected to EthernetLAN
    ip address 195.157.48.28 255.255.255.224
    ip access-group alpha2 in
    no ip directed-broadcast
    ip nat outside
    !
    interface Serial0/0
    ip unnumbered Ethernet0/1
    no ip directed-broadcast
    !
    interface Ethernet0/1
    description connected to EthernetLAN_1
    ip address 200.200.200.129 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    !
    interface BRI1/0
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    dialer rotary-group 1
    isdn switch-type basic-net3
    !
    interface BRI1/1
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    dialer rotary-group 1
    isdn switch-type basic-net3
    !
    interface BRI1/2
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    dialer rotary-group 1
    isdn switch-type basic-net3
    !
    interface BRI1/3
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    dialer rotary-group 1
    isdn switch-type basic-net3
    !
    interface Dialer0
    no ip address
    no ip directed-broadcast
    no cdp enable
    !
    interface Dialer1
    ip address 200.201.200.2 255.255.255.0
    no ip directed-broadcast
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 180
    dialer map ip 200.201.200.1 name sweden 0046855536709
    dialer map ip 200.201.200.3 name paris 0033140838737
    dialer map ip 200.201.200.5 name norway2 004763873758
    dialer map ip 200.201.200.8 name bremen 00494212445660
    dialer map ip 200.201.200.9 name nijmegen 0031243790127
    dialer map ip 200.201.200.10 name milan 00390224412945
    dialer map ip 200.201.200.11 name brondby 004543423032
    dialer map ip 200.201.200.12 name xptest 01189841119
    dialer-group 1
    ppp authentication chap
    !
    router rip
    version 2
    network 195.157.48.0
    network 200.200.200.0
    no auto-summary
    !
    ip nat pool netscalibur 195.157.48.3 195.157.48.25 netmask 255.255.255.224
    ip nat inside source list 1 pool netscalibur overload
    ip nat inside source static 200.200.200.160 195.157.48.25
    ip nat inside source static 200.200.200.2 195.157.48.26
    ip nat inside source static 200.200.200.1 195.157.48.27
    ip nat inside source static 200.200.200.15 195.157.48.29
    ip classless
    ip route 0.0.0.0 0.0.0.0 195.157.48.30
    ip route 195.157.48.0 255.255.255.224 Ethernet0/0
    ip route 200.200.200.0 255.255.255.0 Ethernet0/1
    ip route 200.200.200.224 255.255.255.224 200.200.200.190
    ip route 200.200.201.0 255.255.255.0 200.200.200.3
    ip route 200.200.202.0 255.255.255.0 200.201.200.3
    ip route 200.200.203.0 255.255.255.0 200.201.200.5
    ip route 200.200.204.0 255.255.255.0 200.201.200.4
    ip route 200.200.206.0 255.255.255.0 200.201.200.1
    ip route 200.200.208.0 255.255.255.0 200.201.200.8
    ip route 200.200.209.0 255.255.255.0 200.201.200.9
    ip route 200.200.210.0 255.255.255.0 200.201.200.10
    ip route 200.200.211.0 255.255.255.0 200.201.200.11
    ip route 200.200.222.0 255.255.255.0 200.201.200.12
    no ip http server
    !
    access-list 1 permit 200.200.0.0 0.0.255.255
    dialer-list 1 protocol ip permit
    snmp-server engineID local 000000090200000653651E01
    snmp-server community public RO
    !
    line con 0
    exec-timeout 0 0
    password madoka
    login
    transport input none
    speed 115200
    line aux 0
    line vty 0 4
    password spaniel
    login
    !
    end



    ISDN Router Client
    Building configuration...

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname sweden
    !
    enable secret 5 $1$qFRq$KfJcqfUtbwtWql7RlPUk4.
    enable password mwmadoka
    !
    username xphub.xpplc.com password 0 madoka
    ip subnet-zero
    isdn switch-type basic-net3
    !
    !
    !
    interface Ethernet0
    ip address 200.200.206.1 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    !
    interface Ethernet1
    ip address 212.247.174.197 255.255.255.240
    no ip directed-broadcast
    ip nat outside
    !
    interface BRI0
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    dialer rotary-group 1
    isdn switch-type basic-net3
    no cdp enable
    !
    interface Dialer1
    ip address 200.201.200.1 255.255.255.0
    ip access-group filter out
    no ip directed-broadcast
    encapsulation ppp
    no ip split-horizon
    dialer in-band
    dialer map ip 200.201.200.2 name xphub.xpplc.com 000441189841209
    dialer hold-queue 10
    dialer-group 1
    no cdp enable
    ppp authentication chap
    !
    router rip
    redistribute connected
    network 200.200.206.0
    network 212.247.174.0
    !
    ip nat pool hotel 212.247.174.197 212.247.174.197 netmask 255.255.255.240
    ip nat inside source list 1 pool hotel overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 212.247.174.206
    ip route 200.200.0.0 255.255.0.0 200.201.200.2
    !
    !
    ip access-list extended filter
    deny tcp any eq 5631 any eq 5631
    deny udp any eq 5631 any eq 5631
    deny tcp any eq 5632 any eq 5632
    deny udp any eq 5632 any eq 5632
    access-list 1 permit 200.200.204.0 0.0.0.255
    access-list 1 permit 200.200.206.0 0.0.0.255
    dialer-list 1 protocol ip permit
    dialer-list 1 protocol ipx permit
    !
    line con 0
    transport input none
    line vty 0 4
    password madoka
    login
    !
    end
    , Jan 29, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rits

    CISCO 1721 - ISDN problem

    Rits, Oct 24, 2003, in forum: Cisco
    Replies:
    2
    Views:
    570
  2. dr_rockstar66
    Replies:
    2
    Views:
    6,510
    Hansang Bae
    Feb 5, 2005
  3. Scooter
    Replies:
    1
    Views:
    872
    BradReeseCom
    Feb 25, 2005
  4. sync
    Replies:
    0
    Views:
    559
  5. ph-arj-vador

    ISP connection with ISDN 1721 router

    ph-arj-vador, Apr 14, 2008, in forum: Cisco
    Replies:
    8
    Views:
    581
Loading...

Share This Page