1720 and comcast

Discussion in 'Cisco' started by cbtl, Feb 20, 2006.

  1. cbtl

    cbtl Guest

    I recently purchased a 1720 router and thanks to the help received here
    I have it up and running now. I have a wic-1enet on it. ios 12.39(c)

    I currently do not have it configured, it's not connected to anything
    at the moment.

    I've been trying to find a configuration for my comcast connection.
    using the 10mb wic to the cable modem and the 10/100 nic to my switch
    to the rest of the lan.

    I've looked at the config posted here. But this user is having speed
    issues that I would like to try to avoid if possible.

    http://groups.google.com/group/comp...2629c471e7281?q=1720&rnum=27#e632629c471e7281

    The router has 16mb flash, and maxed out on ram. Any ideas would be
    appreciated.
     
    cbtl, Feb 20, 2006
    #1
    1. Advertising

  2. cbtl

    Merv Guest

    12.3(9c) is now a deffered image.

    Since it looks like you purchased this used, I do not know if Cisco
    will provide an upgrade.

    Call they Cisco TAC tell them your router has a deffered image and see
    if they will provide 12.3(9d) or 12.3(9e). You do not need to mention
    you acquired it used unless they ask.
     
    Merv, Feb 20, 2006
    #2
    1. Advertising

  3. cbtl

    Merv Guest

    Merv, Feb 20, 2006
    #3
  4. cbtl

    cbtl Guest

    Thanks but right now I'm just trying to get a ios configuration up that
    will let me replace my current router with this one.
     
    cbtl, Feb 20, 2006
    #4
  5. cbtl

    Merv Guest

    So what do you have so far ?

    If you have a config please post
     
    Merv, Feb 20, 2006
    #5
  6. I(f speed is the issue, check and make sure thst your cable-modem isn't
    hard-coded at 100mbs/Full. Since your router is 10/half....that would cause
    speed issues in the form of colission etc..........





    "Merv" <> wrote in message
    news:...
    >
    > So what do you have so far ?
    >
    > If you have a config please post
    >
     
    Devecchio Turner, Feb 20, 2006
    #6
  7. cbtl

    Merv Guest

    According to Cisco docs the WIC-1ENET does NOT auto-sense ( amazing ..
    ):

    http://www.cisco.com/en/US/products...guration_guide09186a008007cf93.html#wp1041132

    try setting the speed to 10 and the duplex to full to see if the cable
    modem support it

    send some traffic and then check the output of show interface for runts
    and giants whci is one sign of duplex mismatch.


    IOS Commands

    This section describes the full-duplex and half-duplex IOS commands.
    Cisco WIC-1ENET is set to half-duplex mode by default, and it does not
    auto-sense. If you set the Cisco to full-duplex operation, you must
    also set the device to which the port is attached to full-duplex mode.
    full-duplex Command

    To put the Ethernet interface into full-duplex mode, use the
    full-duplex command. The "no" form of this command changes the port to
    half-duplex mode.

    full-duplex
    no full-duplex

    Syntax Description

    full-duplex


    Interface is in full-duplex mode.

    no full-duplex


    Interface is in half-duplex mode.

    Default

    Half-duplex mode

    Command Mode

    Interface configuration mode

    Usage Guidelines

    Use the full-duplex command to put the Cisco WIC-1ENET Ethernet
    interface into 10-Mbps full-duplex operation. The interface can be put
    into half-duplex mode again by entering the no full-duplex command.

    Example

    The following example puts the Cisco WIC-1ENET Ethernet interface into
    full-duplex mode:

    1750(config)#interface Ethernet 0

    1750(config-if)#full-duplex


    The following example puts the Cisco WIC-1ENET Ethernet interface into
    half-duplex mode:

    1750(config)#interface Ethernet 0

    1750(config-if)#no full-duplex


    To verify the interface state, enter a show interface command as
    follows:

    1750#show interface Ethernet 0

    Ethernet0 is up, line protocol is up

    Hardware is PQUICC Ethernet, address is 0001.64ff.ef6a (bia
    0001.64ff.ef6a)

    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

    reliability 255/255, txload 1/255, rxload 1/255

    Encapsulation ARPA, loopback not set

    Keepalive set (10 sec)

    Full-duplex, 10BaseT

    ....
     
    Merv, Feb 20, 2006
    #7
  8. Worst-case scenario, switch the connections for testing....plug your
    cable-modem into the 100/full side of the router and your switch into the
    10/half side....based on the number of users, you may not have an
    issue......just remenber to change the commands for the interfaces......





    "Merv" <> wrote in message
    news:...
    > According to Cisco docs the WIC-1ENET does NOT auto-sense ( amazing ..
    > ):
    >
    > http://www.cisco.com/en/US/products...guration_guide09186a008007cf93.html#wp1041132
    >
    > try setting the speed to 10 and the duplex to full to see if the cable
    > modem support it
    >
    > send some traffic and then check the output of show interface for runts
    > and giants whci is one sign of duplex mismatch.
    >
    >
    > IOS Commands
    >
    > This section describes the full-duplex and half-duplex IOS commands.
    > Cisco WIC-1ENET is set to half-duplex mode by default, and it does not
    > auto-sense. If you set the Cisco to full-duplex operation, you must
    > also set the device to which the port is attached to full-duplex mode.
    > full-duplex Command
    >
    > To put the Ethernet interface into full-duplex mode, use the
    > full-duplex command. The "no" form of this command changes the port to
    > half-duplex mode.
    >
    > full-duplex
    > no full-duplex
    >
    > Syntax Description
    >
    > full-duplex
    >
    >
    > Interface is in full-duplex mode.
    >
    > no full-duplex
    >
    >
    > Interface is in half-duplex mode.
    >
    > Default
    >
    > Half-duplex mode
    >
    > Command Mode
    >
    > Interface configuration mode
    >
    > Usage Guidelines
    >
    > Use the full-duplex command to put the Cisco WIC-1ENET Ethernet
    > interface into 10-Mbps full-duplex operation. The interface can be put
    > into half-duplex mode again by entering the no full-duplex command.
    >
    > Example
    >
    > The following example puts the Cisco WIC-1ENET Ethernet interface into
    > full-duplex mode:
    >
    > 1750(config)#interface Ethernet 0
    >
    > 1750(config-if)#full-duplex
    >
    >
    > The following example puts the Cisco WIC-1ENET Ethernet interface into
    > half-duplex mode:
    >
    > 1750(config)#interface Ethernet 0
    >
    > 1750(config-if)#no full-duplex
    >
    >
    > To verify the interface state, enter a show interface command as
    > follows:
    >
    > 1750#show interface Ethernet 0
    >
    > Ethernet0 is up, line protocol is up
    >
    > Hardware is PQUICC Ethernet, address is 0001.64ff.ef6a (bia
    > 0001.64ff.ef6a)
    >
    > MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    >
    > reliability 255/255, txload 1/255, rxload 1/255
    >
    > Encapsulation ARPA, loopback not set
    >
    > Keepalive set (10 sec)
    >
    > Full-duplex, 10BaseT
    >
    > ....
    >
     
    Devecchio Turner, Feb 20, 2006
    #8
  9. cbtl

    cbtl Guest

    Thank you all for the help, I've got the router online with comcast
    now. And all is well except for DHCP. the router doesn't seem to be
    doing it at all. Here's my current config if someone would take a look
    for me.

    Building configuration...

    Current configuration : 957 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname boromir
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5
    !
    memory-size iomem 15
    no aaa new-model
    ip subnet-zero
    !
    !
    ip name-server 4.2.2.1
    ip dhcp excluded-address 192.168.1.2 192.168.1.6
    ip dhcp excluded-address 192.168.1.2 192.168.1.7
    !
    ip dhcp pool boromir
    !
    ip cef
    ip address-pool dhcp-pool
    !
    !
    !
    !
    interface Ethernet0
    ip address dhcp
    ip nat outside
    half-duplex
    !
    interface FastEthernet0
    description connected to EthernetLAN
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    speed auto
    !
    router rip
    version 2
    network 192.168.1.0
    no auto-summary
    !
    ip nat inside source list 1 interface Ethernet0 overload
    ip classless
    ip http server
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    line con 0
    exec-timeout 0 0
    password 7
    login
    line aux 0
    line vty 0 4
    password 7
    login
    !
    end
     
    cbtl, Feb 21, 2006
    #9
  10. cbtl

    cbtl Guest

    actually I just figured it out, forgot to set the pool range and
    netmask. all is well now. Thanks much all.
     
    cbtl, Feb 21, 2006
    #10
  11. cbtl

    Merv Guest

    1. Enable internal syslogging:

    conf t
    logging buffer 10000 debug
    exit
    wri mem




    2. Verify that the "outside" interface connected to the cable modem is
    up & up

    sh int e 0
    !

    ! 3. Enable DHCP debugging

    debug dhcp detail


    4. Shut/no shut outside interface or otherwise cuase it to initiate
    DHCP request


    5. Try adding the additional optional parameters for DHCP

    conf t
    int e 0
    ! The DISCOVER message contains the MAC address of the Ethernet 0
    interface
    ! in the client ID field and contains the default host name of the
    router in the
    ! option 12 field.
    ip address dhcp client-id ethernet0
    exit
    wri mem

    repeat the above troubleshooting steps


    after finished testing disable debug

    undebug all

    use "show log" to see debug messages in internal logging buffer


    see
    http://www.cisco.com/en/US/tech/tk86/tk89/technologies_configuration_example09186a0080094be1.shtml


    Also you need to add a default route:

    conf t
    ip route 0.0.0.0 0.0.0.0 dhcp
    wri mem
     
    Merv, Feb 21, 2006
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ali
    Replies:
    2
    Views:
    1,055
    chris
    Nov 5, 2003
  2. ComputerMan
    Replies:
    3
    Views:
    3,067
  3. Mario Lopez

    Cisco 1720 and Linksys RV042

    Mario Lopez, Aug 18, 2004, in forum: Cisco
    Replies:
    0
    Views:
    875
    Mario Lopez
    Aug 18, 2004
  4. david ramon

    Re: "Comcast Mail" <>

    david ramon, Oct 22, 2003, in forum: Computer Support
    Replies:
    1
    Views:
    1,059
    trout
    Oct 22, 2003
  5. Xlat
    Replies:
    1
    Views:
    634
    mcaissie
    Jun 1, 2006
Loading...

Share This Page