Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP.NET Deployment

Reply
Thread Tools

ASP.NET Deployment

 
 
Ann Marinas
Guest
Posts: n/a
 
      02-24-2005
Hello, all!

I am having troubles deploying my ASP.NET Deployment on a virtual webserver.
The webserver has 3 different web applications installed (all of them are
ASP.NET web apps), and whenever I install my app, it keeps on showing the
message below.

Tried compiling and removing the unecessary files for deployment, removed
the old web app files and replaced it with a new one, but still this error
keeps on showing up.

Please help!

Many Thanks!


--Ann

================================================
Server Error in '/' Application.
--------------------------------------------------------------------------------

Parser Error
Description: An error occurred during the parsing of a resource required to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'NZTravelSite.index'.

Source Error:


Line 1: <%@ Page Language="c#" ContentType="text/html"
ResponseEncoding="gb2312" CodeBehind="index.aspx.cs" AutoEventWireup="false"
Inherits="NZTravelSite.index" %>
Line 2: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
Line 3: <html xmlns="http://www.w3.org/1999/xhtml">


Source File: E:\wwwroot\content\n\z\t\nztravelsite_com\index.as px Line: 1



--------------------------------------------------------------------------------

Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET
Version:1.1.4322.2032
==============================================





 
Reply With Quote
 
 
 
 
Rick Strahl [MVP]
Guest
Posts: n/a
 
      02-24-2005
Hi Ann,

Are you copying the assemblies in the BIN directory? index.aspx.cs will be
in your Web Project assembly and must exist on the server.

Also, make sure you set up your application properly as a virtual
directory/application in IIS. Sometimes these types of errors occur because
the root application directory is up a few levels. I notice the app is
showing the root directory of the server? Is that where your bin directory
lives?

That's where ASP.NET will look for the support assemblies.

+++ Rick ---

--


Rick Strahl
West Wind Technologies
http://www.west-wind.com/
http://www.west-wind.com/weblog/
http://www.west-wind.com/wwThreads/
----------------------------------
Making waves on the Web


"Ann Marinas" <(E-Mail Removed)> wrote in message
news:#(E-Mail Removed)...
> Hello, all!
>
> I am having troubles deploying my ASP.NET Deployment on a virtual

webserver.
> The webserver has 3 different web applications installed (all of them are
> ASP.NET web apps), and whenever I install my app, it keeps on showing the
> message below.
>
> Tried compiling and removing the unecessary files for deployment, removed
> the old web app files and replaced it with a new one, but still this error
> keeps on showing up.
>
> Please help!
>
> Many Thanks!
>
>
> --Ann
>
> ================================================
> Server Error in '/' Application.
> --------------------------------------------------------------------------

------
>
> Parser Error
> Description: An error occurred during the parsing of a resource required

to
> service this request. Please review the following specific parse error
> details and modify your source file appropriately.
>
> Parser Error Message: Could not load type 'NZTravelSite.index'.
>
> Source Error:
>
>
> Line 1: <%@ Page Language="c#" ContentType="text/html"
> ResponseEncoding="gb2312" CodeBehind="index.aspx.cs"

AutoEventWireup="false"
> Inherits="NZTravelSite.index" %>
> Line 2: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
> "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
> Line 3: <html xmlns="http://www.w3.org/1999/xhtml">
>
>
> Source File: E:\wwwroot\content\n\z\t\nztravelsite_com\index.as px Line:

1
>
>
>
> --------------------------------------------------------------------------

------
>
> Version Information: Microsoft .NET Framework Version:1.1.4322.2032;

ASP.NET
> Version:1.1.4322.2032
> ==============================================
>
>
>
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enterprise Library deployment problem. Why needs to InstallUtil DLLs to the deployment server? If not, Registry Error whould shown. Benny Ng ASP .Net 0 10-03-2005 05:40 AM
Scripting wireless setup for automated deployment paulwilkinson@gmail.com Wireless Networking 0 09-29-2005 02:17 PM
no touch deployment Mark ASP .Net 5 08-27-2003 03:38 PM
Deployment Question Brad Markisohn ASP .Net 1 08-07-2003 02:01 AM
Deployment Issues .. Runtime Error Sean ASP .Net 2 07-26-2003 04:37 PM



Advertisments