Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Perfmon ASP.NET apps

Reply
Thread Tools

Perfmon ASP.NET apps

 
 
MattC
Guest
Posts: n/a
 
      02-14-2005
I have added all counters for all 'ASP.NET Apps v1.1.4322'. However Every
counter is 0, no matter how many requests are made to the server? Under
ASP.NET applications my web app is not listed there is only _total_.

Is there something I need to do to get perfmon to register my apps existence
and counters?

Running W2K3, IIS6.0

TIA

MattC


 
Reply With Quote
 
 
 
 
MattC
Guest
Posts: n/a
 
      02-14-2005
Just found this in the event log:

The configuration information of the performance library
"C:\WINDOWS\system32\inetsrv\w3ctrs.dll" for the "W3SVC" service does not
match the trusted performance library information stored in the registry.
The functions in this library will not be treated as trusted.

TIA

"MattC" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>I have added all counters for all 'ASP.NET Apps v1.1.4322'. However Every
>counter is 0, no matter how many requests are made to the server? Under
>ASP.NET applications my web app is not listed there is only _total_.
>
> Is there something I need to do to get perfmon to register my apps
> existence and counters?
>
> Running W2K3, IIS6.0
>
> TIA
>
> MattC
>



 
Reply With Quote
 
 
 
 
MattC
Guest
Posts: n/a
 
      02-14-2005
S'Ok found it. run the following from the system32 directory then restart:

unlodctr w3svc
unlodctr msftpsvc
unlodctr asp
unlodctr inetinfo
lodctr w3ctrs.ini
lodctr ftpctrs.ini
lodctr axperf.ini
lodctr infoctrs.ini


"MattC" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
> Just found this in the event log:
>
> The configuration information of the performance library
> "C:\WINDOWS\system32\inetsrv\w3ctrs.dll" for the "W3SVC" service does not
> match the trusted performance library information stored in the registry.
> The functions in this library will not be treated as trusted.
>
> TIA
>
> "MattC" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>>I have added all counters for all 'ASP.NET Apps v1.1.4322'. However Every
>>counter is 0, no matter how many requests are made to the server? Under
>>ASP.NET applications my web app is not listed there is only _total_.
>>
>> Is there something I need to do to get perfmon to register my apps
>> existence and counters?
>>
>> Running W2K3, IIS6.0
>>
>> TIA
>>
>> MattC
>>

>
>



 
Reply With Quote
 
MattC
Guest
Posts: n/a
 
      02-15-2005
This has removed the error from the Event Viewer when I add the counters but
my counters for ASP.NET Apps v1.1.4322 are all 0.

Any help is really appreciated

TIA


"MattC" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>I have added all counters for all 'ASP.NET Apps v1.1.4322'. However Every
>counter is 0, no matter how many requests are made to the server? Under
>ASP.NET applications my web app is not listed there is only _total_.
>
> Is there something I need to do to get perfmon to register my apps
> existence and counters?
>
> Running W2K3, IIS6.0
>
> TIA
>
> MattC
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sessions Active =0 and Requests Executing >0 in perfmon asp.net apps v1.1.4... whidbeywave ASP .Net 0 10-27-2005 07:05 AM
using perfmon counter to eliminate viewstate memory issue =?Utf-8?B?aGF6eg==?= ASP .Net 2 04-11-2005 07:19 PM
Enable ASP.Net perfmon counters Nic ASP .Net 0 03-01-2005 08:20 PM
ASP.NET perfmon counters all 0 ... ?? Z D ASP .Net 4 02-26-2004 06:21 PM
Private Bytes vs. # Bytes in all Heaps in Perfmon Jason Collins ASP .Net 3 02-18-2004 03:59 PM



Advertisments