Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Stateserver behaving strangely

Reply
Thread Tools

Stateserver behaving strangely

 
 
=?iso-8859-1?q?Nils Hedstr=f6m
Guest
Posts: n/a
 
      02-11-2005
I have some problems with my stateserver.
First my setup:
I am running ASP.NET 1.1.4322 SP 1.1 on one computer and the stateserver
on another computer.
Both of the machines are Dell Poweredge 2850 (dual processor machines with
2 GB memory).
The web server is serving traffic with 2000-4000 sessions and 20-40 requests/s.
The web pages are converted from ASP so there is no code behind-pages and
some COM-objects.
The stateserver machine is not doing anything else at the moment.
The sessions are used mainly for login-information (a couple of strings).
But in one directory (where the user creates an item on multiple pages)
I put data from the user in a hashtable and put that hashtable in the session
(to share the data between the pages).
At the moment I am testing ASP.NET on one web server (and one stateserver).
My goal is to run 6 ASP.NET web servers on one stateserver (so I am kind of
worried that I am having problems with just one ASP.NET web server).
The processor time on the stateserver was typically 1.2% (with a maximum
of 20%).
The processor time on the web server is 20%-40%.

Problem 1)
The performance counter ASP.NET -> State Server Sessions Active is showing
a value like 4294936349. When I first started the stateserver it showed numbers
which seemed normal, then the numbers went lower like 7, 5, 2, 0, 4294936349,
2, 4294936349 (these are not exact numbers, just as I remember them). This
phenomenon happened when I ran the stateserver and the web server on the same
machine (so it don't need to be connected to the other problems)
Problem 2)
The stateserver memory usage (working set) was constant at about 45 MB for quite some time. At one point it started to increase at at steady rate. When I turned off the traffic on the web server it stopped at 137 MB but it never returned the memory (it is still 137 MB when the traffic has been of for 12 hours). I did not restart the state server or the web server, I just switched off the traffic. I tried to include a image of the memory usage.
Problem 3)
This is the most severe problem. At high traffic the users get a lot of
"Unable to make the session state request to the session state server. Please ensure that the ASP.NET State service is started and that the client and server ports are the same. If the server is on a remote machine, please ensure that it accepts remote requests by checking the value of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\aspnet_state\Parameters\AllowRemoteConnection."-error messages (like 40000 in 4 hours). The ASP.NET Applications (Total) -> Requests executing was extremely high at the time (600-800). Some requests queued (maximum 50). Lots of requests failed. Overall slow performance (up to 40 seconds to serve a simple page and sometimes failing doing that).

I did not have these problems when I ran the sessions inproc. What could be the problem? I am thinking of setting the sessions to read-only using
<%@page EnableSessionState="Readonly" %>.
How much will this help?
/nisse <(E-Mail Removed)>




 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
re behaving strangely Josh Close Python 2 06-09-2005 06:37 PM
cd drive behaving strangely bj Computer Information 2 01-02-2005 02:31 PM
CD DRIVE BEHAVING STRANGELY-VIRUS? bj Computer Security 0 12-31-2004 07:08 PM
IO.seek behaving strangely on FreeBSD 4.9 Travis Whitton Ruby 5 04-01-2004 11:56 PM
Help. My PC is behaving strangely kackson Computer Support 2 02-01-2004 03:45 PM



Advertisments