Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Python > setup.py Choosing Older Compiler On Windows

Reply
Thread Tools

setup.py Choosing Older Compiler On Windows

 
 
Ami Tavory
Guest
Posts: n/a
 
      12-02-2012
Hello,

I'm porting a C++ extension module to a Windows machine that has both VC8
and VC10 installed. Unfortunately, `setup.py build` tries to build using
VC8, which fails (the extension uses C++ standard libraries that VC didn't
used to have). Is there a way to get setup.py to use VC10 (preferably
externally, without modifying the script)?

Thanks,

Ami

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: setup.py Choosing Older Compiler On Windows Ami Tavory Python 0 12-03-2012 10:52 AM
Re: setup.py Choosing Older Compiler On Windows Dave Angel Python 1 12-03-2012 12:10 AM
problem printing from older DOS program in Windows XP network =?Utf-8?B?Sm9uIEpvbmVz?= Wireless Networking 1 05-05-2006 02:48 PM
I need a CFRONT C++ Compiler for MS-DOS/Windows to replace an Apollo Domain 2.1.0 compiler Wormald C++ 1 02-06-2006 12:53 AM
Older ACS version on Windows Server 2003 butlercellars Cisco 1 01-13-2006 07:22 PM



Advertisments